(Topic ID: 157349)

Twilight Zone Cannot Locate Balls

By WaterFlowing

7 years ago

Topic Stats

  • 6 posts
  • 6 Pinsiders participating
  • Latest reply 4 years ago by Yelobird
  • No one calls this topic a favorite


Linked Games

#1 7 years ago

I am a new TZ owner (yeah!) but, the machine has a problem just a few weeks after bringing it home. (Boo!)

When I press the start button for a new game, the machine immediately cycles through firing all the flippers and solenoids (as if it were trying to shake balls loose). All six balls are loaded and in the through or around the outhole. The machine does not try loading balls into the gumball machine.

In test mode, I can successfully cycle through the gumball test - all the switches and solenoids work fine and in sequence for loading and dispensing balls from the gumball machine. I have tested all the individual switches as well a few times. For sure all the through and outhole switches work.

My best guess is that the CPU is not processing the switch information correctly (although it will display switch state in test mode). Could that bee? Any suggestions on how to proceed? Really stumped.

#2 7 years ago

Try removing two balls, then pressing start. Does the DMD show "2 balls missing..."?

If it does, try the test with only one ball missing.

Pages 1-20 & 1-21 in the manual show both automatic gumball test mode and manual mode. Do both modes function with no errors?

#3 7 years ago

Mine did that once. Assuming you accounted for all balls and none were stuck anywhere since your machine sounds like its going into ball search. I shut the machine, took all the balls out, manually loaded the gumball machine with 3 balls, turned the machine on then drained the remaining 3 balls. That resolved the problem for me. If that does not work I would suspect a stuck switch in the on position in the gumball machine.

#4 7 years ago

Also make sure the gumball diverter, upkicker, and opto are working as well. The game also may be set to "Gumball Broken". That might be why it doesn't try to load it.

2 years later
#5 4 years ago

Make sure all the trough switches work, and that they aren't stuck down. Just found a middle trough switch stuck in the closed position to fix this problem...

#6 4 years ago
Quoted from bheasy:

Make sure all the trough switches work, and that they aren't stuck down. Just found a middle trough switch stuck in the closed position to fix this problem...

As the post is over 2 years old I would hope he fixed it by now. Lol

Promoted items from the Pinside Marketplace
9,500 (Firm)
Machine - For Sale
Chelmsford, MA
$ 129.50
Cabinet - Decals
Pinball Haus


Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!

This page was printed from https://pinside.com/pinball/forum/topic/twilight-zone-cannot-locate-balls and we tried optimising it for printing. Some page elements may have been deliberately hidden.

Scan the QR code on the left to jump to the URL this document was printed from.