(Topic ID: 109795)

TWD LE well walker, prison magnets stopped working


By Demomstr

4 years ago



Topic Stats

  • 39 posts
  • 21 Pinsiders participating
  • Latest reply 2 years ago by wtuttle
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

There have been 2 images uploaded to this topic. (View topic image gallery).

IMG_20141111_222426.jpg
IMG_20141111_222419.jpg

#1 4 years ago

My well walker and prison magnets just stopped working, crossbow diverted mag still works. Thoughts?

#2 4 years ago

I had a connector loose at one of my boards in the head. Some of those harnesses were VERY tightly routed, even being pulled, lost my GI on entire pf for awhile. Re routed with a little slack.

#3 4 years ago

Mine stopped working. The fuse blew. Replaced it and have been good to go for 100 more games.

#4 4 years ago

Frolic what was the fuse rated at? Cuz TWDLE magnets hold the ball, so maybe an underrated fuse, like lotr?

#5 4 years ago

I will check the fuse. Thanks

#6 4 years ago

The fuse was 4amp. I only had 3 and 5, so I put the 3 in and its been ok since. I'll put the 4 in once i buy one.

#7 4 years ago

For the record I had 3 days on my TWDLE before both magnets stopped working. Discovered it was a 4 amp fuse and replaced it but not before it blew twice more during the first game each time after being replaced.

Turns out I was using a 4 amp/250v rapid acting fuse instead of a slow blow. OOOPS! I'm a pinball newb and that was lesson #1 for me. I bought a couple 5 and 3's when I went back for the slow blow 4 just to have some on hand because I didn't know if fuses blowing was going to be a frequent or normal occurrence.

By the way, is it?

Oh well, everything has been great ever since that one incident. Love the machine.

#8 4 years ago

This problem just happened to me. Where is this specific fuse located so I can check it out.

#9 4 years ago

F7 4amp slow blow fuse. This is supposed to be fixed in the next code update.

#10 4 years ago
Quoted from PinballZach:

This problem just happened to me. Where is this specific fuse located so I can check it out.

in the bottom inside of the back box

#11 4 years ago

IMG_20141111_222419.jpg

F7 under the back glass. I snapped these pictures last week when it happened to me. Turned out to be no big deal. Just make sure you use a 'slow blow" 4A fuse

IMG_20141111_222426.jpg
#12 4 years ago

Just bought some 4amp slow blow fuses, that did it!

#13 4 years ago
Quoted from idtattoo:

F7 4amp slow blow fuse. This is supposed to be fixed in the next code update.

Glad to hear this can be solved through software.

#14 4 years ago

The cause is from both magnets being used excessively during multiball.
I've talked with Stern reps, it will be changed in the next code update.

#15 4 years ago

free fuses from stern? how did they not know this happens? geez...

#16 4 years ago

Looks like I'm going to have to grab a bunch of 4A slow blows just in case.

#17 4 years ago

Same fuse that blows on Metallica for the magnets. Stern needs to correct this.

1 week later
#18 4 years ago

Has this fuse blown on anyone more than once? I have at least 500 games on TWDLE since mine blew and it hasn't given me any trouble since the initial trouble on day 3 of owning it.

#19 4 years ago
Quoted from Yipykya:

Has this fuse blown on anyone more than once? I have at least 500 games on TWDLE since mine blew and it hasn't given me any trouble since the initial trouble on day 3 of owning it.

Just the 1 time for me as well.

#20 4 years ago

once for me

#21 4 years ago

Since its the same fuse as MET, I had it blow only once, although other owners had it happens a couple of times

2 weeks later
#22 4 years ago

Where do you buy a 4A Slo Blow fuse?

#23 4 years ago
Quoted from Vanilla_Gorilla:

Where do you buy a 4A Slo Blow fuse?

If you don't want to wait for an online order just go to any radio shack.

#24 4 years ago

Thanks. Just set mine up Sunday night and the magnet worked. The wife and kids have been playing non-stop (I can't get 5 min on it) and no magnets. Checked F7-blown fuse. Thanks to this forum, problem solved!!

#25 4 years ago

BTW-running most up to date firmware.

#26 4 years ago

Do you guys think the game may play better without the magnets. No more sdtm anymore

#27 4 years ago

If you feel you have a SDTM issue and it's affecting your enjoyment pull the fuse and let us know. I remember when my fuse blew a long time ago I played for hours with out the magnets. It definitely felt like something was missing without the random chaos the magnets cause. I wouldn't be happy playing it that way knowing what I was missing.

#28 4 years ago

Nope, I'll keep the magnets and replace a fuse once a year.

#29 4 years ago

Mine did the same thing on the second day of use, F7 blew.

3 weeks later
#30 4 years ago

Mine blew as well and I am having a problem finding fuses locally (in NJ). I can find the metric sizes though, so would a 5x20mm or 6x30mm fuse fit?

Thanks.

#31 4 years ago
Quoted from milhouse:

Mine blew as well and I am having a problem finding fuses locally (in NJ). I can find the metric sizes though, so would a 5x20mm or 6x30mm fuse fit?
Thanks.

Radio Shack should be no problem. Just take the blown fuse with you to compare.

4 weeks later
#32 4 years ago

Both my magnets went out today for the first time since I've owned the game. I'm assuming it's the F7 fuse, but I haven't opened the backbox up yet to check.

#33 4 years ago

I had this happen a few times. Once I installed the latest version. The issue stopped.

#34 4 years ago

Yep. F7 was blown. Of course, I have every other fuse on hand except a 4A. I just got back from my local Ace Hardware store, and they didn't have any 4A ones either. Normally, I would go to Radio Shack for stuff like this, but that ship has sailed. Anyone got a link to some of these online?

#35 4 years ago
Quoted from gweempose:

Yep. F7 was blown. Of course, I have every other fuse on hand except a 4A. I just got back from my local Ace Hardware store, and they didn't have any 4A ones either. Normally, I would go to Radio Shack for stuff like this, but that ship has sailed. Anyone got a link to some of these online?

I would probably order from Great Plains Electronics...
https://www.greatplainselectronics.com/

I believe the part number for 4A SB fuses are: MDL-4

Ed runs a great pinball oriented online electronics site. Someone might be a few cents cheaper (Maybe) but he tends to have your back for hard to find items. I think that is worth supporting.

#36 4 years ago
Quoted from BC_Gambit:

I would probably order from Great Plains Electronics...
https://www.greatplainselectronics.com/
I believe the part number for 4A SB fuses are: MDL-4
Ed runs a great pinball oriented online electronics site. Someone might be a few cents cheaper (Maybe) but he tends to have your back for hard to find items. I think that is worth supporting.

Thanks! I just placed an order for a bunch of different fuses. Figure I might as well stock up on them. The prices and shipping were both very fair.

#37 4 years ago

Pinballlife has the fuses. You need to select the amperage you want with the down arrow:

http://www.pinballlife.com/index.php?p=product&id=3

3 months later
#38 4 years ago

Worked for me!

1 year later
#39 2 years ago

This cropped up for me, and this thread saved me many hours of frustration.
Thanks, all.

Promoted items from the Pinside Marketplace
$ 445.00
Cabinet - Armor And Blades
MI Pinball Refinery
$ 199.99
$ 99.99
Lighting - Other
Lighted Pinball Mods
8,000 (OBO)
Machine - For Sale
Meridian Charter Township, MI
6,390
Machine - For Sale
Cumberland, RI
Wanted
Machine - Wanted
Roswell, GA

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside