(Topic ID: 224924)

TSPP possible ROM issue???


By SmiggleMeThis

8 months ago



Topic Stats

  • 8 posts
  • 4 Pinsiders participating
  • Latest reply 8 months ago by SmiggleMeThis
  • Topic is favorited by 1 Pinsider

You

Linked Games

No games have been linked to this topic.

    Topic Gallery

    One image has been uploaded to this topic. (View topic image gallery).

    IMG_0355 (resized).jpg

    #1 8 months ago

    My TSPP is not ending a game properly and other issues...
    I just put in a new ROM for my Simpsons from Marco and I'm thinking that's gotta be what caused one issue. The old rom worked fine when it came to the game ending, ball drained and the game would end. Now, it drains and nothing happens at all. All rollover switches in the through check fine so I'm thinking maybe the new game rom has something messed up in the code???? I'd usually email and ask John Wort about it since I bought a ton of roms from him in the past but I guess he's not active anymore. Hopefully someone on here can help out!

    I'd just put the old game rom back in and check it but I bought a GQ-4X4 rom burner and a UV eraser and don't know how to use the burner yet!! The UV eraser works great!! (Hence no working old game rom Dab Nabbitt!!!)

    The reason I bought a new rom was to try and fix a freeze issue. After about a minute or so playing the game, the TV glitches and the 20V power doesn't work for like 30 seconds, then it comes back and everything is just fine.
    Any ideas on what may be causing it to do this would be appreciated!
    Also, any help using a GQ-4X4 rom burner would be great as well!
    Thanks in advance

    #2 8 months ago
    Quoted from SmiggleMeThis:

    My TSPP is not ending a game properly and other issues...
    I just put in a new ROM for my Simpsons from Marco and I'm thinking that's gotta be what caused one issue. The old rom worked fine when it came to the game ending, ball drained and the game would end. Now, it drains and nothing happens at all. All rollover switches in the through check fine so I'm thinking maybe the new game rom has something messed up in the code???? I'd usually email and ask John Wort about it since I bought a ton of roms from him in the past but I guess he's not active anymore. Hopefully someone on here can help out!
    I'd just put the old game rom back in and check it but I bought a GQ-4X4 rom burner and a UV eraser and don't know how to use the burner yet!! The UV eraser works great!! (Hence no working old game rom Dab Nabbitt!!!)
    The reason I bought a new rom was to try and fix a freeze issue. After about a minute or so playing the game, the TV glitches and the 20V power doesn't work for like 30 seconds, then it comes back and everything is just fine.
    Any ideas on what may be causing it to do this would be appreciated!
    Also, any help using a GQ-4X4 rom burner would be great as well!
    Thanks in advance

    Check your trough opto boards, you start by reseating the connectors.

    #3 8 months ago

    Yeah, checked them, all rollover switches check fine in the switch test including the optos for the first ball and the VuK up position opto. Thinkin it’s gotta be the programming in the chip not programmed to recognize a ball drain. IDK though... not real familiar with chips yet!
    Thanks for the suggestion!

    #4 8 months ago

    Do you have the correct number of balls in your game? I think there should be 5 in TSPP.

    #5 8 months ago

    I do, messed with my rom burner and burnt a new CPU for it and I'm having the same issue.... There wasn't a harness for the coin door when I got the game and I didn't mess with wiring up everything. I only wired up the start button, coin door buttons, flipper buttons, and coin door switch. I'm not thinking it's the rom now, I think it's gotta be in the wiring.
    I'm going to wire up the coin switches and whatever else isn't connected and see what happens.

    Right now, the ball will drain during gameplay and move to ball 2 and 3 then game over like normal. In multi-ball though, the ball save light stays flashing the entire time and when the ball drains it doesn't kick it back out. So, when all 3 balls drain, they don't return to the playfield and the DMD and game scores like you're still in multiball… Why will it now recognize a ball drain, but not in multi-ball???
    Not sure why, I'm just going to wire everything up 100% and hopefully the ghosts in this machine disappear. Thanks for the help so far guys!

    #6 8 months ago

    Have you gone into switch edge mode and looked at everything active? Run balls through trough and eject them? Everything registering that should. Opto boards can be flaky on these games, they might work in test, but in game play under vibration, don’t. It really sounds like the game is losing track of the balls, which is an opto problem, or trough switch issue, or the incorrect number of balls are in the game.

    Do you have any other games like lotr or sopranos where can swap opto boards?

    #7 8 months ago

    It's possible your RAM is corrupted. If you still have batteries you could pull those and unplug the game for a minute or so and then try again?

    1 week later
    #8 8 months ago

    Thank you everyone for your suggestions. Issue resolved!!
    I wired up the remaining few things into my homemade harness and it took care of it.
    It ended up being the "Memory Protect" switch on the coin door. For some reason the ground wire was not connected to anything...
    I put a connector on it and screwed it to the ground cable and everything works fine now.
    When you open the coin door now, it reads on the DMD that coin door is open and voltage is off like my other sterns.
    Thanks again for the suggestions!

    IMG_0355 (resized).jpg
    Promoted items from the Pinside Marketplace
    $ 29.95
    Playfield - Toys/Add-ons
    ULEKstore
    $ 799.00
    Flipper Parts
    Mircoplayfields
    $ 269.00
    Displays
    Boston Pinball Company
    $ 8.00
    Cabinet Parts
    RPGCor
    From: $ 42.00
    Cabinet - Shooter Rods
    ModFather Pinball Mods
    From: $ 19.95
    $ 11.95
    Playfield - Toys/Add-ons
    ULEKstore
    $ 86.95
    Cabinet - Shooter Rods
    Super Skill Shot Shop
    $ 99.99
    Playfield - Toys/Add-ons
    Lighted Pinball Mods
    $ 159.99
    Lighting - Other
    Lighted Pinball Mods
    $ 199.99
    $ 29.99
    Cabinet - Sound/Speakers
    Lighted Pinball Mods
    $ 159.99
    Lighting - Other
    Lighted Pinball Mods
    $ 21.00
    From: $ 100.00
    Playfield - Toys/Add-ons
    Lermods
    From: $ 99.99
    Cabinet - Other
    Lighted Pinball Mods
    $ 29.99
    Cabinet - Sound/Speakers
    Lighted Pinball Mods
    $ 999.00
    $ 209.99
    Lighting - Led
    PinballBulbs
    $ 149.00
    £ 45.00
    Lighting - Led
    PinballToys
    $ 135.00
    Cabinet - Shooter Rods
    Super Skill Shot Shop
    $ 96.77
    Playfield - Toys/Add-ons
    Pinball-Mods.com

    Hey there! Got a moment?

    Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside