New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 170538)

TRON LE : Led problem, flicking lights...(motor disc problem?) problem solved


By IBARAKURO

4 years ago



Topic Stats

  • 23 posts
  • 8 Pinsiders participating
  • Latest reply 3 years ago by IBARAKURO
  • Topic is favorited by 2 Pinsiders

You

Linked Games

Topic Gallery

There have been 6 images uploaded to this topic. (View topic image gallery).

IMG_2782 (resized).JPG
IMG_2788 (resized).JPG
IMG_2579 (resized).JPG
IMG_2520 (resized).JPG
IMG_2506 (resized).JPG
IMG_2504 (resized).JPG

#1 4 years ago

Hello everybody,

I have my TRON LE for several years
For some time, I have a problem with the lights inserts

do you have an idea to help me find the problem?

it's not always done, but when I play, after a while, it starts to bugger at the SHOOT AGAIN light and SPECIAL light

then it spreads to the entire plateau after

like that affect the entire table, I think it has a connection problem on the motherboard

is that it can result from a defective LED?

thank you

SOLVED :
-----------

I found the problem.
After disassembling all PCB cards. After having replaced all the LEDs with bulbs. I still had the problem.

IMG_2782 (resized).JPG

And there I found.
If I remove the bulb from the start button ... everything works normally !!!! But with a led or bulb; That bug.

So the matrix problem comes from this pellet / start button

GRRRRRRRRRRRR it gave me some wire to twist this problem ....

IMG_2788 (resized).JPG

#2 4 years ago

Wow, that's bad. When the problem starts, go into test mode. Does it go away?

Have you reseated the connectors? I'd reseat everything I could, see if that helps.

#3 4 years ago

Power off & reseat Every Ribbon Cable, that should do the trick. Actually, reseat All connectors on the board's, not just the ribbon cable's.

#4 4 years ago

thanks for the advice. I will try to disconnect / reconnect all connectors

1 week later
#5 4 years ago

hi,
I think I found a clue ...
I try to disconnect / reconnect all connectors (under playfield and backbox)
but it has not solved the problem
on closer inspection, I noticed that the problem happened when the disk spinning
suddenly, I unplugged the drive motor to try
and there, no problem !!!

So the problem is the motor drive when he turns
it must create parasites ...

Is anyone have an idea to solve the problem?
on feeding son, there are components, but I do not know what for.
can be one of these is broken up?

Thank you for your help

IMG_2506 (resized).JPG
IMG_2504 (resized).JPG

#7 4 years ago

That is a mov and a neon bulb. Both serve to absorb electrical spikes created by the motor. Sorry, but I don't have much help to add with your problem. Did you call stern yet? They may have seen this exact issue on someone elses game and can point you where to look. You isolating it to when the motor runs is a very good clue for them.

#8 4 years ago

It's been quite some time since I dealt with this...but way back when the game came out, a bunch of people were having this issue - and Stern would send out some replacement wire harnesses that connect the light boards to each other to solve the problem. I'd contact Stern to see if they'd be able to send you some replacement harnesses.

#9 4 years ago

Yep I had the same and just like Rarehero says they sent some little harnesses that fixed it

#10 4 years ago

hi,

by viewing the motor of the disk.
I noticed that a component was broken

what is this component
where is can I buy ...

thank you

IMG_2520 (resized).JPG

#11 4 years ago

Replacement neon bulb http://www.marcospecialties.com/pinball-parts/165-5021-00

Also available from electronics suppliers. You want a 120v neon bulb. Almost any will do fine in the motor snubber application.

#12 4 years ago

What is the propose of the neon bulb?

#13 4 years ago
Quoted from thepinballworks:

What is the propose of the neon bulb?

Those type of bulbs have a very specific breakdown voltage, usually around 80V. When the voltage gets that high they begin conducting and don't let the voltage rise any further. Normally they are used as lighting, but across a motor like this it would eliminate any large voltage spikes that can come from a motor starting and stopping, or even running. The bulb will serve to protect the rest of the circuitry from high voltage spikes and noise.

#14 4 years ago

I changed the 2 components ... and I still have the same problem ...

when the rotary disc motor is stopped ... no problem.
when it turns, it disrupts the matrix of lights ...

I despair, I really thought that the problem was of such components

Quoted from Rarehero:

It's been quite some time since I dealt with this...but way back when the game came out, a bunch of people were having this issue - and Stern would send out some replacement wire harnesses that connect the light boards to each other to solve the problem. I'd contact Stern to see if they'd be able to send you some replacement harnesses.

I can not contact STERN.
I am not the original purchase of the game.
more I live in France, and STERN not communicating with individuals outside the usa ... I tried to contact them for other games, they never answered me

#15 4 years ago

They're not big on email responses so you'll need to call them. Should not matter that you're not the original owner. They'll likely ask for the serial number of your game.

#16 4 years ago

Thanks for posting. I just started having the same problem with mine. My disc motor is starting to sound horrible. I going to order a new one tomorrow and I wonder if that would fix the problem. I need a new one regardless and it comes with a new neon bulb.

#17 4 years ago
Quoted from RobOOZE:

Thanks for posting. I just started having the same problem with mine. My disc motor is starting to sound horrible. I going to order a new one tomorrow and I wonder if that would fix the problem. I need a new one regardless and it comes with a new neon bulb.

do you also have problems on the lights of the game?

Where did you buy the disc motor ?

#18 4 years ago

Yes, I also have problems with the lights on the game.

Disc Motor link
http://www.pinballlife.com/index.php?p=product&id=3165

#19 4 years ago
Quoted from RobOOZE:

My disc motor is starting to sound horrible. I going to order a new one tomorrow

If you haven't already, try a few drops of machine oil on the top and bottom bushings of the motor shaft; can sometimes cure the noise. If you get the 3 in 1 oil with the extending spout you can get to the top shaft of the motor without removing it (tricky but possibly)

#20 4 years ago

Thanks....I will have to try that

#21 4 years ago
Quoted from IBARAKURO:

I can not contact STERN.
I am not the original purchase of the game.
more I live in France, and STERN not communicating with individuals outside the usa ... I tried to contact them for other games, they never answered me

I'm not the original owner of my Tron LE, but they sent me multiple new harnesses to solve the problem. Stern is really good about taking care of issues that are their fault on the design end, regardless if you're the original owner or not.

Try calling. Your email just might be going into their spam filter.

#22 4 years ago

I think I have found a clue.

in test mode, I tested all the lights: no problem
I tested the matrix rows ... no problem
I tested the columns, and there problem. they all work, except column 1

when I test it, it's anything for lights

an idea of ​​things to test now?

IMG_2579 (resized).JPG

1 month later
#23 3 years ago

I found the problem.
After disassembling all PCB cards. After having replaced all the LEDs with bulbs. I still had the problem.

IMG_2782 (resized).JPG

And there I found.
If I remove the bulb from the start button ... everything works normally !!!! But with a led or bulb; That bug.

So the matrix problem comes from this pellet / start button

GRRRRRRRRRRRR it gave me some wire to twist this problem ....

IMG_2788 (resized).JPG

Promoted items from the Pinside Marketplace
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 279.95
Lighting - Led
Pin Stadium Pinball Mods
$ 35.00
Cabinet - Decals
Pinball Haus
$ 15.00
Playfield - Protection
Pin Mods
From: $ 218.00
Lighting - Backbox
Lermods
Wanted
Machine - Wanted
Southbury, CT
$ 64.00
Lighting - Under Cabinet
Lermods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside