(Topic ID: 354347)

Transporter the Rescue Tilt and Flashers issue

By JoeChamp

3 months ago



Topic Stats

  • 10 posts
  • 6 Pinsiders participating
  • Latest reply 3 months ago by slochar
  • No one calls this topic a favorite

You

Linked Games

No games have been linked to this topic.

    Topic Gallery

    View topic image gallery

    20240404_222651 (resized).jpg
    20240404_223402 (resized).jpg
    20240404_222855 (resized).jpg
    17121539478418815343579935056223 (resized).jpg
    17121539335601964741750085965355 (resized).jpg
    20240403_101800 (resized).jpg
    20240403_101756 (resized).jpg
    20240403_101750 (resized).jpg
    20240403_101742 (resized).jpg
    20240403_101737 (resized).jpg
    17121531684032893567011650608271 (resized).jpg
    1712153119476185195429174783407 (resized).jpg
    #1 3 months ago

    Transporter the Rescue
    Sysyem 11b

    I'm stuck!! 2 issues but they may be related.

    1. During game, hold right flipper and activate left pop bumper = Tilt. So far no other combination causes tilt.

    2. Pressing either left or right flipper buttons causes all Flashers to momentarily flash.

    I installed a new interconnect board, checked all diodes (replaced diode on left pop, Plum Bob Tilt, and both coin slot switches [yes they are oriented correctly])

    Disconnected Grn/Gry from J8 CPU and wired a jumper from J8 pin 9 of the CPU (column 8 in switch matrix) directly to the first switch encountered (left pop). Fixes tilt issue, but bypassing the interconnect board means losing lane change and ability to enter initials.

    Also would like to verify that I wired the coin slot switches correctly. Signal wire (wht/yellow) to right lug, diode from right lug to left lug, and ground wire (grn/brown) to middle lug. BTW a previous owner spliced in New wires to coin slot switches (I verified continuity)

    Pulled and tested diodes (D1-D22) on aux power board, all passed (.5xx/OL)

    Replaced IC @ U40
    Replaced IC @ U19
    Replaced IC @ U45
    Replaced IC @ U50
    Replaced Transistors @ Q69/68, Q75/74, Q73/72, Q77, Q67, Q22/18

    Verified checksums ON ROMs

    I'm sure I've tried something else but I can't recall all my efforts to solve this.

    Any help would be appreciated.

    Need a specific picture? Just ask.
    1712153119476185195429174783407 (resized).jpg1712153119476185195429174783407 (resized).jpg17121531684032893567011650608271 (resized).jpg17121531684032893567011650608271 (resized).jpg17121539335601964741750085965355 (resized).jpg17121539335601964741750085965355 (resized).jpg17121539478418815343579935056223 (resized).jpg17121539478418815343579935056223 (resized).jpg20240403_101737 (resized).jpg20240403_101737 (resized).jpg20240403_101742 (resized).jpg20240403_101742 (resized).jpg20240403_101750 (resized).jpg20240403_101750 (resized).jpg20240403_101756 (resized).jpg20240403_101756 (resized).jpg20240403_101800 (resized).jpg20240403_101800 (resized).jpg

    #2 3 months ago

    Was your game working ok before but now it has this issue? You mentioned a new interconnect board - is it the same with both? I had trouble with a Gulf Pinball interconnect that had a design flaw. Maybe check if those are shorted across that board but it sounds like maybe the old interconnect had the same issue? I've also had shorted tilt switch diodes that have caused weird issues. The flashers all share transistors with coils and are switched by the relay - maybe something shorting at the relay? I'm grasping - weird issue.

    #3 3 months ago

    Broken. Sell to me.

    #4 3 months ago

    Thank to Matt Transporter can finally transport players to high scores! Matt helped me troubleshoot the issue and narrow it down to the diode on the ball 2 trough switch.

    I'm so grateful for his careful instructions and skillful diagnostics.

    #5 3 months ago
    Quoted from JoeChamp:

    Thank to Matt Transporter can finally transport players to high scores! Matt helped me troubleshoot the issue and narrow it down to the diode on the ball 2 trough switch.
    I'm so grateful for his careful instructions and skillful diagnostics.

    My pleasure....that was a fun one to diagnose! The art of troubleshooting has it's nuances!!

    Matt

    #7 3 months ago

    I am curious why did that diode cause all those issues?

    #8 3 months ago

    Well folks... it wasn't a fix.

    I replaced U38 last night (yes... I did it myself and it was not socketed! Before you say it... i did not have a socket to solder in.) Sadly this did not resolve the issue. I tested all the SRCs in the switch matrix and got correct values.

    I redid my test of the switch matrix to create the problematic condition using only jumper wires at the cpu header pins. Only this time I included a diode on the row end of my jumper wires.... to my surprise the cpu did not cause a tilt. This leads me back to the playfield. I've done an exhaustive amount of troubleshooting the playfield. But maybe I've missed something or one or more diodes are bad.

    BTW the condition that causes tilt is... during game play (cannot be replicated in switch edge test mode) HOLDING right Flipper button, a Ball sitting on the "Trough 2" switch, and simultaneously press the skirt on the left pop bumper = playfield tilt. This forms a box of switches on the matrix... I've checked/replaced all 4 diodes... I'll do it again today.

    20240404_222651 (resized).jpg20240404_222651 (resized).jpg20240404_222855 (resized).jpg20240404_222855 (resized).jpg20240404_223402 (resized).jpg20240404_223402 (resized).jpg
    #9 3 months ago

    Oh and the flasher issue was just that I had replaced all the Flashers with LEDs and a small amount of current from the A - C switching relay would momentarily light the flashers when pressi.g either flipper button. I installed incandescent flasher bulbs in place of the LEDs and the problem resloved.

    #10 3 months ago

    U40 looks a little crusty is that just dried flux on the board or corrosion?

    Usually a switch matrix issue like this is a diode issue on one of the 4 switches you are describing the classic setup of it with the switches in a bounded box. Double check that none of them are installed backwards - I think you're on the right path there with your plan. Maybe one is shorted against something (trough one?)

    Also looks like no solder made it up the PIA chip to the topside of the board or is it just your pic before you soldered it in? I think that the PIA was a red herring to replace - if you exercise all the inputs/outputs on a PIA and they work just not with your combination of switches, it's likely not the PIA.

    Reply

    Wanna join the discussion? Please sign in to reply to this topic.

    Hey there! Welcome to Pinside!

    Donate to Pinside

    Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!


    This page was printed from and we tried optimising it for printing. Some page elements may have been deliberately hidden.

    Scan the QR code on the left to jump to the URL this document was printed from.