(Topic ID: 195784)

Total Nuclear Annihilation Club...Welcome to the future!


By Pinballlew

2 years ago



Topic Stats

  • 6,819 posts
  • 506 Pinsiders participating
  • Latest reply 1 hour ago by razorsedge
  • Topic is favorited by 200 Pinsiders

You

Linked Games

Topic Gallery

There have been 1,071 images uploaded to this topic. (View topic image gallery).

IMG_9068 (resized).jpeg
20200526_171705 (resized).jpg
51X+nMkpnpL._SL1001_ (resized).jpg
shopping (resized).png
6cm 12v fan (resized).jpg
BC9021B7-4011-45A8-967C-016D1A72A9CB (resized).jpeg
20200516_175116 (resized).jpg
20200510_114848 (resized).jpg
20200510_110829 (resized).jpg
13A834AC-7357-4C55-AB0F-D615C57C00E7 (resized).jpeg
rgbCLAMP (resized).png
f900268df5b8b61a2546a83a95fcb208 (resized).jpg
20200522_185644 (resized).jpg
20200522_190953 (resized).jpg
20200522_190952 (resized).jpg
20200522_190943 (resized).jpg

Topic index (key posts)

22 key posts have been marked in this topic, showing the first 10 items. (Show topic index)

There are 6819 posts in this topic. You are on page 128 of 137.
13
#6351 52 days ago
Quoted from joelbob:

thenotrashcougar can you please explain:
- Added support for Danesi 2.0 shoot again timer (with RGB lights)
- Added support for new clear drop LED add-on

The hardware is not ready yet...... but......

Danesi 2.0 shoot again timer is a similar one to what I used in Rick and Morty. It has 2 bright ass LEDs to the left and right of the timer and is a drop in replacement for the existing one.

The clear drop support.... Well, there is an open connection on one of the PD-LED boards, so I mapped 3 of the LEDs so that people can add these 3 additional LEDs behind clear drops and they are fully integrated into the code and lightshows now.

I will post when the hardware is ready and I can put it up as a kit on the Pinball Life website once this shitty coronavirus thing is all back to normal.

#6352 52 days ago
Quoted from Cammy:

I guess I'm using the slam tilt term incorrectly lol.
I mean final tilt/ends your turn. So get two tilt warnings, then trigger the mystery cutscene, and during the cutscene, trigger a tilt.
Has happened to me sometimes when the bob hasn't settled.

You know, I tried this many times and was unable to replicate it. The tilt code is working correctly on my machine. I wonder if you maybe had an old version of the code and I fixed this a while ago? I am not sure. Has anyone else seen this happen?

#6353 52 days ago
Quoted from TheNoTrashCougar:

The hardware is not ready yet...... but......
Danesi 2.0 shoot again timer is a similar one to what I used in Rick and Morty. It has 2 bright ass LEDs to the left and right of the timer and is a drop in replacement for the existing one.
The clear drop support.... Well, there is an open connection on one of the PD-LED boards, so I mapped 3 of the LEDs so that people can add these 3 additional LEDs behind clear drops and they are fully integrated into the code and lightshows now.
I will post when the hardware is ready and I can put it up as a kit on the Pinball Life website once this shitty coronavirus thing is all back to normal.

I will be all over that. Awesome!

#6354 52 days ago

OK, I fixed a bunch of the reported things. I still am trying to figure out how to replicate the Mystery locking up on tilt issue as I do not see that on my machine. If anyone can give me more info on this, it would be greatly appreciated.

http://beta.tnapinball.com/

Changelog:
#################################################################
v1.4.0.b4 BETA - 04/04/2019 - Scott Danesi

## Bugs Fixed ##
- Modified sling logic to hopefully stop multiple hits
- Sling modifications to stop occasional sticking
- Fixed CoOp taking away reactor scores from previous players if additional players sneak in
- Fixed lag issue when replay triggered during reactor explosion
- Fixed score display dimming issue that randomly occurs
- Tilt bug fixed when ball falls into shooter lane after a tilt
- Fixed shaker not pulsing every time on ball lock
- Fixed Co-Op abort issue
- Ball search now disabled in service mode... oops
- Fixed Crash after game over in Co-Op with TA reactor < 9
- Fixed disabling coils on game abort via start button
- Fixed insert lighting issue with left targets on new ball start
- Fixed double hit on shooter switch issue
- Fixed certain settings not being saved when exiting service menu

## Features Added / Modifications ##
- Start button now constantly on when no credits are in the machine
- Added ability to hold down up and down buttons in service mode to scroll automatically
- New multiball GI colors added to service menu for the fluorescent green plastic protectors
- Reworded Bonus Credit After to "Bonus Credit After X Credits" in service menu
- Beepgate Update
- Mystery Goodness
- Added support for Danesi 2.0 shoot again timer (with RGB lights)
- Added support for new clear drop LED add-on
- All lightshows cleaned up
- Added Tilt Warnings to LCD
- Added utility for clearing coin audit info
- Significant LED performance improvements
#################################################################

17
#6355 52 days ago

I haven’t made it to reactor nine yet , can you fix that please ?

#6356 52 days ago
Quoted from TheNoTrashCougar:

Added support for Danesi 2.0 shoot again timer (with RGB lights)

thenotrashcougar Is this for both timers in the game?

#6357 52 days ago
Quoted from joelbob:

thenotrashcougar Is this for both timers in the game?

Just for the lower one. I will have the parts ready with the green displays and rgb lights soon. It does not make sense to put one in the core.

#6358 52 days ago

Just downloaded the beta code. Thanks Scott.

I noticed two things right away after booting up.

First thing was after updating the shaker motor intensity has gone up dramatically. Currently it was on the normal setting and it was extremely powerful. I tried changing it to the low setting and when I do the shaker motor does not turn on.

Not sure if this is a bug or something on my machine.

Second was just a question on the lights. When I have a reactor critical I noticed the destroy target lights are rapidly flickering compared to normal. Again not sure if this is a bug or not.

Pete

#6359 52 days ago
Quoted from Pmaino:

Just downloaded the beta code. Thanks Scott.
I noticed two things right away after booting up.
First thing was after updating the shaker motor intensity has gone up dramatically. Currently it was on the normal setting and it was extremely powerful. I tried changing it to the low setting and when I do the shaker motor does not turn on.
Not sure if this is a bug or something on my machine.
Second was just a question on the lights. When I have a reactor critical I noticed the destroy target lights are rapidly flickering compared to normal. Again not sure if this is a bug or not.
Pete

I didn't notice the shaker being stronger than normal, but I did notice the flickering critical reactor lights. Thinking the flicker might be an update?

#6360 52 days ago
Quoted from Pmaino:

Just downloaded the beta code. Thanks Scott.
I noticed two things right away after booting up.
First thing was after updating the shaker motor intensity has gone up dramatically. Currently it was on the normal setting and it was extremely powerful. I tried changing it to the low setting and when I do the shaker motor does not turn on.
Not sure if this is a bug or something on my machine.
Second was just a question on the lights. When I have a reactor critical I noticed the destroy target lights are rapidly flickering compared to normal. Again not sure if this is a bug or not.
Pete

The shaker should not have changed at all, but I will look into it. I did touch the code recently so I may have messed up something. As for the quicker flash of the critical kill shots, I made them flash way faster as I liked it, but it may be a bit too fast. Haha. I am just playing around and taking feedback from others while making changes.

#6361 52 days ago

OK, I just looked back through my notes. I think what happened with the shaker is that the new code reset you to "Normal" and in low setting, I might have overdone it and made it too weak. The low setting works on my machine, but that doe snot mean it will work on everyone's. I will fix this for the next version.
pasted_image (resized).png

#6362 52 days ago

Scott, or anyone I guess.

I'm trying to download the the new code and keep getting this:

drive.google.com refused to connect.

Is that my computer? I've never had an issue downloading the code before.

#6363 52 days ago

I got that error too, try it now. Seems to have not liked the URL mask I had on there. I removed that and it works now.

#6364 52 days ago
Quoted from TheNoTrashCougar:

OK, I just looked back through my notes. I think what happened with the shaker is that the new code reset you to "Normal" and in low setting, I might have overdone it and made it too weak. The low setting works on my machine, but that doe snot mean it will work on everyone's. I will fix this for the next version.
[quoted image]

thenotrashcougar Any way to just make that a number range selection like the coils? Then we can all fine tune it to our hearts content.

Mine on low now just barely shakes, I can hear it more than feel it. on Normal it's just a touch higher than I would like.

#6365 52 days ago
Quoted from TheNoTrashCougar:

I got that error too, try it now. Seems to have not liked the URL mask I had on there. I removed that and it works now.

Works now, thanks.

#6366 52 days ago
Quoted from BorgDog:

thenotrashcougar Any way to just make that a number range selection like the coils? Then we can all fine tune it to our hearts content.
Mine on low now just barely shakes, I can hear it more than feel it. on Normal it's just a touch higher than I would like.

Unfortunately I don't have it programmed like that. There are intensity low, med, and high intensity levels per level that would be confusing to expose in the service menu. I am going to post up a new version here today that should have the shaker issue fixed.

#6367 52 days ago

I’ve been playing the beta since last night. I like all the little changes to the light show! I changed multiball from green to blue and think it looks really great that way, especially with the pink protectors I have on the lower half. The one thing I noticed was that the main theme doesn’t “kick in” as fast as it used to when you put the ball in play. Otherwise looking good! I do miss the original “beep” a little bit.

#6368 52 days ago
Quoted from AndHart120:

I’ve been playing the beta since last night. I like all the little changes to the light show! I changed multiball from green to blue and think it looks really great that way, especially with the pink protectors I have on the lower half. The one thing I noticed was that the main theme doesn’t “kick in” as fast as it used to when you put the ball in play. Otherwise looking good! I do miss the original “beep” a little bit.

Good catch. You are absolutely right. I needed to accommodate a double switch hit on the shooter lane for some machines that bounce the ball into the shooter lane and the game needs to wait to watch for this before proceeding. It is an unfortunate side effect of this compensation. I could code around it, but for double hits, it would start the music too quickly and sound worse.

#6369 52 days ago

thenotrashcougar
thank you for continuing to support TNA - Its two years to the day that I got mine.

TNA 102 Just off the container from Chicago!
TNA 102 nstalled in the DOMINO Arcade!
I stream this game a lot and feed the screen into the computer, whilst I love the LCD score displays they are not the simplest thing to steam. I wonder if you might consider a streamers mode that puts the score on the screen, realise this may be a big piece of work but it would be fantastic.

Got my R&M order in and looking forward to it when this freaking virus is beaten.

Stay Safe.

Cheers,
Neil.

IMG_8426 (resized).PNGIMG_8430 (resized).PNG
#6370 52 days ago
Quoted from AndHart120:

I’ve been playing the beta since last night. I like all the little changes to the light show! I changed multiball from green to blue and think it looks really great that way, especially with the pink protectors I have on the lower half. The one thing I noticed was that the main theme doesn’t “kick in” as fast as it used to when you put the ball in play. Otherwise looking good! I do miss the original “beep” a little bit.

I agree I preferred the previous version of the theme tune.

#6371 52 days ago

thenotrashcougar Did you have a chance to fix the skill shot not activating when the previous game is aborted? I believe there were a few other issues reported a while back related to game restarts such as the shaker motor being stuck on.

Also while i got you here:
- why is the fluorescent pink protector kit not available in a full set like the green?
- is this the scoop used in TNA? https://www.pinballlife.com/scoop-weldment-assembly.html

#6372 52 days ago
Quoted from McSquid:

thenotrashcougar Did you have a chance to fix the skill shot not activating when the previous game is aborted? I believe there were a few other issues reported a while back related to game restarts such as the shaker motor being stuck on.
Also while i got you here:
- why is the fluorescent pink protector kit not available in a full set like the green?
- is this the scoop used in TNA? https://www.pinballlife.com/scoop-weldment-assembly.html

I did not like the pink protectors as much as the green, and yes, that is the scoop!

#6373 52 days ago

OK, so this next version of the software (v1.4.0.b5) includes a P3-ROC firmware update. This means that you cannot turn off the power to your machine when it says not to. Is there anyone that wants to test this for me before I put it out there to the public? I have only been able to test on my machine.

Please PM me.

Thank you!
--Scott

#6374 52 days ago

<deleted .. extra shaker strength settings dupe>

#6375 51 days ago

v1.4.0.b4 BETA

I have found that setting "coins per credit" to >1 seems to make the game reset later whenever I press the start button, after adding credits. (Although I did not try to play using credits with it set to 1)

I remedied this by selecting "factory settings", as switching the coin settings back to default did not fix the issue, even after resetting the game a couple of times.

I played a game no problems on factory settings. I changed the coin settings again, this time to 5 coins per credit, with 1 coin for left slot and 5 for right slot. Free play "No". Coins count correctly, and add credits as desired, but then pressing "start" causes a hard reset where the game goes black for a moment then reboots. Every time.

I did try switching free play to "yes" and back again, but "start" still reset the game. I power cycled and then set free play back to "yes", and played a free game. After the free game I switched back to "no" free play, and the game started and subtracted a credit. I then added some more credits, and the game reset again when pressing start.

Now it seems that I can only get a game to start with it set to Free Play.

Also notice something different with the "clear coin" function. After pressing "enter", the only way out seems to be to power off the game, unlike most other utilities. High score reset locks you in as well.

Games still start on free play, but not with credits, most of the time the machine reboots.

I'm going to re-install the package and see what happens.

P.s. Is it possible to make high score defaults adjustable (or maybe just a little lower) ?

*Updated. I re-downloaded and re-installed the package. The only thing I did was set "free play" to no, exit, add one credit at each slot. Start button reboots game.

Going to install released code and test.

**I have now installed v1.3 and everything works fine again..

#6376 51 days ago

Scott, I can beta if you need testers. If you need streamers, that's another story, though.

#6377 51 days ago
Quoted from razorsedge:

v1.4.0.b4 BETA
I have found that setting "coins per credit" to >1 seems to make the game reset later whenever I press the start button, after adding credits. (Although I did not try to play using credits with it set to 1)
I remedied this by selecting "factory settings", as switching the coin settings back to default did not fix the issue, even after resetting the game a couple of times.
I played a game no problems on factory settings. I changed the coin settings again, this time to 5 coins per credit, with 1 coin for left slot and 5 for right slot. Free play "No". Coins count correctly, and add credits as desired, but then pressing "start" causes a hard reset where the game goes black for a moment then reboots. Every time.
I did try switching free play to "yes" and back again, but "start" still reset the game. I power cycled and then set free play back to "yes", and played a free game. After the free game I switched back to "no" free play, and the game started and subtracted a credit. I then added some more credits, and the game reset again when pressing start.
Now it seems that I can only get a game to start with it set to Free Play.
Also notice something different with the "clear coin" function. After pressing "enter", the only way out seems to be to power off the game, unlike most other utilities. High score reset locks you in as well.
Games still start on free play, but not with credits, most of the time the machine reboots.
I'm going to re-install the package and see what happens.
P.s. Is it possible to make high score defaults adjustable (or maybe just a little lower) ?
*Updated. I re-downloaded and re-installed the package. The only thing I did was set "free play" to no, exit, add one credit at each slot. Start button reboots game.
Going to install released code and test.
**I have now installed v1.3 and everything works fine again..

Wow, that is pretty bad. Can you do me a favor and send me the log files via email that are on your flash drive? scott@scottdanesi.com. Something is definitely odd here.
--Scott

#6378 51 days ago

When will the danesi 2.0 timer be available and where?

#6379 51 days ago

Will be available on Pinball Life, but no idea when as we are not all in the office until the virus lets up. I will put up a post about it once they are up and ready.
--Scott

#6380 51 days ago
Quoted from TheNoTrashCougar:

Will be available on Pinball Life, but no idea when as we are not all in the office until the virus lets up.
--Scott

Uhhhh ...

I erased the flash drive, and the original download from my download folder. Re downloaded the Beta 1.4.0.b4, and installing that now. I will see what goes this time and if it repeats I will certainly save the files and forward to you.

bbs

#6381 51 days ago
Quoted from TheNoTrashCougar:

Will be available on Pinball Life, but no idea when as we are not all in the office until the virus lets up. I will put up a post about it once they are up and ready.
--Scott

Able to share a price range?

#6382 51 days ago
Quoted from TheNoTrashCougar:

Wow, that is pretty bad. Can you do me a favor and send me the log files via email that are on your flash drive? scott@scottdanesi.com. Something is definitely odd here.
--Scott

Okay, second fresh try around I managed to replicate it.

Switching around the values in the coin pricing settings worked fine initially, with various values. Games were starting and playing etc. and charging credits. I reset the coin audits. The machine is in a state requiring power off to reset. When the machine was booted again and in attract mode, start button reset game.

What is the proceedure for gathering the log from the game including these events?

Do you want me to try anything else before gathering the log?

*Atm Games play fine if set to Free Play.

#6383 51 days ago
Quoted from razorsedge:

Okay, second fresh try around I managed to replicate it.
Switching around the values in the coin pricing settings worked fine initially, with various values. Games were starting and playing etc. and charging credits. I reset the coin audits. The machine is in a state requiring power off to reset. When the machine was booted again and in attract mode, start button reset game.
What is the proceedure for gathering the log from the game including these events?
Do you want me to try anything else before gathering the log?
*Atm Games play fine if set to Free Play.

Oh no worries! I can replicate it here and see what is up. I have a feeling I know what it is. Just something I messed up.

#6384 51 days ago

Found the issue! It actually was an issue with the new warning notifications that I put in. Weird, huh? This will be fixed as soon as I can get a new version out. v1.4.0.b4 works fine on free play, not so much on coin op.

#6386 51 days ago

thenotrashcougar any change you can make a quick vid showing the clear drops light show and the timer LEDs?

#6387 51 days ago
Quoted from joelbob:

thenotrashcougar any chance you can make a quick vid showing the clear drops light show and the timer LEDs?

... and remember to change the RaM club thread title too!

#6388 51 days ago

I will post up a video of the LEDs soon. I am still working on some cool effects.
--Scott

#6389 51 days ago

Did anyone else watch DeadFlip’s 20 person Iron Maiden Steam? It looked to be a ton of fun as they were all competing with different challenges. Anyone want to try to set this up for TNA? I don’t have a multi cam streaming setup but could easily do a single cam Zoom call.

#6390 51 days ago
Quoted from joelbob:

Did anyone else watch DeadFlip’s 20 person Iron Maiden Steam? It looked to be a ton of fun as they were all competing with different challenges. Anyone want to try to set this up for TNA? I don’t have a multi cam streaming setup but could easily do a single cam Zoom call.

Im in. no idea how to set it up though

#6391 51 days ago

I think a simple Zoom call would be enough. No need to stream or anything. Just get a bunch of people all in a call together.

#6392 49 days ago
Quoted from Pmaino:

First thing was after updating the shaker motor intensity has gone up dramatically. Currently it was on the normal setting and it was extremely powerful. I tried changing it to the low setting and when I do the shaker motor does not turn on.

I've found that changing the shaker power and the trough kickout power (on older code, at least) don't seem to take effect right away after you set them. I forget but either requires you to play a ball or power cycle.

#6393 49 days ago
Quoted from mrgregb123:

I've found that changing the shaker power and the trough kickout power (on older code, at least) don't seem to take effect right away after you set them. I forget but either requires you to play a ball or power cycle.

This has been corrected in the new Beta. There were a few settings that were not getting refreshed properly without a restart. Try the latest beta on beta.tnapinball.com and please let me know if you see anything else weird. Thank you beta tester so much!
--Scott

#6394 49 days ago

My score ended in 92. I know the 2 is how many reactors I destroyed but does the 9 mean anything? I can’t remember if 10s meant anything in the old code.

#6395 49 days ago
Quoted from joelbob:

My score ended in 92. I know the 2 is how many reactors I destroyed but does the 9 mean anything? I can’t remember if 10s meant anything in the old code.

Tens is for match. 9x = 90

#6396 48 days ago

OK the next Beta version is ready for those that want to test (1.4.0.b8). I added another cool lightshow to the attract mode.

beta.tnapinball.com

As always, please let me know if you see anything weird. Thank you!
--Scott

#6397 48 days ago

thenotrashcougar
1. I like how the new reactor shot flashes between white and red. I like that much more than when it was just flashing white.
2. I do like the new lock light animation but the flashing white might be better if it either just pulsed green instead of white, or alternated between green and white.
3. Has your score always blinked while it was your turn? If so I have never noticed this. I find it slightly distracting and not necessary for a 1 player game
4. Love the new lightshow in attract mode.

Overall I'm loving these new code updates!

#6398 48 days ago
Quoted from TheNoTrashCougar:

OK the next Beta version is ready for those that want to test (1.4.0.b8). I added another cool lightshow to the attract mode.
beta.tnapinball.com
As always, please let me know if you see anything weird. Thank you!
--Scott

Ima install it right now.

#6399 48 days ago

Thank you! I can always tweak these lightshows. Something to keep an eye out for is missed lock attempts. There was a rare occasion that a ball lock would not happen due to the reaction time of the lock logic. I think I have fixed this, but let me know if any of you see it. Thank you!

#6400 48 days ago

Loving that TNA code is getting some love lately! Question, if I install the beta code will I lose my audits?

Promoted items from the Pinside Marketplace
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 25.00
From: $ 6.00
Playfield - Protection
Pin Monk
$ 265.00
$ 134.95
Lighting - Other
Hookedonpinball.com
$ 11.95
$ 119.95
Playfield - Toys/Add-ons
Hookedonpinball.com
$ 17.50
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 399.95
Lighting - Led
Pin Stadium Pinball LEDs
There are 6819 posts in this topic. You are on page 128 of 137.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside