(Topic ID: 132316)

Tommy problems


By Iceman

5 years ago



Topic Stats

  • 2 posts
  • 2 Pinsiders participating
  • Latest reply 5 years ago by Hawk007
  • Topic is favorited by 2 Pinsiders

You

Linked Games

#1 5 years ago

Hi everyone. My Tommy is acting up. I just replaced the battery holder due to acid damage. But now when I turn the game on it starts up with the version of the pin then it goes blank for a few seconds. Then it will only show 3rd and 5th place scores on the screen. Its very slow when I go into test mode. I do see acid on the cpu long chip under the battery but that never affected the game before. Any advise on what I should do? It worked fine last week when I installed the pinsound board.

#2 5 years ago

OOOOoooooo Bummer. What you have is acid damage my friend. Can you post a picture of the affected areas? Then we can let you know the best course of action. You at the very least need to remove the board from the game and replace all affected components with new ones after cleaning and neutralizing the board of all the alkali from battery leakage.
Good luck and I hope its not too bad.

Promoted items from the Pinside Marketplace
$ 24.95
Playfield - Toys/Add-ons
ULEKstore
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 54.99
Cabinet - Shooter Rods
Lighted Pinball Mods
$ 50.00
$ 19.00
$ 28.00
Lighting - Other
Rock Custom Pinball

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside