(Topic ID: 135409)

TOM Trunk Error - Leon's Fix. NOW AVAILABLE, SEE POST #225


By EvanDickson

4 years ago



Topic Stats

  • 754 posts
  • 203 Pinsiders participating
  • Latest reply 9 days ago by Migor
  • Topic is favorited by 60 Pinsiders

You

Linked Games

Topic Gallery

There have been 201 images uploaded to this topic. (View topic image gallery).

B8989610-FE1D-411F-8A39-0917BA32624E (resized).jpeg
20190217_124203 (resized).jpg
IMG_5877 (resized).JPG
image (resized).jpg
Trunk Opto Board Cable (resized).JPG
Cable (resized).jpg
20181208_130847 (resized).jpg
20181208_130824 (resized).jpg
20181208_130808 (resized).jpg
20181123_121557 (resized).jpg
20181123_115252 (resized).jpg
ToM 6 Billion (resized).jpg
20180224_195318 (resized).jpg
mould.pdf (PDF preview)
IMG_3529a (resized).jpg
trunk_board_installed (resized).jpeg

Topic index (key posts)

18 key posts have been marked in this topic (Show topic index)

There are 754 posts in this topic. You are on page 12 of 16.
#551 3 years ago
Quoted from fiberdude120:

I spoke with him sunday and he was mailing things out. I payed for my board a couple of weeks ago and he said it would take a couple of weeks before he shipped. So for me he is right on time.

Thanks. He mentioned a waiting time of a couple of weeks but because I got no reply I got a bit nervous But we'll have some more patience!

#553 3 years ago

This is a great thread! I did this and it made a HUGE difference!Thanks!

#554 3 years ago

Got the board and installed it. Works great! Thanks!

1 week later
#555 3 years ago

Installation took minutes and works perfectly. This is a great addition to the game!

Thanks Ingo!

1 month later
#556 3 years ago

Hello everyone! So as the pic shows I have replaced everything (including motor) and am getting the 'trunk error' message. I think my issue is in the trunk control board or the L6203 specifically. Due to the fact that when I turn the trunk it will stop prematurely before the opto is closed. Then I have to hit the switch again to close the opto. Everything was working before I cleaned the G/B and replaced the old parts with new. But there were other issues I had prior that have since been fixed now I'm down to this last issue.

I hope this is a good place to post as I am using the Leon board but still getting a error.
Thanks.

image (resized).jpeg

1 week later
#557 3 years ago

Have a problem with mine. Under the trunk test the game is reporting a trunk error. In trunk test, trunk barely moves.

Looking under the game, the motor is stuck powered on trying to go counter clockwise (perspective from the underside of the playfield). I unplug the motor cable from the Leon board and rotate it with my hand. All optos register in switch test and trunk test. Trunk eddy registers. Opto interruptor set screw is in the indentation in the trunk post which aligns with the trunk hole at the top. As soon as I plug the motor in it tries to go CCW and never stops on any opto.

No matter what I do, whenever I plug the trunk motor in, it rotates counter clockwise. I plug the motor directly into the motor controller board and it still wants to rotate CCW. The LED on the motor controller board is always on. Try rotating the interruptor to each opto to see if it will stop and no dice. As soon as I plug the motor board into the Leon board, I hear the relay click and the red one LEDgoes on for a split second then turns off and the green LED stays lit. Never had this issue before. Any ideas?

Based on the latter, perhaps it's a bad motor controller? I noticed there was a tiny scratch at the top of the 14 pin IC, but nothing that should affect it. And again, before I put in the Leon board, had zero trunk issues.

IMG_20160908_222149 (resized).jpg

#558 3 years ago

1st you want to know if the bi-dir-motor-board is controlled by the CPU/Powerdriverboard or the the bi-board has failed.

Unplug J126 from PDBoard and check if the LED goes OFF on the LEON-board.
If the motor-activity LED stays ON, the problem is on the bi-dir-motor-board

#559 3 years ago
Quoted from dudah:

Have a problem with mine. Under the trunk test the game is reporting a trunk error. In trunk test, trunk barely moves.
Looking under the game, the motor is stuck powered on trying to go counter clockwise (perspective from the underside of the playfield). I unplug the motor cable from the Leon board and rotate it with my hand. All optos register in switch test and trunk test. Trunk eddy registers. Opto interruptor set screw is in the indentation in the trunk post which aligns with the trunk hole at the top. As soon as I plug the motor in it tries to go CCW and never stops on any opto.
No matter what I do, whenever I plug the trunk motor in, it rotates counter clockwise. I plug the motor directly into the motor controller board and it still wants to rotate CCW. The LED on the motor controller board is always on. Try rotating the interruptor to each opto to see if it will stop and no dice. As soon as I plug the motor board into the Leon board, I hear the relay click and the red one LEDgoes on for a split second then turns off and the green LED stays lit. Never had this issue before. Any ideas?
Based on the latter, perhaps it's a bad motor controller? I noticed there was a tiny scratch at the top of the 14 pin IC, but nothing that should affect it. And again, before I put in the Leon board, had zero trunk issues.

Put the old board back in and see if the problem persists? Check the condition of all/any IDC connectors.

#560 3 years ago
Quoted from pinballinreno:

Put the old board back in and see if the problem persists? Check the condition of all/any IDC connectors.

They all look good on the playfield end, didn't check the driver board. The old board only does the optos which that aspect is working fine. I'm suspecting the motor control board at this point. However, it's very strange that this happened right after installing the Leon board. Game is at a buddy's house, will investigate.

#561 3 years ago

There is a piece of GI-wire under the motor control board. Can you verify if that doesn't make contact to the PCB

1 month later
#562 2 years ago

As the trunk-combo-boards were all sold out, I was asked from many people, if I could make a new run of pcbs.

OK, I did and ordered 50 new boards, 18 are already sold.

Board is the same without any changes, only silkscreen is 10/2016 (October 2016)

Trunk Opto Board Oktober 2016 (resized).jpg

Trunk new boards (resized).jpg

#563 2 years ago
Quoted from german-pinball:

As the trunk-combo-boards were all sold out, I was asked from many people, if I could make a new run of pcbs.
OK, I did and ordered 50 new boards, 18 are already sold.
Board is the same without any changes, only silkscreen is 10/2016 (October 2016)

Just placed my order! My TOM eagerly awaits ...

P1200353 (resized).JPG

1 week later
#564 2 years ago

I have installed the "Trunk opto-board with Leon integrated" but occasionally the trunk gets stuck in a position between two correct positions (see image). The trunk test works as it should. Any suggestion what to do?

Stuck (resized).JPG

#565 2 years ago
Quoted from nibre:

I have installed the "Trunk opto-board with Leon integrated" but occasionally the trunk gets stuck in a position between two correct positions (see image). The trunk test works as it should. Any suggestion what to do?

Is your opto interrupter ring damaged / cracked or is it loose? I could see this causing issues with trunk position.

#566 2 years ago

Ordered my board in the first batch and just installing it now. I seem to have misplaced my 4 wire cable coming from the eddy board to the new board. I have the necessary parts to make my own, I just need the pin out if someone could help me with that. Thanks in advance.

#567 2 years ago
Quoted from GreenMachine19:

Ordered my board in the first batch and just installing it now. I seem to have misplaced my 4 wire cable coming from the eddy board to the new board. I have the necessary parts to make my own, I just need the pin out if someone could help me with that. Thanks in advance.

Does this help?

https://pinside.com/pinball/forum/topic/tom-trunk-error-leons-fix-anyone-done-this/page/3#post-2656974

https://pinside.com/pinball/forum/topic/tom-trunk-error-leons-fix-anyone-done-this/page/3#post-2661404

https://images.pinside.com/3/de/3de49416c5ef6385fc7390eac5fd3d78c80aa1e3/resized/large/3de49416c5ef6385fc7390eac5fd3d78c80aa1e3.jpg

If you want, I could send you a new cable ...

#568 2 years ago

Installed, works like a charm! Also new cables and aluminium opto interrupter. Should be pretty bulletproof for awhile

IMG_20161106_131110 (resized).jpg

#569 2 years ago

That's perfect thank you I can just make the cable. I searched everywhere and couldn't find it.

#570 2 years ago
Quoted from GreenMachine19:

That's perfect thank you I can just make the cable. I searched everywhere and couldn't find it.

My wife packed both cables in an aluminium foil, look, mightbe, you can still find it ...

#571 2 years ago

I've give up the search and made a new one. Thanks for the support my shop is a mess I bet I will find it later after the machine is completely back together.

#572 2 years ago

Can't wait to receive mine, hopefully it shows up soon

1 week later
#573 2 years ago

Just ordered a trunk-combo-board from Ingo. The best on the market. Make sure if you need one to order before he is out of stock. I am very much looking forward to receiving it. I am going through my TOM adding new plastics, ramps, powder coating and the like. The machine is in great physical condition - just neglected some. This should be the last piece I need to finish this project!

2 weeks later
#574 2 years ago

I just donated a set to Free Gold Watch in San Francisco. They added a ToM and weren't using it in tournaments because of the trunk issues. I should have anticipated the cracked opto interrupter, but this will work for now. Once again, thanks german-pinball for the excellent work.

IMG_4085 (resized).JPG

#575 2 years ago

Payment send for a combo with attached. Bought one prior and should have bought a spare. Wasn't missing a second chance to get a spare at a great price. Thanks Ingo

#576 2 years ago

Combo with tester ordered, will be nice for a rainy day thank you!

1 week later
#577 2 years ago

Ordered one on 11/8 after exchanging some pinside mail that the board was available, haven't heard anything since then. Tried pinging through pinside mail if there was a tracking #, unexpected delay, etc. but no response. Has anybody else been in touch recently? Hope everything is ok.

#578 2 years ago
Quoted from MrKegFlex:

Ordered one on 11/8 after exchanging some pinside mail that the board was available, haven't heard anything since then. Tried pinging through pinside mail if there was a tracking #, unexpected delay, etc. but no response. Has anybody else been in touch recently? Hope everything is ok.

Same here. I ordered a few weeks ago and was promised shipping info. I pinged Ingo a few days ago but no response. Hopefully all is well with him.

#579 2 years ago

I had the same fears about the no update or "radio silence" after 6 weeks or so but the board came in. It installed easily and works great. Don't worry too much I'm sure it will show soon. I think it just takes time to hit the states. When mine got to the us I got a tracking update email but like I said it was 5-6 weeks or so

#580 2 years ago
Quoted from MrKegFlex:

Ordered one on 11/8 after exchanging some pinside mail that the board was available, haven't heard anything since then. Tried pinging through pinside mail if there was a tracking #, unexpected delay, etc. but no response. Has anybody else been in touch recently? Hope everything is ok.

Quoted from xfassa:

Same here. I ordered a few weeks ago and was promised shipping info. I pinged Ingo a few days ago but no response. Hopefully all is well with him.

All is good guys, no fear please!!!

But I was very very busy the last weeks and try to satisfy all orders, so sorry for some delay.

@ MrKegFlex:
Your board has been shipped yesterday, I will send you USPS tracking-number via PM now.

xfassa:
Your board is not yet ready soldered, but it will be the next to be shipped in 1-2 days, tracking number follows ...

- Ingo

1 week later
#581 2 years ago

I recent acquired a TOM. I only played it enough to diagnose problems. I finally got it 100% functional (AFAIK). So I played my first couple of games with the glass installed. On my second game (literally!) I hit the bug. Prior to owning the game, I wasn't even aware that this was a problem. I am looking forward to my new board. Thanks Ingo.

#582 2 years ago

are you all replacing the opto interrupters when replacing board? are the originals black plastic and repolacements aluminum?
thanks to all!

#583 2 years ago
Quoted from robotron:

are you all replacing the opto interrupters when replacing board? are the originals black plastic and repolacements aluminum?
thanks to all!

The new ones are aluminum.

#584 2 years ago
Quoted from fiberdude120:

The new ones are aluminum.

Where to order one of these? I checked the usual suspects and came up empty.. Unless I missed it! :/

#585 2 years ago
Quoted from Radius118:

Where to order one of these? I checked the usual suspects and came up empty.. Unless I missed it! :/

german-pinball's board you order directly from him. If you're asking about the aluminum opto interrupter, you can get it from a number of places:

http://www.marcospecialties.com/pinball-parts/03-9318-M

#586 2 years ago

anyone heard from Ingo- want to order one of the boards, anyone got an email for him?

many thanks & happy new year.

Neil.

#587 2 years ago
Quoted from NeilMcRae:

anyone heard from Ingo- want to order one of the boards, anyone got an email for him?
many thanks & happy new year.
Neil.

see post 580 above in this thread.

1 week later
#588 2 years ago

few boards left pm ingo if you need one.

#589 2 years ago

I ordered one in December and have not heard back regarding the status. Any news Ingo? Thanks!

#590 2 years ago

Just ordered mine. Ingo said it would be 2-3 weeks to solder. You should be getting close!

#591 2 years ago

got a im from ingo. ordered and paid for combo board. he says he only has a few left. get in while you can! thanks for making these!

#592 2 years ago

Ingo, please respond to my PM. Thank you.

#593 2 years ago

Payment sent for Trunk opto board with Leon Integrated.

Get them while you still can!
Thanks again for making this fix Ingo!

#594 2 years ago

+1 got one too

#595 2 years ago

OK. I guess I'll stand by with the rest of you all and hope for the best. I've politely asked for multiple updates via PM, no response... not mad or anything but a simple ETA would be nice.

#596 2 years ago
Quoted from GorillaBiscuits:

OK. I guess I'll stand by with the rest of you all and hope for the best. I've politely asked for multiple updates via PM, no response... not mad or anything but a simple ETA would be nice.

Done mate, sorry for the bad communication with you ...

#597 2 years ago

No worries, thanks for getting back to me. Glad to hear I'm next! And thanks again for stepping up to make these.

#598 2 years ago

Took me awhile to finish my ToM resto. The board works great. Haven't had a single hang up since the game has been back together. Thanks again.

#599 2 years ago

I'm looking to buy one as well...Ingo...I sent you a PM!

#600 2 years ago

Payment sent for full Opto Board, and Leon's fix soldered! Thank Ingo!!! Can't wait to hit that trunk!!!

Daniel

Promoted items from the Pinside Marketplace
From: $ 233.10
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 32.99
Lighting - Interactive
Lee's Parts
There are 754 posts in this topic. You are on page 12 of 16.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside