(Topic ID: 170047)

TOM Theatre of Magic Trunk Woes


By Arcadegarage

2 years ago



Topic Stats

  • 44 posts
  • 10 Pinsiders participating
  • Latest reply 1 year ago by Arcadegarage
  • Topic is favorited by 7 Pinsiders

You

Linked Games

Topic Gallery

There have been 18 images uploaded to this topic. (View topic image gallery).

image (resized).jpg
image (resized).jpg
image (resized).jpg
image (resized).jpg
IMG_0328 (resized).JPG
IMG_0327 (resized).JPG
IMG_0326 (resized).JPG
IMG_0325 (resized).JPG
IMG_0324 (resized).JPG
image (resized).jpg
image (resized).jpg
image (resized).jpg
image (resized).jpg
image (resized).jpg
image (resized).jpg
image (resized).jpg

#1 2 years ago

Trunk is giving me trouble. In test mode, the trunk starts off really slow and then picks up after a few tries and acts fluidly. It consistently overshoots and errors in test mode. When it errors, it won't let you go left or right, then it randomly does allow you to begin the process again. Sometimes the trunk spins endlessly. The new interruptor disc does have slight play, meaning that you can move it by hand slightly after it has stopped moving, but it's not enough to bring back to the sensor so I can't imagine that being too much play.

When playing a game, the trunk doesn't move at all sometimes. After it's ready to start an illusion and you put the ball in the trunk hole, nothing happens except the ball keeps getting kicked out of the trap door.

We replaced the trunk opto board with a new one from Great Lakes Modular. New stainless opto interruptor from Marco too. Took apart the entire trunk and looked at the gears...no missing teeth. Had plenty of greased and we added some for good measure. I'm running the latest software (1.3X I think) and put electrical tape over the eddy sensor board LED (as others said that could throw off the trunk).

Adjusted all eddy sensors on the pf since some were slightly off. Probably has nothing to do with the trunk but wanted to get it all going.

What's next? Trunk stop? Trunk motor? Trunk gear box? Trunk board?

image (resized).jpg

image (resized).jpg

image (resized).jpg

#3 2 years ago

Shot in the dark reseat ribbon cables in backbox

#4 2 years ago

Reseated. No change.

#5 2 years ago

Have you tried opening up the motor cleaning out and re-greasing the gears?

#6 2 years ago

Sounds like board or connection kinda hmmmmmm

#7 2 years ago

Yes, have opened the gear box and regreased.

#8 2 years ago

Saturday morning bump...

#10 2 years ago

He doesn't know how to read

#11 2 years ago

Make sure the opto interruptor is lined up properly with the optos. Test each of the 4 optos is working in switch test. Make sure the interruptor is lined up on the shaft properly (you can see this in trunk test and the DMD will show which side of the trunk should be facing front).

Could also be the dual motor drive board. I had an optointerruptor just go bad in mine, causing the trunk to always be spinning in one direction. I documented the fix here -https://pinside.com/pinball/forum/topic/tom-trunk-dc-motor-control-board-issues-a-16120

The same board is in your MB. Swap em out and test.

If it's the board/optointerruptor I'll gladly fix it at no cost.

1 week later
#12 2 years ago

Swapped the board with my MB. No change.

Then I noticed the wires were loose in the 4-prong connector (with only 2 wires) and both wires popped out so I replaced the connector. No change. Gets power because the red light on the board is on.

One wire to the motor broke off so I soldered that back on. No change.

The interruptor seems fine.

The trunk doesn't like to start up in trunk test. Needs a manual push. The it gets smoother and smoother, but still misses the stops, sometimes spins endlessly, and always shows an error on the dmd.

What's next?

#13 2 years ago

Bump......

#14 2 years ago

Should it spin endlessly? When my opto interruptor went bad it was turning one way constantly but it can only rotate 270 degrees due to the cotter pin stuck in the shaft. Check that... As for the push/speed, perhaps the gears are starting to strip? How did the gearbox look when you regreased it?

Otherwise your symptoms sound super weird and erratic. If you haven't already, I'd try reset to factory defaults on the ROM, I've heard of other weird issues being fixed this way.

#15 2 years ago

Never tried doing a factory reset. That must be an option in the menu though. I could try that.

The interruptor is brand new so I think we can rule that out as being bad, unless it's somehow not 100% installed on there. You can wiggle it a quarter inch or so when it's stationary. Is that normal for that piece or should it be adjusted?

The speed sounds like either a motor or gear issue to me. I'm about to order the next part. Just not sure which. The motor is cheap, but the gearbox is expensive. The gearbox looked fine when we saw it. No missing teeth. We regreased too.

#16 2 years ago

You shouldn't be able to move the interruptor. Hoping you got the metal one. Either way, the set screw should be screwed into the dimple in the trunk shaft so it's properly aligned.

#17 2 years ago

Have the metal interruptor, yes. Ok, so I'm gathering the fact that the interruptor can slightly wiggle is throwing it off and that's part of the problem. I'll try and readjust.

The trunk crawling in the beginning and then getting up to speed sounds mechanical to me. Either motor or gearbox, but I really am just guessing.

#18 2 years ago

K's arcade had the motor available. Not sure if still does. If you've already disassembled, cleaned and regreased the gearbox I assume you inspected and everything looks good. Or maybe the voltage to the motor doesn't have even starting current to get it moving until you help it?

#19 2 years ago

I think you have a bad trunk board and bad motor. Regardless of the speed, if it's not stopping at the right points, that's indicative of an optic issue on the board. Does the board work in test mode? All optos are registering open and closed? Tighten that interruptor.

Else, I'll give ya 4K for it.

#20 2 years ago
Quoted from Pinphila:

I think you have a bad trunk board and bad motor.

Sure it wasn't who installed it in the first place? We were drinking that day.

I'll take a vid of the rest and post it. Thanks, guys.

#21 2 years ago

Here's a video I took of me turning it on and putting the trunk in test mode.

After turning the game on the first time, the trunk didn't move. After the second, the trunk crawled. After the third, which is the above video, the trunk started to move. I put it in test mode and it moved pretty well, but still missed its marks and showed errors all the way around. It didn't spin endlessly like usual which is interesting. You can hear me though trying to get the trunk to turn by pushing buttons but it won't go, so I have to turn it around and have it move the other way.

Here's one of the opto interruptor, boards, and trunk motor. The interruptor has slight play.

Here's a video of the trunk in test mode erroring like crazy and spinning endlessly without my holding anything.

And finally, the trunk gets stuck. Sometimes, not in this movie, it allows you to put the hole in the trunk but doesn't advance forward. It just continually spits the ball out from the trap door if you continue to shoot the ball in the trunk.

#22 2 years ago

Good info. On that last video, you're in a mode so the trunk won't turn.

Very weird. I'd make sure your CPU>driver board ribbon cables are secured, worth trying swapping it with another one.

Any luck on the factory reset? Get the 1.4H ROM if you can.

It seems that the trunk only rotates clockwise (top perspective), is this true? Same results with the other motor control board? How it keeps going on it's own HEAVILY makes me suspect the motor board. Especially because the switches all trigger, but the trunk keeps moving. Mine also had a leaky cap. Motor board look OK? Any corrosion on any parts?

#23 2 years ago

I did the factory reset and swapped out the ribbon cable from driver to CPU from my MB. No change.

I should clarify that the play of the opto interruptor that I showed in a vid last night is not with the interruptor, but the shaft itself has that play. Not sure if that's normal or not.

I posted some pics below of the boards. No visible damage or leaky caps.

image (resized).jpg

image (resized).jpg

image (resized).jpg

image (resized).jpg

image (resized).jpg

#24 2 years ago

Why not put some junk in the trunk?

#25 2 years ago

My truck would go slow on start up and eventually start spinning faster in test mode. I reworked the gear box with new grease after a good cleaning. Nothing changed. I tried a new motor, same issue. As a rare instance, my gear box was bad. It weakened the motor even.. so a new gear box and motor and everything is good again. Sucks its so expensive!

#26 2 years ago

I just can't imagine what else it could be except the mechanical side. The board doesn't seem to be bad. Maybe the trunk can't stop with the amount of play in the shaft of the trunk. The gears being slow sound like a mechanical problem either with the gears, the motor, or both.

I don't want to pay the $200-300 for one but do we think we've narrowed it down to that?

Where did you buy your gearbox and motor?

Does anyone rebuild and sell instead of having to buy new?

#27 2 years ago

Your missing the pin which keeps the trunk from doing a 360. You will also twist the trunk wires into a knot. Also look at trunk rotation when in test, make sure trunk is turning clock wise when it indicates it should turn clockwise, if it turn counter clockwise swap leads on the motor as it is not turning the correct direction and confusing the CPU.

#28 2 years ago

You mean this? Marco's website says this is a stop. Didn't realize I was missing parts.

So that could fix the endless spinning problem. Could it fix the other problems too?

image (resized).jpg

#29 2 years ago

I ordered from Marco..

http://www.marcospecialties.com/pinball-parts/14-8018

I have no idea if this will fix your problem but your slow startup issue is similar to what I had and it fixed mine.

#30 2 years ago

Yes, that stop is missing. Did you verify the trunk direction is in sync with screen during test.

#31 2 years ago

Arcadegarage
About a year ago there was a link regarding same problem.

https://pinside.com/pinball/forum/topic/tom-trunk-wires-twist-and-brake

It my also help you.

#32 2 years ago
Quoted from dudah:

it can only rotate 270 degrees due to the cotter pin stuck in the shaft. Check that...

#33 2 years ago
Quoted from Out-West:

Yes, that stop is missing. Did you verify the trunk direction is in sync with screen during test.

Yes, the trunk is in sync.

1 month later
#34 2 years ago

Hey guys, ordered a total rebuild of the trunk.

-Installed new gearbox and motor. The old gearbox was definitely bad. The new gearbox doesn't crawl like the old.
-Installed new trunk stop.
-Installed new trunk cable.
-Played around with getting the trunk to Home, in all positions. Did trunk test in menu.
-Played around with the positions of the opto interruptor on the shaft. The dimple on the shaft of the new gearbox doesn't seem to be in the right place. It sits lower on the shaft and the interruptor just above it. Not sure if this matters.
-Tested the motor board and swapped it out with my MB. Board ok.
-Did not test the opto board but it is newer from Great Lakes modular. The optos register but the trunk continually goes passed each opto.
-Was thinking of swapping out the CPU and roms with my STTNG. Would this do anything?

Has the same problems as before. Trunk continually misses it's mark and ends up being 90 degrees off. Can't play a game with the trunk all messed up like that.

What has changed is:

-The trunk moves quickly and without warmup
-The new gearbox and motor sound strong
-The stop prevents the trunk from twisting endlessly

What's next?

#35 2 years ago

During test was trunk turning direction as noted on dmd?

#36 2 years ago

Yes.

The diagram showing what position the trunk should have been in was wrong.

#37 2 years ago

Weekend bump...

7 months later
#38 1 year ago

I revisited this game now that I have more time. I switched the red and black wires on the motor and guess what it works! So anyone having these problems check that out!

Ok, so I play the game to give it a test run and it looks like I'm having problems with the center targets. The ball goes into the trunk and just gets spit out the trap door. No credit dot, eddy sensors are fine.

I press the right target and it registers 2 things: center ramp targets and trough 1. The left target doesn't register at all. Underneath the pf the wiring looks weird. Can you guys have a look? There are diodes and the targets don't look to be wired right. What's it supposed to look like?

And could fixing this issue fix the rest?

Thanks!

IMG_0324 (resized).JPG

IMG_0325 (resized).JPG

IMG_0326 (resized).JPG

IMG_0327 (resized).JPG

IMG_0328 (resized).JPG

#39 1 year ago

Does anyone have a picture of the underside of their pf in this area they could share? The IPDB pic is old and unfocused. Thanks!

1 week later
#40 1 year ago

Begging please for some pics of the underside of your pf.

#41 1 year ago

It looks like the diode on the left standup target in front of the center ramp is on wrong.
Here's mine

image (resized).jpg

#42 1 year ago

Wiring to the right target looks messed up also.

#43 1 year ago

image (resized).jpg

image (resized).jpg

image (resized).jpg

1 week later
#44 1 year ago

The miswiring of the targets was the reason why the game wasn't starting the illusion but only ejecting the ball from the trap door. It was linked to an opto and opto problems with this game and STTNG make things go haywire.

The miswiring of the motor and the missing stop was the problem with the trunk. I bet the original gearbox and motor were fine but I'm super happy with a new trunk overall. Who wouldn't be?

Game works 100% now! I hope this thread can help others as well. Thanks for all the help everyone!

Promoted items from the Pinside Marketplace
$ 32.99
Lighting - Interactive
Lee's Parts
5,800 (OBO)
Machine - For Sale
Mountain View, CA
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
$ 50.00
Wanted
Machine - Wanted
New York City, NEW YORK
$ 235.00
Lighting - Interactive
Professor Pinball
$ 11.95
$ 45.00
Gameroom - Decorations
Pinball Photos
$ 8.50
Lighting - Led
Bright Lights Pinball
6,900 (OBO)
Machine - For Sale
Huntington Beach, CA
From: $ 16.95
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 109.99
$ 99.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 109.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
$ 55.00
Gameroom - Decorations
Pinball Photos
From: $ 29.00
Boards
KAHR.US Circuits
6,500
Sale Pending!
Advance, NC
$ 55.00
Gameroom - Decorations
Pinball Photos
$ 129.00
Lighting - Led
LED OCD
$ 29.50
Playfield - Plastics
Bright Lights Pinball
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside