(Topic ID: 297034)

ToM Opto Board troubleshooting

By CTDnEUG

10 days ago


Topic Heartbeat

Topic Stats

  • 23 posts
  • 5 Pinsiders participating
  • Latest reply 2 days ago by Roamin
  • Topic is favorited by 2 Pinsiders

You

Linked Games

Topic Gallery

View topic image gallery

IMG_4707 (resized).JPG
IMG_4710 (resized).JPG
IMG_4708 (resized).JPG
IMG_4709 (resized).JPG
Screenshot_20210719-174707_Adobe Acrobat.jpg

#1 10 days ago

I'm working on a Theatre of Magic that suddenly exhibited the "Ground Short Row 1 Is Stuck Closed" error on startup. Switch edge test revealed that it was Row 1, Row 4, Row 5, and Row 6 all locked on.
Fuses all test good.
I disconnected J207, J209, and J212 and the problem disappeared. Additionally, I jumpered between J207 and J209 pins, and the switch matrix worked perfectly. This made me suspect the 7-opto board. I re-connected J207, 209, 212 and disconnected J3 on the opto board, and the problem disappeared.
So ... this board is available for $75, but I'd rather repair if possible. How do I go about troubleshooting this board? I have limited experience with board repairs, but a little bit. I have a multimeter and soldering setup.
Thanks for any guidance!

#2 9 days ago

I know I will probably need to replace one or both of the LM339 chips. I really just need to know how to determine which one to replace. Is there an easy way to test those with a multimeter?
Or do folks just generally replace both chips?

#3 9 days ago

I had a similar issue with Indiana Jones. Same sort of error message. I generally don't give up on things that are fixable and I tried everything including replacing the offending LM339 chip, possibly several, but in the end I just bought a new board. The old one I took home to test on the bench and still couldn't figure it out. Sadly I gave up. Didn't learn much on that one....

#4 9 days ago

Disconnect j2 from the opto board. Is the issue gone? If so, plug it back
Disconnect J3 from the opto board. Are the test results the same? If so, grab your meter and place it on diode test (an arrow with a line at the end.

With the power off, test each diode on your board with the black probe on the side of the diode with a line. You should read around 0.7v on each.

Place your meter on DC voltage.

With the power on,and J3 unplugged measure J3 pins 1 (red probe) and 3 ( black probe for ground). Do you read around 12v?

Move your red probe to pins 5,8,9 and 10. What do you read? Do you read 12v here as well? Compare with what you read on pins 6,7 and 11. Do you read the same? (you should).

Take a look at the schematic below. You can see where each row are connected in the board, at J3. You mentionned rows 1, 4, 5 and 6. If you look closely you see the board has 2 lm339, referred to as U1A through U2D representing the 4 opamps of each chip. You see row 1 is on amp U1D and rows 4, 5 and 6 are on amps U2A, U2D, U2B. This means this issue appears on the 2 different chips.

A shorted diode can cause such behavior even if the opamps are not damaged so diodes are the first thing to check if the issue really is on the board. If you've disconnected J3 and the error disappears then the issue is with the optos themselves. If the issue is present with J3 disconnected then the issue is most likely on the board. Disconnecting j2 from the opto board should clear the issue, if not, then the problem is elsewhere towards the MPU.
Screenshot_20210719-174707_Adobe Acrobat.jpg

#5 9 days ago

Thank you Roamin for the very thorough instructions! I followed them (I think) and have a bit more info now.
I pulled the board out of the machine. No obvious physical damage or burning (apart from the slightly toasty area around the resistors, apparently normal).

Diode test: All diodes tested in a range from 0.555 to 0.6 (V? mV?) Not the 0.7 you were looking for, but they do not seem to be shorted I guess.

Tests on J3 (the connector/plug part, with machine on):
pin 2 measures a bit over 15v (but that seems to be what the 12v unregulated circuit on this machine puts out, that's the same as I measure on the power driver board)
pins 5, 6, 7, 9 measure around 11.8v (seems good)
pins 8 and 10 measure around 10.75v (not sure why these are lower), pin 12 measures the same
pin 11 is not used on this game (I guess this board is only running 6 sets of optos)

As I mentioned, booting up with J3 disconnected from the opto board gives no error message, switch matrix shows no rows locked on.

So ... where does that leave me? Did I somehow manage to kill both LM339 chips at the same time?
Thanks again for the great help!

#6 9 days ago

Ooops , I was looking at the circuit the wrong way, that's what happens when I spend too much time using my phone to answer questions . I made a mistake saying that if you pull J3 and the error disappears, that the issue was with the optos themselves as i had J2 and J3 mixed up. The opto board looks at J2 to see if the optos are closed then it will send the signal through J3 to the MPU.

What happens if you pull both J1 and J2 and power on ? Does it give the same error ? If it gives the same error with J1 and J2 disconnected , the issue is definitely on the opto board. If the error goes away , the optos are to blame. Does pulling J1 and or J2 change anything on the switch test ?

The tests you did on J3 seem to indicate that the outputs of the opamps are good. You did not measure voltages that were very close to ground level, so the MPU is not interpreting this as a ground. Can you measure and write down all the voltages like you did before on J3 , but both with connector plugged in and not? It is curious that the MPU sees the rows grounded with the connector plugged in and when unplugged we don't measure that low voltage on the pins from the opto board. Usually , if the MPU sees those pins grounded , you would measure them grounded or very close to 0v (low enough for the mpu to interpret it as closed).

After you've noted voltages from J3 plugged and unplugged, measure these pins on IC U1, U2 (Do those tests with J3 unplugged) and write them down:

Put black probe on ground ,
Place red probe on :

U1 pin 10 -> (signal from opto) =
U1 pin 13 -> (signal to MPU) =

U1 pin 6 -> (signal from opto) =
U1 pin 1 -> (signal to MPU) =

U1 pin 8 -> (signal from opto) =
U1 pin 14 -> (signal to MPU) =

----------------------

U2 pin 6 -> (signal from opto) =
U2 pin 1 -> (signal to MPU) =

U2 pin 10 -> (signal from opto) =
U2 pin 13 -> (signal to MPU) =

U2 pin 4 -> (signal from opto) =
U2 pin 2 -> (signal to MPU) =

U2 pin 8 -> (signal from opto) =
U2 pin 14 -> (signal to MPU) =

When the signal from the opto is grounded (0v) then the signal to the MPU should also become grounded (0v). With these test results we should know more.

You have the schematic I posted above. You can see that each opto connected to J2 goes to an identical circuit for each. If switch #32 is still working properly (your error message doesn't mention row 2) then the readings on U1 pin 6 -> (signal from opto) and U1 pin 1 -> (signal to MPU) should be good and they should change when you open / close the switch. You can use that part of the circuit to compare with the other optos and see if all optos give out the same voltages (or close) and figure out more. The same circuit is used 7 times on the schematic (you mention your board only using 6 optos) so they should all measure very close when comparing one to the other.

Measuring 0.5 to 0.7 for a diode is a good result , not all parts are made to the exact same specs. As to why some outputs are lower that others , that's just the difference in the parts used (resistors, opamps, etc) and all your measured voltages are close enough. 0.7v for a diode is the "typical" voltage drop.

#7 8 days ago

Roamin thanks again for the help! I'll give this a try tonight. For those tests on U1 & U2, should those be done with the multimeter on the diode setting?

#8 8 days ago

Okay I ran some more tests. Results are ... weird?

1) powered on the machine with J1, J2, and J3 on the opto board all connected. Still has the error message and rows 1, 4, 5, & 6 all lock on. I noticed that occasionally when I power on in this config, the subway popoer solenoid fires repeatedly, but this does not happen every time.
Starting with J3 disconnected still boots without an error, and switch test looks pretty good (only switches 24 and 56 show closed).

2) Leaving J3 connected, and disconnecting J1 & J2...
- J1 and J2 both off: Only Row 1 locks on now (while rows 4, 5, and 6 look fine); only switches showing on in the edge test are 24 ("always closed") & 56 ("cube position 1"). The other normally-closed optos do not appear closed on the switch matrix.
- J1 on, J2 off: same result
- J2 on, J1 off: same result, except now SW 45 sticks on (this is the left outland eddy board--I also noticed that although that eddy board worked fine a few days ago, now it's impossible to adjust with the potentiometer. I can only get the LED to come on by disconnecting the sensor from the board. Weird.)
So ... given that I still have one row still locked-on with all the optos and receivers disconnected, I guess the problem is within the opto board?

3) Testing voltages at J3 (connected & powered on)...
With J1 & J2 connected:
pin 2 14.5v
pin 5 1.2v
pin 6 11.6v
pin 7 11.3v
pin 8 1.2v
pin 9 1.2v
pin 10 1.2v
pin 12 10.2v

With J1 & J2 disconnected:
pin 2 15v
pin 5 1.2v
pin 6 11.7v
pin 7 11.4v
pin 8 10.7v
pin 9 11.8v
pin 10 10.8v
pin 12 10.8v

So ... maybe pin 5 looks anomalous? That corresponds to SW 35 (Trough 4). Not sure.

4) Tests on U1 and U2...
I admittedly did not understand the directions. Since you said to disconnect J3, I figured the board and the downstream optos would have no power anyway, and I just disconnected and removed the 7-opto board from the machine. I tested it in Diode mode; if that's not right please let me know and I'll try again.
U1 pin 10 -> (signal from opto) = 1.1
U1 pin 13 -> (signal to MPU) = 0.07

U1 pin 6 -> (signal from opto) = 1.1
U1 pin 1 -> (signal to MPU) = OL

U1 pin 8 -> (signal from opto) = 1.1
U1 pin 14 -> (signal to MPU) = OL

----------------------

U2 pin 6 -> (signal from opto) = 1.1
U2 pin 1 -> (signal to MPU) = OL

U2 pin 10 -> (signal from opto) = 1.1
U2 pin 13 -> (signal to MPU) =OL

U2 pin 4 -> (signal from opto) =1.1
U2 pin 2 -> (signal to MPU) =OL

The only pattern-breaking one is U1 pin 13 (again this corresponds to SW 35--trough 4).

Confusing! Are signs pointing to "replace U1"? Something else? Is the eddy switch issue unrelated?

Thanks for any additional advice!

#9 7 days ago

Roamin (just realized I forgot to tag you in that last post)--does that give you any grounds for thinking it's the U1/U2 chips, or an obscure issue further upstream (MPU board)?
zaza I think I've seen you contribute to this type of threads before. Any thoughts?

#10 7 days ago

Okay one more bit of info: I did the test described by zaza here: https://pinside.com/pinball/forum/topic/wpc-trough-opto-issue#post-5088875
With J3 unplugged from the opto board, I stuck a 1N4004 diode in the J3 connector, banded end in pin 12. All pins from 5 through 10 activated a switch (J3-5 closes SW31, J3-6 closes SW 32, etc. in order until J3-10 closes SW36). Also notable--the schematics on Theatre of Magic manual pages 3-18 and 3-19 seem to be erroneous on the switch numbers...
So this is further confirmation that the switch matrix on the MPU board is working properly. I think this points again to the opto board. (Right?)

#11 7 days ago
Quoted from CTDnEUG:

I think this points again to the opto board. (Right?)

Yes, I do agree.

Check the 7-opto-board for leaking capacitor

Quoted from CTDnEUG:

powered on the machine with J1, J2, and J3 on the opto board all connected. Still has the error message and rows 1, 4, 5, & 6 all lock on.

That looks like both LM339 are damaged (still could be caused by a short on playfield)
In this case, best replace both LM339 and put them on a socket.

#12 7 days ago

Sorry for the delay , I was out playing disc golf past few days. U1 is definitely bad. You mention J3 pin 5 being at 1.2 volts (MPU sees this as ground) J3 pin 5 is what connects R1 (Row 1) and not switch #35 (the 3 comes from pin 12 of J3 , which is Column 3 , the 5 comes from Row 5 , which is pin 9). As you measured , pin 5 (row 1) always remains at 1.2 if J1/J2 are connected or not. This means that what ever the voltage that appears on pin 10 of U1 , it's output , pin 13 never changes states from HIGH (12v) back down to ground (0v). It always remains really close to 0v, so the MPU sees row 1 closed all the time.

Now , the fact that pins 8, 9 and 10 (Rows 4,5 and 6) are at 1.2v when J1/J2 is connected , but come back high once disconnected,would actually mean that Optos 4,5 and 6 are permanently sending a low signal to connector J2 pins 4,3 and 2. The opamp reacts properly and when it sees these 3 optos grounded , it sends a ground signal through its pins 1, 13 and 2 towards the MPU.

So as it is , it seems that J2 is sending ground signals over pins 4,3 and 2 constantly , which the opamp interprets as closed switches , and sends a ground signal over J3 pins 8,9 and 10.

I'm sorry I had not been more precise. Remember this : You use diode test , to test a diode! (Most of the time). It can also be used to test continuity (you would read 0v for a short , and not OL (overload). The last test you use diode test for , is to test transistors as they are made of diodes in a specific way (in theory, reality is a tiny bit different than diodes). So diode test = Diodes, Transistors , continuity.

Everything you will measure on the opto board is in DC voltage. (2 lines with one dotted).

Plug back in everything , set your meter to DC volts , turn on the machine , and write down the voltage measured at these pins :

U1 pin 10 = ? I assume this pin will be at 12v. It should drop to 0v if the trough jam is detected. You should be able to see this voltage change when you block the trough jam opto with a finger or paper to block the IR from reaching the sensor. The output of this opamp (u1 pin 13) is stucked low. It needs to be changed (install a socket when you remove the chip).

U2 pins 6, 10 and 4 = ? I assume you are going to measure something really low. 1.5v to 0v or close.
Measure once again but at the connect J2 this time :

J2 pins 4,3 and 2 = ? Should still be low , and should be the reason why rows 4,5 and 6 are grounded.

If this is the case, you now have a few choices on what to do. You can , take a known working opto , like trough 2 (sw #33) and exchange it with a suspected broken opto. If you no longer have that replaced opto as a grounded row where you installed that opto , but the trough 2 now gives you issues , then this means you've move the bad opto to a once working switch , confirming the opto is broken.

It is weird that 3 optos would fail all at once (possible if a problematic voltage was applied to the optos , but chances are that would of caused the same issue on ALL optos. This seems to point to a short circuit in your playfield , possibly a pinched wire from lifting the playfield or something.

Disconnect J2 and power on. Are rows 4,5 and 6 still shorted ?

** The only pattern-breaking one is U1 pin 13 (again this corresponds to SW 35--trough 4). **

You were on diode test (which can test short circuits) and you had one probe on the ground. Measuring pin 13 with diode test showed you that there was 0v between pin 13 of U1 and the ground, meaning there is continuity between pin 13 and ground. (you have just confirmed U1 is shorted at pin 13)

Confirm that J2 as its 3 pins low (4,3 and 2) by measuring DC voltage between ground and each pin. Unplug J2 and measure the same pins but on the opto board, are they still low ? Or do you measure closer to 12v ? If they are no longer low with J2 removed, you've confirmed that J2 is grounding those 3 rows.

Pay attention to the wires connected to 4,3 and 2 and look for anything suspicious , damaged insulation , wires running behind something you can't properly see, etc.
If there are no short circuits , swap a known working opto with a suspected one.

Like you tested the switches with a diode directly on the MPU board , a similar test can be done. Disconnect J2 and use a wire (doesn't need to be a diode) between ground and pins 4,3, 2 of J2, the output at J3 pins 8,9 and 10 should change high (12v) and low (0v) when you are grounding pins 4, 3 and 2 of J2.

**Switch 24 should always be closed, switch 51 , cube position 1 , would make sense if the cube starts in position 1. Those 2 switches seem very normal.

So far , U1 needs to be replaced, now we need to find out what is grounding pins 4,3 and 2 of J2. Is it the optos themselves, or a short circuit on the wires.

#13 6 days ago

Roamin & zaza thank you both for the patient assistance and for being so incredibly thorough.
I was unable to source LM339s locally so I'm waiting on some (and sockets) to be shipped. Will swap them out and report back next week when they arrive.
Meanwhile, I'll take a close look at all my wiring, etc. for any visible damage.
Roamin , if I do end up needing to swap out optos, will it be the emitters or the receivers that has the problem? (I'm assuming the receivers.)

#14 6 days ago

It would have to be the receivers. If the emitters were shorted the receivers would just not detect anything. It should be fairly simple to test the IR receiver board of the trough. Disconnect the connector , set your meter on continuity and probe with 1 probe on pin 1 and the other probe on each pin one after the other. You should NOT have continuity anywhere. The weird thing I just noticed is that in the manual , Row 6 is not even connected to the IR receiver board, but you are getting Row 6 as part of the grounded rows. It's possible that board has been changed in the past and now is the upgraded version with all 6 receivers and maybe the cable was changed as well. Pictures always help diagnose too as we might catch something you don't. You did mention resistors showing heat marks, which is normal to a point, did you measure the resistors to see if they are within their spec ? They probably are.

Measure the opto board for short circuits at the connector and report. Can you post pictures of both the opto driver board and the IR receiver board.

#15 6 days ago

Roamin Yes, I noticed that the 6th opto handled by that board is SW36, which is actually part of the Magic Trunk assembly (at the other end of the playfield from the ball trough!) but not one of the 4 trunk position optos (those are mounted on their own separate board). Come to think of it, I was just messing with the trunk...I should check for wiring damage there too. Anyway you can see that assembly on page 2-25 of the manual. There are definitely only 5 opto sets in the ball trough (4 for the balls, 1 for jam detection); 2 pins on each connector are "not used".

On a whim, I did previously check all the resistors on the 7-opto board. All the large ones tested perfectly; there were odd readings on some of the smaller ones, but I figured it was due to them being hard to test in-place. Will test them again.

I'll check for short circuits and try to get you some photos later tonight.

You think the occasional ball popper triggering at startup (SW44), and the non-functional left outlane eddy switch (SW45) are unrelated/coincidence? Those are on in the Row 4/5/6 region we're talking about... I guess that will become more clear once I get the LM339 changed out.

Thanks again.

#16 6 days ago

Roamin test results: on the trough opto receiver board, no shorts (i.e. no continuity). I also tested the opto emitter board with a digital camera, and all 5 emitters were shining brightly.

As you suggested, I plugged in everything except J2, and on the J2 header I jumpered between pin 10 and the other pins. Only pins 2, 3, and 4 generated a response on the switch matrix test, and those lit up rows 4, 5, and 6 respectively. The other pins lit up nothing.

Pretty sure the problem is somewhere within the 7-opto board and I should maybe wait for the LM339s to arrive before doing further troubleshooting.

#17 6 days ago

If the receivers aren't shorted, the then issue has to be with the 2nd lm339. The inputs are most likely shorted, so if any pins receives a signal, it closes all 3 rows.

As for switch 44 and 45, I haven't looked at schematic in depth for those switches, but since rows 4 and 5 are affected by the opto board, the issue might come from there. If you disconnect J3 (or all 3 connectors) do these switches still act up?

The idea is always to isolate the issue, so if you plug the bare minium, can you get sw 44 and sw45 to react properly? Disconnecting anything that could be in relation with what your are testing.

Quick test, is there continuity between pins 10 ,6 and 4 of u2 on the opto board? (this will check if the inputs appear short). Either way, it's better to change both.

While you wait for the opamps, I suggest you diode test all the diodes you see around the affected switches and optos, no diodes should be shorted, if any are you'll get weird behaviors like wrong switches closing.

Edit : no diodes should be shorted, or wired in reverse. The manual can show you which wire color you must place the band of the diode towards.

#18 5 days ago

Roamin I'll do those tests later this weekend, but I was thinking I would change both LM339s anyway just so they are both fresh and socketed. I did already test all the diodes on the opto board, but I'll check some of the others on switches, etc. I may just wait on troubleshooting the eddy switch until I get the opto board sorted out--one thing at a time is probably better troubleshooting procedure.
Here are the photos of the boards--no apparent damage as far as I can see.

IMG_4709 (resized).JPGIMG_4708 (resized).JPGIMG_4710 (resized).JPGIMG_4707 (resized).JPG
#19 5 days ago

Have you reflowed the header pins on those boards? It's something easy and should be done anyway. Especially the .156 headers. You might get lucky.

#20 5 days ago

Roamin I tested U2 and on continuity mode there is not an audible tone, but the meter reads about 1.6 (this was between pins 10 and 6, 10 and 4). U1 gets the same result between 10 and 6 but not 10 and 4. Not sure what this means.
amxfc3s By reflow do you mean heating the pin and adding more solder? Thanks!

#21 5 days ago

Yep just heat it up and add a dab of fresh solder to each pin.

#22 2 days ago

Well folks, I'm happy to report that my ToM is working again. The chips arrived early (I can easily recommend Juried Engineering on eBay as a source for all your IC and socket needs: real TI chips, superbly packed, shipped quickly) and despite my shaky soldering skills I managed to get the job done.

Roamin I replaced (and socketed) both LM339 chips. After hooking everything back up, my switch matrix looks perfect: switches 24, 56, and now 31 through 36 are on, as expected.

It would have been more scientific to replace U1 and then later U2, but it was much easier to replace them both in one go. But based on our testing, I feel sure that U2 had problems as well. As for what I did to simultaneously burn out 2 chips, that's a mystery.

Regarding other anomalies: I'm embarrassed to report that what I thought was the ball popper firing was probably the ball trough ejector firing--probably a normal ball-search function (and the reason it was intermittent was possibly because I sometimes started with the coin door open vs closed). The left outlane eddy switch is suddenly working again too (can be adjusted and detects the ball normally in test mode). I cannot explain how that was related to the 7-opto board, but ... problem solved, it looks like.

amxfc3s All the header pins looked perfect, but I did reflow them all per your instructions anyway, so they should be bullet-proof now.

Thanks again for all the help!

#23 2 days ago

Well, since the receiver boars was tested not short, u2 also had to be broken. On U2, the inputs were shorted internally, and u1 had its output shorted. Don't sweat it, they probably didn't break because of your intervention. Parts are old and have been abused a lot in the past 30 years.. They were going to break with or without you working on the machine.

Happy to know it's back to normal!

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside