(Topic ID: 183403)

Time Warp blowing F2 fuse when powered on

By boostedskex

2 years ago

Topic Stats

  • 48 posts
  • 7 Pinsiders participating
  • Latest reply 1 year ago by boostedskex
  • Topic is favorited by 1 Pinsider


Linked Games

Topic Gallery

One image has been uploaded to this topic. (View topic image gallery).

20180318-122146 (resized).jpg

You're currently viewing posts by Pinsider boostedskex.
Click here to go back to viewing the entire thread.

#1 2 years ago

Hi guys. I have been working on a time warp that was completely dead when I bought it. I got the game working except for 1 coil (top kick out). I noticed a transister was cracked on the driver board and replaced it. Now the game is blowing the F2 fuse as soon as I power on the game. Any ideas what to do now?


#3 2 years ago

yes, I actually replaced both.

#5 2 years ago

went through and checked diodes, its looking good too

#7 2 years ago
Quoted from GRUMPY:

Then you need a logic probe to check the logic signals.

Ok, now im lost. any info on pinside as to what that is and how to do it.

#10 2 years ago
Quoted from vid1900:

Think about it this way, if you don't have a probe:
When Time Warp boots, the saucers all kick out, to clear any left over balls.
Cut one wire to the saucer coil, and then boot the game.
If the fuse does not blow, then the coil or coil diode is bad.
If the fuse still blows, it's back to the 2 transistors/driver board.

I installed a new fuse and pulled the plug from the driver board and the fuse didnt blow.

I will try removing a wire from the kick out coil and give it another try plugged in.

Thanks for the help,

#11 2 years ago

what is the part number for the transistors? TIPxxx?

#13 2 years ago

thanks Vid!

1 year later
#14 1 year ago

getting back into this project a year later. I purchased and replaced the visually blown transistor and pre-driver.

The F2 fuse is blowing when the 2J9 plug is plugged in (bottom left corner of driver board). All of the wires are brown/colored stripe in that plug. When I turn the game on everything works except coils and sound. all lights and switches working.

What should be my next step in figuring this out?

#16 1 year ago
Quoted from Cycloneman:

sorry i did not read most of your thread but did you replace those SCANBE chip sockets with new sockets?

I did not, but it looks like they are the RN sockets.

#17 1 year ago

Update - With a good fuse in F2 and the 2J9 plug unplugged - game powers on and boots up. new game will start. The sling shots, drop targets and right saucer coils are working. The upper saucer, flipper coils and music (sounds) are not working.

If i press the test button on the sound board I do get the forever repeating sounds until the game is powered off.

#19 1 year ago
Quoted from Schwaggs:

Remove F2 - boot the machine up - carefully reinsert F2 using an insulated tool after the game is in attract.
If the fuse DOES NOT blow, you probably have a problem with the blanking circuit.
If it does blow, you need to keep looking for a locked on coil or shorted driver transistor.

Perfect. Ill give this a try asap.


#20 1 year ago
Quoted from Schwaggs:

Remove F2 - boot the machine up - carefully reinsert F2 using an insulated tool after the game is in attract.
If the fuse DOES NOT blow, you probably have a problem with the blanking circuit.
If it does blow, you need to keep looking for a locked on coil or shorted driver transistor.

So I did as stated above and the fuse blew. So, you are saying my issue is still in the driver board?

I had the playfield lifted up and I was focused on the fuse, but I heard a quiet buzz from under the play field and I'm guessing in the upper saucer area.

#25 1 year ago

ok guys. I greatly appreciate the help you have been giving me. Here is where I currently am at:

This morning with the 2J9 plug unplugged from the board. All coils were working except the upper saucer. The signal wire is grey/red. I followed that wire to the board and the traced it to the transistor. I replaced that transistor and pre-driver and reinstalled the board.

Now when I turn the game on it does not boot up. All GI illuminates and the displays are not showing anything. Does this make any sense, where should I turn now?

Before I did this I was actually playing the machine except for the upper saucer not working

#29 1 year ago

Yes, the 40 pin connectir was the very first thing i did.

I will pull then board and reseat it. Every mounting location has a screw in it


#31 1 year ago
Quoted from vid1900:

Leave the 2 mounting screws that align with the 40 pin off .
Sometimes they make the rear of the 40pin males touch the bracket and ground out.

Quoted from Schwaggs:

Make sure you have a couple mounting screws in each board. That helps with the ground plane.
Try pulling the 40 pin apart and back together. Make sure the back of the CPU board is in the bracket slot correctly and the 40 pin solder pads are not touching the bracket. If you push them together too hard, sometimes the boards can short to the mounting bracket.

Thanks for the tip on remounting the boards. The 40 pin connector must have been grounding out.

So... Now that the game is booting again, replacing the transistor for the upper saucer worked! All of the coils are working and the game is almost finished, but as soon as the 2J9 plug is connected the F2 fuse pops!. The plug in 2J9 has all brown wires in it and I traced those wires to the sound board. What would your suggestions be now?

You guys rock !

#33 1 year ago

ok so I was doing some more tinkering.. I pulled all of the cables from the sound board and plugged 2J9 back in and the fuse still popped when I powered it on. Should this lead me to believe that it is not the sound board or should I still go through with your directions above?

#36 1 year ago
Quoted from vid1900:

So the wire cluster blew the fuse, without the other end being connected to anything?

I made one more step of progress. I thought it was odd that the fuse blew when the sound card end of the harness was unplugged so i traced out every wire. I found one wire went down into the cab and went to the knocker coil. i desoldered the knocker coil signal wire and that fixed the fuse blowing. Yeah!!!! I forgot about that coil

Last challenge - i do not have any sound. I can hear the noise/static increase or decrease when either volume pot is turned but no sounds during gameplay. I set the option #35 to 12,14,and 16 as the manual suggests to do with no luck. Any ideas?

#38 1 year ago

Yes, the test button works. Doesnt stop making the sound until the machine is powered off.

Im not sure how to ground the transistors.

#40 1 year ago

I havent done this but i will give it a try. The transistors have 3 legs. I the signal wire is to one leg and i should ground one of the other 2. Does it matter which leg of the transistor i ground out?

#42 1 year ago
Quoted from someotherguy:

You ground the metal tab sticking out of the end of the transistor, not any of its legs.

Makes sense. Thanks. Ill give it a try tonight.

#44 1 year ago
Quoted from vid1900:

Just touch the wire to the transistor tab for a 1/4 second and the coil or sound will fire.
You can't get every sound manually, because some of them occur when a combination of transistors are fired together.

I went through and tried all of the transistors and could not get any sounds. I did get coils to fire.

#46 1 year ago

I just put the sound card from Time Warp in my Flash and it worked as it should. I then put the sound card from Flash into Time Warp and TW still has no sound

#48 1 year ago

Thanks again for the help Vid! I'm not exactly sure what you mean by checking the color codes. I snipped the zip ties from the harness and physically inspected every wire from the sound card to the MPU. They all look good

I think im going to start a new thread specific to no sound instead of fuse f2 blowing. Maybe it will give the solution i need.

Promoted items from the Pinside Marketplace
$ 14.99
$ 99.00
Gameroom - Decorations
Pinball Sales
$ 12.00
Cabinet - Other
Siegecraft Electronics
$ 14.00
Yorktown Parts and Equip
Machine - Wanted
Hagerstown, MD
$ 22.00
$ 17.00
Yorktown Parts and Equip
From: $ 9.00
$ 299.00
$ 69.00
Playfield - Toys/Add-ons
$ 27.99
Matt's Basement Arcade
$ 239.99
Cabinet - Toppers
$ 89.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 85.00
Playfield - Toys/Add-ons

You're currently viewing posts by Pinsider boostedskex.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside