(Topic ID: 295170)

I like those odds - The Mandalorian Owners Club

By flynnibus

1 year ago


Topic Heartbeat

Topic Stats

  • 5,291 posts
  • 451 Pinsiders participating
  • Latest reply 6 hours ago by NickBuffaloPinball
  • Topic is favorited by 265 Pinsiders

You

Linked Games

Topic Gallery

View topic image gallery

396FC057-E54A-4C84-B4F7-F94DC39B8241 (resized).jpeg
20210902_172832 (resized).jpg
IMG_20220620_090211316_HDR.jpg
5f81bbb4562c1d92343e2798f8e1d4b4b33f1a67 (resized).jpg
IMG_20220612_204826003_HDR.jpg
IMG_20220617_091140084_HDR.jpg
2022-06-1619.30.283955621145077838924.jpg
IMG_20220616_171626778_HDR.jpg
IMG_20220615_180104.jpg
IMG_20220615_180053.jpg
IMG_20220615_180807.jpg
IMG_20220615_180801.jpg
IMG_20220615_180755.jpg
IMG_20220522_200953324~2 (resized).jpg
ramp (resized).jpeg
4678990B-FC6D-410A-A2BB-C86AF1C52281 (resized).jpeg

Topic index (key posts)

5 key posts have been marked in this topic (Show topic index)

There are 5,291 posts in this topic. You are on page 19 of 106.
#901 10 months ago

Absolutely loving my Pro. So much fun although either it's a tougher game than I thought it would be or my skills had depreciated in the three years I didn't own a pin. Maybe both.

I've only had it three days but haven't cracked over 200M yet.

#902 10 months ago
Quoted from Apinjunkie:

That looks really nice, although I would have gone with a different topper. in all seriousness where did you pick up the chrome trim?

Tbh it was still laying around from my Metallica when i changed it to purple. Just luck.

#903 10 months ago
Quoted from PismoArcade:

Absolutely loving my Pro. So much fun although either it's a tougher game than I thought it would be or my skills had depreciated in the three years I didn't own a pin. Maybe both.
I've only had it three days but haven't cracked over 200M yet.

I got mine on Monday and my high score is 112,000,000

#904 10 months ago

Anyone having this light issue on Mando Le???

5653E788-4EB7-42CF-A281-68B88AA6C0FF (resized).jpeg
#905 10 months ago

Haven't looked up the rules, but to get 3x and higher multipliers do you just have to hit a scope shot? Or is it Ambush? I know from playing, the Boba Fett gives you 2X. Still trying to figure out how I get a higher multiplier. Fun game overall. Really having a blast playing.

#906 10 months ago
Quoted from Gambeno:

Haven't looked up the rules, but to get 3x and higher multipliers do you just have to hit a scope shot? Or is it Ambush? I know from playing, the Boba Fett gives you 2X. Still trying to figure out how I get a higher multiplier. Fun game overall. Really having a blast playing.

Scope adds another 1x, then if you complete a hunter mode that lights all triangles for 6x playfield (or plus 5x).

#907 10 months ago
Quoted from Gambeno:

Haven't looked up the rules, but to get 3x and higher multipliers do you just have to hit a scope shot? Or is it Ambush? I know from playing, the Boba Fett gives you 2X. Still trying to figure out how I get a higher multiplier. Fun game overall. Really having a blast playing.

Going from memory here so... a little fuzzy, but it seems to me that there's a 3X reward that comes up in the child bonus if it rolls through the correct Lane.

#908 10 months ago

Had the opportunity last night to add some paint and then install the Detonator covers. I'm digging this mod!

20210808_101559 (resized).jpg20210808_101618 (resized).jpg20210808_113951 (resized).jpg

#909 10 months ago

I'm having problems on my Premium with the mini playfield diverter opto. It will catch a ball but then acts as if it can't see the caught ball and starts a ball search after about 30 seconds. I've cleaned the opto and they look aligned. I don't see any disconnected cables. How can I test this further?

PXL_20210808_171551552 (resized).jpg
#910 10 months ago

something to watch for... our left orbit guide keeps working its way outward... leading to the orbit shot hitting the post as it exits the orbit and thus bouncing towards the center of the PF. Fix is to just remove the plastic, and reset the guide's position with the wood screw holding it in place.. but it's happened a few times now.

#911 10 months ago
Quoted from RoyalJack:

I'm having problems on my Premium with the mini playfield diverter opto. It will catch a ball but then acts as if it can't see the caught ball and starts a ball search after about 30 seconds. I've cleaned the opto and they look aligned. I don't see any disconnected cables. How can I test this further?
[quoted image]

When you go into switch testing with the glass off and stick your finger in the path does it ever read at all? Are you any good at soldering? Might have to reflow the solder on one of the wires. I would personally make a small test wire and touch it from the small exposed part of each wire onto the soldered leads on each opto and see if you can get it to register as working to know which wire is possibly causing the issue but be careful not to touch anything but the wire your testing and the solder joint your touching or you could cause a even bigger issue. Tread at your own risk and dont cross the streams, lol!

#912 10 months ago
Quoted from jrockne:

Officially part of the owners group, my premium was delivered today!
Just finished moving it into the basement…[quoted image][quoted image][quoted image]

What a bad ass entrance!!

#913 10 months ago
Quoted from Jerickso77:

Still can't get a clean plunge. Took out the whole shooter rod assembly and you really can't move it much left or right. Looks centered anyway so can't figure out why it pushes right.
[quoted image]

Have the same problem on my JP2; it’s infuriating. I’ll “fix” it, it’ll plunge 12 times perfectly, then completely bounce and bork the next 3 and then back to another good 11 plunges in a row. Let me know if you ever find a perm fix, and I pray I’m not about to receive another pin in this week with the plunger prob.

Quick tip that might help, you can take out the 2 cab wood screws on the back of the shooter housing and just leave the 3 machine screws with washers in; when tightened they will hold the assembly all in place. You’ll get a lot more moveable action to really align and dead center with those colored wood screws out.

Does anyone else feel like some QC guy at Stern plunges thrice and calls it good?

#914 10 months ago
Quoted from Phbooms:

When you go into switch testing with the glass off and stick your finger in the path does it ever read at all? Are you any good at soldering? Might have to reflow the solder on one of the wires. I would personally make a small test wire and touch it from the small exposed part of each wire onto the soldered leads on each opto and see if you can get it to register as working to know which wire is possibly causing the issue but be careful not to touch anything but the wire your testing and the solder joint your touching or you could cause a even bigger issue. Tread at your own risk and dont cross the streams, lol!

Thanks for the quick reply! In switch test mode that opto doesn't register when I pass a ball through or block it with a pencil. Could you further elaborate on the test wire? Would I do this on the emitter or receiver side?

#915 10 months ago
Quoted from chickenscratch:

Have the same problem on my JP2; it’s infuriating. I’ll “fix” it, it’ll plunge 12 times perfectly, then completely bounce and bork the next 3 and then back to another good 11 plunges in a row. Let me know if you ever find a perm fix, and I pray I’m not about to receive another pin in this week with the plunger prob.
Quick tip that might help, you can take out the 2 cab wood screws on the back of the shooter housing and just leave the 3 machine screws with washers in; when tightened they will hold the assembly all in place. You’ll get a lot more moveable action to really align and dead center with those colored wood screws out.
Does anyone else feel like some QC guy at Stern plunges thrice and calls it good?

Premature Evaluation?

#916 10 months ago
Quoted from RoyalJack:

Thanks for the quick reply! In switch test mode that opto doesn't register when I pass a ball through or block it with a pencil. Could you further elaborate on the test wire? Would I do this on the emitter or receiver side?

Did the optos work when you first got the game and then just stop working or did they not work right out of the box?

Does the right opto board red led light once on startup then turn solid once the games fully on?

With a test wire i would test each opto lead(both sides), one wire at a time until i possibly found the culprit. I say possibly because you might not even find the issue this way and might just end up having to reflow each solder joint on the opto boards.

You might be able to wiggle each wire to find the issue also if it is a weak solder job.

The wires are correct on the left side you showed in pic. On the right side opto with the led light the brown wire is in the back and red in front, correct?

#917 10 months ago
Quoted from Phbooms:

Did the optos work when you first got the game and then just stop working or did they not work right out of the box? It worked for about 10 games.
Does the right opto board red led light once on startup then turn solid once the games fully on? Yes
With a test wire i would test each opto lead(both sides), one wire at a time until i possibly found the culprit. I say possibly because you might not even find the issue this way and might just end up having to reflow each solder joint on the opto boards. I'll try this.
You might be able to wiggle each wire to find the issue also if it is a weak solder job.
The wires are correct on the left side you showed in pic. On the right side opto with the led light the brown wire is in the back and red in front, correct? Yes

#918 10 months ago
Quoted from Phbooms:

Did the optos work when you first got the game and then just stop working or did they not work right out of the box?
Does the right opto board red led light once on startup then turn solid once the games fully on?
With a test wire i would test each opto lead(both sides), one wire at a time until i possibly found the culprit. I say possibly because you might not even find the issue this way and might just end up having to reflow each solder joint on the opto boards.
You might be able to wiggle each wire to find the issue also if it is a weak solder job.
The wires are correct on the left side you showed in pic. On the right side opto with the led light the brown wire is in the back and red in front, correct?

Did the optos work when you first got the game and then just stop working or did they not work right out of the box? Yes, the game worked as it should for about 10 games then stopped working.
Does the right opto board red led light once on startup then turn solid once the games fully on? Yes
The wires are correct on the left side you showed in pic. On the right side opto with the led light the brown wire is in the back and red in front, correct? Yes this matches mine.
I'll do the wire test you mentioned. I also have a multimeter if there is a proper way to test voltages. This is my 2nd pin and 1st time I've had to troubleshoot an opto.

#919 10 months ago

Looking to add a shaker motor when mine comes later this week. Are there still aftermarket ones available that would work for this machine? I added one to an Avengers several months ago but I feel like I'm not seeing them now.

#920 10 months ago
Quoted from RoyalJack:

Did the optos work when you first got the game and then just stop working or did they not work right out of the box? Yes, the game worked as it should for about 10 games then stopped working.
Does the right opto board red led light once on startup then turn solid once the games fully on? Yes
The wires are correct on the left side you showed in pic. On the right side opto with the led light the brown wire is in the back and red in front, correct? Yes this matches mine.
I'll do the wire test you mentioned. I also have a multimeter if there is a proper way to test voltages. This is my 2nd pin and 1st time I've had to troubleshoot an opto.

I'd start with the left opto boards wires/solder.

#921 10 months ago
Quoted from DJY2J:

Looking to add a shaker motor when mine comes later this week. Are there still aftermarket ones available that would work for this machine? I added one to an Avengers several months ago but I feel like I'm not seeing them now.

Pin shaker has them for around $200 or you can get one from Stern Direct for a hundred. Stearns is a 5-minute installation and works just fine. I put one in my Pro and I'm digging it!

#922 10 months ago

Shakers are hard to come by. I had to search a lot of sites to find one 3 weeks ago in preparation for Mando

#923 10 months ago
Quoted from Phbooms:

I'd start with the left opto boards wires/solder.

Wire test didn't bring any life to the sensor. Is there a way to test the opto with. Multimeter?

#924 10 months ago
Quoted from RoyalJack:

Wire test didn't bring any life to the sensor. Is there a way to test the opto with. Multimeter?

I checked with the game off and with meter I get between 1.0v and 1.6v on all the wires as I worked through all the combinations. Do you get a reading from every one?

Also did you check this wires plugs?

20210808_172637 (resized).jpg

#925 10 months ago
Quoted from Apinjunkie:

Pin shaker has them for around $200 or you can get one from Stern Direct for a hundred. Stearns is a 5-minute installation and works just fine. I put one in my Pro and I'm digging it!

Actually reached out to the dealer Im getting my machine from and he has one left for $120 that I'm going to grab luckily. Thanks for the insight though.

#926 10 months ago

My right orbit pop up post causes the right orbit shots to come back most of the time. Anyone have a fix for this?

#927 10 months ago
Quoted from Phbooms:

I checked with the game off and with meter I get between 1.0v and 1.6v on all the wires as I worked through all the combinations. Do you get a reading from every one?
Also did you check this wires plugs?
[quoted image]

Upon physically inspecting I discovered the bulb popped off the left side board! Replacement on it's way but trying to find easiest way to remove it. Looks like I need to remove some stuff to get the wire fished out.

PXL_20210808_213505262~2 (resized).jpgScreenshot_20210808-163434~2 (resized).pngreceived_4086153488099987 (resized).jpeg
#928 10 months ago
Quoted from RoyalJack:

Upon physically inspecting I discovered the bulb popped off the left side board! Replacement on it's way but trying to find easiest way to remove it. Looks like I need to remove some stuff to get the wire fished out.
[quoted image][quoted image][quoted image]

Sweet man glad you got it figured out. Might as well solder it back on once you get the wire off the game see if you can fix it. That wire does look to have some fishing to do to get it past the VUK in the back but you'll get it.

#929 10 months ago

Ive notived a bug where you cant reset the game after earning an extra ball. It just adds another player like youve pushed the button during ball one.

#930 10 months ago

Also, just to check...
Should the Razorcrest be centered over that shot? Mine is to the left and it is quite easy to hit the shot on the right side without hitting the Razorcrest flap.

16284645763985557966443364272321 (resized).jpg
#931 10 months ago
Quoted from November:

My 3d printed / metal ramps [quoted image][quoted image]

Nice forms. I just found this thread. I do not see supports on the upper part of the ramps? If they are just resting in the plastic ramps they will slowly destroy your ramp inserts. The smaller wireform turn around rocks that alot. On my first run of forms I had no mounts on top. They dug into the cut out from vibrations. See pictures. Very cool looking forms! If you have nothing locking them in place up top I would suggest a mount.

80E6F668-AE5D-4F55-A4CF-733FC9463796 (resized).jpeg57A4F714-DD91-4457-8E76-7D7BB721F0BD (resized).jpeg73E1C188-DD68-4F6C-9132-F2224194A48F (resized).jpeg

#932 10 months ago
Quoted from Phbooms:

Sweet man glad you got it figured out. Might as well solder it back on once you get the wire off the game see if you can fix it. That wire does look to have some fishing to do to get it past the VUK in the back but you'll get it.

Thank you so much for the help. I managed to fish it out and solder it back on. We're back in action! It was fairly easy to get to by removing the part of the ramp that is behind the playfield wall (4 screws). Then just cut the 2 zip ties next to the diverter coil and pull the opto through the back of the playfield. Reverse those steps to reinstall . This was my first pinball repair and took about 45 minutes once I knew what was wrong so it should be easy for anyone with some experience to do! Thank you again Phbooms

#933 10 months ago

Am I going crazy or are the team play modes not yet coded?
Tried to play 2v1 with my kids tonight and only Player 1 was able to play all 5 of their balls...

Tested 2v2 and same thing...

Cooperative mode and monster mode work fine though...

Did a search through the forum first but couldn't find anyone with the same issue.

Running 0.97 code.
(I have some pics and video to send Stern if they need it but if this was already a known thing, I wouldn't waste Dwight's time!)

IMG_20210808_224547 (resized).jpg
#934 10 months ago

Maybe it’s a bug on 5 ball. Did you test them on three ball?

#935 10 months ago

I don’t see zeros for the other players so I don’t think you pressed the start button more than once.

#936 10 months ago
Quoted from Waxx:

I don’t see zeros for the other players so I don’t think you pressed the start button more than once.

^^^this^^^

#937 10 months ago

Pressing start... Good call.

First machine with any kind of team play...
Thanks for the tip...
(Doh.)

#938 10 months ago

Any word on when the premiums will be back on the line? I know October was the word a couple weeks ago, just wondering if that’s been updated any. Thanks in advance.

#939 10 months ago
Quoted from Loganpinball:

Nice forms. I just found this thread. I do not see supports on the upper part of the ramps? If they are just resting in the plastic ramps they will slowly destroy your ramp inserts. The smaller wireform turn around rocks that alot. On my first run of forms I had no mounts on top. They dug into the cut out from vibrations. See pictures. Very cool looking forms! If you have nothing locking them in place up top I would suggest a mount.
[quoted image][quoted image][quoted image]

Impressive.

I made them the same as on LE/Premium, where there is no mount ?

At the moment i don't see any crack or wear, will watch it

#940 10 months ago
Quoted from Tiki-Ed:

I ordered my Cliffys a few days ago.

I'm having the same damage to the shooter lane and am a pinball owner novice. I'm curious for a link to a shooter lane protector that would work.

#941 10 months ago
Quoted from kjlors:

I'm having the same damage to the shooter lane and am a pinball owner novice. I'm curious for a link to a shooter lane protector that would work.

Turn trough eject power all the way down if you haven't yet.

#942 10 months ago
Quoted from crujones4life:

Turn trough eject power all the way down if you haven't yet.

I did that but already have a little dent in the wood and am curious where people are going to get the right protector.

#943 10 months ago
Quoted from Loganpinball:

Nice forms. I just found this thread. I do not see supports on the upper part of the ramps? If they are just resting in the plastic ramps they will slowly destroy your ramp inserts. The smaller wireform turn around rocks that alot. On my first run of forms I had no mounts on top. They dug into the cut out from vibrations. See pictures. Very cool looking forms! If you have nothing locking them in place up top I would suggest a mount.
[quoted image][quoted image][quoted image]

This design Stern used is absolute garbage. I can't believe that they decided this was a good solution!

#944 10 months ago

Has anyone made a mode to cover up this VUK? Would be nice to not have this so in your face when looking at the playfield.

pasted_image (resized).png
#945 10 months ago
Quoted from kjlors:

I did that but already have a little dent in the wood and am curious where people are going to get the right protector.

Cliffy
Apassionforpinball

passionforpinball.com

But get in line!

#946 10 months ago

Your ratings are in, the new #1 Pinside rated pinball is now........

pasted_image (resized).png
#947 10 months ago

Mod alert - we need decent pop bumper caps please - I know some are being finalized - really doesn’t have to be flashy or big - just without text.

#948 10 months ago
Quoted from GravitaR:

Your ratings are in, the new #1 Pinside rated pinball is now........
[quoted image]

Its a right of passage for every stern!

#949 10 months ago

I can hit the left ramp from the left flipper but the right from the right is not happening on my game. Any advice?
Also that stupid plastic diverter post up in the right orbit just sends the ball back most of the time. Booooooo.
Anyone clear all the encounters yet? Is there another target sequence after completing all three encounters to start the mini wizard? I can usually get to about the 5th round (2-2). I made it through 8 rounds today (3-2). Only one more to complete them dang it.
I find getting the Razorcrest mini wizard pretty easy.
I have made it to the missions mini wizard three times.
No encounter mini wizard yet

#950 10 months ago
Quoted from GravitaR:

Your ratings are in, the new #1 Pinside rated pinball is now........
[quoted image]

Hahaha, I think you are right with your rating and Hot Wheels is over twice as good.

These ratings are amazing, hahahaha.
7E41E92E-8A45-47F7-8E63-E7EB23C55609 (resized).jpeg

Promoted items from the Pinside Marketplace
$ 130.00
$ 110.00
Playfield - Toys/Add-ons
Diddy's Pinball Mods
$ 44.99
Cabinet - Shooter Rods
Pinball Shark
7,600 (Firm)
Sale Pending! Machine - For Sale
Acton, MA
$ 65.00
Playfield - Toys/Add-ons
Diddy's Pinball Mods
$ 8.50
From: $ 6,999.99
$ 25.00
Cabinet - Sound/Speakers
Space Coast Pinball
7,200 (OBO)
Machine - For Sale
Wernersville, PA
$ 30.00
Playfield - Other
YouBentMyWookie
From: $ 125.00
Lighting - Backbox
Myth Pinball Parts Shop
$ 5.00
Cabinet - Other
Pin Monk
8,300 (Firm)
Machine - For Sale
St. Clair Shores , MI
$ 20.00
Playfield - Toys/Add-ons
WilliPinball Mods
From: $ 349.95
Lighting - Led
Pin Stadium Pinball Mods
From: $ 15.00
Playfield - Other
Rocket City Pinball
$ 30.00
Cabinet - Decals
Inscribed Solutions
From: $ 30.00
Cabinet - Other
Rocket City Pinball
From: $ 30.00
Playfield - Toys/Add-ons
JK Pinball
From: $ 29.95
Cabinet - Shooter Rods
Hookedonpinball.com
$ 89.99
Cabinet - Decals
Maine Home Recreation
From: $ 18.00
Apparel - Men
Pinside Shop
From: $ 12.00
Playfield - Toys/Add-ons
Mödley Crüe
$ 6,699.00
Pinball Machine
Old Town Pinball
$ 35.00
Various Other Swag
JK Pinball
From: $ 39.00
$ 93.00
$ 649.95
Lighting - Led
Pin Stadium Pinball Mods
$ 8,899.00
Pinball Machine
Classic Game Rooms
Hey modders!
Your shop name here
There are 5,291 posts in this topic. You are on page 19 of 106.

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!