(Topic ID: 295170)

I like those odds - The Mandalorian Owners Club

By flynnibus

7 months ago


Topic Heartbeat

Topic Stats

  • 3,377 posts
  • 328 Pinsiders participating
  • Latest reply 11 hours ago by DaddyManD
  • Topic is favorited by 201 Pinsiders

You

Linked Games

Topic Gallery

View topic image gallery

20220114_235057339_iOS_LI (resized).jpg
20220113_192837 (resized).jpg
20220112_182436839_iOS (resized).jpg
image-23-12-2021_15-13-51-59 (resized).jpg
IMG-20211205-WA0007 (resized).jpeg
FD9FF0DC-F1FA-4B7C-8AC4-260DB711D9EB (resized).jpeg
69F7BCFC-8BD3-4E72-B408-334BE7BCB42C (resized).jpeg
406F87FD-FB49-494E-B5DA-C7E3614EF143 (resized).jpeg
450D840D-D8BD-4B80-B8A7-EE2474917884 (resized).jpeg
221D44E0-A304-46C4-9A98-65D67B9AD597 (resized).jpeg
Screenshot_20220109-224241_Drive (resized).jpg
00CE6604-F885-4444-B84D-B02BBD1EA617 (resized).png
mando_challenge_mode_highscore (resized).png
33051494-02A0-478E-A417-264AF431BA8C (resized).jpeg
AB307667-4D49-4286-B0DB-656CDD2F1DFB (resized).jpeg
pasted_image (resized).png

Topic index (key posts)

3 key posts have been marked in this topic (Show topic index)

There are 3,377 posts in this topic. You are on page 14 of 68.
#651 6 months ago

Ahhh ok thanks.

#652 6 months ago

Yeah I get a lot of rattle too . Maybe all metal ramps that cross

#653 6 months ago
Quoted from Mando:

Yeah I get a lot of rattle too . Maybe all metal ramps that cross

Damn shaker is a bit too fierce.
Had to dial it back to a roll.

#654 6 months ago

Insert cards on the apron look great!

Bought them here on pinside from Mr_Tantrum

Thanks Chris!

F2900B25-7DE1-47B8-91C1-FBBE49E4CD7E (resized).jpeg25820381-95DC-4BA5-AFDF-FB41C08A7BEC (resized).jpegC789F8B6-6F43-42A6-9376-D92C01507ECE (resized).jpeg
#655 6 months ago
Quoted from Pinball-Obsessed:

More pics, under bright light and with the glass off.[quoted image][quoted image][quoted image][quoted image][quoted image]

You get any surprises under the playfield?

#656 6 months ago
Quoted from GoodOmens:

You get any surprises under the playfield?

nope!

#657 6 months ago

No one else is bothered by the typos on the instruction cards?

Says 5 encounters for wizard mode and everything start at center ramp? So much copy paste.

#658 6 months ago
Quoted from NightTrain:

What is this anti rattle tape you speak of?

I've just been using 1/2 inch thick felt tape off of Amazon on some of my games as needed.

#659 6 months ago
Quoted from Vino:

Damn shaker is a bit too fierce.
Had to dial it back to a roll.

It is ! Xaqery if you listening I really like what the avengers team did with the shaker in that game a little more subtle

Also a lot of my rattle come from the bass of the sub !

#660 6 months ago
Quoted from Vino:

Damn shaker is a bit too fierce.
Had to dial it back to a roll.

Crazy shaker on my LE too. My issue is the shaker itself is making a ton of noise. I tested with both BG and PF glass off and it was still there.

I had a similar situation on a DP and just had to tighten that threaded rod a little to settle it down. I took the cover off on the Mando's and unfortunately the shaker has no stabilizing rod. If you run the test and squeeze the 2 mount side together on top, carefully so your fingers don't get whacked by the weights, and the noise goes away, it's something that rod would help with.

Stern's accessory site shows 2 pics with no rod and 1 with rod, so I guess it's whichever supplier it came from. Doubtful I can get a replacement from Stern, so I guess I'll either:
-Deal with it
-Buy a aftermarket shaker
-Do some frontier medicine with a drill and DIY it.

Hopefully some of y'all might have the adjustable version!

#661 6 months ago
Quoted from jaycbarnett:

Crazy shaker on my LE too. My issue is the shaker itself is making a ton of noise. I tested with both BG and PF glass off and it was still there.
I had a similar situation on a DP and just had to tighten that threaded rod a little to settle it down. I took the cover off on the Mando's and unfortunately the shaker has no stabilizing rod. If you run the test and squeeze the 2 mount side together on top, carefully so your fingers don't get whacked by the weights, and the noise goes away, it's something that rod would help with.
Stern's accessory site shows 2 pics with no rod and 1 with rod, so I guess it's whichever supplier it came from. Doubtful I can get a replacement from Stern, so I guess I'll either:
-Deal with it
-Buy a aftermarket shaker
-Do some frontier medicine with a drill and DIY it.
Hopefully some of y'all might have the adjustable version!

You sure the weights are centered on their little divots? I had a shaker direct from stern where one weight was ever so slightly off. Loosening the set screw and cranking it down in the divot was night and day difference.

Speaking of shakers - does anyone know if the cap is still required? I have a shaker from an older game I'm moving over and it required the cap kit. Does stern still require that or did they fix the boards to eliminate the issue?

Edit: Pablo got back to me 1 minute after I emailed service and said newer stern games don't require the cap kit.

#662 6 months ago

Quick question to Prem/LE folks.

The scoop makes a buzzing noise when it's "engaged", it was so loud it could be heard over in the middle of play and I have the machine pretty loud. With the glass off, I rolled the ball through the loop and the buzz could be felt on the top of the mech.

I messed with the Up/Down Scoop hold power setting, trying values above and below. I would seem to quiet down and then come back, so I was thinking it was mechanical somehow. I looked under the playfield to make sure the mech looked like the drawing in the manual and all the sleeves/washers/springs were in the correct place. Hmmm...

Anyway, just set it back to default setting, and last night it quieted down on it's own. It's still there a little bit, but not audible over the game in play. Not heard back from Pablo on my email, just wondering if anyone else had this.

#663 6 months ago
Quoted from GoodOmens:

You sure the weights are centered on their little divots? I had a shaker direct from stern where one weight was ever so slightly off. Loosening the set screw and cranking it down in the divot was night and day difference.

I've not looked at that, I'll be checking this after work!

Thanks man!

#664 6 months ago
Quoted from jaycbarnett:

I've not looked at that, I'll be checking this after work!
Thanks man!

Yea try moving the weights themselves and see if they are ever so slightly loose or if they are not perfectly in alignment with each other. There is a little divot on the rod they are supposed to be set on. Simple fix if that's the issue.

#665 6 months ago

That moment when you wake up to check tracking, and it's here. *happy dance*

#666 6 months ago

For the post #.

Number-of-the-beast-album-cover.jpg
#667 6 months ago
Quoted from jaycbarnett:

Quick question to Prem/LE folks.
The scoop makes a buzzing noise when it's "engaged", it was so loud it could be heard over in the middle of play and I have the machine pretty loud. With the glass off, I rolled the ball through the loop and the buzz could be felt on the top of the mech.
I messed with the Up/Down Scoop hold power setting, trying values above and below. I would seem to quiet down and then come back, so I was thinking it was mechanical somehow. I looked under the playfield to make sure the mech looked like the drawing in the manual and all the sleeves/washers/springs were in the correct place. Hmmm...
Anyway, just set it back to default setting, and last night it quieted down on it's own. It's still there a little bit, but not audible over the game in play. Not heard back from Pablo on my email, just wondering if anyone else had this.

Mine had the loud buzzing at first too. I believe it was due to my scoop sticking though. It was a little flaky at first but then it just locked in the up position & would not go down. I manually pushed it down from above & it hasn't returned. I'm assuming it just got wedged in there a little tight.

#668 6 months ago
Quoted from jaycbarnett:

Quick question to Prem/LE folks.
The scoop makes a buzzing noise when it's "engaged", it was so loud it could be heard over in the middle of play and I have the machine pretty loud. With the glass off, I rolled the ball through the loop and the buzz could be felt on the top of the mech.
I messed with the Up/Down Scoop hold power setting, trying values above and below. I would seem to quiet down and then come back, so I was thinking it was mechanical somehow. I looked under the playfield to make sure the mech looked like the drawing in the manual and all the sleeves/washers/springs were in the correct place. Hmmm...
Anyway, just set it back to default setting, and last night it quieted down on it's own. It's still there a little bit, but not audible over the game in play. Not heard back from Pablo on my email, just wondering if anyone else had this.

Mine was pretty loud at first too. That has settled down a bit though.

#669 6 months ago

I was playing a mean game on my Mandalorian LE and noticed the shaker vibrating too much as well.........then I woke up and it turned out I was dreaming of owning and playing the LE and it was my dog fuking me on my leg just like the scalpers fuking over the guys that wanted to buy the game and now they are priced 3k higher

#670 6 months ago

I’m good with the shaker level. I don’t see it being too much. Just turn it down to moderate. That might help. I hope he doesn’t change much on the max setting

#671 6 months ago
Quoted from K9Marshal:

I was playing a mean game on my Mandalorian LE and noticed the shaker vibrating too much as well.........then I woke up and it turned out I was dreaming of owning and playing the LE and it was my dog fuking me on my leg just like the scalpers fuking over the guys that wanted to buy the game and now they are priced 3k higher

pasted_image (resized).png
#672 6 months ago
Quoted from Apollyon:

Got word today that I made it into the upcoming premium run! Super excited to get it after having a chance to play the pro at a great pinsider's place this past weekend.

Looking forward to getting some time in on your premium upon arrival!

#673 6 months ago

Just to post when things go well with shipping...box was almost pristine with the exception of one small corner bump. Shipped to Kentucky.

IMG_2815 (resized).jpegMando (resized).png
#674 6 months ago

Heard my premium should be in by Friday this week... Getting excited now

#675 6 months ago
Quoted from Pinball-Obsessed:

More pics, under bright light and with the glass off.[quoted image][quoted image][quoted image][quoted image][quoted image]

Now we know your prem looks just like all other prem

#676 6 months ago

So much fun…

8BEE96BD-3892-4648-9220-3D1EA0D66FF5 (resized).jpeg
#677 6 months ago

Gotta let the clear coat dry before I install them.

IMG_20210721_232417__01.jpgIMG_20210721_232434__01.jpg
#678 6 months ago
Quoted from Pinball-NJA:

Anyone else have their upper flippers stop working?

Saw this on the prem I pl

Quoted from Tjohejsan:

Now we know your prem looks just like all other prem

You must not be waiting on yours. More pics pls.

#679 6 months ago

Anyone get an under-playfield surprise yet?

#680 6 months ago

That flasher popped out of grogu. Does anyone know what setting to use to test the light? Should I just put hot glue to keep it from coming off? Thanks

#681 6 months ago
Quoted from medic7000:

That flasher popped out of grogu. Does anyone know what setting to use to test the light? Should I just put hot glue to keep it from coming off? Thanks

I did one dot of hot glue and done.

#682 6 months ago
Quoted from medic7000:

That flasher popped out of grogu. Does anyone know what setting to use to test the light? Should I just put hot glue to keep it from coming off? Thanks

Search through the thread for the electrical tape method.

#684 6 months ago
Quoted from Yelobird:

I did one dot of hot glue and done.

Where did you put the drop of hot glue?

#685 6 months ago
Quoted from thekaiser82:

Where did you put the drop of hot glue?

At the side base of the reflector then inserted bulb.

#686 6 months ago

Got a call that Fedex will drop it off tomorrow. Fingers crossed for no damage and a surprise under the playfield. Mainly just for no damage...

-18
#687 6 months ago

Hi guys, just reviewed the Mando LE with 6,5 score out of 10, link to the video:

#688 6 months ago

Received my premium yesterday! It appears to be playing really well with no rejects. I did lose the flasher, lol. So far no issues. The right ramp is tough to hit! Otherwise, awesome game!

#689 6 months ago
Quoted from Looprunner:

Received my premium yesterday! It appears to be playing really well with no rejects. I did lose the flasher, lol. So far no issues. The right ramp is tough to hit! Otherwise, awesome game!

Backhand the right ramp from a cradle with right flipper. Its really easy to get since it needs no rollout from a cradle to hit it.

#691 6 months ago
Quoted from RETROCENGO:

Hi guys, just reviewed the Mando LE with 6,5 score out of 10, link to the video:

A 6.5 out of 10? Are you for real?

That would put it at #338 in the Pinside ratings. Really???

#692 6 months ago
Quoted from Looprunner:

Received my premium yesterday! It appears to be playing really well with no rejects. I did lose the flasher, lol. So far no issues. The right ramp is tough to hit! Otherwise, awesome game!

Does your shooter lane have a little jank to it? Been trying to diagnose a little ping-pong/s curving through the lane after a manual or auto plunge. Shooter tip is dead on center, level is perfect, tried pitch at 6.5-7 at the flippers. Talked to a couple others that noticed the same - doesn’t really seem to impact gameplay but definitely seems like unnecessary wear and tear. Anyone else notice this on any model?

#693 6 months ago
Quoted from NightTrain:

A 6.5 out of 10? Are you for real?
That would put it at #338 in the Pinside ratings. Really???

6.5 out of 7.65, they have a weird scoring system over there.

#694 6 months ago
Quoted from vikeking27:

Does your shooter lane have a little jank to it? Been trying to diagnose a little ping-pong/s curving through the lane after a manual or auto plunge. Shooter tip is dead on center, level is perfect, tried pitch at 6.5-7 at the flippers. Talked to a couple others that noticed the same - doesn’t really seem to impact gameplay but definitely seems like unnecessary wear and tear. Anyone else notice this on any model?

Mine is the same way, hard to consistently get full super skill shot plunge. Orbits are also rattletraps. still tweaking

#695 6 months ago

I have no idea how Stage 2 of the "You have what I want" wizard mode works. There is nothing in the tilt forums which describes any of the mini wizard modes. After you complete the first 4 flashing shots in Phase 1 to get on the ship, I can't tell what to do. The screen says hit 8 shots, but what shots? When you complete the upper playfield, it says stage complete, but doesn't reduce the number of shots.

The screen does a really poor job of telling you what to do in this wizard mode in particular. There have been times when watching streams that excellent players like Joannes and Jack Danger are in a mode and they have no idea what the hell to do to advance the mode. Seems like there is a bug that needs to be fixed here, or there needs to be a lot better explanation on the screen for what you are to do next.

This is also a bit of the case in Precious Cargo as you are told to hit flashing shots and when you do, nothing seems to happen to progress the mode.

Anyone with their game know how this mode works? Or can you take the glass off and post a summary?

#696 6 months ago
Quoted from NightTrain:

A 6.5 out of 10? Are you for real?
That would put it at #338 in the Pinside ratings. Really???

65% is such a crazy rating that I almost want to know his scores for everything. Like is MM a 7/10, "I don't like the Castle is a big waste of space and you just hit it up the middle".

#697 6 months ago
Quoted from vikeking27:

Does your shooter lane have a little jank to it? Been trying to diagnose a little ping-pong/s curving through the lane after a manual or auto plunge. Shooter tip is dead on center, level is perfect, tried pitch at 6.5-7 at the flippers. Talked to a couple others that noticed the same - doesn’t really seem to impact gameplay but definitely seems like unnecessary wear and tear. Anyone else notice this on any model?

It does. I didn't notice it until you mentioned it.

#698 6 months ago

Installed - looks pretty good imo. I've been working on other flipper topper designs as well (pulse rifle, blaster, extending the artwork from the lane guides, etc).

thinking about making a small run of these if anyone is interested.

IMG_20210722_182538.jpgIMG_20210722_182548.jpgIMG_20210722_182554.jpg
#699 6 months ago
Quoted from NightTrain:

A 6.5 out of 10? Are you for real?
That would put it at #338 in the Pinside ratings. Really???

Clickbait.

#700 6 months ago

Not sure if this will be the end placement or not yet for Slave 1. Fits. Not as wild that it covers a little bit of artwork on the plastics and shooter lane. Good size though. Don't know. Will have to see if it stays in or not. Haven't made up my mind yet, but for those looking to mod, here is a pic. Is the seismic charge even in the game??

IMG_2850 (resized).jpeg

There are 3,377 posts in this topic. You are on page 14 of 68.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside