(Topic ID: 142990)

The Who's TOMMY Club - Can you hear me? Members Only!


By ChadH

3 years ago



Topic Stats

  • 1,118 posts
  • 130 Pinsiders participating
  • Latest reply 5 hours ago by pinballjah
  • Topic is favorited by 62 Pinsiders

You

Linked Games

Topic Gallery

There have been 269 images uploaded to this topic. (View topic image gallery).

snip1 (resized).JPG
B8D7CE64-56EE-4804-8301-C3BD1797513F (resized).jpeg
pb4 (resized).jpg
Cn1 2 (resized).jpg
Cn1 1 (resized).jpg
762A11B5-258F-4219-9E4B-3C6C53228AF8 (resized).png
tommy proto vs serie2 (resized).jpg
tommy-altern-07 (resized).jpg
AADE2F7E-EB2C-42DA-8A15-15D290396C3D (resized).jpeg
C00A94BE-6285-4139-9787-9E9170A01471 (resized).jpeg
DDFBCE0E-62C0-47C2-92B7-A7E1CBD87270 (resized).png
rails (resized).jpg
image (resized).jpg
image (resized).jpg
image (resized).jpg
AF762282-A3F5-4714-847F-7C764A3E4640 (resized).jpeg

You're currently viewing posts by Pinsider colocole.
Click here to go back to viewing the entire thread.

#957 4 months ago

Would appreciate any help, it's a bummer to have a Tommy with nothing showing on the screen!

https://pinside.com/pinball/forum/topic/de-display-challenges-tommy

#959 4 months ago

I haven’t, I’ll do that tonight and update, thanks!

#961 4 months ago
Quoted from Ive:

You have tried the obvious thing I take it - reseating all the display ROMs ?

The good: the display comes on now, appears mainly due to flipping the display cable on the Display controller board (believe ColorDMD install instr. said put pin 1 to right, it's on the left now and display came on, maybe it's due to the replacement Stern board instead of DE?).

The bad: display freezes and then turns off. When I unplug either end of the display cable the Rom msg comes on and sometimes the display "recovers" and works normally into the beginning of the first ball if I quickly replug the cable, then freezes again. Can most consistently get display back by sliding display cable on/off connector at CPU board (but also works to do it at display board). Can't find any consistent way to get display to stay on or not freeze. Machine does seem to have other minor glitches related to this, sound will delay when display glitches sometimes, ball sitting in VUK but machine has lost it, power down and on recovers...CPU board problem? Thanks for the help.

IMG_3135 (resized).jpgIMG_3136 (resized).jpg
Promoted items from the Pinside Marketplace
Wanted
Machine - Wanted
Commack, NY
$ 25.00
Cabinet - Other
Filament Printing
From: € 15.00
Lighting - Led
TheDudeMods
$ 30.00
Electronics
Yorktown Parts and Equip
$ 50.00
From: € 25.00
Flipper Parts
TheDudeMods
From: $ 9.99

You're currently viewing posts by Pinsider colocole.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside