(Topic ID: 189990)

The Hobbit Windlance Up Post Coil Has Voltage But Doesn't Work...Solved.


By Elevatorman

2 years ago



Topic Stats

  • 13 posts
  • 3 Pinsiders participating
  • Latest reply 2 years ago by Mfsrc791
  • No one calls this topic a favorite

You

Linked Games

You're currently viewing posts by Pinsider wtatumjr.
Click here to go back to viewing the entire thread.

#3 2 years ago

Check fuses though something else would probably not be working if this was the case. Make sure you're testing with the access door closed as there's a safety switch. Trace wires back and see if there's a loose connection. Call JJP if all else fails

#5 2 years ago

You may have problem on the main board. Talk with JJP to diagnose (Best to call directly). It cost about $85 to send yours in for repair if out of warranty.
In my case a coil was stuck ON with my WOZ. Lloyd and the others are great diagnosing over the phone.

#8 2 years ago

Coil is bad most likely. If it shows signs of overheating replace but be prepared to immediately shut off if it's stuck on due to something else

#9 2 years ago

With my WOZ I blocked off the area with pull ties temporarily so it was playable (I'm not too familiar with the Hobbit)
You might find an identical coil under the playfield in a not too critical area and swap it but I'd wait for a replacement.
Also a good idea to order 2 coils from JJP in case this happens again - it's the shipping that's expensive.

Promoted items from the Pinside Marketplace
$ 11.95
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
7,000
Machine - For Sale
Albany, NY
$ 62.00
Playfield - Toys/Add-ons
The MOD Couple

You're currently viewing posts by Pinsider wtatumjr.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside