(Topic ID: 170989)

The Genesis Club

By Hazoff

7 years ago


Topic Heartbeat

Topic Stats

You

Linked Games

Topic Gallery

View topic image gallery

FCC75BCF-DA73-4DD4-BEA0-EC4CC00B87CA (resized).jpeg
6424B971-A708-49E1-B8BD-3A1AD3B47C73 (resized).jpeg
20231214_141649 (resized).jpg
20200807_203422~2 (resized).jpg
IMG_1066 (resized).jpeg
IMG_1067 (resized).jpeg
Screenshot from 2023-11-18 18-28-01 (resized).png
409DF305-3477-4C41-B73B-67F7D95189E6 (resized).jpeg
IMG_0881 (resized).jpeg
IMG_0880 (resized).jpeg
IMG_1775 (resized).jpeg
20231024_002110 (resized).jpg
20231021_115435 (resized).jpg
20231024_001156 (resized).jpg
IMG_9695 (resized).jpeg
20190706_143848 (resized).jpg

You're currently viewing posts by Pinsider cooperscooter.
Click here to go back to viewing the entire thread.

#88 6 years ago

Count me in! Mine has been a project over the years - first, the translite was replaced, then I re-made the paper backing to the reveal below, then replaced the displays, then the Swemmer board went in, with the ground mods, followed by the new clear ramps, and LEDs are next - its actually a neat game (need to figure out how to post vids).

fullsizeoutput_2267 (resized).jpegfullsizeoutput_2267 (resized).jpeg

fullsizeoutput_2268 (resized).jpegfullsizeoutput_2268 (resized).jpeg

fullsizeoutput_2265 (resized).jpegfullsizeoutput_2265 (resized).jpeg

IMG_9206 (resized).JPGIMG_9206 (resized).JPG

fullsizeoutput_2269 (resized).jpegfullsizeoutput_2269 (resized).jpeg

IMG_9203 (resized).JPGIMG_9203 (resized).JPG

5 years later
#404 1 year ago
Quoted from Robotworkshop:

Finally had a chance to shop out my Genesis. Complete rebuild on the flippers and install the new clear ramps and cliffy set. Made a huge difference!
Just one issue to resolve. Not MPU related since it acts the same running the original MPU or a LISY80 board.
The robot reveal rarely works. If I press on the motor relay it will start and go through the cycle. Doesn’t seem to work by MPU control. I’ve seen it work once on its own. Going to try and clean the contacts on the relay again. Beyond that I may try swapping out the transistor on the driver board that controls the relay.
Any other things to watch out for on the robot reveal?

Had this same issue - its the setup of the leaf switch near the motor - a make/break if I remember. Regardless, I had to actually trigger the event in game to see it work correctly - and it was that switch. If you need pics of mine as its set up, let me know!

Promoted items from Pinside Marketplace and Pinside Shops!
$ 83.00
Electronics
PinballReplacementParts
 
Great pinball charity
Pinball Edu

You're currently viewing posts by Pinsider cooperscooter.
Click here to go back to viewing the entire thread.

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, subscribe to Pinside+!


This page was printed from https://pinside.com/pinball/forum/topic/the-genesis-club?tu=cooperscooter and we tried optimising it for printing. Some page elements may have been deliberately hidden.

Scan the QR code on the left to jump to the URL this document was printed from.