(Topic ID: 170989)

The Genesis Club

By Hazoff

5 years ago


Topic Heartbeat

Topic Stats

  • 372 posts
  • 85 Pinsiders participating
  • Latest reply 2 days ago by donjagra
  • Topic is favorited by 35 Pinsiders

You

Linked Games

Topic Gallery

View topic image gallery

IMG_20220523_230512585_HDR.jpg
20220519_204308 (resized).jpg
38300951-D97E-42A5-B3BA-5E3AC510F9F4 (resized).jpeg
Image from iOS (26) (resized).jpg
20220118_141718 (resized).jpg
20220118_141723 (resized).jpg
20211124_163920 (resized).jpg
IMG_20210929_170343602 (resized).jpg
IMG_0458 (resized).JPG
539289D0-17CB-41A9-8402-2D8280AF0AED (resized).jpeg
2021-02-28 17.37.44 (resized).jpg
IMG_2919 (resized).jpg
IMG_2918 (resized).jpg
IMG_2906 (resized).jpg
IMG_2905 (resized).jpg
IMG_2901 (resized).jpg

There are 372 posts in this topic. You are on page 2 of 8.
#51 4 years ago
Quoted from martimagico:

I just finished my plasma disc mod. Went with one disc as the focal point rather than multiples. I think it looks great!

Dude, I dig it! I was thinking about a way to incorporate a plasma globe, but this is way cooler. Will be stealing this idea, thanks.

#52 4 years ago
Quoted from zimjoe:

Dude, I dig it! I was thinking about a way to incorporate a plasma globe, but this is way cooler. Will be stealing this idea, thanks.

https://pinside.com/pinball/forum/topic/fs-in-va-custom-gottlieb-genesis

I got the idea from prowlerman99

#53 4 years ago

Cool! I've been wanting to do this ever since I saw the plasma disked Black Hole. That looks BA. How did you attach the disk to the bumper skirt?

#54 4 years ago

Joined the club this weekend. I will say this is one of the easiest games to "shop". Now just to figure out what to do with the translight

IMG_8362 (resized).JPG

IMG_8365 (resized).JPG

IMG_8374 (resized).JPG

#55 4 years ago
Quoted from Its_me_aj:

Now just to figure out what to do with the translight

I'm going to get one of these printed this week. I had one before, but gave it away. I tweaked this version a little and am trying again. I'll post pics of how it turned out. stpcore printed my alt Raven translite and it came out great. There is a whole thread about it https://pinside.com/pinball/forum/topic/diy-custom-translites
GenesisSample (resized).png

#56 4 years ago

I saw that one!! Not sure if I wanted to do something alternate or look for a clean NOS horribly amazing original

#57 4 years ago

Anyone have a lead on a set of plastics? Really just need the slings and the ones above the bottom lane guides but...

#58 4 years ago
Quoted from Its_me_aj:

I saw that one!! Not sure if I wanted to do something alternate or look for a clean NOS horribly amazing original

The last NOS ones at PBR sold before I bought my Genesis. I almost bought one just to have it ready. The best thing about the translite is that it is easy to change

#59 4 years ago

I have my Genesis near ready but I have never played a 100% working one so I have questions.

The variable target. When I hit all the way back the the 40,000 sometimes the coil doesn't release it. When is it supposed to release it.

When I have Life Generator lit, I hit the 40,000 and it doesn't activate it. Only if I hold the target on that rivet for 4 or 5 seconds, will it activate.

#60 4 years ago
Quoted from futurepinhead:

I have my Genesis near ready but I have never played a 100% working one so I have questions.
The variable target. When I hit all the way back the the 40,000 sometimes the coil doesn't release it. When is it supposed to release it.
When I have Life Generator lit, I hit the 40,000 and it doesn't activate it. Only if I hold the target on that rivet for 4 or 5 seconds, will it activate.

Is it scoring when its shot all the way? I had to clean contacts on mine recently because it wasn't recognizing shots anymore and hanging up at times. Cleaned contacts and it was good to go again. I've never had to adjust it however

#61 4 years ago

Yes, I cleaned them.

They are scoring all rhe way back to 40k, but she only activates if I hold it in place on her switch rivots.

And it doesn't always release the target. I assume it's supposed to release it after you get it back to 40k

#62 4 years ago

Oh, its not revealing when you make the vari-target. The switch on the rotating robot shield cover thing has to be adjusted ever so perfectly. I forget off hand if its supposed to stay open all the way around then close and then open the switch again when its covered again. Mine didn't work right when I got it and I had to F with it for what seemed like forever to get it just right.

#63 4 years ago

The switch on the rotating cover works perfectly, just the damn vari target is the one that has me scratching my head

#64 4 years ago

I'll try and post a video of what it's doing this week.

I just don't know what it's supposed to do, so I don't know how to fix it or if it even needs fixed. Totally lost with it.

#65 4 years ago

I had the same issue with my vary target were it would not reset after being hit way back to 40K. I had to add a few more twists on to the spring. That made a big difference.
It will try and unravel on you.
It also could be a weak spring by the coil itself. Had to cut a few springs first time around on the drop targets to get them to work right, before the replacements came in.
RJ

#66 4 years ago

As far as activates only when you press on it by hand.

Turn the game off, unplug the assembly. Remove it, comes out very easily you do not have to remove the target,and operate the target by hand. clip onto to the wires that lead to each contact using alligator clips, and set your multi meter to ohms/Tone. Move the target to other score point contacts then to the one with a issue. Release it each time and watch the return motion. Since you are clipped in you can move contacts, solder pins,wires arond till you find what is loose. Clean the pins and check the barbs on the pins. This is were a dental pick helps, going into the molex also. If it dose not show up in tone mode. If you still has a issue. Go to ohms only and see if you have to much resistant between swipe and contacts. Compare the ohms reading on the other contacts.

Carefully Use a piece of plastic(monitor tweak tool) or wood stick to press on,move stuff around.

RJ

#67 4 years ago

So I was playing genesis Saturday morning and everything was perfectly fine. Went back later that night to play again and when I turned it off it would only boot with the flashers running. It would start a game but then it would randomly reset midball. Turned it off and checked connectors and everything. Turned it back on and then the under ramp kickouts wouldnt work and the robot cover wouldn't turn. Turned it off again and back on and now every light and coil locks on. No clue what's going on

#68 4 years ago

Have you done the ground mods to your game? Check your 5 and 12 volts.

Dose the display come on? Do you have a cap checker. I had 2 bad caps on the boot board.

RJ

#69 4 years ago
Quoted from rj:

As far as activates only when you press on it by hand.
Turn the game off, unplug the assembly. Remove it, comes out very easily you do not have to remove the target,and operate the target by hand. clip onto to the wires that lead to each contact using alligator clips, and set your multi meter to ohms/Tone. Move the target to other score point contacts then to the one with a issue. Release it each time and watch the return motion. Since you are clipped in you can move contacts, solder pins,wires arond till you find what is loose. Clean the pins and check the barbs on the pins. This is were a dental pick helps, going into the molex also. If it dose not show up in tone mode. If you still has a issue. Go to ohms only and see if you have to much resistant between swipe and contacts. Compare the ohms reading on the other contacts.
Carefully Use a piece of plastic(monitor tweak tool) or wood stick to press on,move stuff around.
RJ

On the vari-target, should it go past the last rivet at all or stop right on top of the last one?

#70 4 years ago

If I rember correctly stops on top. Each score has a position. There is some play on the swipe adjust. Finger nail polish the screw head after your done.

So click position 1 click position 2 and so on.pull the assembly and look at it on a bench.
I did re adjust mine so that all position had thevvsame contact points between the swipe and the circuit board. They started out leaning to one side..Close as I could get it.
It's not a pass by the pads, it has to be on the pads for score to register.

#71 4 years ago
Quoted from rj:

If I rember correctly stops on top. Each score has a position. There is some play on the swipe adjust. Finger nail polish the screw head after your done.
So click position 1 click position 2 and so on.pull the assembly and look at it on a bench.
I did re adjust mine so that all position had thevvsame contact points between the swipe and the circuit board. They started out leaning to one side..Close as I could get it.
It's not a pass by the pads, it has to be on the pads for score to register.

Mine originally had it land on top of the rivets and when it was like that, it just continuously scored that rivet's score. So I made with the contacts going just past the rivets then the scores worked perfectly but then I got the not always releasing and only getting it to activate motor when I held it in position for 3 or 4 seconds. I will do some more testing with it this week and shoot a video if I still have issues with it. I appreciate all the help!

#72 4 years ago

Unfortunatkey my daughter has the game in her basement now.

So I can't look at the vari target. I am sure someone will chime in. I thought there was something about the vari target in the game manual. I just remember mine was dirty off swipe points and the spring needed a few more wrap around the shaft.so it would return from the 40k position

RJ

#73 4 years ago
Quoted from rj:

Have you done the ground mods to your game? Check your 5 and 12 volts.
Dose the display come on? Do you have a cap checker. I had 2 bad caps on the boot board.
RJ

displays work. I thought about ordering a new power supply and the daughter board fix. not sure if that will take care of all the problems though. ill check 12 and 5 v tonight. I do not have a cap tester

#74 4 years ago

I like the solid state 5 volt supplies they offer.
The 2nd Genesis I had , I was playing around with my ESR meter and most of the elec. caps were out of spec. Game is from the early 80's. one of the two I believe 10mfd caps on the daughter board, showed open. No boot no display.

If you are getting the GL and the display is showing up. Then I believe it is booting.

Have you done the grounding mods to the game. It is worth the time. Makes them run some much better.

RJ

#75 4 years ago

I think the previous owner did the grounding mods. I just looked again and now the displays are not working. Everything just locks on as soon as you turn it on. Haven't checked voltage yet.

#76 4 years ago
Quoted from Its_me_aj:

I think the previous owner did the grounding mods. I just looked again and now the displays are not working. Everything just locks on as soon as you turn it on. Haven't checked voltage yet.

check out the TNT video on systems 80 b ground mounds on the molex connectors

#77 4 years ago

well I went through and double checked all the ground mods and everything was clean and good. checked voltages and they were good too. So I lifted the PF to check things under there and found out there were more fuses under the PF that I didn't know about (my first Gottlieb ss game.) the fuse for the outhole under the ramps was blown. so I replaced it and check by the ramp areas. I found that when I out the led flashers in, I mist have twisted the socket so one of the tabs was grounding out. turned it where it ended to be and the game booted up and played just like should. Stupid user error on that one.

#78 4 years ago
Quoted from Its_me_aj:

Stupid user error on that one.

Good to find the error and be up playing. Has the translite grown on you yet?

#79 4 years ago

https://pinside.com/pinball/forum/topic/help-adjusting-gottlieb-varitarget-genesis#post-2973526

This just fixed my vari target. Where I was confused, the coil is supposed to release the target after each score. This fixed it. Thanks for all the input.

#80 4 years ago

So your spring was to tight and I had to add a couple of turns to mine. I could never get it to retrurn to the starting position

Did you end up readjusting the leaf switches so the hits end up on a pad?

RJ

#81 4 years ago

Leaf switches were fine actually. My biggest issue, was I didn't know how it was supposed to act since I had never seen one in action. Mine wasn't so much the spring, but the magnet wasn't releasing it, so I had to adjust the bracket closer to the magnet. But I couldn't figure out why it was scoring non stop, and that's because it was supposed to release. So I had it in between the rivets, but that wasn't allowing it to start the reveal.

Needless to say, I was very excited.

2 weeks later
#82 4 years ago

Hi! I love that there is a Genesis club and I agree it's a great game. Mine hasn't worked for sometime now, but it's currently being fixed and I'm hoping to have it up and running within the next two weeks. This thread is great for getting caught up and I can't wait to help contribute. Also, thanks to this thread, I'll be sure to tell my guy to do the grounding mod asap.

IMG_0381 (resized).JPG

IMG_0389 (resized).JPG

1 month later
#83 4 years ago

While investigating a possible weak coil problem, I discovered my machine has A-20095 coils installed (super flipper). The manual calls for A-17875 coil. I have no idea what a super flipper coil is, nor do I know if this a preferred coil replacement. Is a supper flipper stronger than the correct flipper coil?

Any feedback on which coil should be used is appreciated.

#84 4 years ago

I would call pinball resource Monday see what they have to say

RJ

#85 4 years ago

The factory coils work fine if eos switches and flippers are set right, if what you have are too strong you will end up breaking ramps or plastics.

#86 4 years ago
Quoted from crlush:

The factory coils work fine if eos switches and flippers are set right, if what you have are too strong you will end up breaking ramps or plastics.

Mine plays 100% with the factory coils. When I bought it the flippers barely worked; it was just EOS switches out of adjustments. With them properly adjusted, I didn't even need the rebuild kit I ordered for it.

#87 4 years ago

Ok, dug into it a little closer, looking at the schematics. Apparently the game does use the A-20095 coils for the flippers, per the schematic.

On my game, using the left flipper to shoot up the right ramp was no problem. But using the right flipper to shoot up the left ramp, just didn't have enough power to make the shot. The left ramp does have more of a curve to it than the right ramp, and therefore would require a bit more power.

I replaced the right flipper coil, and now I'm able to shoot the left ramp. I measured the resistance of the new and old coils, and the old coil had slightly more resistance than the new coil.

#88 4 years ago

Count me in! Mine has been a project over the years - first, the translite was replaced, then I re-made the paper backing to the reveal below, then replaced the displays, then the Swemmer board went in, with the ground mods, followed by the new clear ramps, and LEDs are next - its actually a neat game (need to figure out how to post vids).

fullsizeoutput_2267 (resized).jpeg

fullsizeoutput_2268 (resized).jpeg

fullsizeoutput_2265 (resized).jpeg

IMG_9206 (resized).JPG

fullsizeoutput_2269 (resized).jpeg

IMG_9203 (resized).JPG

#89 4 years ago

Welcome! I love this game and I can't wait until it's fixed, which should be this coming up Monday....lol, I hope..

#90 4 years ago

Well, my game is finally working after all these years, but unfortunately there is no sound so I'm not too sure what to do at this point.. background music does come out briefly when we loosened up the connections on the mpu board connectors so there's some hope.

1 week later
#91 4 years ago

I've seen some with clear pop bodies/caps - does anyone know where I could source those?

#92 4 years ago
Quoted from remf:

Well, my game is finally working after all these years, but unfortunately there is no sound so I'm not too sure what to do at this point.. background music does come out briefly when we loosened up the connections on the mpu board connectors so there's some hope.

I currently have two Genesis. One of them is fully working and the other is getting there. I had a sound issue as well. It turned out to be connectors. I ended up just repinning all of them. But it appears the ones for the double edge connectors are drying up.

#93 4 years ago
Quoted from Robotoes:

I've seen some with clear pop bodies/caps - does anyone know where I could source those?

They are williams pop bumper parts on top, just buy the whole top, it will screw/line up with the gottlieb bottom.

#94 4 years ago
Quoted from crlush:

They are williams pop bumper parts on top, just buy the whole top, it will screw/line up with the gottlieb bottom.

Oh cool, thanks. Opens up a lot of possibilities. Putting my clear ramps on this week!

#95 4 years ago

I've got my Genesis machine almost completely re-assembled, but I'm not sure if I have the right shooter rod plate. This wasn't with the other parts of the game and it just doesn't seem like the right fit.
Anyone out there who could verify that this is the right or wrong shooter rod plate?
Thanks,
Jody

20171010_170600 (resized).jpg

#96 4 years ago

That is not the one in my game. I can take a photo tonight if no one else beats me.

#97 4 years ago

Thank you, that would be great if you post a photo!

Jody

#98 4 years ago

Anyone have a spare knocker assembly? I found out that mine is missing

#99 4 years ago
Quoted from jmountjoy111:

I currently have two Genesis. One of them is fully working and the other is getting there. I had a sound issue as well. It turned out to be connectors. I ended up just repinning all of them. But it appears the ones for the double edge connectors are drying up.

Thanks! I'll see if that's the issue when I get home tonight. I also have a buddy who's willing to let me plug in my MPU board to see if that's the issue or not as well.

#100 4 years ago

hey everyone, where are you getting your clear ramps? My dad has a Genesis and would love to install those!

Promoted items from the Pinside Marketplace
Trade
Machine - For Trade
Silver Grove, KY
Wanted
Machine - Wanted
Tampa, FL
$ 83.00
Electronics
PinballReplacementParts
$ 15.00
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 18.00
Apparel - Men
Pinside Shop
$ 14.00
$ 245.95
Boards
Allteksystems
There are 372 posts in this topic. You are on page 2 of 8.

Reply

Wanna join the discussion? Please sign in to reply to this topic.

Hey there! Welcome to Pinside!

Donate to Pinside

Great to see you're enjoying Pinside! Did you know Pinside is able to run without any 3rd-party banners or ads, thanks to the support from our visitors? Please consider a donation to Pinside and get anext to your username to show for it! Or better yet, become a Pinside+ member!