(Topic ID: 70775)

The Firepower Club


By wiredoug

6 years ago



Topic Stats

  • 3,378 posts
  • 292 Pinsiders participating
  • Latest reply 15 hours ago by Bugsy
  • Topic is favorited by 128 Pinsiders

You

Linked Games

Topic Gallery

There have been 885 images uploaded to this topic. (View topic image gallery).

D6955A4E-1360-4DA1-ABEE-F3708DD8D32F (resized).jpeg
E6B4489C-17F5-4452-A040-1E3A12C87806 (resized).jpeg
KIMG0136 (resized).JPG
15857019124281496185889 (resized).jpg
e69896d7fb616a2a22ca2ed72849e4d975e1bcc0 (resized).jpg
thumbnail (resized).jpeg
3FFCC32D-E227-41A4-AF81-E32A71DA126C (resized).jpeg
A009B6AF-DA42-4292-99FD-8A81C27E4DF4 (resized).jpeg
2CEF8019-50F5-410A-A9D5-297D7DF79EC1 (resized).jpeg
1981FAAB-6990-4A27-913C-A57EDB5C9731 (resized).jpeg
photo mar 21, 3 38 52 pm (resized).jpg
photo mar 21, 3 38 46 pm (resized).jpg
20200321_070118 (resized).jpg
20200321_070111 (resized).jpg
20200321_070100 (resized).jpg
20200321_070051 (resized).jpg

There are 3378 posts in this topic. You are on page 67 of 68.
#3301 46 days ago
Quoted from iamdrunker:

My outlane is much closer together. No way you can get a quarter in the gap. Maybe a dime would fit.[quoted image]

Wow! This is close. Ok so I’m comfortable with my decision to fill the extra hole closest to the insert. Thanks for the help everyone.
One step closure to saving another machine!

#3302 46 days ago

Ok I figured it out.
So yesterday I filled the extra hole with epoxy wood and painted it black.

After looking at your guys pics I set up the rails again and tried to adjust the pitch of the curve in the metal by hand.

Basically where the red line is I straightened that up a bit and bent it a little more where the red arrow is. This gave me some more space. Thanks for helping me figure this out guys.
53641464-1C47-430F-B278-157BD64FB255 (resized).jpegBDD85A15-A4B5-40AB-945C-C257B9B3C866 (resized).jpeg

#3303 46 days ago

The outlane ball has about an 1/16” between the wall and guide.

CB0C7EA8-F10C-489C-8799-A68AB191B09D (resized).jpegB5AEBD26-98C0-456E-9E7A-CD3177BC0BFC (resized).jpeg479E8949-5ADA-4B66-AADE-1316B57769D8 (resized).jpeg
#3304 46 days ago

Is the game supposed to be 3 or 5 ball? Thanks

#3305 46 days ago
Quoted from C_Presley:

Is the game supposed to be 3 or 5 ball? Thanks

You put 3 balls in it, but you can set it to 3 or 5 ball (or, anything really from 1-9) - seems to vary by territory. Solid states were always 3 ball by me growing up in central NJ. Other areas might have been different.

#3306 46 days ago
Quoted from RGarriott:

The outlane ball has about an 1/16” between the wall and guide.[quoted image][quoted image][quoted image]

You can countersink the left flat rail in order to give more room for the ball.
I did it to High Speed and the ball never got stuck in the games kickouts, and its kickback.

#3307 46 days ago

Not sure if you guys are seeing the amount of space I gained just by reshaping the metal guide on the rail but for what is worth a simple bend gave me equal space on the inner and outer lane.

Although now that I’m thinking about it, short of taking the metal guide off of the rail I’m not sure how someone having a similar issue would be able to bend it back...

#3308 46 days ago

As long as the ball doesn't hang up, I'd leave it in the outer hole. You need to be careful not to lose the sleeve and screw. They are pretty hard to find in my experience.

#3309 46 days ago
Quoted from Schwaggs:

As long as the ball doesn't hang up, I'd leave it in the outer hole. You need to be careful not to lose the sleeve and screw. They are pretty hard to find in my experience.

I already lost that damn sleeve! I found on actionpinball they used to sell them. 1/2” tall by 5/32. Might try Ace Hardware later today for a replacement.

#3310 46 days ago
Quoted from C_Presley:

Is the game supposed to be 3 or 5 ball? Thanks

Iv always seen it as 3 ball. Although when I bought mine it was set up as 5 ball. Previous owner liked it for the kids.

Quoted from vec-tor:

You can countersink the left flat rail in order to give more room for the ball.
I did it to High Speed and the ball never got stuck in the games kickouts, and its kickback.

Iv never had an issue with the ball getting stuck.

#3311 46 days ago
Quoted from RGarriott:

The outlane ball has about an 1/16” between the wall and guide.

Mine is tight, if I loosen the guide screw, move the guide to the left, hold & tighten, the ball gets stuck, move it to the right & tighten about .8 - 1mm gap, the ball can pass - I think is intentional by design to either have the tight "funnel" effect when draining, or to guide the ball better for when the ball is launched when kicked back.

#3312 46 days ago
Quoted from mrm_4:

I already lost that damn sleeve! I found on actionpinball they used to sell them. 1/2” tall by 5/32. Might try Ace Hardware later today for a replacement.

That stinks. The tricky part I encountered was finding a sleeve that the small screw would go through and wasn't too wide. Also, the screw head on the stock screw is really small in diameter. If that is too big, it can hang up the ball too.

Try aluminum tubing in the hobby section or at a hobby store.

#3313 46 days ago
Quoted from Schwaggs:

That stinks. The tricky part I encountered was finding a sleeve that the small screw would go through and wasn't too wide. Also, the screw head on the stock screw is really small in diameter. If that is too big, it can hang up the ball too.
Try aluminum tubing in the hobby section or at a hobby store.

That screw is a size 4 wood screw 1” long. No luck on the tube. Might hit hobby lobby tomorrow. Thanks for the tip.

#3315 46 days ago
Quoted from RGarriott:

Iv always seen it as 3 ball. Although when I bought mine it was set up as 5 ball. Previous owner liked it for the kids.

Iv never had an issue with the ball getting stuck.

Mine was setup for 5 ball with a factory looking tag, I’ve seen a couple others with the same tag as well. Seemed odd to me.

1 week later
#3316 36 days ago

I just got my boards repaired and now when I try and power up, the two top bumpers and the left slingshot lock on. Then the second fuse on the power board blows. Do I need to send the boards back again? I sent the driver and cpu board away because the game had the top right pop bumper locking on and now it's got more problems...
I also noticed that the switch below the power targets triggers 'tilt'. Any help would be appreciated.

2 weeks later
#3317 19 days ago

Anyone have some high res scan from the playfield planet or spaceship. The grey ball with all the small colored squares. Need a good version to start touching up.

Thx in advance

#3318 18 days ago

Back in the club. This time with the 1st. Firepower.

thumbnail-1 (resized).jpeg
#3319 18 days ago
Quoted from C_Presley:

Mine was setup for 5 ball with a factory looking tag, I’ve seen a couple others with the same tag as well. Seemed odd to me.

Mine is setup as 3 ball, but as you say, I think the original paper inlays for the apron says its a 5 ball game.

#3320 17 days ago

Anyone know which heads are the same size as Firepower?
Looking at a project with a damaged head..

#3321 17 days ago
Quoted from trk12fire:

Back in the club. This time with the 1st. Firepower.[quoted image]

Looks great!!

#3322 17 days ago

Thx Rblo,
Everything works ok, but all the mechanics need to be rebuilt. It’ll keep me busy for a little bit. Plus the play field is super dry, even after waxing. I’ll have to clear coat it asap to protect the artistry.

#3323 16 days ago
Quoted from the4horse:

I just got my boards repaired and now when I try and power up, the two top bumpers and the left slingshot lock on. Then the second fuse on the power board blows. Do I need to send the boards back again? I sent the driver and cpu board away because the game had the top right pop bumper locking on and now it's got more problems...
I also noticed that the switch below the power targets triggers 'tilt'. Any help would be appreciated.

Possibly the diodes on the coils were bad, and also has the 40 pin male/ female headers been replaced.

#3324 16 days ago
Quoted from chad:

Possibly the diodes on the coils were bad, and also has the 40 pin male/ female headers been replaced.

When I got my Firepower a year or so ago to refurb, one of the diodes on a pop bumper had apparently shorted internally, though I didn't know it at the time. After trying to fix then ultimately swapped the MPU and driver boards with a new Rottendog board, the failed diode revealed itself the first time a ball hit the pop bumper. Blew a transistor on my new board. Fixed the transistor and then replaced every diode on every coil for safe measure. The game has played great ever since.

#3325 15 days ago

Hey all,
I have my old plastics available. Let me know if you need anything. The one middle target plastic is cracked

86DCBB9F-4BFE-4945-9A40-74EDF35DB8C3 (resized).jpegDF5805D4-EBBF-4B0E-B302-3B42EE937BCD (resized).jpeg
#3326 15 days ago

Do you have the back left corner plastic?

Quoted from ChrisPINk25:

Hey all,
I have my old plastics available. Let me know if you need anything. The one middle target plastic is cracked[quoted image][quoted image]

#3327 15 days ago
Quoted from AirWolfNH:

Do you have the back left corner plastic?

I did. All plastic has been sold. Thanks all!

#3328 14 days ago
Quoted from chad:

Possibly the diodes on the coils were bad, and also has the 40 pin male/ female headers been replaced.

Yes, the 40 pin m/f headers are new. Only the one pop bumper locked on; then when I got the boards repaired, other coils locked on. I had changed the diode on the pop bumper.

#3329 14 days ago

I have 2 full sets of FP plastics. Condition of one set is very nice. The other set I'll take a look at. Most likely sell as sets.

I won't be home until mid-week, but I can send pics of these to any interested party by next weekend. Shoot me a message if interested

#3330 14 days ago

Leaving the club, for now. Gold CPR playfield and plastics. Decent cab and passable back glass. https://pinside.com/pinball/market/classifieds/ad/93342

#3331 12 days ago

Just got a FP and the person before me had clipped off the 24 pin connector in the backbox. After repinning, there was a yellow/grey wire left. It appears to come from the backbox lights and then loops through the idc connector. Not sure where this wire should go. Any help or maybe a picture would be great. Thank you!

20200321_070044 (resized).jpg20200321_070111 (resized).jpg20200321_070051 (resized).jpg20200321_070100 (resized).jpg20200321_070118 (resized).jpg
#3332 12 days ago

Williams used a universal wiring design. yel-gry is strobe #8 ... it should go to the backbox lamps...
lamps #57---#64... it should then go to a connector for the playfield lamps even though it is not used
on the playfield.

#3333 12 days ago

O.K. Thanks so much. Looks like I'm good then.

#3334 12 days ago

8P2/8J2 (white-24 Pin)
10 N/C not used... from maintenance manual.
From Jungle Lord...
8P2/8J2 pin 10 is used column strobe #8.

#3335 12 days ago

Reporting for duty! Rebuild finally done.

photo mar 21, 3 38 52 pm (resized).jpgphoto mar 21, 3 38 46 pm (resized).jpg
#3336 12 days ago

Does anyone have an extra bracket that holds the volume knob to the tilt panel?

It appears my project is missing the bracket and the machine nuts that hold the knob to the bracket.

Any help is appreciated

#3337 11 days ago

My CPR gold has been perfected by Ron Kruzman.

1981FAAB-6990-4A27-913C-A57EDB5C9731 (resized).jpeg2CEF8019-50F5-410A-A9D5-297D7DF79EC1 (resized).jpeg
#3338 11 days ago

Looks like a million dollars right there jigs. Its gonna be so fast

#3339 10 days ago
Quoted from Jigs:

My CPR gold has been perfected by Ron Kruzman.[quoted image][quoted image]

Only if there was enough time to do that to the whole collection.......

#3340 8 days ago

Does anyone have some high res scan from the FP pop bumper art. The yellow, orange, red blast. I'm trying to recreate them using some sort of transfer.

Thx in advance.

#3341 6 days ago

My lane change (1-4) stopped working. The switch under the right flipper is making contact and cleaned, all wires on the switch have been spliced and resoldered, the diode on the switch was replaced, the diodes under the 1-4 lights have been checked and the flipper button switches have been cleaned. I'm guessing there is something faulty with the board. Any suggestions?

#3342 6 days ago
Quoted from trk12fire:

My lane change (1-4) stopped working. The switch under the right flipper is making contact and cleaned, all wires on the switch have been spliced and resoldered, the diode on the switch was replaced, the diodes under the 1-4 lights have been checked and the flipper button switches have been cleaned. I'm guessing there is something faulty with the board. Any suggestions?

Are any other switches not working in the same row or column in the matrix?

https://www.pinitech.com/switch_database.php?name=Williams_Firepower

Reseating the connections on the board for the switches has fixed issues for me when I realised an entire row is out.

#3343 6 days ago

Yes, I just realized that almost the entire row is out. It appears to be GRN-BLU column 6. However the right kicker and play field tilt are still working in that column. All of the wiring and diodes seem ok. I'll need to reseat the board.

#3344 6 days ago

Reseated the row of dark green wires (switch column) a couple times with no luck. I did find that the amp column (IC13) chip was loose and I pushed it in. Still no luck. Are any of the transistors connected to that column?

#3345 6 days ago

After spending many a long hour hunched over the work bench bringing a System 7 board back to like, my Firepower is now a Firepower Deluxe!
3FFCC32D-E227-41A4-AF81-E32A71DA126C (resized).jpegA009B6AF-DA42-4292-99FD-8A81C27E4DF4 (resized).jpeg

#3346 6 days ago

Resistor R150 at the bottom is a little crispy as well. Not sure if it would cause this problem

thumbnail (resized).jpeg
#3347 6 days ago
Quoted from trk12fire:

Yes, I just realized that almost the entire row is out. It appears to be GRN-BLU column 6. However the right kicker and play field tilt are still working in that column. All of the wiring and diodes seem ok. I'll need to reseat the board.

Correction- The entire row is out. The right kicker works, but doesn't score and I checked the wrong tilt. I'll reflow some solder to the board pins tomorrow.

#3348 5 days ago
Quoted from trk12fire:

Resistor R150 at the bottom is a little crispy as well. Not sure if it would cause this problem[quoted image]

Make sure not only your connectors are making good contact by reseating them, but also that the wires are actually seated in the connector well. I have had to sort of resseat the wires even. Beyond that I do not know.

#3349 5 days ago
Quoted from trk12fire:

Resistor R150 at the bottom is a little crispy as well. Not sure if it would cause this problem[quoted image]

No, that's the lamp matrix resistor.

They're actually in good shape for those, usually the board is really burnt under them.

#3350 5 days ago
Quoted from trk12fire:

Reseated the row of dark green wires (switch column) a couple times with no luck. I did find that the amp column (IC13) chip was loose and I pushed it in. Still no luck. Are any of the transistors connected to that column?

Sometimes a wire in the matrix coming unsoldered can cause what you described. Did you trace the wires and make sure everything under the playfield is still attached?

Promoted items from the Pinside Marketplace
1,500 (Firm)
Machine - For Sale
Reno, NV
1,599 (Firm)
Machine - For Sale
Denver, CO
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 11.00
$ 399.95
Lighting - Led
Pin Stadium Pinball LEDs
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
$ 279.95
Lighting - Led
Pin Stadium Pinball LEDs
$ 22.00
From: $ 9.00
$ 17.00
There are 3378 posts in this topic. You are on page 67 of 68.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside