(Topic ID: 70775)

The Firepower Club


By wiredoug

5 years ago



Topic Stats

  • 3,115 posts
  • 275 Pinsiders participating
  • Latest reply 5 hours ago by Schwaggs
  • Topic is favorited by 117 Pinsiders

You

Linked Games

Topic Gallery

There have been 803 images uploaded to this topic. (View topic image gallery).

20191008_213729 (resized).jpg
20191008_213632 (resized).jpg
20191008_213800 (resized).jpg
20191008_213616 (resized).jpg
IMG_4128 (resized).JPG
IMG_4127 (resized).JPG
IMG_20190911_204026 (resized).jpg
IMG_2426[1] (resized).JPG
IMG_2420[1] (resized).JPG
IMG_20190901_102204__01 (resized).jpg
Flipper switch (resized).jpg
IMG_20190901_083108 (resized).jpg
IMG_20190901_081734__01__01 (resized).jpg
IMG_20190901_174419 (resized).jpg
IMG20190901174034 (resized).jpg
IMG_20190901_181402 (resized).jpg

There are 3115 posts in this topic. You are on page 63 of 63.
#3101 8 days ago
Quoted from someotherguy:

Most likely "prop" is just short for "property" ... it's an asset tag.
Richard

Agree...

#3102 7 days ago
Quoted from Schwaggs:

The bottoms appear to have been made by whatever paneling they could buy on the cheap. I've seen other pictures of brick patterned bottoms but never what you have...
That prop plate is not stock. Seems your game may be a movie or TV star! VERY cool! I would be preserving that provenance!

Hey all.

I have the same bottom on my Firepower

Also, I am a film and television prop master and I can attest that we do not tag assets this way. This is likely an operator inventory tag as mentioned.

Cheers!

#3103 7 days ago

I rebuilt
My. Right flipper and I get 20-24 spins on the spinner when I hit it solid.. does that sound about right or is it still weaker than it should be..

#3104 6 days ago
Quoted from topkat:

I rebuilt
My. Right flipper and I get 20-24 spins on the spinner when I hit it solid.. does that sound about right or is it still weaker than it should be..

The key for that shot is can you lock the ball in the upper lock? If you can, it is powerful enough.

#3105 6 days ago
Quoted from Schwaggs:

The key for that shot is can you lock the ball in the upper lock? If you can, it is powerful enough.

Ok. That’s good benchmark. The ball rarely goes in on that shot but it does make it up there without a problem
Thanks

#3106 5 days ago

An issue with - some - missing speech.

I've literally shotgunned my Firepower: changed all headers (including the 40pins), swapped all IDC connectors to trifurcons, replaced ALL caps on all boards and Mosfet'd the driver board following @vid1900 bulletproofing guide, reflowed all suspect joints, replaced all harnesses connectors/housings, installed @Inkochnito bridge board and @barakandl NVram + Special Solenoid Saver... and eventually got everything working.

Solenoids are working flawlessly as well as lamps (except of course for the right Special that is always on in Attract mode)

But there are some speech sounds that will play in diagnostic mode but not during the game.

For example:

- during multiball, I can hear "three" and "two", but not "one"
- at the end of the game I hear 2 words only not 3 (FP flipper guide says it should be 3 randoms words)
- The only sounds I can hear in-game are: "You", "Win", "Fire", "Power", "3", "2"
- I never hear "Enemy", "Destroy", "Mission"

I've tried to reset the 3 roms on the speech board but it's still not working, and as it's working in diagnostic and not in-game, I actually suspect the driver board.

Then I looked at http://www.firepowerpinball.com/2ya/FP-Parts-Snd.html but not sure where to start my troubleshooting.

For now, I did probe the five TIP122 related to the sounds at 2J9. Q35, Q37, Q39, Q33 and Q31 seem to be ok with B-C ranging from 2.31 to 3.02, and B-E ranging from 1.68 to 1.87. I've tried different methods of reading with the DMM in diode mode, and I never got a value close to 0.

I've ordered new TIP122 just in case, I think I'll change them anyway.

The small transistors Q30, Q32, Q34, Q36, Q38 are fine as well, all having the same readings.

So, any suggestions for me guys? should I replace the speech Roms? should I just accept to live my life with a non-100% working machine after spending hundreds of $ and days of labor?

#3107 2 days ago

Replaced the five TIP122 (Q35, Q37, Q39, Q33 and Q31) as well as the small transistors (Q30, Q32, Q34, Q36, Q38).

Still missing the same words.

Ordered a set of (used) speech ROMs, the missing words are in ROMs 5T4972 (IC5) ST4973 (IC6) so we'll see.

If it doesn't work with these ROMs then I'll replace the sockets and after that, the 2 amps MC1458 at IC2 and IC3.

#3108 1 day ago
Quoted from manples:

Replaced the five TIP122 (Q35, Q37, Q39, Q33 and Q31) as well as the small transistors (Q30, Q32, Q34, Q36, Q38).
Still missing the same words.
Ordered a set of (used) speech ROMs, the missing words are in ROMs 5T4972 (IC5) ST4973 (IC6) so we'll see.
If it doesn't work with these ROMs then I'll replace the sockets and after that, the 2 amps MC1458 at IC2 and IC3.

I would have started with the speech ROMs and their sockets, and the interconnect cable between the speech and sound board (known issue.)

All that shotgunning of parts is unnecessary work, IMO. The transistors can be tested, and the amps are obviously working.

Richard

#3109 1 day ago

The right Special insert that is always on in Attract mode is normal.

#3110 1 day ago
Quoted from orangegsx:

I’ve got an odd issue, that I’m pretty sure I created.
When I press start the flippers cannot be used for about 10 seconds, and after the final drain the flippers can be flipped for about ten seconds. It isn’t totally consistent. After a few games they will turn on right away. But will still be able to be flipped after game over for a bit.
Last week while doing some flipper work I shorted the switch matrix. Replaced IC15-18 and everything worked fine for a few days.
I don’t have a logic probe yet but going to order one. Would IC8 be a good start?

So this problem went away for a few months until the other day all the coils including flippers would work when you powered the game on, if you started a game the coils would all disable. Now I have no coils working at all. I borrowed this driver board to someone to help diagnose their game and it did the same thing.

Where exactly does the the game over signal originate?

#3111 1 day ago
Quoted from kuelman:

The right Special insert that is always on in Attract mode is normal.

Yes, that is normal. Not sure why...

#3112 1 day ago
Quoted from orangegsx:

So this problem went away for a few months until the other day all the coils including flippers would work when you powered the game on, if you started a game the coils would all disable. Now I have no coils working at all. I borrowed this driver board to someone to help diagnose their game and it did the same thing.
Where exactly does the the game over signal originate?

The "game over" signal is a combination of the blanking signal (which if active, would disable everything including displays and inserts) and a signal from the PIA at IC5 pin 19 on the driver board. If everything else is working and fresh (good 40 pin connector, for example), I would try replacing driver board IC5.

#3113 1 day ago
Quoted from Schwaggs:

The "game over" signal is a combination of the blanking signal (which if active, would disable everything including displays and inserts) and a signal from the PIA at IC5 pin 19 on the driver board. If everything else is working and fresh (good 40 pin connector, for example), I would try replacing driver board IC5.

Luckily I had an old sound board to scavenge that chip off of. Worked like a charm. Thanks for the help!

#3114 9 hours ago
Quoted from manples:

Replaced the five TIP122 (Q35, Q37, Q39, Q33 and Q31) as well as the small transistors (Q30, Q32, Q34, Q36, Q38).
Still missing the same words.
Ordered a set of (used) speech ROMs, the missing words are in ROMs 5T4972 (IC5) ST4973 (IC6) so we'll see.
If it doesn't work with these ROMs then I'll replace the sockets and after that, the 2 amps MC1458 at IC2 and IC3.

Following

#3115 5 hours ago
Quoted from orangegsx:

Luckily I had an old sound board to scavenge that chip off of. Worked like a charm. Thanks for the help!

Love it when a plan comes together! Congrats on the fix!

Promoted items from the Pinside Marketplace
$ 12.00
Cabinet - Other
Siegecraft Electronics
1,220 (OBO)
Machine - For Sale
Lincoln, NE
$ 20.00
Electronics
Yorktown Parts and Equip
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 22.00
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
There are 3115 posts in this topic. You are on page 63 of 63.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside