(Topic ID: 166858)

The Big Lebowski: Software Bugs and Errors - Post them here!


By zsciaeount

4 years ago



Topic Stats

  • 68 posts
  • 22 Pinsiders participating
  • Latest reply 1 day ago by KoenHeltzel
  • Topic is favorited by 24 Pinsiders

You

Linked Games

Topic Gallery

There have been 5 images uploaded to this topic. (View topic image gallery).

54209449-94D7-4D2E-BE58-3C3B729EE62E (resized).png
A738EE7D-7232-43E8-B936-62CEC066E500 (resized).png
A5B8CBE7-8E48-4224-B73C-15D17EF19032 (resized).jpeg
IMG_2900 (resized).jpg
F39D8E20-55D5-4085-9683-F7E77F594AB5 (resized).jpeg

There are 68 posts in this topic. You are on page 1 of 2.
#1 4 years ago

The Big Lebowski is here, and even though this is only DP's second time delivering code, and first time delivering a full set of hardware, they've managed to put together a pretty solid pin. Of course, there are always going to be issues and bugs, so I thought I'd create a thread for Achievers to post bugs and feature requests, etc. in one space to make it easy for the DP guys to process.

To make it easy to parse, please put your reports under these headings: DEFINITE BUGS, POSSIBLE BUGS, MECHANICAL ISSUES, MISSING FEATURES, FEATURE REQUESTS

Also, if something posted isn't a definite issue, or is not an issue on yours, please let me know... after all, mine arrived damaged, thanks to the delivery company...

DEFINITE BUGS

1) When a car mode has been completed, if the car is hit again while it is trying to be retracted, it will re-open fully and not retract until the end of the ball. Hits to the car will register as hits to the bare targets (X hits to light car mode), and since the right upper playfield exit is blocked by the car, you cannot start another car mode for the rest of the ball

2) Occasionally, the attempt at the super skill shot (right flipper held), will not award a "let's go bowling" light, even if hit early. It will offer only a letter

3) If the super skill shot is missed, the normal skill shot letter remains blinking until a MAUDE rollover is lit. Hitting the lit rollover does not award skill shot, so the scoring software knows the skill has been missed. This means it's probably just a light error

4) When starting the Female Form rug mode (and maybe others), and then quickly starting a character multiball, the music drops out, but sound effects remain

POSSIBLE BUGS:

1) The rug on my game is not responsive during the beginning of the game, and only responds to hits after I have lit a character or gotten a mystery. It will not register if the left ramp lock is lit for lock 1.

2) The Z at the left outlane will not register when the ball rolls down, but will register when the ball is kicked back up by the kickback

3) Sometimes hits to Walter or Donny will register multiple hits, especially if a switch is hit quickly after the shot is made. As in, I can hit up the right ramp and immediately nail a handicap parking target, and I am awarded a completion of Walter.

4) During character multiball and regular multiball, lit shots award a jackpot, but unlit shots often award no score at all

5) Countdowns do not pause when in the pop bumpers or while the ball is being held for a movie clip or mode start

6) There appears to be no way to enable wifi on the machine at present

7) Occasional double taps of the launch button will award a random shot

Rug will sometimes advance during mystery award collection

MECHANICAL ISSUES

1) The left ramp is loose - shots can bounce side to side and lose momentum quickly, resulting in rollbacks. This could be due in part to some of the flipper action, but it's also because the ramp shakes a bit

2) Rug intermittently sensitive

3) Car intermittently sensitive

4) Shooter lane switch has a tendency to get caught on the stuff below it on the underside of the playfield

5) The flipper buttons have a huge dead zone - can be difficult to cradle separate, tap pass, post pass, upper flipper cannot be staged

MISSING FEATURES

1) The car modes give no indication about progress towards completion

2) No callout when "let's go bowling is lit"

3) No callout when characters are lit

4) Difficult to gauge progress towards rug mode completion, as there are no audio cues

5) No grace period on Mark it Zero scoop hits

6) No callout to let you know you need to shoot the rug to finish rug mode

7) If there's an add-a-ball or a way to get an extra ball, I sure haven't found it.

FEATURE REQUESTS

1) Grace period on Mark It Zero scoop or just keep it lit since it's hard enough to complete as-is - that scoop is a bitch to hit in time if the right inlane is not the last switch hit... have that ball on the left flipper and you're not getting it. Also, it's annoying when you shoot while the light is still lit, the light goes out in transit, and all of the sudden, you are starting a multiball too early.

2) Countdowns pause when ball is not under player control

3) More callouts

4) More robust nihilist battle - not just banging targets

5) During multiball, make unlit shots worth more (maybe unlit awards jackpot, lit shot awards double jackpot)

6) Allow lock light stacking for first multiball

7) Knox Harrington, The Video Artist, Video Mode

Kickback lit at the start of each ball

9) More match sequences

#2 4 years ago

Great post!

#3 4 years ago

FYI in case you didn't know, DP runs its own customer support forums. So at minimum i'd post this over there as well.

3 years later
#4 1 year ago

As of 0.51 release:

  1. DEFINITE BUG | Let's Go Bowling Skill Shot doesn't light if you hold the right flipper down too early.
  2. POSSIBLE BUG | Timers don't stop while the cut scene plays in "MARK IT ZERO" & "START CHARACTER MULTIBALL"
  3. MISSING FEATURE | Allow option to STOP game from Start Button for Paid games
  4. FEATURE REQUEST | Option to End Bowling while Bowling

Let's Go Bowling Skill Shot-- Explanation
Hold the right flipper before you start a game or right after a ball drains. As long as you keep holding, the skill shot in the upper playfield doesn't light. You need to release the flipper and then press it again to activate the skill shot light. This is not an issue on the right flipper skill shot.

Timers don't stop for Mark it Zero-- Explanation
Now that timers stop while the ball is in the upper playfield and pops, it seems broken that timers don't stop while cut scenes play for MARK IT ZERO or START CHARACTER MULTIBALL. A lot of time is lost while those cut scenes play. It may also not be stopping for Mystery Award either.

Allow STOP Game from Start Button - NON-FREEPLAY-- Explanation
The feature to stop an in-progress game by holding down the start button is wonderful. Please add a choosable option to allow this for non-freeplay games also. It doesn't need to return credits or anything, just should be an option if owners wish to turn it on. Personally, I use coin mechs for my home games because I like the feeling of dropping coins in.

Option to End Bowling while Bowling-- Explanation
More than once I've had a drained bowling ball not register. It might be a physical issue with the switch, but there should still be a way to end bowling mode while bowling. At least after a ball search timer or something. Right now if the drain doesn't register the game just gets stuck. Maybe just an overall timer in the mode? There must be a time limit in bowling right? this is not ‘Nam. This is bowling. There are rules.

#5 1 year ago

In 0.51 release:

DEFINITE BUG | In bowling mode, the green lock arrow remains flashing while all other non-character playfield lights go out.

2 weeks later
#6 1 year ago

I unboxed my TBL yesterday and played a few games. It was shipped with .51 installed. It froze up last night and had a progress bar at about 25% during a game, so I held the start button down until it restarted. When games are over, a loud high pitched sound like a pop happens for about a split second around 80% of the time. Today I fired it up and everything displayed on the monitor is zoomed in. Top, sides, and bottom are cut off. When I go into the menu, most of it is cut off to the left. I went through the menu settings on the display itself and the issue appears to be from the video board because when I shifted the display to the right, the menu was still cut off.

Has anyone seen issues like my TBL has?

#7 1 year ago

I turned off my TBL when I made the last post and unplugged it. Turned it on a few minutes ago and the display was no longer zoomed.

Looking forward to the 1.0 code.

1 month later
#8 12 months ago

Gathering a list with reported bugs and wishes.

Can be seen at https://docs.google.com/spreadsheets/d/17Xb9AkuhFceae9Au2YzKGtETdpg9cNBMY4FQAmSaYQs

Pls use it if you have any need.

I will try to include ASAP also the things mentions here.

Sent this link also to the programmer Koen and Barry

1 week later
#9 11 months ago

I found that the ball search doesn’t include the shooter lane. Software?

Video:

https://1drv.ms/v/s!AqoPEeSaU3W1gbUqX_7UEZJKxrt2NA

#10 11 months ago

I don’t see the shooterlane. Only see ball in the through. Is it not normal to NOT include through in the ball search?

#11 11 months ago

That’s what I meant. It’s not ejecting into the lane even when ball search starts. The game is waiting to start a ball. The only way to continue the game at this point is to either power cycle or open the coin door and manually plunge.

#12 11 months ago

Is perhaps a switch in the through not working properly causing the game to think the ball is not in the through? Was this a single or multiplayer game?

#13 11 months ago

Multiple players

#14 11 months ago

When I just had my TBL I had this happen to. If I remember correctly this is a softwarebug which rarely occurs.

You can manually plunge it or do it via test menu. I will check on it.

#15 11 months ago

Checked and my memory was OK

It’s a rare difficult to reproduce softwarebug present during multiplay.

#16 11 months ago

You think this should be removed now?

F39D8E20-55D5-4085-9683-F7E77F594AB5 (resized).jpeg
#17 11 months ago
Quoted from JimB:

You think this should be removed now? [quoted image]

Thats in the settings. You can change it to what you like. Technically they made all the parts in the games we have now so it seems fitting anyway.

1 month later
#18 10 months ago

Where is firmware version 0.52?

I've added the following to the spreadsheet:

Bug - Detect trampoline failures - single ball, plays sound, immediate drain, new ball should kick out

Wish - Add new character 'modes' and 'hidden' character modes - game says Jesus mode lit, but I think this simply means 'for character multiball'

Bug- Upper flipper should be enabled when ball search is active. Will allow balls stuck behind upper flipper to be 'freed'

#19 10 months ago

Separate 'car' post...

On my game, the car doesn't behave well.

1. The stepper motor works fine in test but during the game, the car seems to be in the correct position around half the time. The game logic doesn't seem to be aware, detect, or address issues like this.

2. Oftentimes, strong car-hits don't register.

3. The sound effect played from a hit is very delayed

Do I have bad switches or optos? Beyond the stepper motor test, I didn't see any software options to calibrate.

#20 10 months ago

Firmware 0.52 is not officially released yet. Biggest difference against 0.51 is added light show for the EA apron which is not available yet so 0.51 is fine for now.

The car doesn’t have any calibration I am aware off. There are just a home switch inside the ‘garage’ and the standup targets are the end switchEs and register also hits to the car. Sounds like they need some tinkering with you. Removing the roof and than you can reach these targets.

In regard to delayed sound, no idea. Is it a specific target or ....??

#21 10 months ago

So my game was playing jesus video right after the ball launched and once the ball ran over MAUDE letters, the two videos would play causing the audio on the Jesus video to be out of sync. I realized what the issue is!

My game right now is registering Jesus letters when shooting Maude! Anyone know how to reverse so the game will register Jesus shots when shooting Jesus and stop recognizing Jesus only in Maude shot?

I think the switches are working fine to register they just need to be switched but I don't have schematic for this game.

Might even be helpful to have a pic of someone's correct boards in that area so I can compare number and name the change. I guess it could be in the head too.

Thanks!

#22 10 months ago
Quoted from delt31:

My game right now is registering Jesus letters when shooting Maude! Anyone know how to reverse so the game will register Jesus shots when shooting Jesus and stop recognizing Jesus only in Maude shot?
I think the switches are working fine to register they just need to be switched but I don't have schematic for this game.
Might even be helpful to have a pic of someone's correct boards in that area so I can compare number and name the change. I guess it could be in the head too.
Thanks!

My new game is also behaving oddly and unreliably (ghost switches, car hits not registering, bowling alley stops registering hits). Lack of docs is a real problem. For example, is this the default output of the switch test mode?

IMG_2900 (resized).jpg
#23 10 months ago

All fixed! Figured it out. On the PCB, switch 43 was plugged into 34. Kudos to Dutch for really doing a good job labeling the wires (each with their own number) and when I went into switch test I could tell center ramp (Jesus) was going off for a right loop MAUDE shot. Knew 43 was reversed and it was.

This was NIB too. Just a human error and it wasn't identified during the "testing". Rest of the game needed tweaks too (all pinball related) - plays perfectly.

As for garage car registering, mine always worked well but it's documented here and the TBL owners thread - all about tweaking the switch leaf underneath.

Make sure your pop bumpers are both shooting too. My right one had to be tweaked to work! Game is great.

#24 10 months ago
Quoted from Reznnate:

My new game is also behaving oddly and unreliably (ghost switches, car hits not registering, bowling alley stops registering hits). Lack of docs is a real problem. For example, is this the default output of the switch test mode?[quoted image]

This is my standard switch test screen after booting the pinball. You have two more switches as me activated.

I would check all connectors are seated properly. Perhaps one got loose during transport.

A5B8CBE7-8E48-4224-B73C-15D17EF19032 (resized).jpeg
#25 10 months ago
Quoted from delt31:

Make sure your pop bumpers are both shooting too. My right one had to be tweaked to work! Game is great.

Mine had the same issue

1 month later
#26 8 months ago

I got a dead R lower flipper today, all other coils test fine. Flipper buttons test fine in switch. I have continuity from coil to the large PCB....where do I look next? Transistors on the large board?

#27 8 months ago

My right flipper did that and it was a loose connection. That connection isn’t snug on mine and vibration made it keep coming off.

#28 8 months ago

Yeah I reseated the connector with no improvement

Quoted from JimB:

My right flipper did that and it was a loose connection. That connection isn’t snug on mine and vibration made it keep coming off.

5 months later
#29 86 days ago
Quoted from Reznnate:

Separate 'car' post...
On my game, the car doesn't behave well.
1. The stepper motor works fine in test but during the game, the car seems to be in the correct position around half the time. The game logic doesn't seem to be aware, detect, or address issues like this.

Following up. I was able to fix bowling alley with new opto sensor. Yay!

Unfortunately, the 'state' of the car still gets stuck half-out when it should have moved inside. This is terrible because it blocks the scoop. I believe this is due to bad red switches that might be ghosting. I need new switches. I'm waiting. But from a code standpoint, this is a fault tolerance issue that is a game killer. Is anyone else seeing this? I'd like to add this to the bug list if I'm not the only one seeing it.

#30 80 days ago
Quoted from Reznnate:

Following up. I was able to fix bowling alley with new opto sensor. Yay!
Unfortunately, the 'state' of the car still gets stuck half-out when it should have moved inside. This is terrible because it blocks the scoop. I believe this is due to bad red switches that might be ghosting. I need new switches. I'm waiting. But from a code standpoint, this is a fault tolerance issue that is a game killer. Is anyone else seeing this? I'd like to add this to the bug list if I'm not the only one seeing it.

Sounds like a faulty or misaligned home switch. If you remove the roof you will see immediately which switch it is. Check proper working and if working, adjust position. Don’t think this is a softwarebug.

2 weeks later
#31 66 days ago

Just opened up a BL and have a problem with the bowling alley that we can't seem to find the answer to. Originally if you bowled, the pins did nothing. no registration of bowling and it eventually failed you even though you could bowl the ball.

Testing the alley, the pins in the solenoid test section, all of the mechanisms work. The optical sensor registers, it all works gread. You can go into the gear motor menu and see that the LEFT TO RIGHT function is working properly and reading the info correctly.

After testing, the alley worked, *kind of* for a while. I say kind of because it flat out was not reading the ball launch correctly The second the ball was let go, the machine would flip the pins it knew you would hit before the ball got close to it. Then, the next round it would work perfect, a few rounds later, back to "pre-predicted" bowling.

Now, no matter what, it flat doesn't work. All the switches, sensors and solenoids work great.

Any advice is greatly appreciated.

#32 66 days ago
Quoted from splittingatoms:

Just opened up a BL and have a problem with the bowling alley that we can't seem to find the answer to. Originally if you bowled, the pins did nothing. no registration of bowling and it eventually failed you even though you could bowl the ball.
Testing the alley, the pins in the solenoid test section, all of the mechanisms work. The optical sensor registers, it all works gread. You can go into the gear motor menu and see that the LEFT TO RIGHT function is working properly and reading the info correctly.
After testing, the alley worked, *kind of* for a while. I say kind of because it flat out was not reading the ball launch correctly The second the ball was let go, the machine would flip the pins it knew you would hit before the ball got close to it. Then, the next round it would work perfect, a few rounds later, back to "pre-predicted" bowling.
Now, no matter what, it flat doesn't work. All the switches, sensors and solenoids work great.
Any advice is greatly appreciated.

My suggestion is to ask your question here.....

https://pinside.com/pinball/forum/topic/a-lotta-ins-a-lotta-outs-tbl-maintenance-thread

3 weeks later
#33 42 days ago

Have any of you guys experienced while playing a game the machine stops registering shots and once you shoot it into to the drain, the saucer or the scoop it sits there. It doesn't go into ball search. At that point my machine has frozen up and needs to be turned off and on. This seems to be happening more and more. Last night it happened 5 out of 6 games. It happens in 1 to 4 player games.

My wife and I both have noticed it happens a lot when the left stand up target for the ball lock on the the dude ramp is hit.

Thanks for the help.

#34 41 days ago

Not in all.
I only remember the ball was in the left kicker, I opened the coindoor to set volumen. After closing the machine forgot where the ball was and .. no ball search.
Had to reboot. But in play this did not happen yet.

2 weeks later
#35 27 days ago

Wondering when spelling the letters MAUDE, only the A at the start doesn’t like to register a hit, how is this part of the game suppose to work? Fix? I checked all those switches and they’re fine.

#36 27 days ago
Quoted from Sandeep:

Wondering when spelling the letters MAUDE, only the A at the start doesn’t like to register a hit, how is this part of the game suppose to work? Fix? I checked all those switches and they’re fine.

I've had this happen with various letters. Doesn't register the first one, but works fine thereafter.

#37 27 days ago
Quoted from Tuna_Delight:

I've had this happen with various letters. Doesn't register the first one, but works fine thereafter.

Ok, then could be another bug to add to the list. Thanks. I’m told new code for 2021, gonna be great.

#38 27 days ago
Quoted from Sandeep:

Ok, then could be another big to add to the list. Thanks. I’m told new code for 2021, gonna be great.

Quoted from Tuna_Delight:

I've had this happen with various letters. Doesn't register the first one, but works fine thereafter.

Did switch test, reseated connectors, switch works and problem solved...needed to be tested in switch matrix then..?

#39 27 days ago

How much can a new code update improve the game?

#40 27 days ago
Quoted from Sandeep:

How much can a new code update improve the game?

It will not change the hardware nor the playfield layout. If the layout is boring for you, code will not safe your day.
If you love the gameplay but unhappy with bugs and little software issues like the non registered switches, sound drop offs, no extraballs and no big final ... this will be solved within the months.

Updates can do a lot, but you have to like the basic machine. TBL plays right little like a MM, if you like this rules you will like TBL.
I love TBL for its theme ...

#41 27 days ago
Quoted from Sandeep:

Wondering when spelling the letters MAUDE, only the A at the start doesn’t like to register a hit, how is this part of the game suppose to work? Fix? I checked all those switches and they’re fine.

For me this sounds like a malfunctioning switch issue. Try it in switch test with a real ball is always the advice. But I read you reseated the connectors and now it’s fine. It’s not a known bug to me at least.

I have done a several months trial with these switches https://www.pinballlife.com/rollover-switch-with-mounting-bracket.html

DP is about to step over or already did. These switches work great and especially with the kickback at the left outlane it’s much more consistent. You do need to cut off however the Lshape at the end of the ‘wire’.

#42 27 days ago
Quoted from Sandeep:

How much can a new code update improve the game?

Talk with the Lyman fans I would say.

Just see how the code turned TWD around. What it did to B66. No, code can do a lot but yup, it doesn’t change the geometry of a game. Clunky remains clunky.

#43 26 days ago

Mhh .. I have the same, MAU does not react on the first balls, if DE is triggered also the upper row works. So the switches are fine, this seems to me like an other bug ! After 2 games all switches react as they should, but upper line need a trigger first ...

Quoted from Rensh:

For me this sounds like a malfunctioning switch issue. Try it in switch test with a real ball is always the advice. But I read you reseated the connectors and now it’s fine. It’s not a known bug to me at least.
I have done a several months trial with these switches https://www.pinballlife.com/rollover-switch-with-mounting-bracket.html
DP is about to step over or already did. These switches work great and especially with the kickback at the left outlane it’s much more consistent. You do need to cut off however the Lshape at the end of the ‘wire’.

1 week later
#44 18 days ago
Quoted from Rensh:

For me this sounds like a malfunctioning switch issue. Try it in switch test with a real ball is always the advice. But I read you reseated the connectors and now it’s fine. It’s not a known bug to me at least.
I have done a several months trial with these switches https://www.pinballlife.com/rollover-switch-with-mounting-bracket.html
DP is about to step over or already did. These switches work great and especially with the kickback at the left outlane it’s much more consistent. You do need to cut off however the Lshape at the end of the ‘wire’.

This could be shipping issue. From Netherlands to Canada, lots of moving. Thank you.

#45 18 days ago
Quoted from TomDK:

It will not change the hardware nor the playfield layout. If the layout is boring for you, code will not safe your day.
If you love the gameplay but unhappy with bugs and little software issues like the non registered switches, sound drop offs, no extraballs and no big final ... this will be solved within the months.
Updates can do a lot, but you have to like the basic machine. TBL plays right little like a MM, if you like this rules you will like TBL.
I love TBL for its theme ...

Thank you, I really enjoy MM and the layout is fantastic. Looking forward.

#46 18 days ago
Quoted from Rensh:

Talk with the Lyman fans I would say.
Just see how the code turned TWD around. What it did to B66. No, code can do a lot but yup, it doesn’t change the geometry of a game. Clunky remains clunky.

Yes code can do wonders especially if you’re happy with the geometry of the game. Love the tbl layout.

#47 18 days ago

Does anyone know how to get to nihilist? I’ve hit the 3 targets red with the nihilist. They flash when hit.

#48 18 days ago
Quoted from Sandeep:

Does anyone know how to get to nihilist? I’ve hit the 3 targets red with the nihilist. They flash when hit.

When you hit the target, look at the display. There will be a little nihilist and a number that counts down with each hit to enable the mode

#49 18 days ago
Quoted from Sandeep:

Does anyone know how to get to nihilist? I’ve hit the 3 targets red with the nihilist. They flash when hit.

The default code is 25 collective hits to the 3 Nihilist standup targets will activate the mode at the scoop.

The number of hits required is adjustable in the game settings.

#50 17 days ago

Have the manual concept ready for the menu and gamerules. Its now with Barry for final check after which it goes to a spelling checker to make sure it’s readable English and than to a DTP person who makes the layout.

So hopefully somewhere februari ready for download from DP website and than all these kind of questions can more easily be answered .

54209449-94D7-4D2E-BE58-3C3B729EE62E (resized).pngA738EE7D-7232-43E8-B936-62CEC066E500 (resized).png
Promoted items from the Pinside Marketplace
$ 259.95
Lighting - Led
Pin Stadium Pinball Mods
$ 50.00
Playfield - Toys/Add-ons
Back Alley Creations
$ 259.99
Cabinet - Toppers
Lighted Pinball Mods
$ 50.00
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
$ 12.50
Cabinet - Sound/Speakers
Gweem's Mods
Wanted
Machine - Wanted
Greeley, CO
$ 399.95
Lighting - Led
Pin Stadium Pinball Mods
From: $ 18.00
Apparel - Men
Pinside Shop
$ 39.00
Playfield - Toys/Add-ons
The MOD Couple
$ 22.50
$ 44.50
Playfield - Toys/Add-ons
The MOD Couple
There are 68 posts in this topic. You are on page 1 of 2.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside