TFTC OWNERS: "Fang Club" - "The MORGUE, the merrier!"


By E_N_3

4 years ago


Stats

  • 2,580 posts
  • 211 Pinsiders participating
  • Latest reply 2 hours ago by davebart5
  • Topic is favorited by 88 Pinsiders

Find

Search this topic for posts matching certain words or written by a specific Pinsider. Or both!




Linked Games



Topic Gallery

There have been 730 images uploaded to this topic. (View topic image gallery).

IMG_3892.JPG
IMG_3893.JPG
WhatsApp Image 2017-10-12 at 14.04.20 (resized).jpeg
P1000079 (resized).JPG
IMG_20171010_1621334.jpg
IMG-20171007-WA0012 (resized).jpg
TFTC_Plastic (resized).jpg
IMG-20171007-WA0015 (resized).jpg
IMG_1728 (resized).JPG
IMG_1727 (resized).JPG
DSC07964.JPG
DSC07969.JPG
DSC07986.JPG
DSC07992.JPG
DSC07925.JPG
DSC07979.JPG


There are 2580 posts in topic. You are on page 50 of 52.
#2451 4 months ago
Quoted from Billy16:

Was there anything wrong with your old sound board, or did you swap out hoping for an upgrade in sound quality? Which board did you use?

I've noticed my sound jumps when I start multiball. Anyone have this delayed sound jump? Goes from base level and jumps to the increased multiball level.

#2452 4 months ago
Quoted from Billy16:

Was there anything wrong with your old sound board, or did you swap out hoping for an upgrade in sound quality? Which board did you use?

Sorry,
just edited my post.
I actually fitted a separate PSU for the sound card!

The plunger in the dropps would sometimes drop out when I got it.
talked to a few other owners and someone said there was incorrect parts fitted from the factory.
I've never (4 years ownership) been about to find the right plunger/link combo.

The plunger would always drop down too far causing the link to "elbow" too much which would stop the plunger pulling up.

#2453 4 months ago

Hi all, I'm new to preside and have had a TFTC for years. Still love the game. I'm a bit behind the times as just read about the 4.00 update which I will definitely be chasing up. Great info and love the thread . Much more info than the other site I have been using .

#2454 4 months ago

The new code transforms the game and makes it way more fun, you'll like it.

#2455 4 months ago

Has anyone found the eyes shown in the pic a page back from here!? I don't want the eye mod from eBay I want to make my own! Anyone?

#2456 4 months ago
Quoted from Toastie:

Hi all, I'm new to preside and have had a TFTC for years. Still love the game. I'm a bit behind the times as just read about the 4.00 update which I will definitely be chasing up.

You are in for a treat.

#2457 4 months ago
Quoted from Jackontherocks:

My DMD is acting up, while playing screen went completely blank but game would still play and sound worked. Turned it off and back on and it worked but sometimes the DMD would break up a little or appear to cut off with not the full screen or a few lines missing, any ideas for a none tech guy, thanks. I will post pictures if happens again.

I had a similar issue with my DE WWFRR. It turned out to be the connector going to the DMD was no longer making good connections with the pins in the DMD, and/or the wires in the connector were no longer making good contact with the "teeth" that grip with wires for the harness (commn issue with that style harness). Knowing that connector setup often has problems with the wires getting loose, I switch to the connector style that you crimp the connector on to the end of the wire and slide it in to the harness. And I went with the crimp connectors with the three edges, so it insures a tight and snug connection on to the pins on the DMD.

I included a pic so you can see what I am talking about a little better.

IMG_1716 (resized).JPG

#2458 4 months ago
Quoted from E_N_3:

I had a similar issue with my DE WWFRR. It turned out to be the connector doing to the DMD was no longer making good connections with the pins in the DMD, and/or the wires in the connector were no longer making good contact with the "teeth" that grip with wires for the harness (commn issue with that style harness). Knowing that connector setup often has problems with the wires getting loose, I switch to the connector style that you crimp the connector on to the end of the wire and slide it in to the harness. And I wend with the crimp connectors with the theee edges, so it insures a tight and snug connection on to the pins on the DMD.

Good write up! I had to do the same thing to my DESW, JP, and TFTC... very common issue with Data East games.

#2459 4 months ago

This might be more just a Data East question, but since I'm dealing with my TFTC thought I'd opt it out in case anyone has seen a like situation. Just about done "shopping out" my TFTC. It was a long ago re-import from Spain and HUO the last decade or so.

The final thing I wanted/needed to do was replace the micro-switch http://www.marcospecialties.com/pinball-parts/180-5101-00 that signals the solenoid to shoot the ball into the shooter lane. It was not always firing.

When I went to take off the old switch I saw that the diode was no longer connected (see photo). I looked on line and found under-playfield photos of JP which seems to have the same configuration, and the diode was connected. I reconnected the diode after which the coil would no longer fire. The ball would only be ejected into the shooter lane during a ball search. I disconnected the diode and the solenoid immediately began firing again.

Is anybody else's Tales configured the same way--with the diode detached? If anyone has a photo of their switch that they can share I'd be grateful.

It was like that when I got the game a few months ago; not a show stopper but one of those little things that bugs me. I fixed all the other wiring issues, and this one of the last issues I have remaining. I can easily change a diode, but wanted to get some more information on this first. Thanks!

DSC01928 (resized).JPG

#2460 4 months ago
Quoted from E_N_3:

I had a similar issue with my DE WWFRR. It turned out to be the connector doing to the DMD was no longer making good connections with the pins in the DMD, and/or the wires in the connector were no longer making good contact with the "teeth" that grip with wires for the harness (commn issue with that style harness). Knowing that connector setup often has problems with the wires getting loose, I switch to the connector style that you crimp the connector on to the end of the wire and slide it in to the harness. And I wend with the crimp connectors with the theee edges, so it insures a tight and snug connection on to the pins on the DMD.
I included a pic so you can see what I am talking about a little better.

Thanks very much for the response, I will try my best. Also thanks to others as well who responded.

#2461 4 months ago

Diode is present and needed....I'd replace it and you should be good....

20170630_193959 (resized).jpg

#2462 4 months ago
Quoted from Jackontherocks:

Thanks very much for the response, I will try my best. Also thanks to others as well who responded.

If you are nervous, and don't feel like you can handle doing the change to the different connector, I would be happy to help you if you need help. Let me know.
--Ed

#2463 4 months ago
Quoted from Sonic:

Diode is present and needed....I'd replace it and you should be good....

Ok, thanks. Maybe the diode went bad at some point and somebody decided to disconnect it entirely. I'll put a new one on today. Thanks for the photo.

#2464 4 months ago

Any body rocking any coloured rubbers?
I'm sick of the back rubber in mine and fancy a change.
Dont think white would suit this pin ?

Maybe green ?

#2465 4 months ago
Quoted from urbanledge:

Any body rocking any coloured rubbers?
I'm sick of the back rubber in mine and fancy a change.
Dont think white would suit this pin ?
Maybe green ?

IMG_3694 (resized).JPG

IMG_3696 (resized).JPG

IMG_3697 (resized).JPG

IMG_3698 (resized).JPG

#2466 4 months ago
Quoted from Antennaejim:

Has anyone found the eyes shown in the pic a page back from here!? I don't want the eye mod from eBay I want to make my own! Anyone?

@Antennaejim I found these on eBay and used a drimmel to cut an opening. I then placed some sealant on the backside.
ebay.com link » One Pair Bloody Ripped Out Eyeball Haunted House Horror Prop Decoration Eye

IMG_8696 (resized).JPG

IMG_8697 (resized).JPG

#2467 4 months ago
Quoted from urbanledge:

Any body rocking any coloured rubbers?
I'm sick of the back rubber in mine and fancy a change.
Dont think white would suit this pin ?
Maybe green ?

Here are a couple of photos of my TFTC using some colored rubbers. The rubber colors used on my TFTC are pretty subtle, but a little more flashy than the standard black rubbers.

Gord

DSCN3674 (resized).JPG
DSCN3670 (resized).JPG

1 week later
#2468 4 months ago

Had to share this as it was very fitting. New owner picked her up with this!

20170715_133454 (resized).jpg

#2469 4 months ago

Picked up my TFTC yesterday. My first pin, and I LOVE it. Great theme - so much fun, approachable for newbies but deep enough to keep a pinhead scrapping. Only gotten replay twice in a little over 24 hours. Good stuff!

#2470 4 months ago

Anyone looking to leave the club? Pm me!

#2471 4 months ago

Changing to black decals.....

image (resized).jpeg

image (resized).jpeg

image (resized).jpeg

1 week later
#2472 3 months ago

Where is the best place to order the 4.0 roms? New to the club and also wondering how to adjust the tombstone sensitivity?
Thanks for any help in advance!

#2473 3 months ago

Black decals installed

image (resized).jpeg

#2474 3 months ago

Nice . . . are those from RetroRefurbs?

#2475 3 months ago
Quoted from wcbu64:

Nice . . . are those from RetroRefurbs?

Sadly no ... Bought them from German company 3 years ago... procrastination at its finest!

#2476 3 months ago

Ha . . . I did purchase the black version decals from RetroRefurb, but don't even have my TFTC machine yet. I've been acquiring parts in anticipation of the day I find a good one for sale locally to refurbish.

#2477 3 months ago
Quoted from gibsonrd:

Where is the best place to order the 4.0 roms? New to the club and also wondering how to adjust the tombstone sensitivity?
Thanks for any help in advance!

John Wart....he's the main guy around these parts.... his handle is johnwartjr here on Pinside...

#2478 3 months ago

Today got my new ROMs from John Wart and loving this upgrade.

But...quick question. My TFTC came with lots of small issues and one by one I've fixed them.

I thought I had everything sorted but was installing the ROM upgrade and realized I have a loose grounding wire. Does anyone know where this one goes???? It's on the bottom right of the back box. I can't find any info on line or in the owners manual.

Thanks.

IMG_0677 (resized).JPG

IMG_0678 (resized).JPG

#2479 3 months ago
Quoted from Cyrus:

loose grounding wire

make sure you have a grounding wire to the DMD (would go under one of the ~6 nuts that secure the DMD and controller board).

#2480 3 months ago
Quoted from Cyrus:

Today got my new ROMs from John Wart and loving this upgrade.
But...quick question. My TFTC came with lots of small issues and one by one I've fixed them.
I thought I had everything sorted but was installing the ROM upgrade and realized I have a loose grounding wire. Does anyone know where this one goes???? It's on the bottom right of the back box. I can't find any info on line or in the owners manual.
Thanks.

Mine is connected to the speaker 1 either side of Back box to each speaker

1 week later
#2481 3 months ago

Hi guys,

Got a TFTC recently and was unable to play. These are some of the problems which I have noticed and was unable to find a solution. Would love you seek your expertise on repairing this lovely creepy machine.

1. Game boots up perfectly and was greeted with attract mode, but the moment I press the start button, ball was not launched on the playfield and flippers are not working at all when pressed. Check all fuse and it is all good, pop bumpers and slingshot coils are working well. Also, I noticed that my flippers buttons are not registered under switch test and there is LED was not seen on the flipper board when I press down the buttons. Where should I trouble shoot next?

2. Laser Kickback coil was activated the moment I switch on the machine, burn smell was noticed and I quickly remove the wire from the coil. Any idea where to trouble shoot?

3. DMD was flickering, is it due to the ribbon cable?

#2482 3 months ago

Almost done the restore!
IMO the black looks better than the blue!

image (resized).jpeg

image (resized).jpeg

image (resized).jpeg

image (resized).jpeg

image (resized).jpeg

image (resized).jpeg

image (resized).jpeg

image (resized).jpeg

#2483 3 months ago

There are a lot of issues present from your description...knowing whether you have good boards or not is key....the weak link in any of this era-Data East pins is the Power Supply board (if it's original or Rottendog - I immediately put in an Xpin, that's just me) - which undoubtedly is an issue, but it also sounds like your MPU could be a problem too...

Have any pics of the MPU and PS? Look for burnt connectors or prior repairs on the PS - and on the MPU - look for battery acid damage. The PPB board may have some issues as well, from board damage to blown fuses....take a look at it as well... but it typically starts with the PS....

#2484 3 months ago
Quoted from Sonic:

There are a lot of issues present from your description...knowing whether you have good boards or not is key....the weak link in any of this era-Data East pins is the Power Supply board (if it's original or Rottendog - I immediately put in an Xpin, that's just me) - which undoubtedly is an issue, but it also sounds like your MPU could be a problem too...
Have any pics of the MPU and PS? Look for burnt connectors or prior repairs on the PS - and on the MPU - look for battery acid damage. The PPB board may have some issues as well, from board damage to blown fuses....take a look at it as well... but it typically starts with the PS....

Good news! the flippers works now. not sure what did i did.. but all VUK, ball launch coil, lock ball coil, drop target coil are still not working. check the ohms on the coil, it reads at 3-5 ohms. so it should be working. can you point me where to look now?

I measured the DMD, seems like my pin one reading is at -58V and pin 2 is at -36v.. that explain the flickering, how to solve this?

#2485 3 months ago

Check all of your fuse holders. Data east used some cheap fuse holders they look fine to the naked eye. Remove each fuse and make sure the tabs are not soft or losing spring. They break off easily unfortunately. just because they look good doesn't mean that they are fine! I have had several look and test with good continuity. i removed a fuse and the tab just fell out.

#2486 3 months ago

Like brand new!

image (resized).jpeg

image (resized).jpeg

image (resized).jpeg

image (resized).jpeg

image (resized).jpeg

#2487 3 months ago
Quoted from transprtr4u:

Like brand new!

I love the black look man! Would love to do that to mine one day. Nice work.

#2488 3 months ago

Sorry if this has been covered already. Has anyone ever added a spotlight above each sling to help light up the main area of the PF? I tend to keep my game room a little dim at times, and find the middle of the PF dark. I was thinking of adding two spotlights and either shine some white in those areas, or even put UV bulbs in them and pull out some more of the black light art.

Anyone have pics of this on their game?

#2489 3 months ago
Quoted from transprtr4u:

Like brand new!

You should send me your trim to do green Powder coat that glows in the dark. Guarantee best prices you'll find. About to do same Thing to my tftc if you want the example. Here's work I've done for customers

20170819_141908 (resized).jpg

20170819_132728 (resized).jpg

received_1609696825741257 (resized).jpeg

#2490 3 months ago

Damn, I love this game. I want one!

1 week later
#2491 84 days ago

I was wondering if anyone had any issues with their 4.0ROM after installation? In general, I love it but I notice after installation my machine does not always boot up properly - which requires turning off and on again. It feels like a boot timing problem. Power comes up, DMD lights up but light test doesn't happen, everything just sort of freezes.

The thing that makes me think this is a timing/code issue is because 1.) it's the only thing that has changed and 2.) it happens sporadically - maybe once in every three times I power up. I've never not been able to get it to boot properly eventually, but I'd like to fix it.

Has anyone else had this issue?

#2492 84 days ago
Quoted from stroupnp:

I was wondering if anyone had any issues with their 4.0ROM after installation? In general, I love it but I notice after installation my machine does not always boot up properly - which requires turning off and on again. It feels like a boot timing problem. Power comes up, DMD lights up but light test doesn't happen, everything just sort of freezes.
The thing that makes me think this is a timing/code issue is because 1.) it's the only thing that has changed and 2.) it happens sporadically - maybe once in every three times I power up. I've never not been able to get it to boot properly eventually, but I'd like to fix it.
Has anyone else had this issue?

I play my TFTC several times per week and it always boots up in a few seconds without any problems. I have been running the 4.0 ROM since it was released in the Fall of 2015. Have you re-confirmed that both your display ROM and game ROM are properly seated without any bent legs on the ROM chips?

Gord

#2493 84 days ago
Quoted from stroupnp:

I was wondering if anyone had any issues with their 4.0ROM after installation? In general, I love it but I notice after installation my machine does not always boot up properly - which requires turning off and on again. It feels like a boot timing problem. Power comes up, DMD lights up but light test doesn't happen, everything just sort of freezes.
The thing that makes me think this is a timing/code issue is because 1.) it's the only thing that has changed and 2.) it happens sporadically - maybe once in every three times I power up. I've never not been able to get it to boot properly eventually, but I'd like to fix it.
Has anyone else had this issue?

I doubt you'll find anyone else that has an issue (I know I don't) - begin looking at potential problems with your ROM's themselves or their installation...

#2494 84 days ago

Sad day for me! Leaving the club, one of the best games I've ever owned! To all of you that helped over the past years ... A big thank you!
Sure the the new owner will be happy!
Again thanks to all .... Off to the Capcom Airbourne Club
Regards

#2495 79 days ago
Quoted from transprtr4u:

Sad day for me! Leaving the club, one of the best games I've ever owned! To all of you that helped over the past years ... A big thank you!
Sure the the new owner will be happy!
Again thanks to all .... Off to the Capcom Airbourne Club
Regards

Well the club lost a member but also gained a member at the same time. I was fortunate enough to be the one who purchased it from @transprtr4u. What an amazingly well taken care of machine!! Looks brand spanking new and was on my wishlist.

The wife and I look forward to many years of yelling at this machine in frustration. Lol

IMG_20170903_1739268.jpg

IMG_20170903_1739077.jpg

#2496 79 days ago

PS - Can anyone direct me to where I can get the finger mods?

#2497 79 days ago
Quoted from TheHueManatee:

PS - Can anyone direct me to where I can get the finger mods

Are you talking about the little doll where the arms hang over the ball guides..... And the other holds the light?
I have one ... Pm me if that's what your after!

#2498 79 days ago

Pm sent.

Also....anybody know where I can get the flipper fingers? Not the boney ones....but the colored ones that look like the crypt Keepers nasty lookin fingers

#2499 78 days ago

Congrats dude, TFTC is a very underrated game, the more machines you play, the more you will find that out. PM me if you are looking for any specific parts to save you from going out of country for them.

#2500 78 days ago

There's a tftc i've seen photos of recently with a second flipper button on one side, what's the go there? Someone wired up the upper flipper to it's own button?

Promoted items from the Pinside Marketplace
$ 15.00
£ 32.00
$ 90.00
Lighting - Under Cabinet
Rock Custom Pinball
$ 128.00
Playfield - Toys/Add-ons
ModFather Pinball Mods
From: $ 369.95
From: $ 14.95
$ 66.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 159.99
Lighting - Other
Lighted Pinball Mods
From: $ 21.95
Apparel - Unisex
Pinball Wheezer
$ 219.00
Cabinet Parts
Tilted Pinball
$ 27.99
Eproms
Matt's Basement Arcade
$ 24.95
$ 9.95
$ 159.99
Lighting - Other
Lighted Pinball Mods
$ 9.99
Eproms
Matt's Basement Arcade
$ 12.95
Playfield - Toys/Add-ons
ULEKstore
£ 49.00
Lighting - Led
PinballToys
There are 2580 posts in topic. You are on page 50 of 52.

Reply

Wanna join the discussion? Sign up for a Pinside account, or log in if you already have an account.


Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside