(Topic ID: 6037)

Terminator 2 Power Troubleshooting

By R_Coles

10 years ago



Topic Stats

  • 8 posts
  • 3 Pinsiders participating
  • Latest reply 10 years ago by R_Coles
  • No one calls this topic a favorite

You

Linked Games

#1 10 years ago

Hi Guys,

I have a T2 pinball machine. Every now and then all of the lights will dim on the machine and the flippers will cease to work. Sometimes it will come back up and play fine but other times it will not come back up until you restart the game. I think this has to do with a short in the machine somewhere but cant be sure. Any advice on where I should start looking for the problem? It seems random when it happens. Thanks for your time!

#2 10 years ago

One more thing...the DMD display stays on fine and does not dim when this happens.

#3 10 years ago

You might want to make sure you don't have diminished/low power on the circuit the pin is plugged into. I have heard that has been the problem on some issues similar to the one you are describing. Do you have other pins on the same circuit?

#4 10 years ago

Thanks man, I will need to get a voltage meter and check the outlet. I do not have another pin on that particular outlet or circuit no. I have a TZ plugged into another outlet and I have never had problems with that machine, I'll plug the T2 into that outlet and see if it happens again.

#5 10 years ago

I looked at the outlet and cofirmed that the power output is not affecting the machine. I also tried plugging it into different circuits, including the one my TZ is plugged into. Still have the same results. Any other ideas? Whenever i turn it on the back box and dot matrix light up fine. Just no GI or playfield lights. Also, i can press start and the game functions like it is playing, but nothing happens.

#6 10 years ago

Does it happen when there is a lot going on and you press both flippers at the same time?

#7 10 years ago

Craig, no not at all. It used to happen every once in awhile during gameplay, but when i turn the machine on this morning, its starts up and the lights are very dim, and nothing works. Sometimes the lights do not come on at all. Its like there is power loss somewhere. The backbox and DMD are unaffected though.

#8 10 years ago

Also, just noticed that J127 on the power driver board is slightly burned. What is this connection responsible for? Could this be the culprit? I reseated it and it seems to be working fine now.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside