(Topic ID: 27799)

Terminator 2 Club....Members Only!


By spfxted

7 years ago



Topic Stats

  • 7,732 posts
  • 564 Pinsiders participating
  • Latest reply 1 hour ago by mpdb6
  • Topic is favorited by 201 Pinsiders

You

Linked Games

Topic Gallery

There have been 2,623 images uploaded to this topic. (View topic image gallery).

IMG_6197 (resized).JPG
IMG_6191 (resized).JPG
20200208_161053 (resized).jpg
20200208_101942 (resized).jpg
20200208_101848 (resized).jpg
20200208_101827 (resized).jpg
20200130_223123 (resized).jpg
20200130_223032 (resized).jpg
20200130_222607 (resized).jpg
DSCN7764 (resized).JPG
DSCN7763 (resized).JPG
1F318C73-13A2-4F8C-8973-11E17530BBC7 (resized).jpeg
IMG_5609 (resized).jpg
20200120_122023 (resized).jpg
20200120_122015 (resized).jpg
20200120_122004 (resized).jpg

There are 7732 posts in this topic. You are on page 151 of 155.
#7501 3 months ago

Can someone please help me.
I can’t figure out if there should be a washer on the top side when mounting the rails of if there is only a washer under the playfield?

48F233B1-D825-4B7C-A09E-E56C68941182 (resized).jpeg
#7502 3 months ago
Quoted from tezting:

Can someone please help me.
I can’t figure out if there should be a washer on the top side when mounting the rails of if there is only a washer under the playfield?[quoted image]

Typically always a washer on top or when tightened the rail will dig into the art work in short order.

#7503 3 months ago

I do mount clear plastic washers usually.
Regards Patric

#7504 3 months ago
Quoted from Yelobird:

Typically always a washer on top or when tightened the rail will dig into the art work in short order.

Quoted from the_one:

I do mount clear plastic washers usually.
Regards Patric

Thank you both for fast replies

#7505 3 months ago

They generally didn't have washers from the factory, which means when you shop out a game, the edge of the rail has already dug a groove into the playfield.

#7506 3 months ago
Quoted from Manny65:

It was the arm bracket (not the coil bracket) that I was referring to, as the arm needs to make contact with the ball in the trough and if there is too much play in the arm or it is slightly misaligned then it'll affect the ball going into the shooter lane

Yup I checked that as well. It was tightly secured to the bottom of the playfield. This is the part that has a little play in it. Game was fine over the weekend so far.

#7507 3 months ago

Anyone know where to get one of those detailed heads to use as a mod? I thought I saw a post here a while ago about something from Amazon that looked good.

#7508 3 months ago
Quoted from BertoDRINK1:

Anyone know where to get one of those detailed heads to use as a mod? I thought I saw a post here a while ago about something from Amazon that looked good.

It's the Loot Crate Terminator Genisys skull, you'll find various places selling them if you do a search

amazon.com link »

#7509 3 months ago
Quoted from Manny65:

It's the Loot Crate Terminator Genisys skull, you'll find various places selling them if you do a search
amazon.com link »

Thanks going to start planning a playfield swap and would be the perfect time to do a few tasteful mods.

#7510 3 months ago

Hey everyone! I got a used machine about 2 months ago. Been working great, but my center target suddenly stopped working. It's the square one in these photos. I did a few manual tests with my hand and no matter how hard I pushed it, it doesn't register anymore.

Probably over my head and something I'll need a pro to repair, but just putting it out here in case anyone has ideas. In the UNDER picture, it's the one with the silver attachment... I do see one loose yellow cable under there, but not sure if that has anything to do with it. Thanks for any help you can give!

IMG_5319 (resized).JPGIMG_5322 2 (resized).JPGIMG_5325 (resized).JPG
#7511 3 months ago
Quoted from Luckdragon100:

Hey everyone! I got a used machine about 2 months ago. Been working great, but my center target suddenly stopped working. It's the square one in these photos. I did a few manual tests with my hand and no matter how hard I pushed it, it doesn't register anymore.
Probably over my head and something I'll need a pro to repair, but just putting it out here in case anyone has ideas. In the UNDER picture, it's the one with the silver attachment... I do see one loose yellow cable under there, but not sure if that has anything to do with it. Thanks for any help you can give![quoted image][quoted image][quoted image]

Yes the loose yellow wire should be connected (quite common issue to occur). Just need to solder the wire back on to the switch terminal (see how the yellow wire daisy chains between the switches, so you just need to solder it back on the centre switch that has the one yellow wire)

#7512 3 months ago

Anyone interested in a topper at a reduced price? Pm me for info.
Thank you in advance...

651E9F3B-4853-43C0-BF05-28AA0E201F42 (resized).jpeg
#7513 3 months ago
Quoted from Manny65:

Yes the loose yellow wire should be connected (quite common issue to occur). Just need to solder the wire back on to the switch terminal (see how the yellow wire daisy chains between the switches, so you just need to solder it back on the centre switch that has the one yellow wire)

Thanks for the tip! Sounds encouraging. Just ordered a soldering kit

#7514 3 months ago

Hi posted a while back looking for T2 parts to build a machine from scratch. Would like to thank many people that have been so helpful that I have come across. I’m after any Playfield lighting pcb’s if any one has any spares. Also after a gun motor emi pcb. I’m getting pretty close to starting the build so will post pics once started. Thanks in advance to any one who can help! Cheers Brendan

#7515 3 months ago

Soon my playfield will be finished. Today I went to my local paint shop and was astonished how fine the surface is so far.
Found three little issues on two inserts and at the hot dog.
Playfield is sanded again and will get two more clear coatings, next Friday it will be finished.

#7516 3 months ago

My new playfield and plastic set has arrived!!!!

This will be my final playfield swap...

Can't wait to see/play it installed!

IMG_0560 (resized).jpeg
#7517 3 months ago
Quoted from MrBellMan:

My new playfield and plastic set has arrived!!!!
This will be my final playfield swap...
Can't wait to see/play it installed![quoted image]

Very nice! This one of the repros from Peter in Germany?

#7518 3 months ago
Quoted from aztarac:

Very nice! This one of the repros from Peter in Germany?

Yup!

#7519 3 months ago

And here's my final playfield.

DSCN7307 (resized).JPG

DSCN7315 (resized).JPG

DSCN7304 (resized).JPG

DSCN7305 (resized).JPG

DSCN7308 (resized).JPG

DSCN7316 (resized).JPG

DSCN7309 (resized).JPG

DSCN7317 (resized).JPG

DSCN7306 (resized).JPG

DSCN7314 (resized).JPG

DSCN7318 (resized).JPG

DSCN7313 (resized).JPG

#7520 3 months ago

Anybody have any favorite art blades they'd like to share pics for on T2?

Full mirror blades seem pretty cool for this machine, but curious what people have tried.

Thanks!

G

#7521 3 months ago

These. They totally match the pf:
https://www.retrorefurbs.com/shop/terminator-2-pinball-sideblades/

They also have mirror and chrome versions of these.

#7522 3 months ago
Quoted from Luckdragon100:

Anybody have any favorite art blades they'd like to share pics for on T2?
Full mirror blades seem pretty cool for this machine, but curious what people have tried.
Thanks!
G

These came with my game. They are not bad, but are some kind of contact paper...

36CF368F-33FB-4721-B781-990128E2C06D (resized).jpeg
#7523 3 months ago

Is there a good source for this decal available?

Thanks,

Ken

Screenshot_20191116-195739_Chrome (resized).jpg
#7524 3 months ago

I'm guessing you mean a cheaper source. Marco has it.

https://www.marcospecialties.com/pinball-parts/31-1640

#7525 3 months ago
Quoted from treborlicec:

I'm guessing you mean a cheaper source. Marco has it.
https://www.marcospecialties.com/pinball-parts/31-1640

Thanks, not sure how I missed that on their site.

#7526 3 months ago
Quoted from Luckdragon100:

Anybody have any favorite art blades they'd like to share pics for on T2?
Full mirror blades seem pretty cool for this machine, but curious what people have tried.
Thanks!
G

I would also love to see.
I am in doubt about what to buy...

#7527 3 months ago

I found an issue this evening and was hoping to get some advice. I turned on my T2 tonight and noticed the controlled lamps were acting strangely. When one was supposed to light, in some cases, two were lit instead. I went into single lamp test mode and saw, for example, Jackpot was lit with Extra Ball.
If anyone can offer advice or a strategy on how to begin diagnosising and fixing the problem I'd greatly appreciate it! I'm willing to try/learn anything you suggest, but don't have the expertise that many of you have to know how to begin to root out the problem. Thanks for your time.

#7528 3 months ago

T2 club, if anyone is looking for a Collector grade T2 I’m putting one up for sale. Every thing on the playfield is new
Mike chestnut did the wireforms, gun handle, new cabinet, captain Neo restored the playfield, color dmd, the best LEDs, mods, I’ve never seen s nicer T2

Pics for serious, I have slot of nice pins
Making room for some new games coming, $5500
I will consider trades, prefer to ad cash
For HUO games

Thanks!

#7529 3 months ago
Quoted from hassanchop:

These. They totally match the pf:
https://www.retrorefurbs.com/shop/terminator-2-pinball-sideblades/
They also have mirror and chrome versions of these.

Wow, the mirrored version look pretty awesome!! Watch the video:

https://www.retrorefurbs.com/shop/terminator-2-mirror-chrome-pinball-sideblades/

#7530 3 months ago

Those do look pretty sick. Definitely leaning towards these!

#7531 87 days ago
Quoted from Luckdragon100:

Those do look pretty sick. Definitely leaning towards these!

But does anyone have a picture of them installed?

#7532 86 days ago
Quoted from tezting:

But does anyone have a picture of them installed?

I ended up ordering the non-mirror ones here: https://www.retrorefurbs.com/shop/terminator-2-pinball-sideblades/?fbclid=IwAR05OPij14P5DsjoySRDIScMmvY9XUk2X2Hn09zjMISsE6VxAepzuJ2YBvU

There's some shots in the gallery of them installed, but I'll take some pics when I put mine in.

#7533 86 days ago
Quoted from Luckdragon100:

I ended up ordering the non-mirror ones here: https://www.retrorefurbs.com/shop/terminator-2-pinball-sideblades/?fbclid=IwAR05OPij14P5DsjoySRDIScMmvY9XUk2X2Hn09zjMISsE6VxAepzuJ2YBvU
There's some shots in the gallery of them installed, but I'll take some pics when I put mine in.

Thank you

Do you know if it is the correct fluorescent orange? Or just red...
Why did you not choose the mirror?

#7534 86 days ago

Does anyone have scans of the 2 cyberdyne plastics? I want to make new decals.

Ken

williams-terminator-pinball-playfield_1_24c6bc70ba237494809ad1e191a49ee3 (resized).jpg
#7535 86 days ago

Not sure what I’m putting on my (in)sides yet. I have a pair of AMH side mirrors which would fit, they have cut outs in the middle, thought about putting some comet matrix strips in there and tying those to an insert during gameplay..

#7536 83 days ago

Can someone post a picture of how their start button is wired up? I have everything working but the start button. Even in switch test the button does not work.

Thanks

#7538 82 days ago
Quoted from jjoravec:

Can someone post a picture of how their start button is wired up? I have everything working but the start button. Even in switch test the button does not work.
Thanks

I will when I get home, I have mine tore apart rrstoration and can take a few pics.

#7539 82 days ago
Quoted from jjoravec:

Can someone post a picture of how their start button is wired up? I have everything working but the start button. Even in switch test the button does not work.
Thanks

Hope these help solve your issue.

20191126_154627 (resized).jpg20191126_154655 (resized).jpg
#7540 82 days ago
Quoted from eyeamred2u:

Hope these help solve your issue.[quoted image][quoted image]

Yep, That got me past the start button problem

Thanks

#7541 82 days ago

I resolved my start button problem, which led me to hopefully my final issue. When I power on the game it blows the f105 fuse, which is for solenoids 1-8. If I unplugged connector J130, the fuse doesn't blow. I am assuming this means one of those solenoids are bad. I unplugged the knocker one so that eliminates it. I check the rest of the solenoids with my multi-meter and the ohms range for 2 -10.

I did notice non of the solenoids had diodes on then, Is there supposed to be?

Any ideas what the issue could be, before I disconnect each solenoid?

Thanks

#7542 81 days ago
Quoted from jjoravec:

I resolved my start button problem, which led me to hopefully my final issue. When I power on the game it blows the f105 fuse, which is for solenoids 1-8. If I unplugged connector J130, the fuse doesn't blow. I am assuming this means one of those solenoids are bad. I unplugged the knocker one so that eliminates it. I check the rest of the solenoids with my multi-meter and the ohms range for 2 -10.
I did notice non of the solenoids had diodes on then, Is there supposed to be?
Any ideas what the issue could be, before I disconnect each solenoid?
Thanks

Check your driver board transistors as well as the solenoids

#7543 81 days ago

When I picked up my T2 it had a yellow post here and was told that it was correct. It was something Steve often did.
Is this correct? Do anyone else have a yellow post here?
I can see that the rubber kit from pinball.center also has a yellow post in the kit.

D8C74C46-3C0E-4320-AA23-7A9268759A69 (resized).jpeg
#7544 81 days ago
Quoted from tezting:

When I picked up my T2 it had a yellow post here and was told that it was correct. It was something Steve often did.
Is this correct? Do anyone else have a yellow post here?
I can see that the rubber kit from pinball.center also has a yellow post in the kit.[quoted image]

Here is a pic, as I was tearing a T2 down for resto, yellow appears to be correct.

20191116_143101 (resized).jpg
#7545 81 days ago
Quoted from eyeamred2u:

Here is a pic, as I was tearing a T2 down for resto, yellow appears to be correct.[quoted image]

Thank you!
It just seems strange. Only yellow post on the game..

#7546 81 days ago
Quoted from eyeamred2u:

Here is a pic, as I was tearing a T2 down for resto, yellow appears to be correct.[quoted image]

Same on mine...

#7547 81 days ago
Quoted from eyeamred2u:

Here is a pic, as I was tearing a T2 down for resto, yellow appears to be correct.[quoted image]

Btw. wonder why your special insert is white? is it the same on the other side?

#7548 81 days ago
Quoted from tezting:

Btw. wonder why your special insert is white? is it the same on the other side?

Yes

#7549 81 days ago

Mine's black and my special insert is red on both the PF in the game and the restored PF

#7550 80 days ago
Quoted from Malenko:

Mine's black and my special insert is red on both the PF in the game and the restored PF

Mine are also red in both sides on both my playfields.
Wonder if they changed “design” during production?

Promoted items from the Pinside Marketplace
$ 259.95
Lighting - Led
Pin Stadium Pinball LEDs
Trade
Machine - For Trade
San Mateo, CA
$ 50.00
There are 7732 posts in this topic. You are on page 151 of 155.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside