(Topic ID: 27799)

Terminator 2 Club....Members Only!


By spfxted

6 years ago



Topic Stats

  • 7,366 posts
  • 535 Pinsiders participating
  • Latest reply 1 day ago by Milltown
  • Topic is favorited by 196 Pinsiders

You

Linked Games

Topic Gallery

There have been 2,426 images uploaded to this topic. (View topic image gallery).

E9EC4251-0E27-49F7-B6FF-80EB364EF576 (resized).jpeg
77974C5D-6E94-44D0-AAFB-BC04DE0BBE08 (resized).jpeg
375DC353-F883-4D15-9453-9A5C9E20F2F1 (resized).jpeg
E20248EF-B874-4B88-A4EF-809214D27E3C (resized).jpeg
6D5BF1A6-07D7-4CC0-BB67-68BFD638156C (resized).jpeg
20190710_221700 (resized).jpg
20190710_221644 (resized).jpg
20190710_221714 (resized).jpg
156268555959459412861752750457 (resized).jpg
20190704_235815 (resized).jpg
IMG_20190708_011150_711 (resized).jpg
DSCN6807 (resized).JPG
2019-06-20 (resized).jpg
60A14E34-51FB-4634-9307-46CB0F82041B (resized).jpeg
FC8EA64F-C522-45A9-AE26-367209B7BAD1 (resized).jpeg
20190607_001219 (resized).jpg

There are 7366 posts in this topic. You are on page 144 of 148.
#7151 3 months ago
Quoted from Fezmid:

I'll take it if it's available - message me. Going to bed so will respond in the morning. Thanks.

It’s yours...Thank you.........Joey

#7152 3 months ago

Still looking for a set of NOS slingshot plastics to replace the crap I bought on ebay.

Thx,

Rob

#7153 3 months ago

Hi all. Chasing an apron if anyone has a spare post to Usa. Thankyou

#7154 3 months ago

Afternoon guys. So I bought a new blue Start button from Pinball Life. My original button has 4 wires leading straight out of switch, 2 on each side. This new one has 5 lugs, 2 coming out the top, one on each side, and one on the bottom. Any help in hooking this up would be appreciated, as I dont know which wire does what.

#7155 3 months ago
Quoted from CTHOMAS1998:

Afternoon guys. So I bought a new blue Start button from Pinball Life. My original button has 4 wires leading straight out of switch, 2 on each side. This new one has 5 lugs, 2 coming out the top, one on each side, and one on the bottom. Any help in hooking this up would be appreciated, as I dont know which wire does what.

The wires on the side of the switch are for the lighted bulb. The three on the switch should have one wire on the "COM" and one wire on the "NO". I couldn't tell you what color wires go to it until I take a look. I will snap a pic later if needed. Let me know.

#7156 3 months ago
Quoted from Scoot:The wires on the side of the switch are for the lighted bulb. The three on the switch should have one wire on the "COM" and one wire on the "NO". I couldn't tell you what color wires go to it until I take a look. I will snap a pic later if needed. Let me know.

I would greatly appreciate that Scoot

#7157 3 months ago

Crappy pic but hope it’s good enough.

3B4ACC32-4E7D-4767-BFF6-14DB7713CAAF (resized).jpeg
#7158 3 months ago

Nearly there! hopefully fully done in the next week or two.

20190324_103447 (resized).jpg
#7159 3 months ago

Looks amazing!

#7161 3 months ago
Quoted from Scoot:

Crappy pic but hope it’s good enough.
[quoted image]

Thank you sir!

#7162 3 months ago

Bit more progress...6 hrs on the skull area!
I bought a loot one last year and it's finally in.
Hoping my ohms law theory is ok with the lighting mods I did to the eyes.
Big thanks to everyone who posted tips in this topic... has helped a lot. Read the whole thing from the start last week.
20190407_115618 (resized).jpg

#7163 3 months ago
Quoted from Jakusu:

Bit more progress...6 hrs on the skull area!
I bought a loot one last year and it's finally in.
Hoping my ohms law theory is ok with the lighting mods I did to the eyes.
Big thanks to everyone who posted tips in this topic... has helped a lot. Read the whole thing from the start last week.
[quoted image]

Well worth the effort, it looks awesome!

#7164 3 months ago
Quoted from Jakusu:

Bit more progress...6 hrs on the skull area!
I bought a loot one last year and it's finally in.
Hoping my ohms law theory is ok with the lighting mods I did to the eyes.
Big thanks to everyone who posted tips in this topic... has helped a lot. Read the whole thing from the start last week.
[quoted image]

This looks fantastic!

One thing I noticed that you may want to consider is the leds you have for your gi. The ones I can see from the pic are older technology and don’t put out nearly as much light as the newer smd leds. The smds also last much longer so you wouldn’t ever have to change them out.

#7165 3 months ago

Thanks Scoot. I have a lot of Leds on hand and usually set them up once back in the machine and powered up. I like these concave ones in areas where you see the light itself. Thinking some spotlights will be needed. Will post more pics soon.

#7166 3 months ago

Muy bueno ese cráneo!! Donde lo compraste !

#7167 3 months ago

Well test playing is on! Few tweaks to do.
One issue is getting bounce back air ball from cannon shot to targets and ball getting stuck back behind canon. Any tips appreciated!

20190409_175555 (resized).jpg20190413_173613 (resized).jpg20190413_171732 (resized).jpg20190413_171940 (resized).jpg
#7168 3 months ago

Beautiful machine. I too had a lot of air balls from the canon to the targets. I changed the foam padding on the back of the stand up targets to a more dense foam rubber. It still gets some air but not nearly as much.

#7169 3 months ago

Anybody knows where to get a cool terminator T-1000 figure, like the one from Pinball Decals but not for that price...

Pic129969 (resized).png

#7170 3 months ago
Quoted from PeterG:

Anybody knows where to get a cool terminator T-1000 figure, like the one from Pinball Decals but not for that price...
[quoted image]

amazon.com link »

Cut it in half and paint it silver if you have to..

#7171 3 months ago
Quoted from PeterG:

Anybody knows where to get a cool terminator T-1000 figure, like the one from Pinball Decals but not for that price...
[quoted image]

Heres the REAL one. Not the goofy ghost T1000 that lights up for some reason even though he never lit up in the movie....

https://pinside.com/pinball/forum/topic/t-1000-mods-for-terminator-2-available/page/2

#7172 3 months ago
Quoted from PeterG:

Anybody knows where to get a cool terminator T-1000 figure, like the one from Pinball Decals but not for that price...
[quoted image]

Ebay

#7173 3 months ago

Finally got mine working 100% and did the slight mods referenced by “spfxted”. Still need to paint the teeth white!

779327B3-6BC5-4B51-B7C8-5BBD57657251 (resized).jpeg28735DB3-9177-42FF-A078-5C4D6A408190 (resized).jpegEF2EBDC5-D292-4FCA-9957-3FD3D348D6FC (resized).jpeg6B9B5518-5022-4540-B795-945A63C74E2B (resized).jpeg
#7174 3 months ago
Quoted from Nikrox2:

Finally got mine working 100% and did the slight mods referenced by “spfxted”. Still need to paint the teeth white!
[quoted image][quoted image][quoted image][quoted image]

Sorry to bust your bubble bro but your general illumination looks to be OUT.

#7175 3 months ago
Quoted from Chitownpinball:

Sorry to bust your bubble bro but your general illumination looks to be OUT.

To each their own with the choice of lights but his GI is clearly not out. Just not super bright

#7176 3 months ago
Quoted from jmountjoy111:

To each their own with the choice of lights but his GI is clearly not out. Just not super bright

That is the darkest T2 I have ever seen then...

#7177 3 months ago

Am looking at some LED’s to help in that regard (only had 2 so threw them in the bottom area).

Any suggestions on that? Rather than the $160 “kit”?

#7178 3 months ago
Quoted from Nikrox2:

Am looking at some LED’s to help in that regard (only had 2 so threw them in the bottom area).
Any suggestions on that? Rather than the $160 “kit”?

I bought the cointaker kit because I am lazy.

I would just buy some warm and cool temp leds and test them where you like them. You dont NEED the kit....it was just easy for me.

#7179 3 months ago

Perfect Thanks! Will look into those!

#7180 3 months ago

I buy 2835 2smd frosted domes from comet for all of my playfield GI. I color match the inserts with a variety of different types of bulbs. On top of that I add a 10 LED strip in the trough

Here is what the T2 I just traded looked like. I’m picking up another T2 next week. I’ll do the same to it but I’m going to add a couple of spot lights as well

C684D6A7-B0A3-443C-8A56-DCFA7B36DC31 (resized).png

C9369687-C707-4240-83BD-F73679E174C6 (resized).png
#7181 3 months ago
Quoted from Nikrox2:

Am looking at some LED’s to help in that regard (only had 2 so threw them in the bottom area).
Any suggestions on that? Rather than the $160 “kit”?

Just leave your GI as is and put a Pinstadium lights kit on it. Have mine with a UV flasher tied to the left hole. It's FRIKKING awesome!!

#7182 3 months ago

Talk about wasting money....

#7183 3 months ago
Quoted from Chitownpinball:

Talk about wasting money....

Lol, well I got one of his early ones, so it wasn't as expensive as it is now, and it's AMAZING on T2 with the UV flasher. Well worth the $ I paid for it.

#7184 3 months ago

Trying to figure out if I have a problem with mine, or just buggy software: do you guys frequently have multiball rounds end unexpectedly/jackpots seem to cancel out before shooting the cannon?

Everything works normally with mine, all switches test out going through each in the edges test. I don't think it's just losing track of balls or a normal trough switch issue and thinking I've drained, as the ball doesn't end and I've never had it think I drained improperly in single ball play. But I guess I will recheck those. I also don't think it has ever offered the pity jackpot grace period to load the cannon either when it does this... it's just boom back in single ball gameplay. Several times I've started payback time right in the middle of a multiball, I was thinking that shouldn't be happening.

#7185 3 months ago
Quoted from PinKopf:

Trying to figure out if I have a problem with mine, or just buggy software: do you guys frequently have multiball rounds end unexpectedly/jackpots seem to cancel out before shooting the cannon?
Everything works normally with mine, all switches test out going through each in the edges test. I don't think it's just losing track of balls or a normal trough switch issue and thinking I've drained, as the ball doesn't end and I've never had it think I drained improperly in single ball play. But I guess I will recheck those. I also don't think it has ever offered the pity jackpot grace period to load the cannon either when it does this... it's just boom back in single ball gameplay. Several times I've started payback time right in the middle of a multiball, I was thinking that shouldn't be happening.

Not normal for sure. I don't think I've seen that on my game. Maybe you have a switch that is gapped too close that phantom scores when the VUK or another solenoid fires? Try gently pounding the playfield in various areas when in switch edge test to see if something scores? The jackpot issue could be an intermittent wire to the "ball loaded switch" on the cannon that breaks (opens) when the cannon turns...

#7186 3 months ago

Put the Comet LED kit and gray Titan rings in my T2. I think I’m in love

0B595AF1-4882-44DC-8982-A88CA7F14702 (resized).jpeg3429D165-0D42-4322-BCF5-160A28179ADA (resized).jpeg3A4A5E51-B453-4565-9039-7E75617D5BA3 (resized).jpeg688CEF23-99A8-4416-9EA6-F7AB04B23B42 (resized).jpeg
1 week later
#7187 87 days ago

Help. Looking for the obvious mistake here. Swapped DMDs out. WoF got T2s ColorDMD. T2 went back to orange from WoF. WoF is doing great but T2 is dark. What am I missing?
B72BA5EE-EA2C-4866-BC87-B21B9E583092 (resized).jpeg0CFE62DE-1998-449C-9EDF-4F28AD431DAD (resized).jpeg

Also, what is up with my right speaker? Good, cheap replacement for this apparent hack? CDA3BB44-DF10-496B-9ED1-B76CAC12AFAE (resized).jpeg

#7188 87 days ago

The dmd power cable needs to be plugged back in on the power supply board. You can see it unplugged in the first pic. If still no power, make sure the ribbon cable is installed correctly.

The speaker is not a hack. That is the speaker that came with the pin.

#7189 87 days ago
Quoted from Scoot:

The dmd power cable needs to be plugged back in on the power supply board. You can see it unplugged in the first pic. If still no power, make sure the ribbon cable is installed correctly.
The speaker is not a hack. That is the speaker that came with the pin.

Bahaha. thanks. I knew it was late and I was missing something simple.

Interesting on the speaker.

#7190 87 days ago
Quoted from ypurchn:

Help. Looking for the obvious mistake here. Swapped DMDs out. WoF got T2s ColorDMD. T2 went back to orange from WoF. WoF is doing great but T2 is dark. What am I missing?
[quoted image][quoted image]
Also, what is up with my right speaker? Good, cheap replacement for this apparent hack? [quoted image]

That speaker on the right is factory.

#7191 87 days ago
Quoted from ypurchn:

Bahaha. thanks. I knew it was late and I was missing something simple.
Interesting on the speaker.

Been there, done that.

#7192 87 days ago

Looks like I'm leaving the club... T2 was my first pin, purchased a couple of years ago, and I learned so much from it! I learned how to solder (still learning, but...), I rebuilt a flipper, learned how to clean/wax, and even more basic things like how to look under the playfield, how to look behind the backglass, replace the DMD, and more. But I've grown bored of the game (everyone said that'd happen, but I didn't believe them when I first got it! LOL), and a coworker wants a machine -- so my T2 will be someone else's first and he'll be able to learn on it like I did. It's still a little sad, though....

#7193 87 days ago
Quoted from Fezmid:

Looks like I'm leaving the club... T2 was my first pin, purchased a couple of years ago, and I learned so much from it! I learned how to solder (still learning, but...), I rebuilt a flipper, learned how to clean/wax, and even more basic things like how to look under the playfield, how to look behind the backglass, replace the DMD, and more. But I've grown bored of the game (everyone said that'd happen, but I didn't believe them when I first got it! LOL), and a coworker wants a machine -- so my T2 will be someone else's first and he'll be able to learn on it like I did. It's still a little sad, though....

Ive been working behind the scenes to move mine as well....

The real question is: what are you replacing it with?

#7194 87 days ago
Quoted from Chitownpinball:

Ive been working behind the scenes to move mine as well....
The real question is: what are you replacing it with?

I'm leaning towards DI LE. If that deal falls through, I don't have any leads (but still have MET Pre and IM Pro to keep me busy until I find a third one ).

#7195 87 days ago
Quoted from Fezmid:

I'm leaning towards DI LE. If that deal falls through, I don't have any leads (but still have MET Pre and IM Pro to keep me busy until I find a third one ).

Wow, quite an upgrade. GL!

#7196 84 days ago

Hi all,

When I picked up my T2, the batteries had been removed, so each time I turned on the game it would restore factory settings. I've finally replaced the batteries, but the game still restores factory setting on start up.

Any thoughts?

thx

#7197 84 days ago
Quoted from DropTarget:

Hi all,
When I picked up my T2, the batteries had been removed, so each time I turned on the game it would restore factory settings. I've finally replaced the batteries, but the game still restores factory setting on start up.
Any thoughts?
thx

Hopefully the issue is with the battery holder. Check to see if there is any corrosion or damaged contacts. Put a voltmeter on it to see if it is getting around 5 volts with new batteries. Clean the contacts with a wire brush. If you still don’t have a good connection, check for board damage from battery acid corrosion. Majority of the time it just needs a little cleaning.

#7198 84 days ago
Quoted from DropTarget:

Hi all,
When I picked up my T2, the batteries had been removed, so each time I turned on the game it would restore factory settings. I've finally replaced the batteries, but the game still restores factory setting on start up.
Any thoughts?
thx

Game is bad, sell it it to me. lol

No, check the battery terminals and the CPU connectors for green corrosion

#7199 84 days ago

I agree, the game must be bad. How about if I just give it to you?

Some corrosion on a battery terminal, I didn't look to see if it made it's way to the board, nor will I be able to as the game just left my house.

So, I guess I'm out of the club as well

#7200 84 days ago

I’m back!

0EB5325E-D48D-40FC-B5B8-66282C5EFE27 (resized).jpeg1160696D-E44B-4F1E-839A-84B1C3ABFC0B (resized).jpeg
Promoted items from the Pinside Marketplace
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
3,400 (OBO)
Machine - For Sale
Crazytown, MINNESOTA
There are 7366 posts in this topic. You are on page 144 of 148.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside