Terminator 2 Club....Members Only!

(Topic ID: 27799)

Terminator 2 Club....Members Only!


By spfxted

6 years ago



Topic Stats

  • 6,926 posts
  • 493 Pinsiders participating
  • Latest reply 2 days ago by Chitownpinball
  • Topic is favorited by 176 Pinsiders

You

Linked Games

Topic Gallery

There have been 2,212 images uploaded to this topic. (View topic image gallery).

IMG_3025 (resized).JPG
IMG_20181208_080947 (resized).jpg
C80E3B18-C331-4469-A8B5-F7E2C86BE766 (resized).jpeg
6F07EDA2-E99E-4870-977C-9A283100801A (resized).jpeg
P1080082 (resized).jpg
IMG_3024 (resized).jpg
20181107_173046 (resized).jpg
IMG_8616 (resized).JPG
IMG_8615 (resized).JPG
20181028_182300 (resized).jpg
terminator parts (resized).jpg
poly545-6162-00 (resized).jpg
8196a4d7156aa02a02c6d2ead23fdcbe57199706 (resized).jpg
IMG_0903 (resized).JPG
439A6A30-A5CC-4148-990F-25D12578CE0F (resized).jpeg
EE5DE678-728E-424D-86B1-258759F07FD1 (resized).jpeg

There are 6926 posts in this topic. You are on page 137 of 139.
#6801 79 days ago
Quoted from algrande:

They only answer is OCD board. http://ledocd.com

No, it's not the only answer. Plus it's expensive. You could get away with non-ghosting bulbs if the root cause can't be found.

#6802 79 days ago
Quoted from ForceFlow:

No, it's not the only answer. Plus it's expensive. You could get away with non-ghosting bulbs if the root cause can't be found.

bad choice of words....a great answer....

#6803 79 days ago
Quoted from ForceFlow:

No, it's not the only answer. Plus it's expensive. You could get away with non-ghosting bulbs if the root cause can't be found.

I have non ghosting comet bulbs in every insert

#6804 79 days ago
Quoted from Yesh23:

Looking for some help here. I have non-ghosting Comet bulbs in the insert and the whole playfield doesn't ghost but the left bank for CPU, Access code etc. The right bank doesn't do it, just the left. You can see in the first picture the top CPU is about 20% lit and in the second picture you can see the checkpoint 100% lit like it should be but the cpu is still 20% lit (hard to see in the picture). Before I launch the ball and the skill shot lights cycle up in down (bank of lights right above) the 20% ghosting cycles with the those. What I mean by this is if the middle skill shot lot is lit then I'll have the silent alarm on at 20%. Any thoughts?
[quoted image][quoted image]

I noticed a similar issue with mine the other day, when I hit the flippers I get a little micro/pulse flash with the GI. I'm assuming it's an electrical component going bad.

#6805 79 days ago

I use standard Comet LEDs but have a non-ghosting ROM.

#6806 79 days ago
Quoted from Brijam:

Got all balls in trough? Are all the trough switches working properly? Anything jamming up the trough?

I found the issue, connector on mpu was bad. I did a jump between the door board connector and the mpu connector, and start button and tilt works.
BUT, i now have another issue: the machine reboots after few seconds of game (usually when the ball hits the targets) or when I push the test button. Any clue?

#6807 79 days ago
Quoted from algrande:

They only answer is OCD board. http://ledocd.com

That's not the only answer for WPC games!

You can apply the WPC ghost patch to early WPC games like T2 which works great. I have done so and I use cheap LED (NOT non-ghosting) and I have zero ghosting artifacts on my game. PM me if you want and I can send you the modified rom or burn for you.

#6808 79 days ago

Does anyone else feel like T2 plays more like a system 11 style ruleset? Even compared to Getaway it's pretty limited in its modes/variety. Doesn't make it any less fun, it's an all time favorite of mine, just interesting to compare it to the overall evolution of rules and some of the games right after it.

#6809 79 days ago
Quoted from snakesnsparklers:

That's not the only answer for WPC games!
You can apply the WPC ghost patch to early WPC games like T2 which works great. I have done so and I use cheap LED (NOT non-ghosting) and I have zero ghosting artifacts on my game. PM me if you want and I can send you the modified rom or burn for you.

Mine has ghosting as well and I have the profanity old rom set (I didn’t install it). Was planning to update to latest code since I read the profanity set was on older code. Do I also need to apply a patch to the latest code or is that the patch itself?

#6810 79 days ago
Quoted from brainmegaphone:

Mine has ghosting as well and I have the profanity old rom set (I didn’t install it). Was planning to update to latest code since I read the profanity set was on older code. Do I also need to apply a patch to the latest code or is that the patch itself?

Ghost patch has to be manually applied to any T2 code including the profanity rom.

#6811 78 days ago
Quoted from ForceFlow:

No, it's not the only answer. Plus it's expensive. You could get away with non-ghosting bulbs if the root cause can't be found.

Its not all about ghosting LED's. The board also makes LED's act like incandescents. I did both the GI and INSERTS boards on my restored WH20 and it looks 100x better than without OCD. I think it's worth the 129 bucks, but that is my opinion. It's going on mine T2 that I am restoring. You spend thousands and thousands and months working on a pin, What's a another 129?
It's all about the your taste and your level of ADD.

#6812 78 days ago
Quoted from algrande:

The board also makes LED's act like incandescents.

Yep, I have it installed in my shadow and IJ, and the LED OCD GI on just my Shadow. I really like the LED OCD effects a lot. I wish it was available for pin2000.

The point earlier was that it's not the only anti-ghosting solution.

#6813 77 days ago

Need help with problem:
Gun not firing when trigger pulled

All switches work in test mode. Solenoid fires in test mode. Gun calibrates. Trigger launches ball into playfield. But when Ball goes into gun fir jackpot shot, the trigger doesn’t fire the ball out. Gun rotated but trigger doesn’t shoot it.

What next?

#6814 77 days ago

Just a quick thought till the real helpers chime in...just double check the switch on the right when the ball is in the cannon...if everything is working from your description it sounds like the game is not recognizing the ball is in there(cannon)...besides that I hope all is well with you bro....!!!..............Joey

#6815 77 days ago
Quoted from Blitzburgh99:

Need help with problem:
Gun not firing when trigger pulled
All switches work in test mode. Solenoid fires in test mode. Gun calibrates. Trigger launches ball into playfield. But when Ball goes into gun fir jackpot shot, the trigger doesn’t fire the ball out. Gun rotated but trigger doesn’t shoot it.
What next?

Rotate the canon (in test mode), then back out and try to fire the solenoid (in test mode). Maybe there's an issue with the coil lugs or wiring that prevents it from firing when in a certain position?

#6816 76 days ago
Quoted from Blitzburgh99:

Need help with problem:
Gun not firing when trigger pulled
All switches work in test mode. Solenoid fires in test mode. Gun calibrates. Trigger launches ball into playfield. But when Ball goes into gun fir jackpot shot, the trigger doesn’t fire the ball out. Gun rotated but trigger doesn’t shoot it.
What next?

I ran into a similar issue earlier this year. Underneath the cannon (bottom side of the playfield), there's a cam and a switch (with a roller on the leaf) that rides along the edge of the cam as the cannon rotates. The cam has a "notch" that this roller drops into, as the cam rotates. The cannon can only fire when this switch is open, i.e., during the time the roller drops into the notch. Check the position of the switch, and that you hear the switch 'click' open as it drops into the notch (it should open almost immediately as it starts down the slope of the notch). On mine, the leaf had bent a little bit so the switch wasn't 'opening' until it was at the very bottom of the notch, which equates to having a very limited window when the cannon would actually fire.

#6817 75 days ago

Did anybody buy the new plastics sets from Germany was curious what you guys thought of them. Was thinking about picking up a spare set. I have his decals on my cabinet they are perfect I assume the plastics are too

#6818 75 days ago

OK guys I need some troubleshooting help on where to start looking

Backbox lights are flickering ever so slightly
When I hit the flippers the GI lights dim for 1/4 second and then come back to full strength

I'm assuming this is a electronic issue.

Where do I start?

#6819 74 days ago
Quoted from ypurchn:

OK guys I need some troubleshooting help on where to start looking
Backbox lights are flickering ever so slightly
When I hit the flippers the GI lights dim for 1/4 second and then come back to full strength
I'm assuming this is a electronic issue.
Where do I start?

This may not be the only issue or even THE issue, but make sure to turn off power saver option in menu.

#6820 74 days ago
Quoted from CoPinfan:

This may not be the only issue or even THE issue, but make sure to turn off power saver option in menu.

Is this A.1 29 “GI POWER SAVER”? I just switched this to off and moved A.1 30 to “4” which is as low as it would go but I’m assuming with 29 off that this won’t be used.

This actually kind of makes sense because it wouldn’t immediately do it. It was after some time. In my mind this was heat build up not a stupid setting.

Let’s hope for a quick win.

#6821 74 days ago
Quoted from ypurchn:

Is this A.1 29 “GI POWER SAVER”? I just switched this to off and moved A.1 30 to “4” which is as low as it would go but I’m assuming with 29 off that this won’t be used.
This actually kind of makes sense because it wouldn’t immediately do it. It was after some time. In my mind this was heat build up not a stupid setting.
Let’s hope for a quick win.

Negative. Still have my issue with the GI and backbox lights

#6822 73 days ago
Quoted from ypurchn:

Is this A.1 29 “GI POWER SAVER”? I just switched this to off and moved A.1 30 to “4” which is as low as it would go but I’m assuming with 29 off that this won’t be used.
This actually kind of makes sense because it wouldn’t immediately do it. It was after some time. In my mind this was heat build up not a stupid setting.
Let’s hope for a quick win.

yeah that was the one I was thinking of. Dang, sorry that didn't work.

#6823 73 days ago
Quoted from CoPinfan:

yeah that was the one I was thinking of. Dang, sorry that didn't work.

I appreciate you tossing something out. It didn't help me but it may help someone else who reads this.

Quoted from ypurchn:

OK guys I need some troubleshooting help on where to start looking
Backbox lights are flickering ever so slightly
When I hit the flippers the GI lights dim for 1/4 second and then come back to full strength
I'm assuming this is a electronic issue.
Where do I start?

Anyone got something? I guess I could get out the old manual and flip through it...

#6824 71 days ago

Random question- I’ve been trying to get the “T2 Fanclub” to display during attract mode. I’ve turned the option in settings ON but I still am not seeing it display. Anyone experience this same issue? If so, any advice how to get that screen to show up?

I’ve thought of performing a factory reset but didnt want to go that route unless it was absolutely necessary.

Thanks!

#6825 71 days ago
Quoted from Yesh23:

Looking for some help here. I have non-ghosting Comet bulbs in the insert and the whole playfield doesn't ghost but the left bank for CPU, Access code etc. The right bank doesn't do it, just the left. You can see in the first picture the top CPU is about 20% lit and in the second picture you can see the checkpoint 100% lit like it should be but the cpu is still 20% lit (hard to see in the picture). Before I launch the ball and the skill shot lights cycle up in down (bank of lights right above) the 20% ghosting cycles with the those. What I mean by this is if the middle skill shot lot is lit then I'll have the silent alarm on at 20%. Any thoughts?
[quoted image][quoted image]

Can put install incandescent bulbs in the place of the troubled inserts? It will prove you have a board problem if it still does it with regular bulbs.

-1
#6826 71 days ago
Quoted from ypurchn:

Anyone got something? I guess I could get out the old manual and flip through it...

Have a look at this:

http://www.pinwiki.com/wiki/index.php?title=Williams_WPC#General_Illumination_Problems

#6827 67 days ago

Alright so I bought a little bit of a project T2, when I bought it the game wasn't working. It appeared to have battery acid damage on the board so I ordered a new MPU board and installed it.. Now the game boots and plays but resets a lot and the dmd is all scrambled on it. So I swapped out the DMD controller board from my No fear pin and it didn't fixed the problem. Swapped the DMD and it works in my No fear.. My next plan of action was to put a new rottendog board into it and when I did this the main line fuse blew by on/off switch 8amp and the solenoid fuse blew too on the board.

Only thing that looks fishy to me is the connector was redone on the Driverboard, the one on bottom left yellow wiring. My tech guy was out yesterday and was stumped on it. The original driverboard works but resets and there is no sound either. Any suggestions or help is much appreciated. Thanks guys

#6828 67 days ago
Quoted from pacman11:

dmd is all scrambled

Try swapping ribbon cables.

#6829 67 days ago

Try reseating this ribbon cable at each board. (T2 has one less board connection).fc3b5b6f5a7b15a35f34f1e58a09844c716eb8af (resized).jpg

#6830 67 days ago
Quoted from PinballManiac40:

Try reseating this ribbon cable at each board. (T2 has one less board connection).[quoted image]

Thanks I did that today and that seemed to fix it.. Awesome guys! Alright game is now booting and playing except the cannon doesn’t seem to be working on it..

C6204DE1-A0F5-4167-B7FB-564BD3798DF4 (resized).png
#6831 67 days ago
Quoted from pacman11:

My tech guy was out yesterday and was stumped on it.

Ribbon cable is one of the main causes of funny acting DMD

#6832 63 days ago

Does anyone have the plastics that go around the skull? Mine are broken and I was hoping someone might have them left over from where they got new plastics or something

Thanks!

#6833 63 days ago
Quoted from darcangeloel:

Does anyone have the plastics that go around the skull? Mine are broken and I was hoping someone might have them left over from where they got new plastics or something
Thanks!

Usually those are broken, I bought a new set of plastics to replace those and several other broken ones.

#6834 63 days ago
Quoted from mmr61184:

Usually those are broken, I bought a new set of plastics to replace those and several other broken ones.

Where?

#6835 62 days ago
Quoted from Buthamburg:

Hello to all
We can now announce that the Terminator 2 plastic sets are now ready for shipping.
The plastics are genuine Silk Screened with fluorescent orange / red. The complete
art work has been redone from scans of the original films used by Bally Williams.
These plastics are fully licensed.
The picture is showing all the plastics contained in the set.
Here is a list with the price shipped to your country for
1 Set of Terminator Plastic set. The Plastic Set will be sent via air mail
and insured.
USA. Euro 190
AUS. Euro 195
CAN. Euro 190
EC. Euro 210,63
DE. Euro 196,35
If you wish to purchase a set of Terminator 2 plastics set, please send me an email directly to
peter(at)buthamburg.de
Sorry to those whom have waited so long, thank you for your patients.
We are busy modifying our production facilities, it will still take some time
until we are finished. The biggest work is done and we can start to concentrate
on our projects again.
Terminator 2 Playfields are primered, we are waiting for an appointment at
the printers shop.
Regards from Hamburg
Peter
B&T Automaten Vertr.
Brunner & Tuazon GmbH
Ringstr. 43
22145 Hamburg
Germany
Web: www.buthamburg.de[quoted image]

Here you go...........Joey

#6836 62 days ago
Quoted from rx3:

Ribbon cable is one of the main causes of funny acting DMD

Alright ribbon cable seem to fix my problem thanks, now on to the next problem. The cannon isn’t working, put it in test mode and nothing seems to be working. Won’t move but it does shoot the ball out. Any tips or tricks to get this thing working or just buy a new replacement for it..

#6837 62 days ago

My CPU lights (see photo) appear to have a hack repair. Someone wired the board for them to another bulb socket and it appears they only turn on when that bulb would otherwise turn on. I'm assuming these should be wired somewhere else. While I intend to go through the schematic I was wondering if anyone could just confirm I am right in that these should ultimately be wired back to the backbox somehow. I saw no obvious cuts or missing wires in the harness. See photos.

Just to clarify - those 3 or 4 pins in the photo had a harness on them that led to another bulb socket in the game. I took that out. I highly doubt Williams wired it that way (and the molex connector was not an IDC one like all the others telling me it was an aftermarket "quick fix".

T2 CPU Lights (Under) (resized).JPGT2 CPU Lights (resized).JPG

#6838 62 days ago

Further research indicates that this is connected to the GI circuit. I wonder how / where?

#6839 62 days ago
Quoted from pacman11:

Alright ribbon cable seem to fix my problem thanks, now on to the next problem. The cannon isn’t working, put it in test mode and nothing seems to be working. Won’t move but it does shoot the ball out. Any tips or tricks to get this thing working or just buy a new replacement for it..

If it won't move at all and the motor makes no noise, I would check the motor. First, make sure a wire didn't come off it. Remove the motor and connect a battery to it to see if it works. If the motor works, I would take apart the gear mechanism, clean, inspect and lubricate the gears. Take lots of pictures as you take out the gears, so you know how to put them back together.

#6840 62 days ago

I found a NOS set a few years ago but you can buy really nice remakes from the German guy on this thread he makes playfields plastics and cabinet art

#6841 62 days ago
Quoted from Jakusu:

Here is the pinsound file I am working on for myself.
Credit to the the ones on the community sound forum already that I am using as the frame work.

I mean, to each their own, but the original score from the film is nothing short of Epic.

I'll be working on that original movie soundtrack mixed with the original Arnold quotes, some movie quotes mixed in and ''You could be Mine'' by Guns N' Roses for Payback time, soon.

1 week later
#6842 52 days ago

Only T2 at the Houston Expo this past weekend...held up well with over 500 plays.

1FEE7CFE-13EC-4BC8-AA78-D0B5B6519201 (resized).jpeg8BEE6C2A-AD9B-44EB-B7CC-1CCF542FBAD7 (resized).jpegA3AA7130-4C61-487C-AAA0-076E54FA730C (resized).jpegA4DDB05C-18E9-4FFF-A70E-B060B11C50E3 (resized).jpegF1D26A3A-BBF1-4409-BD44-397B971D701E (resized).jpeg
#6843 52 days ago

Machine looks great. I wish I could fix the wear near my hotdog

#6844 52 days ago

Can someone with the original backbox give me measurements for the three yellow "lines" on this image? I forgot to measure and have to install new decals. Would be great help so I can align perfectly.

IMG_6271 (resized).JPG
#6845 52 days ago

Guys - thinking about joining the T2 club. Are there replacement play fields available? I don’t see for sale at the usual spots

#6846 52 days ago
Quoted from Elicash:

Guys - thinking about joining the T2 club. Are there replacement play fields available? I don’t see for sale at the usual spots

Yes, around $1,000 shipped, I believe. See here: https://pinside.com/pinball/forum/topic/terminator-2-judgment-day-repro-playfields-pre-order-open/page/2#post-4646981

#6847 52 days ago
Quoted from tezting:

Can someone with the original backbox give me measurements for the three yellow "lines" on this image? I forgot to measure and have to install new decals. Would be great help so I can align perfectly.[quoted image]

What are the 3 yellow lines? I don't have those on my back box, so not exactly sure what you want measured?

#6848 52 days ago
Quoted from tezting:

Can someone with the original backbox give me measurements for the three yellow "lines" on this image? I forgot to measure and have to install new decals. Would be great help so I can align perfectly.[quoted image]

On my backbox:

- blue starts 53mm from base
- top (right edge) is flush (aligned) with edge
- bottom (left edge) graphic starts 13mm in from edge

I think you could centre the left and right edges and it would look fine

#6849 52 days ago
Quoted from Blitzburgh99:

Need help with problem:
Gun not firing when trigger pulled
All switches work in test mode. Solenoid fires in test mode. Gun calibrates. Trigger launches ball into playfield. But when Ball goes into gun fir jackpot shot, the trigger doesn’t fire the ball out. Gun rotated but trigger doesn’t shoot it.
What next?

Did you check the ball load micro switch in the canon in test mode... ie. does it register?
Also, when the ball is in the canon, is it fully depressing the switch. I replaced mine a while back and had to adjust the position so that the ball keeps the switch depressed when loaded.

#6850 52 days ago
Quoted from zimbakin:

What are the 3 yellow lines? I don't have those on my back box, so not exactly sure what you want measured?

Sorry if they where not so visible

Screen Shot 2018-10-24 at 08.26.16 (resized).png
Promoted items from the Pinside Marketplace
$ 15.50
Lighting - Led
Lermods
From: $ 180.00
$ 40.00
Lighting - Other
Rock Custom Pinball
$ 15.00
Playfield - Decals
Metal-Mods
$ 99.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 48.00
Cabinet - Other
ModFather Pinball Mods
$ 129.00
Lighting - Led
LED OCD
$ 49.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 159.99
Lighting - Other
Lighted Pinball Mods
€ 4.95
Playfield - Toys/Add-ons
Multigame
€ 222.00
Cabinet - Decals
Buthamburg
3,400 (OBO)
Sale Pending!
Luling, LA
From: $ 29.00
Boards
KAHR.US Circuits
2,900
Machine - For Sale
Kalamazoo, MI
€ 3.70
$ 20.00
Electronics
Yorktown Parts and Equip
$ 19.99
$ 29.99
Cabinet - Sound/Speakers
Lighted Pinball Mods
From: $ 16.95
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 28.00
$ 25.00
Playfield - Decals
Flashinstinct
From: € 189.00
Displays
GermanGamingSupplies.com
There are 6926 posts in this topic. You are on page 137 of 139.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside