(Topic ID: 68023)

TECH: WPC-89 MPU Won't Boot - Bet You Have Never Heard Of This One!


By robgo777

5 years ago



Topic Stats

  • 13 posts
  • 5 Pinsiders participating
  • Latest reply 5 years ago by robgo777
  • Topic is favorited by 2 Pinsiders

You

Linked Games

You're currently viewing posts by Pinsider robgo777.
Click here to go back to viewing the entire thread.

#1 5 years ago

So, one bazillion dollars to whoever figures out the cause...

There I was... Eating, Drinking, and being Merry while playing my TZ. Suddenly, out of nowhere, the machine gives me a switch error then dies. So after coughing up the Cheetos I started to choke on, I tried restarting the machine. No Joy... all I get are the LEDs D19 and D21, no blinking D20. When the machine it turned on, only those two LEDs are solid, no blinks or anything from D20. The nerve of some machines!

Tested all voltages, what I have found is that the board is getting the proper voltages with the exception of U21 pin 3. There is no 5vdc coming from that pin on that chip. I am however getting 5vdc going to the banded end of the diode at D25, however the non-banded end is not registering any voltage. Easy fix right? Just replace the diode you say? Well I did and no change! In fact, what I have found is that when the non-banded end of the diode is removed from the board, it registers 5vdc however as soon as I touch it to the board, bahhm! Voltage drops! When I remove C50 and R90 the diode at D25 will keep it's voltage after attaching back to the board. However as soon as I put C50 or R90 back in, the voltage drops again.

I did remove the board from the game BTW and am in the process of bench testing it with a switching power supply.

Replaced the following chips with working ones from my IJ:

U4
U6
U9

Replaced the following chips and components with brand new ones:

U1
U2
U3
U5
U7
U8
U10
U12
D25
C50

Still no joy. Tested voltage at U10 pin 1 and am getting 4.85vdc.

Any guesses?

#3 5 years ago

Thanks kvan, but isolated the power supply already. It is a problem with the MPU. This MPU has been connected to 3 different power boards from 3 other working games, plus the bench power supply and still have the same issue. Watchdog resets below 4.7vdc at U10.

I would however be interested in finding out how to disable the watchdog feature just to rule that out. I see there is a section of the MPU for watchdog disable, but I have never had to do that before.

Rob

#5 5 years ago

Replaced U21, still same issue.

Thanks for the try Chris!

Rob

#9 5 years ago

Actually Rob, several of the chips were replaced prior to the board coming to me. I don't have a logic probe, however I do have plenty of chips and sockets on hand.

I do appreaciate your input and help though, keep up the good work Rob Anthony, you have been a huge help.

#13 5 years ago
Quoted from johnwartjr:

Go spend 20 bucks and get one. You can do so much with them!
I have this one, and use it all the time:
http://www.mcmelectronics.com/product/72-190&green=9D124A8C-6C62-557F-B6E1-406F47277293

Thanks for the link John, I will put an order in for one along with some more 74LS244s

Any recommendations on some documentation that covers what to look for with a logic probe? My experience is limited to replacing at the component level. I do have the ability to test two boards side by side on my bench.

BTW, removing chips is pretty quick and easy with the P808KIT!

Promoted items from the Pinside Marketplace
7,500 (OBO)
Sale Pending!
Boonsboro, MD
6,550
Sale Pending!
Lehigh Valley, PA
$ 159.99
Lighting - Other
Lighted Pinball Mods
$ 63.00
Playfield - Toys/Add-ons
Lermods

You're currently viewing posts by Pinsider robgo777.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside