(Topic ID: 165153)

[TECH] - Space Invaders


By Spock

3 years ago



Topic Stats

  • 29 posts
  • 8 Pinsiders participating
  • Latest reply 2 years ago by cody_chunn
  • Topic is favorited by 3 Pinsiders

You

Linked Games

Topic Gallery

There have been 6 images uploaded to this topic. (View topic image gallery).

FO 560-3 (resized).png
solenoid doesn't fire (resized).png
IMG_6065_(resized).JPG
IMG_6064_(resized).JPG
IMG_6062_(resized).JPG
IMG_6063_(resized).JPG

#1 3 years ago

Recently installed a new MPU and have some issues.

Problems:

1. Top right Pop-Bumper Switch works but not the coil.
2. Wall drop target "Right side", Switch works but not the coil.
3. I hear an alarm sound on my first ball

Any thoughts?

#2 3 years ago

Check with a meter if the dead coils have power.

If they don't, find the last coil in the chain that DOES have power and figure out how it got lost.

Note that the power daisy-chains from one coil to the next

#3 3 years ago

Ahh I see, so having the right pop coil dead would also be connected to the wall target which is also dead. Will check soon, thanks

#4 3 years ago

alarm is normal on first ball ....it sounds on first ball on my game with no issues

#5 3 years ago

Update:

Correction, Left and Right pop-bumper do not work.

I put the game in solenoid test and no voltage to, (Left, Right Pop-Bumper and Wall Drop target)

Also: If I hit the Left Pop-Bumper it triggers the Right Sling.

Question:
The MPU I replaced had heavy Acid Damage and was dead. I am thinking the connectors could have some corrosion maybe? Could that cause this problem?

#6 3 years ago
Quoted from itshowtime:

alarm is normal on first ball ....it sounds on first ball on my game with no issues

Ok cool, thanks for confirming.

#7 3 years ago

Update: I just tested all (3) coils with a wire to ground. All 3 fired correctly. So, could this be communication from MPU to the Solinoid Driver Board or the Solenoid Driver Board itself.

#8 3 years ago

Did you ground the coils directly or did you ground the tab of the applicable transistor on the SDB?

#9 3 years ago

I tested just on the coil first. Now I just tested directly on the SDB and they also all work. So, I assume the MPU is not communicating to the SDB. Do note, all the switches for these coils work.

#10 3 years ago

Yup! If you can fire the coil by grounding the tab of the transistor then everything between the SDB and the coil is fine. Next I would look at the connectors between the MPU and SDB.

#11 3 years ago

Yup, I am already ordering new connectors and crimps. That was my first guess. My second guess 1 of 4 chips on the SDB is bad?
I will let you all know once I change the connectors.

*Connectors ordered.... Now the waiting game.

#12 3 years ago

It is possible that one of the chips is bad. All of those coils are driven through U-3.

#13 3 years ago

Take a good look at the back of the board where the chip is. If there was repair work done there, might be a short. Take a sharp knife or razor and see that you can run it between the solder for each leg. If there is a short, you'll feel it. Also, if you have a magnifier and a strong flashlight, give it a good once over. Here's a couple of pics of an SDB I had trouble with. The chip actually failed because of cracks in the solder. Once I touched up the solder, it worked like a champ.

IMG_6063_(resized).JPG

IMG_6062_(resized).JPG

IMG_6064_(resized).JPG

IMG_6065_(resized).JPG

#14 3 years ago

Thanks for the photos and the help, I can also reflow the pins.

#15 3 years ago

I would check the transistors first.....start with the simple stuff.

Not likely to be a connector issue unless one cycle of the solenoid test fires some of the coils more than once, then you would want to repin J4 on both the MPU and SDB.

Could be a chip on the SDB, but that's least likely to be your problem and they are getting hard to find so you don't want to destroy one removing it unless you're out of options.

#17 3 years ago

All the Transistors on the SDB seem to be working fine. However, the old MPU was massively compromised by acid. So, I would not be surprised if the connector is shot.

I am about to reflow the chips on the SDB. If it messes up the chips, I can just buy the Universal SDB for $150 which is fine by me. I got this SI for a really good price anyway and I already have the Universal MPU.

2 weeks later
#18 3 years ago

Update: Got the connectors today, just got done crimping everything on the MPU. My solenoids are working correctly, so the culprit was J4 connector.

Thank you EVERYONE for all the help. My SI is working great

7 months later
#20 2 years ago

Same subject, same board, slightly different problem. I did a 1/2 High Voltage kit from Bob, and all my connectors. Everything works except the relay circuit that turns on the flippers. That transistor works fine and I can short it to ground and the flippers then have power all the time, but I want to make it right.

Suggestions?
-Scott

#21 2 years ago

Keep in mind shorting the tranny tab to ground only tests continuity from the tranny (through the coil) back to the solenoid power buss. That doesn't switch the tranny on, it substitutes for the tranny. It could be bad. You have to dig a little deeper into the schems and force TTL signals HI or LO to prove it. Or just replace it since it's the highest % chance it's the bad component.

IMO

#22 2 years ago

Sorry, yes, already replaced it, didn't help.

#23 2 years ago

solenoid doesn't fire (resized).png

#24 2 years ago

cody_chunn -- what manual is that from?
-mof

#25 2 years ago
Quoted from mof:

cody_chunn -- what manual is that from?
-mof

Your life is about to get a lot better

FO 560-3 (resized).png

#26 2 years ago

I might have a hard copy of that. Guess I should go find it.

#27 2 years ago

Thanks! I'll try that.

1 week later
#28 2 years ago

This fixed it, thanks! Pin 8 at J4 on my board didn't have continuity. Step 1e on that trouble resolved it. I have that manual, but it must be a different revision, can you post a link to it?

#29 2 years ago
Quoted from sed6:

This fixed it, thanks! Pin 8 at J4 on my board didn't have continuity. Step 1e on that trouble resolved it. I have that manual, but it must be a different revision, can you post a link to it?

Well, it looks like where I found it doesn't have it any more...or I am mistaken and forgotten where I found it. Dig around...you'll probably find it.

Promoted items from the Pinside Marketplace
$ 44.99
Electronics
PinballElectronics.com
From: $ 19.95
$ 14.50
Electronics
PinballElectronics.com
From: $ 140.00
$ 7.65
Cabinet Parts
Third Coast Pinball
2,500
Machine - For Sale
Cincinnati, OH

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside