(Topic ID: 62712)

Tech: LOTR ring LED out


By CookyJar

6 years ago



Topic Stats

  • 9 posts
  • 3 Pinsiders participating
  • Latest reply 6 years ago by CookyJar
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 6 years ago

I'm having a problem with one of the LED lights on my LOTR, the light either flickers or is completely off. It's one of the white elf LEDs on the ring LED light board towards the bottom of the playfield.

I've checked the ends of both connectors and they seem fine, also visually checked the LED board for any broken traces and I didn't see any. Could the LED just be going bad or is it something else? Thanks for any help.

-Stephen

#2 6 years ago

Reflow the solder on it, see if it improves.

LTG : )

#3 6 years ago

One of the white bulbs on my board starting flickering years ago and finally went out a few months after. I went to radio shack and found an LED bulb that was the same size for less than a dollar from what I remember. Changing it out was a breeze.

#4 6 years ago

Thanks for the tips, will try to reflow first. If that doesn't work I'll go for the new LED bulb. Any chance you remember the part number from radio shack?

2 weeks later
#5 6 years ago

Trying to replace the White (Elf ring) LED, does anyone know the specific type of LED it is? I found a similar LED at Radio Shack, but I'm not sure of the voltage on the originals. Can't find it listed in the manual.

#6 6 years ago

Sorry I didn't see your reply from before. I just looked for the bulb that was the same size and white. Are there different choices in voltage for those size LEDs? The radio shack on my island is very limited, so I had just one choice for a led of that size and color, and it worked perfectly.

#7 6 years ago

One of my friends who does board repair said to check the voltage on the LED so I don't fry the board. The LEDs that I found at my Radio shack appear to be the same size and color as well, the supply voltage says 3.3V - 3.6V (max). Just trying to play it safe before doing the repair.

Here's a link to the LED that I bought, is this the same that you used?

http://www.radioshack.com/product/index.jsp?productId=3060980

#8 6 years ago

Yeah, I'm almost positive that was the pack I picked up. I can't remember how long I've had the thing installed for, but I've had no issues with the board ever since I put that LED in it.

#9 6 years ago

Excellent! Thanks for the info, going to try soldering it in sometime this week.

Promoted items from the Pinside Marketplace
$ 29.95
Gameroom - Decorations
Pinball Photos
6,700 (OBO)
Machine - For Sale
Davenport, IA

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside