(Topic ID: 208397)

Teacher's Pet no ball count


By JDCycle

2 years ago



Topic Stats

  • 6 posts
  • 3 Pinsiders participating
  • Latest reply 2 years ago by JDCycle
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

One image has been uploaded to this topic. (View topic image gallery).

Teacher (resized).jpg

#1 2 years ago

When I first got the game going it worked and then had a strange blowing issue that righted itself. I've been over switches. Also just what does the game relay do?

Teacher (resized).jpg

#2 2 years ago

You'll first want to check the switches in the ball count step up solenoid circuit. Check the following switches:

Trough switch - black/blue wire and orange/white wire
Game relay switch - orange/white wire

Make sure these switches are clean and adjusted properly. If these switches check out okay, then you'll need to look at the circuit that controls power to the game relay coil.

The game relay, depending on the machine, has a relation to the ball count unit and the coin relay...

#3 2 years ago

Welcome to the Teacher's Pet family! Great game!
If I can help you....................
Jim

#4 2 years ago

Thanks for stepping in. I have checked those switches and verified voltage on the red wire at game relay. The trough switch appears to be working as I can play the game. I tried mechanically dropping the game relay and still no ball count. Ball step coil at 2 ohms.

#5 2 years ago

If the game relay switch and the trough switch look okay, then verify that power can get to the ball count step up solenoid.

Power off the machine. You can adjust the two switches so they are always closed or you can tape the switches closed. Then power on the machine and start a game. The ball count step up solenoid should be constantly energized. Power off the machine and readjust the switches to their normal position. If this is the case, one of the switches in the circuit is not closing at the right time (most likely the game relay switch) and the circuit that controls power to that particular relay coil will need to be looked at...

If the ball count set up solenoid is not energized, then there's a broken wire in the circuit or there's a Jones plug problem on the main board. Or there is another switch in the circuit that isn't closing which would be shown on the schematic closer to the transformer...

#6 2 years ago

The result repair was a burned game relay coil thus explaining the mystry blown fuses.

Promoted items from the Pinside Marketplace
From: $ 40.00
Various Novelties
Pinball Photos
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
From: $ 18.00
Apparel - Men
Pinside Shop
$ 3.00
Electronics
Docent Electronics
From: $ 15.00
$ 999.00
Pinball Machine
Mircoplayfields
$ 209.99
$ 30.00
Playfield - Toys/Add-ons
Game Room Info Shop
$ 218.00
$ 495.00
Cabinet - Armor And Blades
MI Pinball Refinery
$ 92.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 42.00
Playfield - Toys/Add-ons
ModFather Pinball Mods
$ 79.95
Cabinet - Shooter Rods
Hookedonpinball.com
$ 495.00
Cabinet - Armor And Blades
MI Pinball Refinery
$ 39.00
Playfield - Toys/Add-ons
The MOD Couple
$ 5.00
Various Other Swag
UpKick Pinball
$ 139.00
Playfield - Toys/Add-ons
Sparky Pinball
$ 12.95
From: $ 220.00
Playfield - Toys/Add-ons
CzTV Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside