(Topic ID: 186644)

Mr. Tantrum's Guide to PinSound

By Mr_Tantrum

4 years ago


Topic Heartbeat

Topic Stats

  • 884 posts
  • 91 Pinsiders participating
  • Latest reply 16 hours ago by spidey
  • Topic is favorited by 182 Pinsiders

You

Linked Games

No games have been linked to this topic.

    Topic Gallery

    View topic image gallery

    pasted_image (resized).png
    new_firmware_with _funhouse _shakers (resized).jpg
    screenshot3 (resized).jpg
    Capture (resized).JPG
    Screenshot_20210320-091418_Chrome (resized).jpg
    pasted_image (resized).png
    screenshot2.jpg
    screenshot (resized).jpg
    D4A998E0-D5E2-4117-AC3F-A51F0F28E492 (resized).jpeg
    A04773E7-CF49-476C-9CBC-34A5522BBEC0 (resized).jpeg
    image (resized).jpg
    pasted_image (resized).png
    pasted_image (resized).png
    Screen Shot 2020-11-02 at 7.23.28 PM (resized).png
    Screenshot_20201101-212449_Samsung Internet (resized).jpg
    1027201955 (resized).jpg

    Topic index (key posts)

    10 key posts have been marked in this topic (Show topic index)

    There are 884 posts in this topic. You are on page 18 of 18.
    #851 23 days ago
    Quoted from Ashram56:

    OK, so just tested on another PC where it seems to work. Will have to think of reinstalling windows
    That said, I have a TZ which is fully equipped with Pinsound + Pinsound shaker. Working fine, but wanted to add a little bit more power to some events.
    Turns out that when I take the USB key on which all orchestrations are installed, if I copy the file over to my PC and open it, I can see the orchestration, but it does not display the embedded shaker settings. So I can't edit them (aside of recreating from scratch). Am I missing something ?

    When you are playing the pin, is the shaker working when set to the orchestration you are trying to edit? Shaker settings should be saved in the pinsound.config files, but I'm wondering if for routines that are included in the firmware if something different is going on.

    #852 23 days ago
    Quoted from Mr_Tantrum:

    When you are playing the pin, is the shaker working when set to the orchestration you are trying to edit? Shaker settings should be saved in the pinsound.config files, but I'm wondering if for routines that are included in the firmware if something different is going on.

    Yes shaker is working. I'm using regular pinsound orchestrations with no edits (ie the one available to download on the community website), downloaded them, put them on USB key for installation, started the Pinball. Orchestrations are working, so is shaker.

    After that, I simply took the USB key, and copied the files back on my computer, assuming the shaker commands would appear when opening in Pinsound Studio Pro. No dice.

    #853 23 days ago
    Quoted from Ashram56:

    Yes shaker is working. I'm using regular pinsound orchestrations with no edits (ie the one available to download on the community website), downloaded them, put them on USB key for installation, started the Pinball. Orchestrations are working, so is shaker.
    After that, I simply took the USB key, and copied the files back on my computer, assuming the shaker commands would appear when opening in Pinsound Studio Pro. No dice.

    You cant edit the firmware shakers.

    They are on the ROM. Not the USB stick.

    You can however, replace them all with your own version by making a new routine and saving it to the USB.

    #854 22 days ago
    Quoted from pinballinreno:

    You cant edit the firmware shakers.
    They are on the ROM. Not the USB stick.
    You can however, replace them all with your own version by making a new routine and saving it to the USB.

    That's a bummer

    But let me get this straight, just want to make sure I understand correctly...

    - Community develops shaker orchestration
    - These orchestration are then provided to Pinsound, who decides on whether to integrate them or modify them
    - They are then embedded inside the firmware, but in such a way that they don't allow to access them nor modify them
    - If a user wants to modify a few shaker routines, he needs to start from scratch and recreate the entire shaker orchestration
    - There is no repository of the shaker orchestrations done by the community
    - If using community shaker orchestrations anyway, they would be tied to a given sound mix (since there does not seem to be a way to transfer shaker orchestration from sound mix to another)

    Does this summarize well my understanding ?

    Regards

    #855 22 days ago

    Sort of. Some of us include shaker routines in the orchestrations we upload, so if you had one of these you could edit it.

    As simple as it is to create a routine, most want it working out of the box which is why I believe PinSound has taken the path they have.

    #856 22 days ago
    Quoted from Mr_Tantrum:

    Sort of. Some of us include shaker routines in the orchestrations we upload, so if you had one of these you could edit it.
    As simple as it is to create a routine, most want it working out of the box which is why I believe PinSound has taken the path they have.

    Thanks for the insight. I suspect there's a difference reason for the path taken by Pinsound, but that's a topic for another discussion.

    Now back on what I'm attempting: could whoever did the shaker routines for TZ share his sound package ? I downloaded the most recent sound mix available (TZ Deep Funky) (even though I don't use this one), but it does not seem to include the shaker routines. Other sound mix are too old

    Thanks !

    #857 22 days ago

    Well, who knows if that creator follows this thread or not, so you may want to inquire in the TZ owners thread.

    You can d/l the various available TZ orchestrations and see if any of them contain a shaker routine. Now, here is a bit of a tricky part in that orchestrations from the same game can have different naming conventions. If the conventions are the same between an orchestration that has a shaker routine and one that does not, then you can simply copy the pinsound.config file from the one with the shaker routine to the one without and you are off and running. However, if the one w/o the shaker routine uses a different naming convention (i.e. the folder names have different numbers) then you are back to square one starting from scratch to create a shaker routine for the orchestration (at lease you can reference the current one as long as you can align the sounds from one to the other given they are contained in folders with different names).

    Hopefully, I'm explaining this clearly enough for others to understand.

    #858 17 days ago

    Big firmware update today at pinsound.

    Included my funhouse shakers!

    Lots of positive updates.

    #859 17 days ago

    Sweet, thanks for the alert.

    Looks like the firmware download link is broken for now: https://www.pinsound.org/help/pinsound-plus-help

    #860 17 days ago

    ^^ +1 Yep guess addressing some discovered bugs

    #861 17 days ago

    I just noticed a May pinsound studio version update listed on there as well.

    #862 17 days ago

    Any release notes on the new pinsound version?

    #863 17 days ago
    Quoted from SDVmnt:

    Any release notes on the new pinsound version?

    ** VERSION 21.05.6 - 31 MAY 2021
    ------------------------------------------------------------

    * New: sound files can now be in OGG (or WAV) file format
    * New: shakerization for Fish Tales
    * New: shakerization for The Simpsons Party Pinball
    * New: shakerization for Funhouse
    * Improved: Headphones Station volume management on WPC machines
    * Improved: boot.wav can now be located at the root of the flash drive
    * Fixed: volume issue during soundpack preview
    * Fixed: recording files (PSRECORD) correctly saved

    #864 17 days ago
    Quoted from Mr_Tantrum:

    Sweet, thanks for the alert.
    Looks like the firmware download link is broken for now: https://www.pinsound.org/help/pinsound-plus-help

    It downloaded for me just now, so I guess it works again.

    #865 17 days ago
    Quoted from pinballinreno:

    It downloaded for me just now, so I guess it works again.

    I PM'd Nicholas, so maybe that did the trick (or was coincidental).

    #866 17 days ago

    Official funhouse shakers across the board !!!!!!!

    new_firmware_with funhouse shakers (resized).jpg

    #867 17 days ago

    Just moved my boot.wav out of the audio folder and to the root of the USB stick.

    Works petfectly!

    In fact it also still works just fine in the audio folder also.

    #868 11 days ago

    Anyone got a working link to a site that will convert Youtube videos to MP3? My old site seems to be down. Thanks for the assistance.

    #869 11 days ago
    Quoted from pinballjah:

    Anyone got a working link to a site that will convert Youtube videos to MP3? My old site seems to be down. Thanks for the assistance.

    Free download is a program called ClipGrab. It will capture video and audio just be sure to hit the drop down box on the settings to select if you want the MP4 or MP3 of what you want to grab.

    #870 11 days ago
    Quoted from DeathHimself:

    Free download is a program called ClipGrab. It will capture video and audio just be sure to hit the drop down box on the settings to select if you want the MP4 or MP3 of what you want to grab.

    Ok, thanks. Is it an app or can you do it through a website?

    #871 11 days ago
    Quoted from pinballjah:

    Ok, thanks. Is it an app or can you do it through a website?

    Is a small program you download, nothing done through a website. Just be sure what you are downloading as sites it will try to throw a bunch of other crap at you to download like winzip etc.... just the clipgrab you want. When you close those other pop up offer clipgrab download box will open up. It's just a few mb's.

    #872 11 days ago

    Just Google "Youtube to MP3". I've used a few of them

    Quoted from pinballjah:

    Anyone got a working link to a site that will convert Youtube videos to MP3? My old site seems to be down. Thanks for the assistance.

    Site may be back since the Fastly data outage has been corrected.

    #873 11 days ago
    Quoted from Mr_Tantrum:

    Just Google "Youtube to MP3". I've used a few of them

    Site may be back since the Fastly data outage has been corrected.

    Yes, my go to site seem to load the file but then it was getting removed by my computer. Will try it again. Thanks.

    #874 11 days ago

    So this question may have been covered but I’ve searched a few times and haven’t found an answer.

    I have a Data East JP with a Neo board in it, everything works great but I cannot turn down the volume any lower than it currently is(or “mute” it), which is somewhat loud for when the family is asleep upstairs

    Same goes for the Plus board I currently have on loan in my WWFRR. Volume /gain controls on the board itself don’t help.

    The volume pot inside the cabinet door on both games is turned all the way down to its lowest. Both pots worked properly prior to the pinsound boards being installed and was. Am I missing something?

    #875 11 days ago
    Quoted from mad_carl:

    So this question may have been covered but I’ve searched a few times and haven’t found an answer.
    I have a Data East JP with a Neo board in it, everything works great but I cannot turn down the volume any lower than it currently is(or “mute” it), which is somewhat loud for when the family is asleep upstairs
    Same goes for the Plus board I currently have on loan in my WWFRR. Volume /gain controls on the board itself don’t help.
    The volume pot inside the cabinet door on both games is turned all the way down to its lowest. Both pots worked properly prior to the pinsound boards being installed and was. Am I missing something?

    On Williams pins there is a minimum volume override that had to be disabled to address the exact issue you are referring to. However, I don't think a similar setting exists on the DE pins. I can't recall with my old DE JP I sold, but I always had a PinSound 1 with PinSound Headphones Station installed on it which gave me very fine control on volume leaves to the point of fully off to blowout my speakers and everywhere soft and loud in between.

    I don't recall, but I don't think their is a volume control on the new boards is there (I do have a PinSound Plus on my Getaway, but again with a Headphones Station installed)?

    Do you have a PinSound Headphones Station, and if not have you ever considered buying one? If if I were to never actually plug headphones in it the external volume control and ability to switch between orchestrations w/o having to open the coin door is a must for me. Unfortunately, I cannot say if this would or would not automatically solve your issue. Would be great if some current DE owners chimed in.

    #876 10 days ago

    The Plus had the EQ adjustments on board I believe.

    I don’t have headphone station on either. No real desire for one to be honest.

    Maybe I’ll look into this minimum volume setting. I assume it’s in a config file somewhere on the SD card. Not the end of the world, but it would be nice to be able to mute a game if I had to, or at least turn it down a tad bit more.

    #877 10 days ago
    Quoted from mad_carl:

    The Plus had the EQ adjustments on board I believe.
    I don’t have headphone station on either. No real desire for one to be honest.
    Maybe I’ll look into this minimum volume setting. I assume it’s in a config file somewhere on the SD card. Not the end of the world, but it would be nice to be able to mute a game if I had to, or at least turn it down a tad bit more.

    No, min volume setting is a service adjustment in the pin's firmware, but again I don't think DE has this setting (just Williams and maybe others). Also, I know the EQ is on board, but the original PinSound 1 also have volume adjustments before they converted to the digital EQ.

    Alternatively, you could probably add negative gain switches to the orchestration(s) you use via PinSound Studio Pro.

    #878 10 days ago

    I just looked up in my old JP manual, and there is a service setting for Background volume (Adj. 39 in JP). Not sure if this will help you or not.

    pasted_image (resized).png
    #879 9 days ago

    No difference with the Background volume adjustment.

    Looked into the firmware and both boards were running older versions from 2018 (ver 18.x.x)

    Updated both and now the volume pot near the coin box is working great.

    Heads up, if you’re having similar issues with the minimum volume on Data East or System 11 games, try updating the firmware. Checking out the change log, there has been a few updates to address volume issues on these systems over the past few years.

    It’s literally just grabbing the file from the pinsound site and dragging it to the SD card and turning on your game.

    #880 9 days ago
    Quoted from mad_carl:

    No difference with the Background volume adjustment.
    Looked into the firmware and both boards were running older versions from 2018 (ver 18.x.x)
    Updated both and now the volume pot near the coin box is working great.
    Heads up, if you’re having similar issues with the minimum volume on Data East or System 11 games, try updating the firmware. Checking out the change log, there has been a few updates to address volume issues on these systems over the past few years.
    It’s literally just grabbing the file from the pinsound site and dragging it to the SD card and turning on your game.

    Well darn, I shouldn't have assumed you were on new firmware. Definitely ALWAYS the first diagnostic step with PinSound is to upgrade to latest firmware.

    1 week later
    #881 1 day ago

    Have read most of this thread (some skimming- lots of repeats). Thanks to all for the posts, especially Mr_Tantrum!
    I have posted a question on Pinsound Support, will also write to Bros through "Contact".

    Game: Diner
    PS+ updated to newest firmware (June2021). Headphone Station installed.
    Different USB sticks tried, all SanDisk: 3.0, 3.2 (is 3.2 supported-not in documentation?)
    Tried another ribbon cable, same issue. Tried reseating cables.
    Voltage within recommended tolerance. Physically checked as well.

    Diner posts the original file and an "orchestration". Both tried. Both same results:
    My issue is like one that was posted awhile back on a Radical game, also a Sys 11 game (post #470):
    1) works perfectly with the OEM board
    2) the files are present and playing fine on my computer
    3) it's random, some sounds or music will play and then not, even during the same game

    In my words: both posted files produce same results:
    Game sounds seem random at all times, many events produce no sounds, then different music at different times, but not consistent, sfx not consistent as well, meaning one time one of two sounds will come on at end of game for bonus (for example), the next time one will, next time no sound (bonus on this game is two sound files of cash register sound played back to back).

    On post #470, the solution was: "Issue solved with the Help of Nicolas from pinsound.
    It was actually extremely simple, the lack of config.ini file stating to use the system11 was the cause."

    MY diagnosis file shows that newest firmware is indeed installed but it also says SYSTEM: DE. And that is on both the original mix and the Sixties Orchestration Mix. I don't know it that is the issue, as SYS 11 and DE are a lot the same and not sure if Pinsound uses DE for both in this case...but - I am thinking perhaps they have not updated Diner's config files at some point where they needed to be? Just guessing, not a computer guru.

    There are no hits on the Pinsound Question page for this issue or for that matter the word "Diner" so popularity is obviously not high and she could have been overlooked? Posted question on Pinsound Questions, not yet approved. Out of ideas and patience.

    If anyone knows how to change the config file or has other ideas, please give a shout.
    Thanks in advance for any help.
    Brad

    #882 17 hours ago

    My STTNG mix often has delays starting the audio when a starting a mode. Is that normal or a side effect of my usb card? It’s a PNY Usb3.0 card rated at 90Mbps read times.

    #883 17 hours ago
    Quoted from spidey:

    My STTNG mix often has delays starting the audio when a starting a mode. Is that normal or a side effect of my usb card? It’s a PNY Usb3.0 card rated at 90Mbps read times.

    Are you running an USB extension cable? If so make sure the cable is 3.0 as well, in addition the USB drives are cheap enough so grab another one that is 3.0 and do a compassion test to see what can be ruled out.

    #884 16 hours ago
    Quoted from DeathHimself:

    Are you running an USB extension cable? If so make sure the cable is 3.0 as well, in addition the USB drives are cheap enough so grab another one that is 3.0 and do a compassion test to see what can be ruled out.

    No cable. I’ve ordered a faster stick that will get here tomorrow. Getting IJ soon so I need another stick anyway, so I’ll see if this fixes it. Thanks

    There are 884 posts in this topic. You are on page 18 of 18.

    Hey there! Got a moment?

    Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside