TAF - looking for help with THING


By PittPin

1 week ago


Stats

  • 28 posts
  • 6 Pinsiders participating
  • Latest reply 6 days ago by mschonbrun
  • Topic is favorited by 1 Pinsider

Find

Search this topic for posts matching certain words or written by a specific Pinsider. Or both!




Linked Games



Topic Gallery

There have been 3 images uploaded to this topic. (View topic image gallery).

Addams Family 2 (resized).jpg
sol7 trig.jpg
Addams Family (resized).jpg


#1 10 days ago

When Thing takes the ball and drops it the game doesn't know where the ball went. It start looking for a missing ball. If the game is turned off and back on it gives a "missing ball" error. I checked continuity on switch 77 and it looked ok. Using the solenoid tests I expected Thing Kickout to fire and it did not.
What is supposed to happen when Thing hand drops the ball? Is the Thing Kickout supposed to fire right away or is the ball to sit on the switch? I read other posts about how to test Q68 if that is where this leads. Any suggestions on debugging this "Thing" would be appreciated.

#2 10 days ago

Game not knowing where a ball is, is a switch error.

Tests - Switch Edge - start tripping switches and see if they report on the DMD.

LTG : )

#3 10 days ago

When the ball hits the Thing kickout switch (77) what is supposed to happen?

#4 10 days ago
Quoted from PittPin:

When the ball hits the Thing kickout switch (77) what is supposed to happen?

In switch edge test ? A noise and a report on the DMD.

LTG : )

#5 10 days ago

LTG,
I suspected switch 77, Thing Kickout because that is when the game halts and starts looking for a ball. I did the switch edge test and had the ball roll over the switch and it closed as expected. I did the single switch test on it and was able to close/open it. So that seems like the actual switch is working.

#6 10 days ago

Would the Thing Up Opto and Thing Down Opto cause the problem with the ball getting lost in the thing trough?

#7 10 days ago
Quoted from PittPin:

Would the Thing Up Opto and Thing Down Opto cause the problem with the ball getting lost in the thing trough?

No.

LTG : )

#8 10 days ago

It is definately the switch LTG said . Listen to this guy he knows what he is talking about . Plus I’ve shopped and fixed a lot of these and it sounds like it’s the switch or related to that switch

#9 10 days ago

When the ball hits switch 77 is it supposed to be kicked out to the swamp immediately? I am thinking that if switch 77 checks out, the game expects the Thing kickout solenoid to fire and then one of the swamp lock switches should close. This leads me to guess that the solenoid not firing is the problem because the swamp lock switch does not close, not because the switch is bad but because the ball doesn't ever get sent there. Does this make sense?

#10 8 days ago

I have been debugging this offline with him. It’s not the switch. Grounding the transistor tab causes it to fire. The downstream power path works. Ball search fails to fire the coil and the coil has power. The issue has to be upstream of the TIP102.

I am not an expert in how to debug this with a logic probe, so paging @zaza and @chrishibler for help.

Marc

#11 8 days ago

And to add to this, specifically, the game is far dumber than that. The switch in front of the thing kicker is just telling the game “there’s a ball here, please fire the solenoid to clear it” and it hits the scoop to the subway and away it goes to the swamp. The game doesn’t know or care about the swamp in this instance. What is likely happening because the switch is working is that the game gets the signal to move the solenoid, sends the signal down the power path and due to whatever issue is preventing this, it’s not firing.

A logic probe will validate that the logic to fire the coil is intact from point to point which will either show an issue with the TTL upstream of the transistors, or the pre driver upstream of the 102, which fires the 36c.

Good luck - I will be watching this from the sidelines.

#12 8 days ago

Won't be as fancy as zaza's drawings, but here you go. The text below the schematic explains what reading you should see. Note: This is a generic high voltage solenoid circuit, use the manual to identify the specific components.

Put your probe on point A and then trigger the solenoid. The signal should go from high to low. The reverse will happen at point B when the solenoid is triggered.

You can always compare to another circuit to validate your methodology.

Addams Family (resized).jpg

#13 8 days ago

I have to get a logic probe ordered up. Any suggestions on what to buy.
How do I trigger the solenoid? The only way I have been able to get it to fire was by grounding TIP102.

#14 8 days ago

Trigger the coil in coil test.

#15 8 days ago

Just read TerryB's guide to Logic Probes and saw the suggested probe. Ordering it now.

#16 8 days ago

Looking at the High Power Solenoid Circuit above I can identify the TIP36c as Q68. TIP 102 is Q67, and 2N5401 could be Q59 - Q62. I am guessing Q61 is the one for the circuit I need. Next is the LS374 which looks to be either U1 - U5, or U18. How do I determine which one and locate point A. This is the generic circuit shown in the TAF manual and I don't see any other more specific schematic.

#17 8 days ago

I’ll pull the WPC schematic and check.

#18 7 days ago

Without a logic probe you can test in another way by 'pull low' base Q62 (2N5401) -preferable with a 470 ohm resistor but it can be done with a wire.
If this fires sol#7, the 3 transistors ( Q62-Q67-68) are working.
And if sol#15 'Right Slingshot' fires in solenoid test, data D6 is functional.

In that case U5 is likely the problem.

sol7 trig.jpg

#19 7 days ago

zaza, thanks for the advice and I will try this today. You graphic explanations are first rate.

#20 7 days ago

The WPC manuals don't include full schematics. You can download them here: http://arcarc.xmission.com/Pinball/PDF%20Pinball%20Misc/

Addams Family 2 (resized).jpg

#21 7 days ago

Thanks, Terry.

#22 6 days ago

Some test results to report:
per zaza above
I ran the jumper from TP5 ground to the transistor side of R132 and the Solenoid 7 (Thing Kickout) DID fire indicating the transistors are good.
I tried the Solenoid 15 in solenoid test and it does NOT fire.

Quoted from zaza:

And if sol#15 'Right Slingshot' fires in solenoid test, data D6 is functional.

Since #15 did not fire what does this indicate?

My logic probe should be here Tuesday if you guys can suggest other testing.

#23 6 days ago

Your transistors are working. That’s good news. And now you get a logic probe and you test U5 when in coil test and see if it’s doing what it should.

#24 6 days ago
Quoted from PittPin:

Since #15 did not fire what does this indicate?

Possible the dataline D6 doesn't work on the powerdriver.
Let's test that. Go into single lamptest and test all lamps. Do lamps work on lamp column7 and row7 ?
If not, reseat the ribbon cable between cpu- and powerdriverboard.

#25 6 days ago

Just so I understand the troubleshooting process could you explain the relationship between D6 and col/row 7? I do have the schematic and am curious as to the "why" as much as the what to do. I'll go check the lamps shortly.

I'll get into checking U5 once the probe arrives.

#26 6 days ago
Quoted from PittPin:

explain the relationship between D6 and col/row 7?

The picture TerryB posted in post#20 shows the data lines D0-D7 on left side of U5.
Those lines are travelling all over the drivertboard and data D6 is used for sol#7, but also for lamp row+col 7 and some more.

#27 6 days ago

All of Col/Row 7 lamps were out. I reseated the ribbon and the lights and the Thing kickout both function now. zaza, you nailed it.

Do you guys do anything more permanent when ribbon cable reseating solves problem?

Thank you to everyone that chimed in on this thread. It was an interesting learning experience and I got to buy a logic probe for the next time.

#28 6 days ago

Great news! Get a new ribbon cable

Marc

Promoted items from the Pinside Marketplace
$ 24.99
Lighting - Led
Lee's Parts
From: $ 14.95
Wanted
Machine - Wanted
Yoder, IN
$ 229.99
Lighting - Other
Lighted Pinball Mods
$ 27.99
Playfield - Protection
Lee's Parts
From: $ 29.00
Boards
KAHR.US Circuits
$ 29.99
Eproms
Matt's Basement Arcade
$ 66.99
Lighting - Led
Lee's Parts
From: $ 19.50
7,200 (OBO)
Machine - For Sale
West Des Moines , IOWA
$ 40.00
Lighting - Other
Rock Custom Pinball
$ 57.00
Playfield - Toys/Add-ons
Lermods
$ 53.00
Playfield - Toys/Add-ons
Lermods
€ 95.00
Lighting - Led
FlipperLED
$ 8.50
Lighting - Led
Bright Lights Pinball
$ 159.99
Lighting - Other
Lighted Pinball Mods
$ 24.99
Lighting - Led
Lee's Parts
$ 25.99
Playfield - Other
Lee's Parts
$ 29.99
Lighting - Interactive
Lee's Parts
$ 129.00
Lighting - Led
LED OCD
$ 29.99
Cabinet - Sound/Speakers
Lighted Pinball Mods
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
$ 29.99
Cabinet - Sound/Speakers
Lighted Pinball Mods
$ 1,089.00
Great pinball charity
Pinball Edu

Reply

Wanna join the discussion? Sign up for a Pinside account, or log in if you already have an account.


Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside