(Topic ID: 169892)

TAF fuse 115 blowing

By Kazak

5 years ago



Topic Stats

  • 5 posts
  • 4 Pinsiders participating
  • Latest reply 5 years ago by adii
  • No one calls this topic a favorite

You

Linked Games

#1 5 years ago

I get a message on start up saying Check Fuses 114 and 115. I cannot access the test menus. Fuse 115 is blown. Replaced it but the replacement blows. Don't tell me it's BR2 or C5 please. Any help would be greatly appreciated.
P/S. There are no 3/4 amp 3AG sloblo fuses in Australia at the moment... am waiting for our importers to bring them in from USA or Canada. Can't even find from China!

#2 5 years ago

I have them

#3 5 years ago

F115 is the switch matrix. Check the manual and disconnect the switch connectors (or all connectors except the inputs in the right corner) and retry. You need a circuit breaker for your fuse, like I do for a game I'm working on...troubleshooting with fuses gets expensive!

You need to isolate the problem to the wiring/playfield or the driver board.

#4 5 years ago

We've had this issue come up a couple times recently. When I get back to my computer I'll try to find the threads for you. On my Addams it was a broken wire on the upper right flipper that grounded out to a switch in the trough under Thing. It fried U20 on the MPU. That F114 F115 error usually comes back to an issue with U20. But, find out what physically caused it before smoking a repaired board.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside