(Topic ID: 247723)

(SOLVED) T2 where to start?


By VolunteerPin

4 months ago



Topic Stats

  • 11 posts
  • 6 Pinsiders participating
  • Latest reply 3 months ago by VolunteerPin
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 3 images uploaded to this topic. (View topic image gallery).

IMG_1020 (resized).jpg
IMG_1019 (resized).jpg
IMG_1018 (resized).jpg

#1 4 months ago

Some of you may remember Andy “Drewblood” who passed away last year from leukemia. He was a very good friend. I recently purchased his non working T2 from his old girlfriend with proceeds to his daughter. Game overall is in nice shape but won’t boot up. See enclosed video for what it does. Any idea where I should start troubleshooting this? I was told that on route it did have a burnt smell at one point and that is when they pulled it from the lineup. This will end up being a keeper for me just for the remembrance of Andy. Would love to get his thing in awesome shape.

Thanks for the help.

#2 4 months ago

I'd start by looking over the circuit boards. Check for alkaline damage from batteries, look for burnt connectors, any caps that look bulging or leaking. Disconnect everything from the power supply and check the voltages on the power supply. If your not comfortable with board repair, have a reputable pinsider or tech look them over.
Under the playfield, check for burnt, locked up coils, broken wires, anything that just doesnt seem right. To fully diagnose switches and coils, you'll need to get into the test menus.

#3 4 months ago

The dmd is doing that as it lost its memory. Go into test and then exit. The game should come to life.

#4 4 months ago

If this game has batteries installed, remove them immediately.

#5 4 months ago

here's an update:

Quoted from Pin_Guy:

If this game has batteries installed, remove them immediately.

game has a remote battery holder. I did go ahead and switch them out.

Quoted from tonyhoff1:

The dmd is doing that as it lost its memory. Go into test and then exit. The game should come to life.

Silly me. I can't believe I didn't try hitting a button. I guess I just have never seen this before so got a little worried after what I'd been told about the game. Game did "come to life" albeit with some errors. Main error report is something to the effect of "gun cannot find home error". Checking switches and solenoids shows that the gun does not move. I was able to start a game but obviously game had to be aborted when I loaded a ball but could not get the gun to move.

Looks like next step is to look more closely at the gun solenoid and switches. Thanks for the help so far. I'll keep posting as I know more.

Darin

#6 4 months ago

A little more investigation:

I didn't take a photo of it, but it looks like there is a replacement board which looks pretty new on the gun motor. Interestingly, I found a connector which is not connected to anything. The circled connector is the one not connected to anything. Not sure where that is supposed to go. Now this pin does have a Rottendog CPU so I don't know if that is why this connector is no longer connected to anything and maybe this is a non-issue.

Any thoughts on this specifically?
IMG_1018 (resized).jpgIMG_1019 (resized).jpgIMG_1020 (resized).jpg

Also, switches #32 and 33 (gun mark and home) are both showing closed which I believe is correct. The cannon is in the correct "home" position and ball loads fine. The ball present switch is working.

#7 4 months ago

The circled connector is the high voltage for your plasma display. If you have a LED or LCD display the high
Voltage wire is no longer used.

#8 4 months ago

There’s a test for the gun in the test menu. Does it activate through there at all? Does wiring to gun look alright?

#9 4 months ago

Okay. I do have a color DMD so that makes sense.

No activity at all with gun test. I’ll do more troubleshooting and take a few more pics in the next day or two as schedule allows.

Again, thanks for the help!

#10 4 months ago

It's possible that the gun has seized up and the motor can't turn it, it happened on one of mine. It was a fair bit of work, but completely disassembled the entire gun and cleaned it, worked perfectly after re-installing.

#11 3 months ago

SOLVED!

So, did a little more checking and realized no flashers were working either. Looked over the solenoid chart in the manual. Tried a couple of the main fuses which were fine. The secondary fuse for flashers was bad. Simple fix. Changed the fuse and all is well! Fixed the flashers and the gun motor.

I hope this helps someone in the future.

Thanks for the input and help.

Darin

Promoted items from the Pinside Marketplace
$ 26.50

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside