(Topic ID: 211050)

T2 Intermittent switch and controlled lamps issue


By futurepinhead

1 year ago



Topic Stats

  • 4 posts
  • 3 Pinsiders participating
  • Latest reply 1 year ago by futurepinhead
  • No one calls this topic a favorite

You

Linked Games

#1 1 year ago

It seems like every other game, a few switches won't register and some of the controlled lamps refuse to work every now and then. The only thing that I could imagine it would be is battery acid damage or a loose connector but none of those are the cause.

Any other leads?

#2 1 year ago

it would help to know which switches? might just be dirty contacts. do they register sometimes but not others?

#3 1 year ago

They're most likely unrelated, because switches and lamps are driven by different boards. The only way they would be connected is if something was putting garbage on your data line, and even then, it would be switches firing incorrectly, instead of the other way around. Look in the switch and lamp matrixes to see if all the ones that don't work line up on a row or column.

1 week later
#4 1 year ago

Updating here.
They were unrelated. The switches I think are due to a low 5v that I had. I fixed the voltage and it started working fine. The lights were several cold solder joints on the insert light boards under the playfield.

Thanks for your help.

Promoted items from the Pinside Marketplace
3,100
Machine - For Sale
Monroe, MI

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside