(Topic ID: 160079)

T2 CPU board blow fuse


By arakissun

3 years ago



Topic Stats

  • 8 posts
  • 5 Pinsiders participating
  • Latest reply 3 years ago by arakissun
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

There have been 5 images uploaded to this topic. (View topic image gallery).

P60517-175759_(resized).jpg
P60517-175752_(resized).jpg
P60517-175737_(resized).jpg
P60517-175723_(resized).jpg
P60517-175728_(resized).jpg

#1 3 years ago

I need some help with WPC Terminator 2 CPU board.
I try to help a friend.
So he bought the machine a year ago,but looks like the previous owner had evaded the main problem from the board somehow.
I swap the original board with another fully work and the machine works without problems.
So the problem is with the original board that came with the machine.
Here is what is happen:
1.Several lights stayed on constantly.
2.When the machine is turn on,immediately active one coil,but don't hold it.Just active it for a second.

Even with these problems,the machine is 100% work.

I put the original board on other two machine to see what will happen,and when I power them on,immediately blow fuse F105 which is solenoid fuse,but this not happen on T2 machine.

What can you suggest me for this problem?

#2 3 years ago

Bad MPU state is erroneously firing off many coils blowing the fuse. I would leave the driver board disconnected and see what the MPU LEDs do.

#3 3 years ago

Does the board have acid damage from leaky batteries? Take a hi-res photo, front and back of the cpu board. Post on pinside.

#4 3 years ago

I can see too many bad solders and one ULN2803 changed previously but no battery damage.
I think to fill the bad solders and to change the socket and ULN2803.
Also for what is juper W18,it looks like that it had it before.
Any other idea at this situation?

P60517-175728_(resized).jpg
P60517-175723_(resized).jpg
P60517-175737_(resized).jpg
P60517-175752_(resized).jpg
P60517-175759_(resized).jpg

#5 3 years ago
Quoted from arakissun:

Also for what is juper W18,it looks like that it had it before.

Those are your county selections switches, having W18 removed (along with 15-17 installed) is setting the game to German. Having W18 installed (along with 15-17 ) is setting the game to American.

This information should be listed on the inside front cover of your manual.

1 week later
#6 3 years ago

Same problem after reflow.

#7 3 years ago
Quoted from arakissun:

1.Several lights stayed on constantly.

Which ones? Can you post a picture?

#8 3 years ago

Problems fixed.
Shorted U12 74LS240,bad ULN2803 and one LM339.
Now everything is work.

Promoted items from the Pinside Marketplace
€ 3.70
$ 16.50
Lighting - Led
Lermods
$ 229.00
Lighting - Led
PinballBulbs
$ 19.99
Wanted
Machine - Wanted
Rexford, NY
$ 279.95
Lighting - Led
Pin Stadium Pinball LEDs
From: $ 129.10
Cabinet - Sound/Speakers
PinWoofer
$ 15.00
Playfield - Decals
Metal-Mods
$ 69.00
Cabinet - Armor And Blades
Id Rather Play Pinball
Wanted
Machine - Wanted
Powell, OH
$ 135.00
Lighting - Led
LED OCD
$ 259.95
Lighting - Led
Pin Stadium Pinball LEDs
$ 14.95
Playfield - Toys/Add-ons
ULEKstore
Trade
Machine - For Trade
Chicago, IL
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
€ 4.95
Playfield - Toys/Add-ons
Multigame
€ 12.50
Playfield - Plastics
Multigame
$ 26.50
$ 28.00
From: $ 233.10
$ 70.00
Gameroom - Decorations
The Pinball Vault
$ 9.99
Eproms
Matt's Basement Arcade
Great pinball charity
Pinball Edu

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside