(Topic ID: 212262)

System 9 Board Help: LED 7 Error


By comment23

1 year ago



Topic Stats

  • 2 posts
  • 1 Pinsider participating
  • Latest reply 1 year ago by comment23
  • No one calls this topic a favorite

You

Linked Games

#1 1 year ago

Hi everyone,

I'me close to pulling my hair out on this Sys9 board and am hoping you could lend some assistance to me:

Problem: Board on bench, booting to LED 7.

Probable Issue: Pin 4 on 6808 (IRQ) measures a steady 4.7 VDC.

Things I've attempted:

1. Replaced both 6808s with new / tested CPUs
2. Reseated all socketed ICs. Replaced some sockets (ROM at U20, RAM, 6810 RAM as someone did a crappy job before me)
3. Burned new ROMs, tested working in another board.
4. Replaced RAM with tested working RAM.
5. Did some testing of the logic gates. Replaced U39 which had a short at pin 4 or 5.
6. Dropped in Leon's Test ROM. Program boots. RAM checks successful. IRQ still stuck at 4.7 VDC.
7. I've read all other threads based around Sys9 LED 7 error boards. Haven't found anything too interesting.
8. Pin 39 (Crystal), Pin 5 (VMA) measurig between 2-3 VDC on DMM.

Questions: What components in the IRQ am I missing? I've never had to fix that circuit before and was wondering if there is something very stupid I'm not checking?

#2 1 year ago

Bump, anyone have any ideas?

Promoted items from the Pinside Marketplace
$ 689.00
Flipper Parts
Mircoplayfields
$ 21.00
Wanted
Machine - Wanted
Kalamazoo, MI
$ 279.95
$ 76.95
Cabinet - Shooter Rods
Super Skill Shot Shop
$ 20.00
Electronics
Yorktown Parts and Equip
2,200 (OBO)
Machine - For Sale
Pennsville Township, NJ
From: $ 16.95
From: $ 40.00
Cabinet - Other
Rock Custom Pinball
From: $ 40.00
Cabinet - Other
Rock Custom Pinball

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside