(Topic ID: 212318)

system 80 problem


By arcadebeast

2 years ago



Topic Stats

  • 25 posts
  • 10 Pinsiders participating
  • Latest reply 1 year ago by arcadebeast
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

There have been 9 images uploaded to this topic. (View topic image gallery).

fuse2 (resized).jpg
fuse1 (resized).jpg
coil (resized).jpg
image-6[1] (resized).jpg
image-4[1] (resized).jpg
IMG_0175 (resized).JPG
IMG_0174 (resized).JPG
IMG_0171 (resized).JPG
IMG_0176 (resized).JPG

#1 2 years ago

1987 monte carlo
game was working fine until i decided to move.
finely in the new house and had some time to set it up.
know score displays do not lite up and coil after kick out
burnt out smoking. any one with any help? thanks

#2 2 years ago

when you moved it did you unplug things?
Are all of the plugs in the correct places and connected correctly?

#3 2 years ago

i did remove the head. every thing looks like it's in the right place.
there is a plug i can't figure out. i can take pics tomorrow. thanks

#4 2 years ago
Quoted from arcadebeast:

i did remove the head. every thing looks like it's in the right place.
there is a plug i can't figure out. i can take pics tomorrow. thanks

There may be a few connectors that can get mixed up or reversed.

Did you take photos before you took things apart?

Check the manual and the labels in the connectors to make sure they are in the right places. If the labels have fallen off, use the wire colors and their positions to determine where they need to go.

After that, you should be able to better a assess the damage and determine what needs repairs.

#5 2 years ago

here are pics the last pic is of the plug i cant' figure out.
if there's any thing any one sees wrong please let me know. thanks

IMG_0176 (resized).JPG

IMG_0171 (resized).JPG

IMG_0174 (resized).JPG

IMG_0175 (resized).JPG

#6 2 years ago

it's the first pic not the last LoL. thanks

#7 2 years ago

Give this photo a try. It is of a Genesis. Everything should be the same. That idle connector has a mate.

image-4[1] (resized).jpg

#8 2 years ago

Here is a Raven photo. It might show things a little better. All brothers from a different mother.

image-6[1] (resized).jpg

#9 2 years ago

hey mad dog
checked all out. all pugs in the right place.
when i turn machine on all coils stick open and one gets hot and burnt up.
is this a driver board problem?

coil (resized).jpg

#10 2 years ago

Monte Carlo has a large number of under PF transistors. Fish out the schematics to see if one drives that coil. The OEM transistors were 2N5875s. They seem to fail quite often. Pick up some beefier 2N5884s from Big Daddy Enterprises.

Obviously, replace the coil. Take note of diode orientation and wire colors.

Chris Hibler - CARGPB #31
http://ChrisHiblerPinball.com/contact/
http://www.PinWiki.com - The new place for pinball repair info

#11 2 years ago

Double check the ground wires on the transformer panel sounds like a floating ground if all the coils are locking on.

#12 2 years ago
Quoted from arcadebeast:

here are pics the last pic is of the plug i cant' figure out.
if there's any thing any one sees wrong please let me know. thanks

I think that plug is for the topper. I just finished restoring that had the topper on it. Mike

#13 2 years ago

If everything that is mentioned above checks out then the problem is likely the driver board. By the way, are your pins in good shape? Those edge connector pins fail easily. It looks like you still have the original cable running between your MPU and driver board. You might want to re-pin or replace that. Also make sure you replace or remove that brunt up coil before doing any additional testing. We already know that item is toast.

#14 2 years ago

it was the ground wire on the cable running between the MPU and driver board. i have to replace burnt coil .
thanks to mad_dog_coin_op and every ones help. now that i'm all moved in i'll be setting my
games up again so you'll be seeing me back on the forum. i'll get some pics up as i clean up.
again thanks guys (good site,good people)

#15 2 years ago

Glade you got it sorted out. Re-pin that cable while the parts are still available. They quit making replacement pins so the price is going up dramatically. It will save you future headaches. Everybody says Gottlieb pins need a ton of grounding mods. In reality it grounds fairly good on its own if the pins are in good shape. Enjoy.

2 weeks later
#16 1 year ago

so i replaced burnt coil and every thing worked but the replaced coil doesn't release ball to start game and ramp coil gets hot.
i ran test mode and the 2 coils don't fire and shows switch 17 and 27 closed. all most there. any ideas?

#17 1 year ago

I don’t have the manual for this one so I can’t tell you what those switches are. My guess is you have a couple fried transistors on the driver board or bad pins between the mpu and the driver board. The driver board isn’t that expensive if you just want to buy a replacement. Like 110 dollars at the Arcade Shop. Just be sure your pins check out on that cable before you apply power.

#18 1 year ago

ok so i noticed a fuse that was blown out so i replaced it and as soon as i turn on the game it blows the fuse.this could be why the coil doesn't fire.
the fuse is the right bottom fuse in pic. it's a 1.5

fuse1 (resized).jpg

fuse2 (resized).jpg

#19 1 year ago

Do you have a manual? If so, what does the fuse control and is it the correct size? If you can, follow the wires back from the fuse holder. If it goes to the driver board you likely fried a transistor. The wires might also go to a stand alone transistor. If so, that would be the likely problem.

#20 1 year ago

will do thanks mad_dog

1 week later
#21 1 year ago

this thing is killing me. i bought a new rottendog driver board and still the same coil engages when game is turned on and stays that way, will not release ball for game start. so i disconnected every board and coil still stays engaged as soon as i turn game on. I'm lost on this one.

#22 1 year ago
Quoted from arcadebeast:

this thing is killing me. i bought a new rottendog driver board and still the same coil engages when game is turned on and stays that way, will not release ball for game start. so i disconnected every board and coil still stays engaged as soon as i turn game on.

Quoted from ChrisHibler:

Monte Carlo has a large number of under PF transistors. Fish out the schematics to see if one drives that coil. The OEM transistors were 2N5875s. They seem to fail quite often. Pick up some beefier 2N5884s from Big Daddy Enterprises.

This is good ^^^^^^^ advice.

#23 1 year ago

Ah, yes. As my good friend Steve used to say-

"Gottlieb: It's Not Just a Job, It's an Adventure"

arcadebeast: You could probably benefit from a System 80 Repair Guide. Send me a PM, and I'll reply with the Repair Guide.
If you already have one, disregard.

#24 1 year ago
Quoted from ChrisHibler:

Monte Carlo has a large number of under PF transistors. Fish out the schematics to see if one drives that coil. The OEM transistors were 2N5875s. They seem to fail quite often. Pick up some beefier 2N5884s from Big Daddy Enterprises.

This. This. And This.
Also, I would take Greg (swanng) up on his offer of the Sys80 Repair Guide.

mark

1 month later
#25 1 year ago

finally had some time to fish out the bad transistor (mj2955) under playfield. thanks every one for all the help. Greg (swanng) thanks for the repair guide big help.

Promoted items from the Pinside Marketplace
€ 8.40
$ 299.00
Displays
Boston Pinball Company
From: $ 18.00
Apparel - Men
Pinside Shop
Wanted
Machine - Wanted
York, PA
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
Trade
Machine - For Trade
Smithfield, RI
$ 10.00
Cabinet Parts
Ramp-O-Matic
$ 120.00
Playfield - Toys/Add-ons
ModFather Pinball Mods
$ 89.99
$ 8,999.00
Pinball Machine
Nitro Pinball Shop
$ 40.00
Gameroom - Decorations
Arcade Arts
$ 46.00
Playfield - Toys/Add-ons
Lermods
$ 229.99
From: $ 34.99
Playfield - Toys/Add-ons
Medisinyl Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside