(Topic ID: 173427)

System 11 Rollergames Display problem


By kilmarnock1350

2 years ago



Topic Stats

  • 4 posts
  • 4 Pinsiders participating
  • Latest reply 2 years ago by sneakerpin
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 3 images uploaded to this topic. (View topic image gallery).

IMG_9782 (resized).JPG
IMG_9783 (resized).JPG
IMG_9781 (resized).JPG

You're currently viewing posts by Pinsider sneakerpin.
Click here to go back to viewing the entire thread.

#4 2 years ago

The OP says the are "other weird things going on"... I would like to hear what those are.

Aside from double checking the ribbon cables, I notice the game EPROMs have no sticker over them... its a longshot, but perhaps a little sunshine spoiled some data locations on a chip or two.

Promoted items from the Pinside Marketplace
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
$ 50.00
$ 20.00
Electronics
Yorktown Parts and Equip
From: $ 19.99
Eproms
Matt's Basement Arcade
$ 14.99
Electronics
PinballElectronics.com
From: $ 16.95
$ 99.00
Gameroom - Decorations
Pinball Sales
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
From: $ 369.95
Boards
PinSound
1,995 (OBO)
Machine - For Sale
Simpsonville, SC
From: $ 18.00
Apparel - Men
Pinside Shop
$ 55.00
Lighting - Interactive
Rock Custom Pinball
From: $ 29.00
Boards
KAHR.US Circuits

You're currently viewing posts by Pinsider sneakerpin.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside