(Topic ID: 31838)

system 11 display problems

By mdclips

9 years ago


Topic Heartbeat

Topic Stats

  • 11 posts
  • 5 Pinsiders participating
  • Latest reply 9 years ago by viperrwk
  • No one calls this topic a favorite

You

Linked Games

#1 9 years ago

On my Space Station (Williams System 11) - the score displays on player one and two are beginning to have trouble. Some segments aren't lighting and some flicker. Its not too bad, but I am wondering if the problem might not be the display at all, perhaps something else driving it - or are the displays about to give up the ghost?

And if I do need to replace them is the pinscore the best way to go?

Thanks

#2 9 years ago

Any signs of previous work on the displays (replaced glass, jumper wires, etc)?

#3 9 years ago

Turn off the machine and reseat the ribbon cables on the display and on the other end on the board.You dont have to take them completely off just slightly pull them out and push them back on.My earthshaker does this from time to time and it fixes it every time.

#4 9 years ago

If you're losing segments it could be a bad 7180. Could also be the HV section of your PS. If you have a DMM you should check you HV section and make sure you are getting +100 & -100 volts.

viperrwk

#5 9 years ago

Thanks guys! I reseated the connectors on the display board and the problem disappeared. A while ago I reseated and cleaned every connector I could find, but I ignored the display board. In addition, I see that someone at some point replaced one of the glass displays on the board. Good to know.

Sure beats spending $200 on a board. Plus, I like the look of the old plasma.

#6 9 years ago

Had reseating the cables not fixed it, the next step would have been to swap the display cable to a different display and see if the problem was fixed or followed.

#7 9 years ago
Quoted from vid1900:

Had reseating the cables not fixed it, the next step would have been to swap the display cable to a different display and see if the problem was fixed or followed.

If he has another Sys11B machine with D-11609 display board

viperrwk

#8 9 years ago

I was meaning to swap player1 display with player4 and see if the problem persists.

If the player4 display still had problems on the player1 channel, then swap the ribbon cable, if problem still then you could could deduce that the problem was not the display (common) or cable (semi common).

I have both types of display boards at the moment for sys9 if anybody needs them.

#9 9 years ago
Quoted from vid1900:

I was meaning to swap player1 display with player4 and see if the problem persists.
If the player4 display still had problems on the player1 channel, then swap the ribbon cable, if problem still then you could could deduce that the problem was not the display (common) or cable (semi common).
I have both types of display boards at the moment for sys9 if anybody needs them.

He has a Sys11B Space Station not Sys9 Space Shuttle.

viperrwk

#10 9 years ago
Quoted from viperrwk:

He has a Sys11B Space Station not Sys9 Space Shuttle.
viperrwk

Ah, you are so right. I'm an idiot.

These phones are terrible for internet....LOL

#11 9 years ago
Quoted from vid1900:

Ah, you are so right. I'm an idiot.
These phones are terrible for internet....LOL

I hear you on the phone thing!

But now you have me thinking I want both a Space Shuttle and Space Station next to each other in my game room! Ack I hate this hobby!

viperrwk

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside