(Topic ID: 204745)

Switch matrix issues on Shadow


By arolden

1 year ago



Topic Stats

  • 4 posts
  • 2 Pinsiders participating
  • Latest reply 1 year ago by arolden
  • No one calls this topic a favorite

You

Linked Games

#1 1 year ago

Hi all.

Helping a friend fix up his Shadow and have run into a switch matrix issue that I can't figure out. The first issue was that the switch for battle drop target down was not working. I replaced the switch and diode, but it still did not work. So then I checked some other switches.

G in MONGOL does not register either. Left rubber (SW 35) closes all switches in column 5 except 54. The centre standup (SW 56) works, but also opens switch 46 and 36 (both originally closed).

I checked most of the other game switches (including locks, left eject, all ramp switches, inlanes and outlanes, and they are all fine. Centre standup (SW 56) originally had no diode, but even after adding one, the problem persisted.

Left rubber seemed to be the first in the problem chain so I checked the diode (after disconnecting it) and it was good. All other diodes seemed ok, but I didn't disconnect them so I'm not sure.

This seems like a diode issue to me but I can't tell where to focus on.

Any help appreciated!

#2 1 year ago

Bump! Appreciate some guidance on this one if anyone is able to help.

#3 1 year ago

Well, at this point I'd guess a chip. I mean switch 35 should not affect column 5 in any way. The kind of weird behavior you're getting isn't what you get from a single line being bad or shorted. u20 is the go-to replacement chip for switch issues, but this may be further back, or even a problem with your ROM. What happens when you push left Phurba control?

#4 1 year ago
Quoted from CadillacMusic:

Well, at this point I'd guess a chip. I mean switch 35 should not affect column 5 in any way. The kind of weird behavior you're getting isn't what you get from a single line being bad or shorted. u20 is the go-to replacement chip for switch issues, but this may be further back, or even a problem with your ROM. What happens when you push left Phurba control?

U20 is also what I expected but I've never seen U20 issues cause this kind of weird behaviour. Left phurba control works fine.

Promoted items from the Pinside Marketplace
From: $ 35.00
Boards
PCB Emporium
From: $ 16.95
From: $ 29.00
Boards
KAHR.US Circuits
From: $ 9.99
Eproms
Matt's Basement Arcade
$ 40.00
Lighting - Other
Rock Custom Pinball

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside