(Topic ID: 216453)

SWEP1 Loyal Order of the Gungans Club


By Jive

1 year ago



Topic Stats

  • 90 posts
  • 26 Pinsiders participating
  • Latest reply 21 days ago by ricard2798
  • Topic is favorited by 23 Pinsiders

You

Linked Games

Topic Gallery

There have been 29 images uploaded to this topic. (View topic image gallery).

3465FE81-7098-4B07-B495-B6C6ABF563F7 (resized).jpeg
pasted_image (resized).png
IMG-20191009-WA0004 (resized).jpeg
FE1941EA-9EAC-48CF-BF62-D1FB50AA411B (resized).jpeg
F2A8BA59-8EF9-452A-BD22-2704580C91DC (resized).jpeg
IMG_3446 (resized).JPG
IMG_3445 (resized).JPG
fullsizeoutput_d20 (resized).jpeg
fullsizeoutput_d1e (resized).jpeg
IMG_3442 (resized).JPG
fullsizeoutput_d1c (resized).jpeg
fullsizeoutput_d1a (resized).jpeg
fullsizeoutput_d14 (resized).jpeg
focUrTIBTkGGCg9zXtRhZQ (resized).jpg
fullsizeoutput_d18 (resized).jpeg
fullsizeoutput_d16 (resized).jpeg

There are 90 posts in this topic. You are on page 2 of 2.
#51 8 months ago
Quoted from paynemic:

Any bugs or deficits you know of? I’m interested in upgrading.

I played it for almost a year as 1.5, I did not see any issues. I'd imagine you could re-install 1.4 if you wanted.

#52 8 months ago
Quoted from WhiskeyTango:

True, I technically have other builds, but I'm not sure how they play.
50069_0150_07252000
50069_0150_09222003
50069_0160_02012013
50069_0165_02212018
50069_0200_02262016

The last official release I saw was v1.5 (50069_0150_09222003). Where did these "other builds" come from?

#53 8 months ago
Quoted from paynemic:

Any bugs or deficits you know of? I’m interested in upgrading.

Me too, I think I'm on 1.4. Very interested in the graphic quality increasing. I put in the video amp and it helped a ton.

#54 8 months ago
Quoted from mattosborn:

The last official release I saw was v1.5 (50069_0150_09222003). Where did these "other builds" come from?

I pulled them from the same servers and assumed they were home grown like the RFM updates.

Here are the release notes from Williams for up to 1.65

Star Wars Episode One - Revision History

Version: 1.65 - DEC 09 2018
(Changes From 1.60)
Updated XINA (1.23)
This version doesn't require 8MB of system memory anymore.
German-Translation fixes.
Pod-Race needs 5 Checkpoints to win.

Version: 1.60 - APR 23 2006
(Changes From 1.50)
Updated XINA (1.21)
This version requires 8MB of system memory.

Version: 1.50 - SEP 22 2003
(Changes From 1.40)
Incorporate the final version of XINA (1.19) which fixes the problem
where booting the system with the power driver board disconnected
can cause factory reset to occur due to the mismatch of the last
country dipswitch setting in CMOS vs. the country setting for
an open power driver board cable.

Version 1.40 - July 31, 2000
(Changes from V1.30)

Updated to latest operating system.
Enhanced coin/bill handling and credit system.
Added tournament mode fix for exploiting ramp shots.

Version 1.30 - September 21, 1999
(Changes From V1.20)

Added power-cycle fix for games with Japanese dipswitch settings.

If you have already upgraded to version 1.20 and are not using Japanese dipswitch settings, this upgrade is not necessary.

Version 1.20 - September 16, 1999
(Changes From V1.00)

Added translations
Added optional ball saver (off by default)
Added G-U-N-G-A-N / J-A-R-J-A-R rule to bumpers/spinner.
Made locked balls kick out immediately at end of game.
Added HSTD tables to status report.
Added instructions to attract mode.
Added action buttons (up/down one line) to initials entry.
Tweaked various scoring, lamp, and display choreography problems.
Made ramp/spinner combos forgiving of ramp/switch errors.
Fixed bug in Replay Boost.
Fixed screen when a PC keyboard is connected.
Added adjustment to allow slam tilt to reset the game.
Fixed O/S bug which incorrectly calculated ROM checksums in some cases.

Copyright (c) 1999, Williams Electronics Games, Inc.

#55 8 months ago
Quoted from WhiskeyTango:

Version: 1.65 - DEC 09 2018
Pod-Race needs 5 Checkpoints to win.

NICE!

1 week later
#56 8 months ago

hi,
just grabbed a really nice swep1
my wife loves it and it seems enjoyable.
a good companion for rfm and the others.
smallest club I join !

#57 8 months ago

i have a nos kit for this game to, waiting to plug it in

#58 8 months ago
Quoted from applejuice:

i have a nos kit for this game to, waiting to plug it in

Enjoying your RFM 2.0 update, would love for you to work on this game as well.

#59 8 months ago

by the way applejuice i have currently no time to work on translation. I hope it's not something that blocks your work :/
sorry for that.
SWEP1 update would be great indeed, your work on RFM is spectacular !

1 week later
#60 7 months ago

I'll second wanting an update to SWEP1, as the RFM work looks very good indeed! I've also wondered if it would be possible to update the movie clips to better quality, say HD? I know it wouldn't work on the original hardware, but with Nucore, I don't see why not, and that would make the game look so much better!

#61 7 months ago
Quoted from Jive:

I'll second wanting an update to SWEP1, as the RFM work looks very good indeed! I've also wondered if it would be possible to update the movie clips to better quality, say HD? I know it wouldn't work on the original hardware, but with Nucore, I don't see why not, and that would make the game look so much better!

I would definitely pay for that upgrade

#62 7 months ago

I would also

#63 7 months ago

I would love an update for this one and have been thinking about figuring out how to do it myself.
With just a little tweaking this game can be so much better!

1 week later
#64 7 months ago

I was installing the video amplifier board from ultimarc when I accidentally unplugged a small pair of wires on the computer.

Where exactly does this connect? I circled them in yellow in the closer picture.

F2A8BA59-8EF9-452A-BD22-2704580C91DC (resized).jpegFE1941EA-9EAC-48CF-BF62-D1FB50AA411B (resized).jpeg
#65 7 months ago
Quoted from shirkle:

I was installing the video amplifier board from ultimarc when I accidentally unplugged a small pair of wires on the computer.
Where exactly does this connect? I circled them in yellow in the closer picture.
[quoted image][quoted image]

If it's from the prism card, that's the motherboard reset.

2 weeks later
#66 6 months ago

I have some PUB cards left if anyone is interested.

1 week later
#67 6 months ago

Question for SWEP1 owners - how long does your shield stay up once it's in the open position? I feel like mine comes down too quickly and as a result I'm never able to get the ball into popper behind the shield. I have replaced the shield switch and the diode on the switch but nothing seems to change this behavior. Diagnostics reports no errors with the shield.

Thanks for any guidance.

#68 6 months ago
Quoted from Boslaw:

Question for SWEP1 owners - how long does your shield stay up once it's in the open position? I feel like mine comes down too quickly and as a result I'm never able to get the ball into popper behind the shield. I have replaced the shield switch and the diode on the switch but nothing seems to change this behavior. Diagnostics reports no errors with the shield.
Thanks for any guidance.

Maybe I have mine set up differently or on an easier setting, but mine seems to stay up indefinitely, until I make the shot or drain the ball. I’ll double check later.

#69 6 months ago

Cross posting here in hopes that more people who own this game will see this:

Quoted from JamesH007:

Does the switch register in the switch test ?

I don't know how to interpret the switch test screen. I see a number of green squares, some white with O in the middle (these are the ball trough optos I think). I don't understand what any of the options are in the switch diagnostics screen when I press the start button either.

I've tried putting the playfield up and testing the shield hold solenoid diagnostic while I manually press the shield switch but it doesn't make any difference - during shield hold test, the solenoid weakly tries to raise the bar but it never goes all the way to the top and it never holds. Regular shield power test is strong - the shield shoots up to the top with force.

#70 6 months ago

Hello,

as a member of this club, I would like to share with you our current fundraising to purchase 3 pinball machines for our local Children's Hospital, they would replace the actual machines I've placed with my wife.
Share the love and don't hesitate to PM me for details :

https://www.ulule.com/des-lumieres-dans-les-yeux/
all details : https://www.deslumieresdanslesyeux.fr/en

#71 6 months ago

Finally fixed the issue and figured out how the switch test works. For those who are new to the game (like me), the switch test works by manually pressing any of the switches in the game - the diagnostic will beep if the switch is registering correctly. In my game, no switches were reporting errors. However, even though the switch was working correctly, it was not getting fully triggered by the shield. I had re-installed the switch at least a dozen times trying to get it just right, but on the thirteenth try I finally succeeded. The shield hold is now working as intended. Hopefully this helps another new owner to the game.

#72 6 months ago
Quoted from Boslaw:

Finally fixed the issue and figured out how the switch test works. For those who are new to the game (like me), the switch test works by manually pressing any of the switches in the game - the diagnostic will beep if the switch is registering correctly. In my game, no switches were reporting errors. However, even though the switch was working correctly, it was not getting fully triggered by the shield. I had re-installed the switch at least a dozen times trying to get it just right, but on the thirteenth try I finally succeeded. The shield hold is now working as intended. Hopefully this helps another new owner to the game.

Thanks for posting that!

1 month later
#73 4 months ago

Hi.
I own a SWEP1 since Jan 2018, but I played it only 2 or 3 times, due all the blue posts are destroying themselves.
Ordered them last month. In some days will I replace them and start again playing.
Does the problem of this plastic affects only my pin ?

I find the pinball fantastic. It is the 9th of my collection but I think is great. Totally different from the others: music is great, video is great, playing is really fast, colours are intensive.

I changed the light saber with one of Frank Niro, because the original one was broken.

At work finished will I post some pictures.

#74 4 months ago

The multiball in this FANTASTIC pin is made of 3 balls; right ?

1 week later
#75 4 months ago

Correct, both multiballs are three ball multiballs.

2 months later
#76 64 days ago

Hello,

In search of complete working lightsaber for swep1.

#77 64 days ago
Quoted from jcarruth:

Hello,
In search of complete working lightsaber for swep1.

Hi. I bought the mod of niro pinball having problems in finding an original one.

#78 64 days ago

Does someone installed macrolon on the pinballs playfield ?
According to producer declaration the playfield coat is really hard.
Does we have to have trust or not ?

#79 64 days ago

Sold mine, bye bye

#80 64 days ago
Quoted from Marco1973:

Does someone installed macrolon on the pinballs playfield ?
According to producer declaration the playfield coat is really hard.
Does we have to have trust or not ?

What is the question? The playfield has a very good coating of what is called clearcoat. It is very tough.

#81 63 days ago
Quoted from alexmogil:

What is the question? The playfield has a very good coating of what is called clearcoat. It is very tough.

The question is, if you would install the macrolon or not.

#82 60 days ago
Quoted from Marco1973:

The question is, if you would install the macrolon or not.

If the playfield is in good shape with little wear, I would not. It should have a nice clear coat already.

#83 58 days ago

Does someone knows if there are some protectors for the two small holes and the big central one ?
I mean something like cliffy protectors.

IMG-20191009-WA0004 (resized).jpeg
#84 56 days ago

Sadly I have left the swamp. I hope many enjoy it in its new home.

pasted_image (resized).png
#85 54 days ago

They already have! It was an absolute hit at my dads 60th birthday party and personally find it’s simplicity quite refreshing. Thanks again Tim!
3465FE81-7098-4B07-B495-B6C6ABF563F7 (resized).jpeg

#86 54 days ago
Quoted from ruralcollector:

They already have! It was an absolute hit at my dads 60th birthday party and personally find it’s simplicity quite refreshing. Thanks again Tim!
[quoted image]

It was great meeting you Peter. Glad it has found a good home. How much did you sell the Hamm's sign for?

1 month later
#87 22 days ago

I recently bought a SWEP1, and am enjoying it, but need some help. Really hope someone here is able to assist.
First, if there is anyone in the Atlanta Ga region that knows how to service it, please let me know. Else, here are my issues.

1- Original monitor has been replaced with a 19inch LED, paired with a vid converter card. Seems to be working fine, and i have tried to align screen as best as possible. Still, would be great if i could have a photo of the hologram effect to use as a sample for my alignment. currently the 2 light sabers below the score sit between the word star and wars. Would love to align better and check best alternatives to make display better.

2-my green light saber is dim and lights up 3/4 of the way. it never strobes or flashes. How to fix?

3-The most important issue. Something wierd happens often after a ball is locked, or thrown in the mid target hole thing... it will first give me a new ball to shoot out of the shoot lane (normal), and after i shoot it, immediately give me another one to shoot (not normal... i think). so technically i can play with 2 balls... but the moment one ball goes down... flipers stop responding, and the pin waits for next ball to fall so i can proceed. even if i leave the second ball in the launch lane, if i loose the first one, the round will not be over until i launch second ball... despite flipers being locked cause of first lost ball. HOW DO I FIX THIS?!

Thanks in advance!

#88 21 days ago

Hi. I would try to make a test to verify if the opto switches where the balls "sleeps" works fine.
Sometimes they just need to be cleaned.

For the saber I will replace it. I will post in this days my new saber made from 2NiroPinball.

#89 21 days ago

For the double ball issue it could be a couple things - how many balls are installed? Does the shooter lane have a switch in it (I don't remember)? If it does, is it registering? Do you get any switch errors in diagnostics?

#90 21 days ago

ill check tonight and try to post a video (since im z total noob). ill link once its posted to follow up

Promoted items from the Pinside Marketplace
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
$ 86.95
Cabinet - Shooter Rods
Super Skill Shot Shop
4,100 (Firm)
Machine - For Sale
Hollis, ME
$ 40.00
From: $ 20.00
Cabinet - Other
Rock Custom Pinball
$ 99.00
Gameroom - Decorations
Pinball Sales
From: $ 35.00
Boards
PCB Emporium
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
From: $ 22.00
There are 90 posts in this topic. You are on page 2 of 2.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside