(Topic ID: 197241)

Surfer / Surf Champ add extra bonus not lit or scrolling.


By the4horse

1 year ago



Topic Stats

  • 19 posts
  • 7 Pinsiders participating
  • Latest reply 1 year ago by the4horse
  • Topic is favorited by 3 Pinsiders

You

Linked Games

Topic Gallery

There have been 8 images uploaded to this topic. (View topic image gallery).

20171022_135154 (resized).jpg
IMG20170907120602 (resized).jpg
IMG_2609 (resized).JPG
IMG_2608 (resized).JPG
IMG20170906140624 (resized).jpg
IMG20170905191605 (resized).jpg
IMG20170905191627 (resized).jpg
IMG20170811221416 (resized).jpg

#1 1 year ago

Hi fellow Surfer / Surf Champ owners : )

My surfer has an issue where the 5 'add bonus & add extra bonus when lit' features don't light up or scroll as they should when the ball hits the spinner. They've never worked at all since I've owned it but the spinner scores perfectly both lit and otherwise. Can someone tell me if the issue is linked to the spinner or is it a separate relay I need to track down. Not great with schematics, that's why I'm asking.

btw...picked Surfer up from a bloke who had her since '89 and it still has the original locks and keys and all the score cards, manual and schematics in their little folder in excellent condition! Just wish he'd stored it some place dry as the base had rotted and bits on each side. Luckily playfield, backglass and internals are all lovely. After repairing the cabinet and checking / cleaning relays n switches she started up and played great from the get go...except for the issue with the bonus lights. I think this machine is quite rare here in Australia and I love it...it's staying put.

IMG20170811221416 (resized).jpg

#2 1 year ago

Nice looking Surfer! "C" is the spin target relay, but you'll probably find your problem is with the "KS" advance unit relay, which is mounted under the playfield on the left side. It has its own jones plug so you can remove it for servicing, which may be just a matter of degreasing the wipers, etc. I think there are discussions on here about dismantling and adjusting these units.

#3 1 year ago
Quoted from Pinbee:

Nice looking Surfer! "C" is the spin target relay, but you'll probably find your problem is with the "KS" advance unit relay, which is mounted under the playfield on the left side. It has its own jones plug so you can remove it for servicing, which may be just a matter of degreasing the wipers, etc. I think there are discussions on here about dismantling and adjusting these units.

Thanks Pinbee!
I know the relay you mean...I'll look at it soon and let you know how I get on.

#4 1 year ago

The 'c' relay functions well. When I manually advance the 'ks' relay it now lights up three of the five inserts. I checked the two not lighting and the bulbs are okay. The light stays fixed on the whole game. They also score correctly when lit. Not sure how to get them to scroll with the spinner...is there another relay or unit attached to this action?

On another topic...mine's had the coil for the knocker unit removed. I've got an A 5195 coil; can I use that? I think the one it should have is an A 5194. Also, there's only one wire going to the knocker...which tab do I attach it to or is it either?

Thanks in advance.

IMG20170905191627 (resized).jpg
IMG20170905191605 (resized).jpg

#5 1 year ago

When C is manually activated, it should add 10 points (with chime) and advance the KS stepper. The spinner switch is the only one that activates C, so make sure it's clean and adjusted.
The KS is technically an AS type stepper, there's detailed info here, http://www.pinrepair.com/em/index2.htm#steps, scroll down to the end of the chapter.
The knocker coil needs two wires, there should be a black one in that bundle for it. The 5195 coil is what the chimes use, 5194 is what is spec'd for the knocker, but I guess the 95 will do in the meantime. The sleeve on the knocker coil looks displaced, should be down inside the coil.

#6 1 year ago
Quoted from Pinbee:

When C is manually activated, it should add 10 points (with chime) and advance the KS stepper. The spinner switch is the only one that activates C, so make sure it's clean and adjusted.
The KS is technically an AS type stepper, there's detailed info here, http://www.pinrepair.com/em/index2.htm#steps, scroll down to the end of the chapter.
The knocker coil needs two wires, there should be a black one in that bundle for it. The 5195 coil is what the chimes use, 5194 is what is spec'd for the knocker, but I guess the 95 will do in the meantime. The sleeve on the knocker coil looks displaced, should be down inside the coil.

Yeah, when the c activates it doesn't advance that ks unit...all scoring is correct and cleaned and adjusted. I'll double check it all though.
Strange...no black wire only the grey green which was neatly tied off and the coil was missing. I took the plunger and coil stops from my Class of 1812 just to test it. No black wire except on chimes and going to power supply...see pic.

IMG20170906140624 (resized).jpg

#7 1 year ago

If continuity is good between C and KS, then the KS coil is suspect.
The knocker's black wire is on the middle chime tab. The blue wire links all the chime coils to their black wire on the left.

#8 1 year ago
Quoted from Pinbee:

If continuity is good between C and KS, then the KS coil is suspect.
The knocker's black wire is on the middle chime tab. The blue wire links all the chime coils to their black wire on the left.

Oh wow...thanks! Does it matter which way round the wires are attached to the knocker coil?

#9 1 year ago

For the knocker I have black on the inside, gray towards the cabinet.

Make sure those KS boards are shiny. Dull boards create drag and less contact.
Make sure the jones plug is clean too.

You may have noticed I have no power switch in my pic... wondering if you can take your black cover off and snap a pic of the wires?

IMG_2608 (resized).JPG

IMG_2609 (resized).JPG

#10 1 year ago
Quoted from brenna98:

For the knocker I have black on the inside, gray towards the cabinet.
Make sure those KS boards are shiny. Dull boards create drag and less contact.
Make sure the jones plug is clean too.
You may have noticed I have no power switch in my pic... wondering if you can take your black cover off and snap a pic of the wires?

Thanks, I've hooked the knocker up and it works...thought it'd be louder...lol. Maybe that's because my coil is 5195 not 5194??
I did shine up the two sides of the ks boards and lightly wet and dry sanded the jones plug connectors. I'll have to check the coil too.
I attached the pic of under the plastic power switch cover as requested.

IMG20170907120602 (resized).jpg

1 month later
#11 1 year ago

Hi there. Did you fix the problem with the spinner and scrolling add bonuses? I have the same problem with my Surf Champ.

#12 1 year ago
Quoted from Misdestructo:

Hi there. Did you fix the problem with the spinner and scrolling add bonuses? I have the same problem with my Surf Champ.

I was just reading and , See post 5 of this thread , that explains it well.
Id. Check C relay switches are clean and gapped correct .

Make sure the KS stepper works freely
Take the KS out and clean out the little nylon gears with alcohol
.making sure the spring action that's inside the gears works okay , and that the nylon gears are not stripped, or it will slip .

But before you turn the game on. let the alcohol dry completely

#13 1 year ago

But before you turn the game on. let the alcohol dry completely
That takes all the fun out of it.

#14 1 year ago
Quoted from Ralph67:

I was just reading and , See post 5 of this thread , that explains it well.
Id. Check C relay switches are clean and gapped correct .
Make sure the KS stepper works freely
Take the KS out and clean out the little nylon gears with alcohol
.making sure the spring action that's inside the gears works okay , and that the nylon gears are not stripped, or it will slip .
But before you turn the game on. let the alcohol dry completely

Thanks for that. I think I'll check out the spinner switch first and work from there. I'm still very new to all this, so am a little reluctant to muck around with stepper units at this stage. Although, I surprised myself yesterday by successfully replacing my Surf Champ's five drop targets.

#15 1 year ago
Quoted from Ralph67:

I was just reading and , See post 5 of this thread , that explains it well.
Id. Check C relay switches are clean and gapped correct .
Make sure the KS stepper works freely
Take the KS out and clean out the little nylon gears with alcohol
.making sure the spring action that's inside the gears works okay , and that the nylon gears are not stripped, or it will slip .
But before you turn the game on. let the alcohol dry completely

Thanks Ralph67. With your advise and the link from #5, I've managed to get the lights working. There was a little dirt on the nylon gears which I removed with a plastic toothpick and some alcohol. I also gave the copper plates a bit of a clean with a Scotch Brite scourer and some alcohol. The pic below is of the unit before I cleaned the unit.

20171022_135154 (resized).jpg

#16 1 year ago
Quoted from Misdestructo:

Thanks Ralph67. With your advise and the link from #5, I've managed to get the lights working. There was a little dirt on the nylon gears which I removed with a plastic toothpick and some alcohol. I also gave the copper plates a bit of a clean with a Scotch Brite scourer and some alcohol. The pic below is of the unit before I cleaned the unit.

Well done you're learning fast . you got to be happy when things start to work again ...

#17 1 year ago
Quoted from Ralph67:

Well done you're learning fast . you got to be happy when things start to work again ...

The sense of achievement is ridiculous. Not to mention the dosh saved not having to call someone out to fix the problem. Now that's satisfying! Thanks again.

#18 1 year ago

Off topic.. What kind of cat is that? I have the same cat.. Mine is called a Ragdoll..

3 weeks later
#19 1 year ago

It was a dead coil on the KS relay as Pinbee predicted. Replaced the coil and it all works beautifully now...thanks again Pinbee!

Promoted items from the Pinside Marketplace
$ 45.00
Gameroom - Decorations
Pinball Photos
$ 45.00
Gameroom - Decorations
Pinball Photos
$ 55.00
Gameroom - Decorations
Pinball Photos
900 (OBO)
Machine - For Sale
Perrysburg, OH
€ 8.40
$ 399.95
$ 299.00
Cabinet - Armor And Blades
Lermods
$ 27.99
Eproms
Matt's Basement Arcade
$ 26.95
From: $ 370.00
Gameroom - Decorations
Gameroom Mods
$ 48.00
Cabinet - Other
ModFather Pinball Mods
$ 14.00
Electronics
Yorktown Parts and Equip
$ 89.99
Lighting - Led
Lighted Pinball Mods
$ 69.99
Playfield - Toys/Add-ons
Lighted Pinball Mods

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside