New! Dark mode!

Browsing Pinside at night? Getting tired of all the white? Switch to dark mode using the button in the top right (or CTRL-B)!

(Topic ID: 236845)

Surf Champ - "Add Extra Bonus" Rollover not adding "extra bonus"


By ChipS

1 year ago



Topic Stats

  • 10 posts
  • 3 Pinsiders participating
  • Latest reply 1 year ago by ChipS
  • No one calls this topic a favorite

You

Linked Games

Topic Gallery

There have been 5 images uploaded to this topic. (View topic image gallery).

KS Relay_Clean01 (resized).jpg
KS Relay Ratchet05b (resized).jpg
Pinball (resized).png
Pinball (resized).png
Surf Champ Top Rollovers (resized).jpg

#1 1 year ago

Thanks to everyone here who has been helping me get my Surf Champ up and running. I think I'm down to my last issue (for now).

With the KS relay now cleaned up, the lights above the top rollovers rotate when the spinner is hit. Problem is, when the ball goes through the lit rollover, it only scores 500 and one bonus advance. That's the same that it scores when it goes through an unlit lane.

I'm assuming that since it says "Add Extra Bonus When Lit," it should advance bonus by two units, correct? How is that controlled? I can't figure it out from the schematic...

Surf Champ Top Rollovers (resized).jpg
#2 1 year ago

Each upper rollover has 2 switches. The switches at 7H activate the E relay. The lit switch at 9H activates the D relay.
Now over to the Add Bonus unit coil at 4E, it pulses once if the E relay is on, and once if the D relay is also on.

Does that answer your question?

Pinball (resized).png
#3 1 year ago

Thanks!

I think I'm following you. So that means that when the ball passes through the lit rollover, it should activate both the D and E relays, correct? But it isn't, since it's not sending the pulses to both.

I checked the rollover switches - when I depress the rollover, both switches make contact. I then did a little test - tried each rollover in turn (moving the spinner by hand to move the light to each rollover). While they each score 500 points and advance one bonus (the D relay), none of them advanced it by two bonuses. So that suggests it is the E relay that is not activating. Correct?

So that is likely the culprit? Or could there be some other problem? How does the game know that Rollover #1 (or 2 or 3 or 4 or 5) is lit and should activate both relays?

#4 1 year ago

More info: I ran the test again and watched the D relay as I ran my finger over each lit rollover in turn - the D relay did not activate.

I answered my last question: the KS relay should be telling that game which rollover is lit and making both of those switches hot. Is that the issue?

#5 1 year ago

Some more testing: The D relay is working. I ran my finger over the left and right side rollovers and they did activate the relay. So that works.

I noticed that according to the schematic, when the game is set to three ball, the #2 top rollover stays lit and appears to energize the D relay by bypassing the KS Relay. And sure enough, when I switched it to 3 ball play, and ran my finger over the #2 top rollover, it energized the D Relay and E Relay and advanced bonus by two. But when I ran my finger over the other lit rollover, it only energized the E relay.

So that seems to confirm that the issue is the KS relay. Is that correct?

I took that relay apart a couple days ago and cleaned/lubed it. It's appears to be working perfectly (as far as I can see). None of the wires are broken. Anything in particular I should look for?

#6 1 year ago

I had the same question years ago. I don't think TimMe has been around for a long time, but he posted some great info on this topic in my thread:
https://pinside.com/pinball/forum/topic/surf-champ-1k-bonus-vs-1k-1k-bonus

Jeff

#7 1 year ago

Thanks, Jeff!

Yes, I think I now understand how it is supposed to work (thanks to Howard, and Rolf on your thread). And indeed, I do get the two bonus advance when in 3-ball mode and I activate the #2 rollover (which is always lit in 3-ball mode). It bypasses the KS relay and activates both the "D" and "E" relay.

What I can't figure out now is why it will not give the two bonus advance when I activate the rollover which is lit by the KS relay. That is supposed to activate the "D" relay, giving the second bonus advance, but will not.

Did you ever have this problem? Or were you simply trying to figure out why it did what it did?

#8 1 year ago
Quoted from ChipS:

That is supposed to activate the "D" relay, giving the second bonus advance, but will not.

If when the #1 top rollover is lit, it doesn't activate the 500 Point (D) relay, Inspect and diagnose this circuit with Alligator clip jumper wires. The problem is probably a dirty Advance Unit (KS) relay disk.
http://www.planetimming.com/Pinball/troubleshooting/EM%20Troubleshooting.pdf
http://www.pinrepair.com/em/index3.htm#features

Pinball (resized).png

#9 1 year ago
Quoted from ChipS:

Thanks, Jeff!

Did you ever have this problem? Or were you simply trying to figure out why it did what it did?

My game was working; I was trying to understand the schematic better.

#10 1 year ago

HowardR - I did what you said and jumped the #1 Rollover switch directly to the (D) Relay and then ran my finger over the rollover, it advanced bonus by two positions. That said the KS Relay was the problem.

Just a couple of days ago, I completely cleaned the KS relay - it was not advancing the "Extra bonus" light at all. And now the light was working, so I thought it was fixed. I couldn't figure out why it wasn't giving me the 2 bonus advance. So I did a test, running my finger over the other, unlit rollovers, and was surprised to find that one did give me two bonus advance. For example: the #2 Rollover was lit but only gave me one bonus advance. But when I ran my finger over the #3 Rollover (unlit), I did get two bonus advance. I activated the spinner one position at a time and found the rollover that gave me two bonus advance was always the one RIGHT NEXT TO to the lit rollover. Not sure why.

So I took out the KS relay and again took it apart. I manually activated the armature and noticed that there was one spot on the cam where it would get stuck. (Before I cleaned the ratchet, it got stuck every time it approached the "hump" in the cam - where the switch opened up. The photo is from a previous thread.) There are 5 clicks through each "hump" and 4 humps, so 19 out of the 20 clicks was fine, it was just the one spot where the drive finger wouldn't fully advance the ratchet. So I thoroughly cleaned the ratchet again - got out every single speck of dirt in the ratchet teeth - and put it back together. It worked. Now the KS relay operates flawlessly and the lit rollover, whichever one is lit, scores the two bonus advance.

Not sure why it was lighting one rollover and giving two bonus advance for the one next to it. Any guesses?

Thanks for solving this one for me!!

KS Relay Ratchet05b (resized).jpgKS Relay_Clean01 (resized).jpg
Promoted items from the Pinside Marketplace
From: $ 18.00
Apparel - Men
Pinside Shop
$ 4.49
Electronics
Yorktown Arcade Supply
From: $ 2.50
Various Other Swag
UpKick Pinball
$ 149.99
Playfield - Toys/Add-ons
Lighted Pinball Mods
$ 9.99
Eproms
Matt's Basement Arcade
$ 15.00
Playfield - Toys/Add-ons
The MOD Couple
$ 40.00
Gameroom - Decorations
Arcade Arts
From: $ 218.00
$ 119.95
Playfield - Toys/Add-ons
Hookedonpinball.com
$ 7,599.00
$ 14.95
Playfield - Toys/Add-ons
ULEKstore
$ 48.00
Cabinet - Other
ModFather Pinball Mods
$ 19.99
Eproms
Matt's Basement Arcade
$ 35.00
Playfield - Plastics
Ramp-O-Matic
$ 199.00
Playfield - Toys/Add-ons
Pixels Arcade Games
$ 6.00
Cabinet - Other
Siegecraft Electronics
$ 19.99
Cabinet - Other
Bent Mods
$ 239.99
Cabinet - Toppers
Tilttopper
$ 12.00
Electronics
Yorktown Arcade Supply
$ 11.95
Playfield - Toys/Add-ons
ULEKstore
$ 9.90
Playfields
The Super Fasteners
$ 16.00
Cabinet - Sound/Speakers
ModFather Pinball Mods
From: € 25.00
Flipper Parts
TheDudeMods
$ 79.99
Cabinet - Armor And Blades
PinGraffix Pinside Shop
$ 34.95
Playfield - Toys/Add-ons
pinballmod
$ 259.99
Cabinet - Toppers
Lighted Pinball Mods
$ 7.00
Electronics
APB Enterprises
From: $ 9.99
From: $ 9.99
Eproms
Matt's Basement Arcade

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside