(Topic ID: 168051)

Sttng weak flippers


By CrazyLevi

3 years ago



Topic Stats

  • 6 posts
  • 5 Pinsiders participating
  • Latest reply 3 years ago by PinballManiac40
  • Topic is favorited by 1 Pinsider

You

Linked Games

#1 3 years ago

All three of my sttng flippers are weak. They hold fine, it's pretty clear they aren't getting that initial high power shot.

Eos are all fine.

I've tried swapping the driver board and fliptronics board with known working boards, to no avail. All other solenoids work fine.

Isn't that odd? Any ideas?

Maybe it's the CPU?

#2 3 years ago

Are the main flipper coils 17636 or 11629? The manual shows all 3 to be 11629 but the main coils seem better with the more powerful 17636 coils.

#3 3 years ago

Not sure I'll check. I'll point out this game was playing fine for a year so probably isn't that.

#4 3 years ago

No mechanical binding I assume. Power supply test points good? Test mode and in game the same? Doesn't make sense, you just turn on the transistor. Check voltages at the fliptronics board.

4 months later
#5 3 years ago

Hey Levi, did you ever solve this problem? I also have a STTNG that the flippers seem to be weak. They hold fine and the game plays well but the flippers just seem to be about 60% or so. Any ideas would be great. Thanks.

Bob...

#6 3 years ago

Trying cleaning the flipper button board U-shaped optos with glass cleaner and Qtips.

Promoted items from the Pinside Marketplace
$ 64.00
Lighting - Under Cabinet
Lermods
From: $ 175.00
Gameroom - Decorations
Pinball Photos
From: $ 175.00
Gameroom - Decorations
Pinball Photos

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside