(Topic ID: 145926)

STTNG Sets Phasers to Kill Locked Balls


By DANGERTERROR

3 years ago



Topic Stats

  • 14 posts
  • 6 Pinsiders participating
  • Latest reply 2 years ago by eldawg
  • Topic is favorited by 1 Pinsider

You

Linked Games

Topic Gallery

There have been 2 images uploaded to this topic. (View topic image gallery).

Screen_Shot_2015-12-09_at_1.42.39_PM.png
IMG_0603.jpg

#1 3 years ago

Totally mystified by this problem -- I just spent a long time cleaning out the mess that is Williams' Star Trek: The Next Genreation's under PF diverter/opto area a few weeks back and got it working great. But a new problem arose.

As soon as you activate Lock 2, the game plays the lock animation about engaging the Borg, but after no kick out, it plays game music for a few seconds, then ends the ball.

No search: It just jumps right to the ball drain sequence. Starting up the next ball allows you to Lock 3 and start Borg multiball without issue.

The crazy thing is that the opto switches and coil are all registering and working perfectly -- and this is NOT an intermittent problem which is what's so confounding. For instance, if I leave 2, 3 or 4 balls in the Borg ball lock, it will show they are there in switch edges test, and it will fire them out when I start up the game for the pre-start ball search/staging. All staging is working perfectly, and balls are getting to the right places.

I've tested the ball lock switches in many different ways, and everything seems good. I'm not sure what else to do.

Thanks in advance for your wisdom, TNG folks!

#2 3 years ago

Have you checked the trough switches? If one of them is registering incorrectly, it could think it has more balls in the trough than it actually has.

Also, have you confirmed your subway diverters coils are working properly? Any problems staging balls when the game first powers up?

#3 3 years ago

Thanks for the response!

You know, I hadn't paid much attention to the trough yet as it has a new Great Lakes set in it and the convenient test LEDs on that board are registering properly, and I believe the switch test is fine, but I'll have to dig in a bit more. I just played another STTNG and that Lock 2 ball that goes missing is supposed to shoot out of the trough, NOT the left lock VUK, as I suspected. So I will have to look into that.

There are no staging issues -- the balls get to the three VUKs just fine at startup. So frustrating!

#4 3 years ago

yeah, the expected behavior is after locking ball two, a ball should come out of the trough and fire automatically from the launcher.

the game obviously knows lock two was activated ... but then it doesn't eject a ball from the trough. hmm.

i assume your second locked ball is always at the drop target under the borg ship. have you tried locking the second ball by going up the delta ramp and into the back of the borg ship, or at the neutral zone? lock behavior from these other lock locations might give us a clue.

unfortunately, the game seems to turn those locks on only if the multiball percentage drops below a certain level, so you may have to reset audits or something. i don't think there's a direct setting to enable them.

#5 3 years ago

Oh wow, that's a great test, thanks for the suggestion. Yes, I have only tried locking from the drop target shot.

I had no idea you could lock from those two other shots. Looks like I'll have to do some research!

#6 3 years ago

Connector on the ball trough is shit. I bet changing that fixes the issue! I would also bet that in switch test if you move the wires a bit, you see the switches open and close based on just moving the wires right at the trough.

#7 3 years ago

You do realize there are more than just one set of optic's on the left VUK, the second or third might not be registering.

#8 3 years ago

Thanks all.

New intel, but no fixes yet.

1) If I use the Borg ship lock for Ball 2, it *does properly kick out a ball* and the game functions normally!

2) The trough connector does not seem to have any issues, even when I mess with the connectors. All trough optos are perfect.

3) I noticed that this game labels the trough switches TROUGH RL. 6 - 1, but the manual reverses that order and calls them TROUGH LR 1 - 6. No biggie, but I thought it was amusing.

4) More switch tests. In the images attached, you can see the switch edges test immediately after the Lock 2 ball is lost. I just switched it right over as soon as the ball mistakenly drained. You can see there are balls in:

1 Trough slot 1
2 L Phaser Upkicker 1
3 R Phaser Upkicker 1
4-6 L VUK locks 1-3

That seems right, unless Borg Lock 2 isn't supposed to go to the L VUK trough. If anyone could confirm this, it would be helpful.

Anyway, all rolling of balls past all optos in all parts of the subway and trough seems to be 100% fine.

STUMPED AGAIN.

IMG_0603.jpg

Screen_Shot_2015-12-09_at_1.42.39_PM.png

#9 3 years ago

When you lock ball 2, where does it end up at?
I had a problem where the left VUK diverter was not always catching the ball and it would end up on the right VUK.
I just had to adjust the diverter.

#10 3 years ago

ok, so your test with the borg ship lock tells me that the problem has something to do with the subway / diverter / left VUK. for whatever reason, either the ball isn't getting to its expected position down there or the game thinks it's not getting there. that's the root cause of your issue.

i think we can eliminate the ball trough as a suspect, since it works fine when you lock a ball in the borg ship.

#11 3 years ago

I agree. Thing is, the switch test indicates the balls are all indeed where they need to be... Ball 2 ends up at the left VUK, as the third ball there (after the staged ball and the Lock 1 ball). Why would the game not recognize this but the switch test would?

Staging is fine, so I believe diverters are working great. And Lock 1 always works. Which should be the same, mechanically, as Lock 2.

Good grief

3 weeks later
#12 3 years ago

Fixed this one. It was the main ball trough. When only one ball was left, the ball wouldn't roll to the jam area due to wear on the trough. I fixed it with a plastic anti-magnetic trough protector -- although even after polishing the trough like crazy I was able to get the balls rolling again without the protector. Also: leveling really accurately helped too.

Thanks, all!

#13 3 years ago

Congrats on the fix! Thanks for posting the solution!

1 year later
#14 2 years ago

DANGERTERROR how did you get the lock to light for the delta ramp to test the back of the Borg ship? Thanks!

Promoted items from the Pinside Marketplace
From: $ 130.20
Cabinet - Sound/Speakers
PinWoofer
$ 14.99
Electronics
PinballElectronics.com

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside