(Topic ID: 82398)

sttng cannon not finding its home position

By flipperG

7 years ago


Topic Heartbeat

Topic Stats

  • 24 posts
  • 8 Pinsiders participating
  • Latest reply 7 years ago by flipperG
  • Topic is favorited by 1 Pinsider

You

Linked Games

You're currently viewing posts by Pinsider racerrik.
Click here to go back to viewing the entire thread.

#2 7 years ago

mine does this sometimes also... not sure how to fix it

#7 7 years ago
Quoted from Craig:

I'd guess something in the wiring harness is off or loose. (Assuming you've checked the optos.) All of my STTNG cannon problems were solved when I put in a new harness.

where can you buy the new canon harnesses?
I have been looking for a couple years and nobody seems to have them.

#14 7 years ago
Quoted from Craig:

It took me a while to find out where I bought my wiring harness. I got them from Jim at jimspinballshop.com. They were inexpensive and worked perfectly. Be sure to buy a spare. It's worth it to have an extra on hand. You'll need to send Jim an email to get them made for you.

When did you get these from Jim? I have sent him three emails and never heard back from him. Not sure how else to contact him.

#16 7 years ago

His website says the harnesses are out of stock. And there is no direct email address. You have to send an email through the contact us page which then responds with an error. If someone has a direct email address for Jim, I would like to try that. Or a phone number maybe?

#17 7 years ago

Another question - what signals on the harness would prevent the cannons from rotating properly. That does not make sense to me.

You're currently viewing posts by Pinsider racerrik.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside