(Topic ID: 74582)

STLE Owners - Any Major Problems?


By Goalerj

5 years ago



Topic Stats

  • 102 posts
  • 51 Pinsiders participating
  • Latest reply 1 year ago by NeilMcRae
  • Topic is favorited by 5 Pinsiders

You

Linked Games

Topic Gallery

There have been 9 images uploaded to this topic. (View topic image gallery).

image-181.jpg
image.jpg
image-864.jpg
IMG_0688 [800x600].jpg
IMG_0848.JPG
P1180815.JPG
image.jpg
image-967.jpg
image.jpg

There are 102 posts in this topic. You are on page 3 of 3.
#101 1 year ago

weird, they went again and randomly come back. reported to stern.

#102 1 year ago
Quoted from monkeyboypaul:

Make sure the wires feeding the Vengeance nacelle lights aren't snagging or flexing too much - they rise up on the rear left of the ship.
They break easily with all that ship movement. Might need slackening off, of some heat shrink to protect and keep it stiff.
They're still broken on the LE i used to own and get to play occasionally as it's not far from me still.

will check thanks.

Promoted items from the Pinside Marketplace
$ 399.95
$ 25.00
Cabinet - Other
Filament Printing
$ 5,599.00
Pinball Machine
Classic Game Rooms
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
There are 102 posts in this topic. You are on page 3 of 3.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside