(Topic ID: 74582)

STLE Owners - Any Major Problems?


By Goalerj

5 years ago



Topic Stats

  • 102 posts
  • 51 Pinsiders participating
  • Latest reply 1 year ago by NeilMcRae
  • Topic is favorited by 5 Pinsiders

You

Linked Games

Topic Gallery

There have been 9 images uploaded to this topic. (View topic image gallery).

image-181.jpg
image.jpg
image-864.jpg
IMG_0688 [800x600].jpg
IMG_0848.JPG
P1180815.JPG
image.jpg
image-967.jpg
image.jpg

There are 102 posts in this topic. You are on page 1 of 3.
#1 5 years ago

I am considering buying a STLE and was wondering if new owners have been experiencing any major issues with the game, lights, etc?. How far along is the code? Is Stern planning on a series of code updates or is it substantially complete?

I am a newbie and would prefer not to have to make many repairs to the game so just asking.

Appreciate the help.

#2 5 years ago

My laser quite working but that's my only issue

#3 5 years ago

Haven't had anything yet. The kickback gets beat sometimes but other than that everything is tip top.

#4 5 years ago

I've got a major problem with my STLE... I don't have it yet
Ships out tomorrow from Stern

#5 5 years ago

May I ask how long those of you that have the games have had them. I am not trying to slam any manufacturer but I bought a NIB WOZLE. While I love the game I have had to change out several boards and a shaker motor. The team at JJP has been great at helping me resolve the issues and I realize there may be issues with any new game (especially from a new manufacturer) but I would prefer not to have to do it again with another NIB.

#6 5 years ago

I love mine. The connector for the side rail lights had been disconnected from the PCB in transit. It took a call to Stern tech support to figure that out. I also had to adjust the switch for the left outlane to get the kickback to work more reliably. I had to adjust the "punch it" switch as well to get it to work. The left inlane switch is bad, and Stern is sending me a replacement.

All that being said, it's working nearly 100% perfect now (and will be 100% perfect when I get the left inlane switch replacement). It's a great game, and I'm very satisfied. I think the code is very complete as is, and will only get better with time.

My full review of the machine is here, near the bottom of the page:

http://pinside.com/pinball/forum/topic/the-official-i-got-my-stle-and-this-is-what-i-think-thread/page/9

#7 5 years ago

Flasher lights popping out seems to be an issue on mine. I put some duct tape on the base and have not had it happen again. Only other issue is a ball occasionally gets stuck on top of the bumpers but a little nudge gets it going again.

#8 5 years ago

I've a major problem with the ST LE.
- It's a Stern.

Yes really, i guess my pin got no quality control.
Maybe it's a Monday-machine.

1. One multicolor one LED was damaged (need to change)
2. No speaker-light and Star Trek sign light
3. Neon starter was damaged
4. The shooter-lane has the look and feel of an mogul field
5. One screw from the power supply comes out of the bottom
6. The right siderail has an piece of tape under the finished clear coat
7. Very dirty, and many glue leftovers

This will be a Limited Collector's Edition ??

Unfortunately still a great pin.

Bad luck. - Last time i got a perfect MET Premium (except for code

#9 5 years ago
Quoted from waynetrane:

Unfortunately still a great pin.

#10 5 years ago

Played a brand new LE at a friend this afternoon. The kickback worked really bad, often missed the ball after 2 tries, not sure if it was a mechanical or code problem, but for sure, the code of a 1996 Totan is smarter 'cause when the ball save cages miss the ball and it drains, the codes knows it should not have drained and gives you the ball again.. Not the ST LE with current code...
The backbox flashers seem to only work in attract mode.
Oh when he got it unboxed 3 days ago, the dot was not working, its cable was disconnected. They EVEN spare a spot of hot glue to secure the connector like on previous models.... unbelievable.
Plus the usual led(s) that falls on the playfield, etc.. now we're used to that.

#11 5 years ago

I've put over 200 games on mine. Right spot flasher fell out a few times but some glue fixed that and my kickback was a bit flakey initially but is fine now. Everything else working fine

#12 5 years ago
Quoted from Crrispy:

Played a brand new LE at a friend this afternoon. The kickback worked really bad, often missed the ball after 2 tries, not sure if it was a mechanical or code problem, but for sure, the code of a 1996 Totan is smarter 'cause when the ball save cages miss the ball and it drains, the codes knows it should not have drained and gives you the ball again.. Not the ST LE with current code...
The backbox flashers seem to only work in attract mode.
Oh when he got it unboxed 3 days ago, the dot was not working, its cable was disconnected. They EVEN spare a spot of hot glue to secure the connector like on previous models.... unbelievable.
Plus the usual led(s) that falls on the playfield, etc.. now we're used to that.

You sound outraged by the whole ordeal.... Sounds like pinball isn't for you or your buddy if its that big of a deal plugging in a connector or plugging an LED back into a socket. Its a complex machine has been shipped Half way around the world, so if that's all your buddy had to do I'd say he got off pretty easy.

#13 5 years ago

The unit at the arcade I go got one in last week. Their topper doesn't light. Came in defective.
There are bound to be some issues here and there. Same goes for JJP.
Get the ST LE, you will love it. And this is coming from a very happy WOZ person. Wish I had both!

#14 5 years ago

Just my kickback needed adjusting,and my warp ramp chase lights are not working.
Game plays great otherwise

I also had the same issues with boards on Woz LE,changed them all out to 7.5 volts and new power supply.

#15 5 years ago

I got mine last week and have about 50 plays on it. Amazing, no issues. Lights, warp ramp lights, and kickback all work properly. Only had one it two occurances where it failed to save a ball. Usually really slow drains.

Loving it!!!image.jpg

#16 5 years ago
Quoted from Goalerj:

I am considering buying a STLE and was wondering if new owners have been experiencing any major issues with the game, lights, etc?. How far along is the code? Is Stern planning on a series of code updates or is it substantially complete?
I am a newbie and would prefer not to have to make many repairs to the game so just asking.
Appreciate the help.

A major code update within a week, as well as another update in a month. Karl Urban speech will add a lot to this game. It's gonna be a Stern top 5. As it is the code is awesome out of the box already.

#17 5 years ago

The only issue I had was the drop down target in front of the vengeance ship would reject hard straight on hits I fixed it by making the return spring tighter by moving it down 18 loops works great now.

#18 5 years ago
Quoted from Goalerj:

May I ask how long those of you that have the games have had them. I am not trying to slam any manufacturer but I bought a NIB WOZLE. While I love the game I have had to change out several boards and a shaker motor. The team at JJP has been great at helping me resolve the issues and I realize there may be issues with any new game (especially from a new manufacturer) but I would prefer not to have to do it again with another NIB.

About a week 20 games in

#19 5 years ago

My first NIB and it works almost perfectly. Look forward to the upcoming code updates. Never gets caught on bottom bumper but has slowed on rare occasions. Kickback has only missed 3 times after 125 games on fast drains. My flashers haven't even fallen out yet. Wish they weren't on in attract mode. It can be annoying seeing the flash reflections from other rooms in house. No lights out. I was worried I'd get a lemon but so far, so good.

#20 5 years ago

There is an LE on location near me. It was shipped with a bad LED board. One insert light would display the wrong color, and at other times, not illuminate at all. A free replacement board fixed it.

No problems with anything related to the cosmetics or mechanics.

A buddy had one sent without keys.

#21 5 years ago

Few hundred games with a few fast kickbacks missed and chase light seen to not light every warp shot,that is it,Great game

#22 5 years ago

the only issue with STLE that I have had is quartergrabber. other than that the game is amazing !

#23 5 years ago

unit 108 has just under 100 plays. No issues at all out of the box. kickback missed a handful of times, and that's it for now. Giving it a waxing for Christmas! Only problem found is that if you jump back on an E.M. game the speed change drives you nuts!!

#24 5 years ago
Quoted from edwinpblue:

the only issue with STLE that I have had is quartergrabber. other than that the game is amazing !

oh canada come on! that was funny! and you give me a thumbs down?!? I can see you not giving me a thumbs up because of your pride but a thumbs down?!?

image-967.jpg
#25 5 years ago
Quoted from edwinpblue:

oh canada come on! that was funny! and you give me a thumbs down?!? I can see you not giving me a thumbs up because of your pride but a thumbs down?!?

image-967.jpg 91 KB

Sorry, I thought it was an insult. I didn't realize you were just kidding Removed my thumbs down, sorry.

#27 5 years ago

I have the Premium and haven't had any issues, besides the ball getting stuck in the pops (maybe 5 times--not much). The kickback has missed maybe 3 times.

I'm loving it so far!

#28 5 years ago

I also have a premium and the only issue I had is with the ball hang ups in the bottom pop bumper.
It was an easy fix by putting a small rubber bumper post under the existing rubber band. You could also use a small rubber sleeve or cliffy post and cut it in half and split it down the middle so you don't have to remove the ramp to replace the rubber. Other than that, no issues. Love the game.

#30 5 years ago

Just set mine up my premium last night. The sparkly metallic red trim really looks nice. Its inspiring me to do a similar treatment in green to my creech right next to it.

I also had the ball getting stuck behind the pops. I will try and add some rubber back there as suggested.

Also after playing for an hours or so It lost one track of one of the balls. It looks like the one of the ball trough optos is flaky. It seems to be intermittently seeing the first ball in the trough. The connectors looked like they were one tight. If I go into diagnostics and gently poke the receiving LED with my finger I can see it toggle on and off on the DMD. Maybe a loose LED or bad solder connection to the LED?

#31 5 years ago
Quoted from pingod:

Just my kickback needed adjusting,and my warp ramp chase lights are not working.
Game plays great otherwise
I also had the same issues with boards on Woz LE,changed them all out to 7.5 volts and new power supply.

How did you change them all out? Like ALL of them with 7.5's?

#32 5 years ago
Quoted from underlord:

How did you change them all out? Like ALL of them with 7.5's?

Yep,every board was changed out,even under the mini playfields.
All updated boards now.
I only had one bad board,but my supplier decided to change them all.
I'm glad he did

#33 5 years ago

Quibbles with my STLE that I have had for 11 days (manufacture date Dec 6, 2013):

  • Left outlane kickback sometimes misses, which is the most annoying thing, and obviates the point of the kickback.
  • Ball sometimes gets stuck right of the bottom pop bumper. This can be helpful in multiball.
  • Right slingshot strobe "lightbulb" comes out of the radar-dish-looking holder sometimes when a slingshot airball hits it. This is with the slingshot power set down 5 points to 27 from default, too.
  • Knocker sound is amazingly bad and earsplitting. A real knocker is a necessity, or at least a knocker-sounding sound.
  • No player's manual. It's very hard to figure out what you're supposed to do at any time, how to enter and exit modes, and so forth.
  • A number of LED bulbs (standard, always lit ones) are not working. I haven't disassembled them to see if they're the bulb, the wiring, or what.
  • Left flipper has a very distinct hum. Right flippers do too if you put your ear up against the machine, but this can be heard over sound effects and such.

The first is the worst, and the second is annoying. I doubt the first can be fixed, but don't really know.

#34 5 years ago
Quoted from pingod:

Just my kickback needed adjusting

A few people have said they have adjusted this.

Being new to pinball ownership (but pretty handy with some guidance) I would love to hear how these adjustments were made, please.

Thanks!

#35 5 years ago
Quoted from Admiral:

A few people have said they have adjusted this.
Being new to pinball ownership (but pretty handy with some guidance) I would love to hear how these adjustments were made, please.
Thanks!

Yea the kickback can be aligned I think you pull the cover off and straighten it... Apparently it has some adjustability.

#36 5 years ago

My kickback was aiming a little more to the left of centre.
My supplier fixed it by moving it over,and adjusting the switch a bit before the kickback.
It used to barely kick it to the middle of the playfield,if it hit it back at all.
Most times it would kick it to the right outlane.

Now it makes it to the upper flipper most of the time.
Still misses once in a while.
I hope they fix that with code.

#37 5 years ago

Least amount of issues out of any nib pin I purchased. Great purchase and a kick ass game!

#38 5 years ago

I've got one big problem and I can't figure it out. I can't get the time to play the damn game! It's sitting at home and no one is playing it! The problem is I'm not home!!!

#39 5 years ago

My biggest problem is I'm obsessed with completing Nero 3 and Prime Directive 3!!! Very difficult modes but I know I can do it!!!

Game was really solid out of the box. A few flickery LEDs but IMO that's from shipping. Like my other newer Sterns, once I go thru the game and press them back in solidly - they'll be OK. Everything mechanical works as it should.

#40 5 years ago
Quoted from pingod:

My kickback was aiming a little more to the left of centre.
My supplier fixed it by moving it over,and adjusting the switch a bit before the kickback.
It used to barely kick it to the middle of the playfield,if it hit it back at all.
Most times it would kick it to the right outlane.
Now it makes it to the upper flipper most of the time.
Still misses once in a while.
I hope they fix that with code.

I believe that a weak kickback IS a part of the code. It is weak when you have no power lights lit up on the lower right side targets, and very strong when they are all lit up. At least that's the way mine works.

#41 5 years ago

My plunger barely makes it up the shooter lane. It also feels hard to pull back on this. Right now Ive been using auto launch. Not sure whats causing this issue yet. Everything else worked like a charm!

#42 5 years ago
Quoted from MurphyPeoples:

I believe that a weak kickback IS a part of the code. It is weak when you have no power lights lit up on the lower right side targets, and very strong when they are all lit up. At least that's the way mine works.

Coincidence. Kickback just kicks back.

1 week later
#43 5 years ago

Anyone had this issue? My drop target when hit sometimes resets twice but not all the time? Also the Opto just behind the target are both sides meant to be glowing? My left front Opto is on but the right side isn't although in switch test mode and with glass off it triggers fine any ideas?

I attached photo

Peter
image.jpg

#44 5 years ago
Quoted from Gorgar1:

Anyone had this issue? My drop target when hit sometimes resets twice but not all the time? Also the Opto just behind the target are both sides meant to be glowing? My left front Opto is on but the right side isn't although in switch test mode and with glass off it triggers fine any ideas?
I attached photo
Peter

image.jpg 189 KB

If your drop target starts acting funny like this, lift up the pf (take balls out), locate the pin connector that controls the drop target, unhook it, and reseat it firmly back into place.

#45 5 years ago
Quoted from Eskaybee:

If your drop target starts acting funny like this, lift up the pf (take balls out), locate the pin connector that controls the drop target, unhook it, and reseat it firmly back into place.

Cool thanks will do but I'm still not sure about the Opto?

#46 5 years ago

Both sides of the opto light up, thats how it works. When the ball interrupts the light, it registers.

#47 5 years ago

I am waiting on a board replacement; my left vuk emblem color changer isn't working properly. Problem with the led.
Board should be on its way in the mail.

One or both of my spot (for sure the right one twice) flashers over slings popped out and same thing has happened to the both for sure on the one at CP Pinball. Mine had a lot of glue on it from the factory, but obviously did not help. They vibrate out way too easily. Right now the flashers sit in the coin boxes...

Had to latch my back box using the holes inside the cab as one of the ones outside the cab would not line up properly.

Not major problems since the light board is getting replaced (although I probably have to pay for return shipping for yet another warranty part), but still frustrating with the lights still popping out since XMEN!

Oh, the display at CP Pinball probably needs replaced. It already has a vertical line on the right side. I have not checked with Chuck to see if the problem still exists or if he checked connections or anything on it. It would also be under warranty if it needs to be replaced.

Expect problems with any NIB from any company and be happy if you don't encounter any issues.

#48 5 years ago

My STLE drop target will repeatedly go up and down without being hit. I think I have narrowed it down to faulty optos, the first set behind the drop target (even though they are fine in test). I have some doubts as that being the source of the problem. Already added washers to the target.

The game worked fine for the first three days I had it. It's been down now for a week waiting on replacement parts from Stern. It would be nice if they were to sent out warranty parts on a new game more quickly than standard USPS. I think Stern can probably afford the extra shipping to get me back in the game quicker than a 7 day delivery.

#49 5 years ago
Quoted from blimpey:

My STLE drop target will repeatedly go up and down without being hit. I think I have narrowed it down to faulty optos, the first set behind the drop target (even though they are fine in test). I have some doubts as that being the source of the problem.

The optos trigger the target, so it makes sense that they'd be the likely culprit.

#50 5 years ago

I have problems with the LEDs under the power weapon/mission status inserts.
they are flashing random colors during gameplay.
sometimes 2 leds light up during singel lamp test.
I am waiting for an answer from stern...

also problems with the drop target and the vengeance ship

P1180815.JPG

Promoted items from the Pinside Marketplace
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
$ 96.95
Cabinet - Shooter Rods
Super Skill Shot Shop
From: $ 42.00
Cabinet - Shooter Rods
ModFather Pinball Mods
There are 102 posts in this topic. You are on page 1 of 3.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside