(Topic ID: 190343)

Stern STAR WARS club...May The Force Be With You


By Micky

2 years ago



Topic Stats

  • 8,380 posts
  • 580 Pinsiders participating
  • Latest reply 6 hours ago by Thunderbird
  • Topic is favorited by 219 Pinsiders

You

Linked Games

Topic poll

“Which one are you getting.”

  • Pro 129 votes
    28%
  • Premium 191 votes
    41%
  • LE 148 votes
    32%

(468 votes)

Topic Gallery

There have been 1,256 images uploaded to this topic. (View topic image gallery).

1E85029F-62B0-498E-AB89-64CF050C8F16 (resized).jpeg
videomode (resized).jpg
20200112_210804.jpg
20200112_210819.jpg
20200111_191859.jpg
20200111_191842.jpg
20200111_191351.jpg
20200111_191334.jpg
20200111_191341.jpg
20200111_191300.jpg
20200111_191157.jpg
20200111_191240.jpg
20200111_191147.jpg
20200111_170853_HDR (resized).jpg
82790820_1220950488107934_7391565646137393152_n (resized).jpg
81559856_3121942514696867_3985339418549420032_n (resized).jpg

Topic index (key posts)

3 key posts have been marked in this topic (Show topic index)

There are 8380 posts in this topic. You are on page 52 of 168.
#2551 2 years ago
Quoted from PlayPin:

I think that is the best looking set of upgrade ships I have seen so far, nice work! I really like how you mounted the star destroyer. Do you know how long the aluminum mount turned out to be for that? There must not be too much wiggle room or the ship would stick up and be in the way of the glass.

Thanks!! I was actually in Corvallis a few months ago...beautiful country up there.
The rod I used for the Star Destroyer was short, about 1". Because the aluminum rod was so easy to bend, I was able to bring it to the pf already screwed into the base of the Destroyer, bend the rod rather dramatically to allow access to screw it to a bolt on the upper portion of the right ramp, and then bend the rod back into final position. I'm actually amazed at just how sturdy it is. No wiggling at all during gameplay and it hasn't budged an inch since I placed it. I was rather surprised at the amount of space that was available between the ramp and the glass.

#2552 2 years ago
Quoted from ChipScott:

Thanks!! I was actually in Corvallis a few months ago...beautiful country up there.
The rod I used for the Star Destroyer was short, about 1-1.25". Because the aluminum rod was so easy to bend, I was able to bring it to the pf already screwed into the base of the Destroyer, bend the rod rather dramatically to allow access to screw it to a bolt on the upper portion of the right ramp, and then bend the rod back into final position. I'm actually amazed at just how sturdy it is. No wiggling at all during gameplay and it hasn't budged an inch since I placed it. I was rather surprised at the amount of space that was available between the ramp and the glass.

I want to thank you for your posts here. I had just ordered a lighted Star Destroyer yesterday on Ebay. Minutes later saw your post and thought it looked a lot nicer. Much more detail in your version. I also think the way you mounted it on the premium is perfect. I was able to cancel the order for the S.D. on Ebay and I ordered the same one you have. I can't see finding a nicer one and the size seems perfect. I think some of this kind of detail is just what this game is begging for. Can I ask you where you found your other ships?

#2553 2 years ago

I was playing R2D2 and got defeat the Death Star mode. As I was going through it tie fighter multi ball started. Played that until I had lost all but 2 balls and then it seemed Death Star mode continued. One problem, the fork ramp had dropped during tie fighter multiball and never came back up. I hit the left loop and finished Death Star, but I didn’t get the pleasure of seeing the Death Star explode (would’ve been the first time). I got over 600 mil for Death Star, but kinda bummed.

#2554 2 years ago
Quoted from PlayPin:

I want to thank you for your posts here. I had just ordered a lighted Star Destroyer yesterday on Ebay. Minutes later saw your post and thought it looked a lot nicer. Much more detail in your version. I also think the way you mounted it on the premium is perfect. I was able to cancel the order for the S.D. on Ebay and I ordered the same one you have. I can't see finding a nicer one and the size seems perfect. I think some of this kind of detail is just what this game is begging for. Can I ask you where you found your other ships?

I agree, the detail in these starship figurines can be really amazing, and really helped enhance an already a very cool game. I got everything off of Amazon. The Collection that these Starship figures come from is called Star Wars X-Wing miniatures game expansion pack, which includes multiple different ships including the ones that I used. Shipped in like 2 to 3 days.

MVIMG_20171219_193049.jpg
MVIMG_20171219_193006.jpg

#2555 2 years ago
Quoted from tbanthony:

Is that the smaller "Victory" ship or the same one (larger) used by ChipScott?

Armada victory class Star Destroyer

#2556 2 years ago
Quoted from ChipScott:

I agree, the detail in these starship figurines can be really amazing, and really helped enhance an already a very cool game. I got everything off of Amazon. The Collection that these Starship figures come from is called Star Wars X-Wing miniatures game expansion pack, which includes multiple different ships including the ones that I used. Shipped in like 2 to 3 days.

This is what I used...including slave 1. Really look good in the game without obstructing view or being so big they are overwhelming. These fill in some of the holes and just enhance the game. Highly recommend.

#2557 2 years ago
Quoted from dnapac:

This is what I used...including slave 1. Really look good in the game without obstructing view or being so big they are overwhelming. These fill in some of the holes and just enhance the game. Highly recommend.

I added the Destroyer last night, and it looks awesome. Slave 1 is next.

#2558 2 years ago
Quoted from 30FathomDave:

I added the Destroyer last night, and it looks awesome. Slave 1 is next.

My star destroyer is from lightedpinballmods.com...looks different when outside the glass, but really cool when mounted...especially lit.

#2559 2 years ago
Quoted from fastchef:

I noticed over the weekend that the right outlane insert is missing paint. I don’t think it was like this when I got it 2 months ago. Is this something I should be concerned about or is it no big deal?

It is minor wear . Yes do something about it absolutely. I would . Easy fix .
Step # 1 black sharpie ever so lightly color worn/defective paint on insert. If Step # 1 makes you nervous skip to Step # 2.
Step # 2 Buy some 3 mil. Self adhesive laminating sheet from an office store.
Step # 3 lay a piece of the 3 mil. Self adhesive laminating sheet over insert and trace the out line of outer black circle. Cut to fit .
Step # 4 take template. Peel off white backing and adhere over insert .
I have been doing this for many years .Better than mylar for this type of fix as it does not have as much sticky adhesive .
amazon.com link »
This photo has nothing to do with SW. It is an example were I used the Laminate to make a decal to cover my KISS LE black rubber Disc as it was leaving black residue all over pinballs and playfield .

KISS Disc motor mylar decal (resized).jpg

#2560 2 years ago
Quoted from Bond_Gadget_007:

‘Just installed 1.00 on Pro, but I now have issues with the Hoth shot: the flippers are dead and ball drains 3 times in 5 games.’
Can anybody help this guy out?

Quoted from TheLaw:

Yes Stern can; pick up the phone and call them.

Quoted from rotstern:

No its only when shooting Hoth.

Maybe. Maybe not . Chas and Patrick are good but if it is a code glitch STERN may have no clue .
(Does this Hoth issue happen on other people Pro model or LE ?)
I remember the STERN StarTrek Vengeance Multi-Ball issue were the magnet would hold the two pinballs together and not release them or add the third pinball . I called Chas and Patrick they had no Idea what I was talking about . I sent them a video of the issue . It took a year for STERN to find the problem . I almost sold my machine do to the issue . But STERN absolutely fixed with a Code up date it was a real Head scratcher .

#2561 2 years ago

Had my first V1.0 code glitch last night. Made the hyperspace hurry up shot while the purple rectangular DeathStar insert was flashing. Ball went around the accelerator 4 times likes it’s supposed to for the hurry up, then the upper gate opened to divert the ball to the right ramp return. Hyperspace hurry up video ends and it immediately goes to mode select while darkening the pin and shutting off the flippers. Ball drains and ends, goes to bonus count.........arrrghh!!!

While I know the Stern guys check out pinside every now and then, what is the best way of contacting them to let them know about this bug??

#2562 2 years ago
Quoted from AUKraut:

Had my first V1.0 code glitch last night. Made the hyperspace hurry up shot while the purple rectangular DeathStar insert was flashing. Ball went around the accelerator 4 times likes it’s supposed to for the hurry up, then the upper gate opened to divert the ball to the right ramp return. Hyperspace hurry up video ends and it immediately goes to mode select while darkening the pin and shutting off the flippers. Ball drains and ends, goes to bonus count.........arrrghh!!!
While I know the Stern guys check out pinside every now and then, what is the best way of contacting them to let them know about this bug??

Yeah I had this happen also.

Before this, Mode start up would occasionaly release early too causing a flipperless drain on .91&.93

#2563 2 years ago

Not always though so its not really a bug in my opinion..

I get confused at times when travelling slow, so I guess a machine at this lightspeed pace is allowed to do do once in a while )

#2564 2 years ago

I’m not a big mod guy usually but liked the little ships from the Star Wars card game or something (which I don’t play). EAch was about 14.00.

30BD487C-044E-461C-B1FA-DA3120317D2F (resized).jpeg

#2565 2 years ago
Quoted from ChipScott:

I agree, the detail in these starship figurines can be really amazing, and really helped enhance an already a very cool game. I got everything off of Amazon. The Collection that these Starship figures come from is called Star Wars X-Wing miniatures game expansion pack, which includes multiple different ships including the ones that I used. Shipped in like 2 to 3 days.

Thanks again! I hope you don't mind me copying your ideas on the ships. Now I just need to figure out what color to powder coat the legs & armor on my premium. I don't care for the black wrinkle finish. The shiny black on the LE is better. I was wondering what blue would look like. I think the premium is a bit harder(to pick armor color) than the other versions since it is very light on the left side and black on the right. It may end up looking good on one side and weird on the other? Does anyone know if the deluxe (top)armor on the LE is being reproduced or is available?

#2566 2 years ago
Quoted from PlayPin:

Thanks again! I hope you don't mind me copying your ideas on the ships. Now I just need to figure out what color to powder coat the legs & armor on my premium. I don't care for the black wrinkle finish. The shiny black on the LE is better. I was wondering what blue would look like. I think the premium is a bit harder(to pick armor color) than the other versions since it is very light on the left side and black on the right. It may end up looking good on one side and weird on the other? Does anyone know if the deluxe (top)armor on the LE is being reproduced or is available?

One I am doing .

StarWars White trim kit t-molding (resized).jpg

#2567 2 years ago
Quoted from RobKnapp:

One I am doing .

I like the top armor. The white really stands out too. Thanks for posting.

#2568 2 years ago
Quoted from AUKraut:

Had my first V1.0 code glitch last night. Made the hyperspace hurry up shot while the purple rectangular DeathStar insert was flashing. Ball went around the accelerator 4 times likes it’s supposed to for the hurry up, then the upper gate opened to divert the ball to the right ramp return. Hyperspace hurry up video ends and it immediately goes to mode select while darkening the pin and shutting off the flippers. Ball drains and ends, goes to bonus count.........arrrghh!!!
While I know the Stern guys check out pinside every now and then, what is the best way of contacting them to let them know about this bug??

Patrick.powers@sternpinball.com

#2570 2 years ago

I want the head of STERN Technical Support Patrick Powers to read any issues .
I would attach all three email address. Thanks for more information .

#2571 2 years ago
Quoted from RobKnapp:

I want the head of STERN Technical Support Patrick Powers to read any issues .
I would attach all three email address. Thanks for more information .

Yep agreed can't hurt to over communicate in this case.

#2572 2 years ago
Quoted from RobKnapp:

One I am doing .

Looking good robknapp !! where did u get the side armor if u dont mind me asking

#2573 2 years ago

Thanks Rob & Kermit, I've sent an email to all 3 addresses.....

#2574 2 years ago
Quoted from AUKraut:

Had my first V1.0 code glitch last night. Made the hyperspace hurry up shot while the purple rectangular DeathStar insert was flashing. Ball went around the accelerator 4 times likes it’s supposed to for the hurry up, then the upper gate opened to divert the ball to the right ramp return. Hyperspace hurry up video ends and it immediately goes to mode select while darkening the pin and shutting off the flippers. Ball drains and ends, goes to bonus count.........arrrghh!!!
While I know the Stern guys check out pinside every now and then, what is the best way of contacting them to let them know about this bug??

Call them. Very easy to get a hold of the right person (normally Chaz). 708-345-7700 then press the most correct number.

#2575 2 years ago
Quoted from chuckcasey:

Call them. Very easy to get a hold of the right person (normally Chaz). 708-345-7700 then press the most correct number.

Yeah, thought about that, but it's easier to describe a software bug in a detailed email, that way I can make sure that the bug is described correctly.

#2576 2 years ago

Got flame red powdercoat for my pro. Turned out quite nice.

20171125_102122 (resized).jpg

20171124_221433 (resized).jpg

20171124_220654 (resized).jpg

#2577 2 years ago
Quoted from John1210:

Got flame red powdercoat for my pro. Turned out quite nice.

That red looks amazing on that Pro cabinet!

#2578 2 years ago

Hoth, we have a problem.....

8ABFCA31-A74A-46E6-A027-459C4B5977B8 (resized).jpeg

#2579 2 years ago

hooked
Lit LE side armor later today!
Thanks Robert!

20171221_101822 (resized).jpg

#2580 2 years ago

On the Pro, I keep having an issue where the screw pops out in the left corner of the back of the right ramp. No big deal, but I am operating it on location and have had two service calls where the screw popped out, fell into one of the switch holes in the top rollover switches, and the ball got stuck. I left the screw out of the ramp for now, but is anyone else having issues with loose parts?

Minor problems but I have also had the bottom screw come out of my spinner bracket and a few LEDs shake loose.

#2581 2 years ago

Still noticing lots of R2-D2 love, even after more perks/abilities were added to the other three characters. Danger’s last stream scored GC and a 2.9 Bill hyper loop shot using R2. Anybody score high with the other characters in 1.0?

#2582 2 years ago
Quoted from MattS:

hooked
Lit LE side armor later today!
Thanks Robert!

That LE side armor lighted rocks! Hope you post some pics when installed. Can I ask what that kit costs? Thanks

#2583 2 years ago
Quoted from John1210:

Got flame red powdercoat for my pro. Turned out quite nice.

That red armor does look great on the Pro! I saw another poster in this thread who had mystic purple on a pro and I thought that looked great too. The mostly black art on the pro seems to work with about any color. The premium is very light on the left and black on the right. I am wondering if any powder coating will look good on the premium besides black or white?

#2584 2 years ago
Quoted from PlayPin:

That LE side armor lighted rocks! Hope you post some pics when installed. Can I ask what that kit costs? Thanks

Can't wait to install it, hopefully will have time tonight and will definitely post pics.

I was in on the early (pre) orders so not sure if the regular price will be the same. PM hooked (Robert) and he will take care of you. I'm sure he will post the price here also at some point. All of his mods are first class.

#2585 2 years ago

Did white pearl on mine, looks grest in person!

sww.jpg

#2586 2 years ago
Quoted from speederice:

On the Pro, I keep having an issue where the screw pops out in the left corner of the back of the right ramp. No big deal, but I am operating it on location and have had two service calls where the screw popped out, fell into one of the switch holes in the top rollover switches, and the ball got stuck. I left the screw out of the ramp for now, but is anyone else having issues with loose parts?
Minor problems but I have also had the bottom screw come out of my spinner bracket and a few LEDs shake loose.

I haven't had a problem with those particular screws, but the screws that hold the double posts on the Death Star on keep falling off. Ill get a call that the posts wont release and everytime, the spring and screws are in the bottom of the cabinet.

#2587 2 years ago
Quoted from MattS:

hooked
Lit LE side armor later today!
Thanks Robert!

So i'm not getting it, is hooked selleng them or not? Been trying to buy a set and was told not yet? Not on his site either. Just want someone to take my money for a set....

#2588 2 years ago
Quoted from MattS:

Lit LE side armor later today!

Please post pictures, and also how easy it is to install? I am interested, just want to see first. Thanks

#2589 2 years ago

Got my Prem yesterday, locked in our mechanical room closet or I'd take pics (kids have NO idea, so excited for Christmas morning!) but I have to say, the clear coat on this playfield looks amazing. Can't wait to get some time on this pin!

#2590 2 years ago
Quoted from oyvindmo:

Got the SW blues... Received a message last night that our on-location SW LE said "Node Not Found" on boot. Going to check it out today; hoping it's just a broken-off diode, as per the recent service bulletin from Stern

In case anyone wondered: Yeah, you should do the fix in the service bulletin if you haven't already. Since we didn't hear about the bulletin before the damage was already done, we ended up having to replace no less than seven PCBs, just because a $0.20 component broke one of its legs...

sw_dead_pcbs (resized).jpg

#2591 2 years ago
Quoted from cscmtp:

Got my Prem yesterday, locked in our mechanical room closet or I'd take pics (kids have NO idea, so excited for Christmas morning!) but I have to say, the clear coat on this playfield looks amazing. Can't wait to get some time on this pin!

Congratulations! It's an awesome game!
Certainly it's per personal preference, although the majority of users I've noticed, including myself, have decreased the Right eject scoop from 40 to 20 - 25, which ejects it fairly reliably to the right flipper as opposed to a quick hard drain SDTM. Other than that, I've not noticed many other people making any other major adjustments in the menu, with the exception of possibly decreasing the video mode time, and making sure to adjust to freeplay, as default is to payment.

Also, if you turn it on to check these things (and sneak a few plays on it while you're there)... May want to check in just make sure it's updated to the new 1.00.0 code. Most folks, including myself, have had the most success using the PNY brand flash drives (available at Best Buy, and the like) and using Windows as opposed to Mac for the download process.
Congrats again...great Christmas!

#2592 2 years ago
Quoted from oyvindmo:

In case anyone wondered: Yeah, you should do the fix in the service bulletin if you haven't already. Since we didn't hear about the bulletin before the damage was already done, we ended up having to replace no less than seven PCBs, just because a $0.20 component broke one of its legs...

Stern warrantied the boards?

#2593 2 years ago

I have called stern multiple times and have yet to receive the kit that is supposed to fix this problem. Anyone else actually receive the kit?

#2594 2 years ago
Quoted from rs812:

I have called stern multiple times and have yet to receive the kit that is supposed to fix this problem. Anyone else actually receive the kit?

I ordered a kit through my distributor shortly after it was announced and haven't received it yet. I wish I knew the length of the spacer that Stern sends out so I could make my own.

#2595 2 years ago
Quoted from PinballManiac40:

Stern warrantied the boards?

Yes, we were met with top notch support from both our distributor and Stern.

But, I do wish Stern provided a way to subscribe for notifications when new service bulletins get published. If we had gotten a notice when that bulletin was posted, the problem would have been solved at no cost for Stern and we wouldn't have had two weeks of downtime on a solid location earner. (It took two weeks because they first sent one batch of cards, but it turned out even more cards were dead.)

#2596 2 years ago
Quoted from rs812:

I have called stern multiple times and have yet to receive the kit that is supposed to fix this problem. Anyone else actually receive the kit?

Ditto - calls, emails - no kit. Chaz said he showed where I was "on the list."

#2597 2 years ago

I’ve seen a couple comments about a service bulletin, but I can’t seem to find it. Come someone point me in the right direction?

#2599 2 years ago

I emailed Stern as soon as the service bulletins came out. They said they would send them right out. I waited a couple weeks and asked how it was going. I got this response from David Carver.

“We actually don’t have these yet. We have just been compiling the orders so we can send them out as soon as possible.”

Hope it’s soon. Sounds like a small price if the get these out vs. a big price to replace boards. Hope it’s soon.

#2600 2 years ago

Folks; the spacers cost me .99 at frys and I already had the zip ties. I’m all for this being a warranty issue and all, but I didn’t want to wait until I had a problem so I bought my own. Which was enough for 4 games!

Promoted items from the Pinside Marketplace
$ 76.00
Cabinet - Sound/Speakers
ModFather Pinball Mods
$ 10.00
Cabinet - Sound/Speakers
Gweem's Mods
There are 8380 posts in this topic. You are on page 52 of 168.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside