(Topic ID: 82803)

Stern Star Trek multiball magnet *Solution found*


By nodyeliab

5 years ago



Topic Stats

  • 539 posts
  • 81 Pinsiders participating
  • Latest reply 4 years ago by paul_8788
  • Topic is favorited by 34 Pinsiders

You

Linked Games

Topic Gallery

There have been 25 images uploaded to this topic. (View topic image gallery).

004-120.JPG
003.JPG
IMG_20140629_070106.jpg
IMG_20140629_070201.jpg
shelted.jpg
radiation-twisted-pairs-1359143187_500_289_75.jpg
ST Premium Optos.jpg
Untitled.jpg
ferrite-clip-on-hem3012.jpg
ferrite core.jpg
wires2.JPG
wires1.JPG
222030-i.jpg
14454078532_e6429bfbf5_b-2.jpg
14454317984_abbcc55fa8_b-655.jpg
twisted wire.png

You're currently viewing posts by Pinsider nodyeliab.
Click here to go back to viewing the entire thread.

#1 5 years ago

Update:

A solution to this problem has been found. It appears that EM interference from magnet was messing with the optos. The solution is to twist the wires going from the optos to the boards underneath the playfield. This will make the game behave normally.

----------------------------------------------------

Hello, I was wondering if anyone else is having the same issue and if there is a fix. When the ball locks on the magnet for vengeance multiball and I try to hit it with the other ball, it either sticks to the ball or it bounces off, but doesn't start the multiball, it ends up timing out and then starts the multiball.

#16 5 years ago

Thanks for all the input, I will check the opto when I get home. This is a pro version and it came from STERN with 1.4 installed.

As far as hitting it hard enough to trigger the other opto, I've hit it so hard that it moved the ball on the magnet up and my other ball took it's spot on the magnet, so it sound like an opto issue. I will let everyone know if that was it.

#24 5 years ago

Ok, I just got home to try out the switch test and found that both opto's are working. This is really strange though, so if I start vengeance multiball, and stick my finger in front of the first opto, it starts the multiball with no problems. I even tried it again, but this time I used the ball throwing it up there with my hand and it works. So the next time I tried the same test but with the flipper, and guess what, no go, it does not trigger the opto. So if I use the flipper to get the ball up to the opto it will not work, it's very very strange. I've thought about downgrading to 1.3 and to see if it has the same issues, because the one at our mall has 1.3 and does not do this.

#25 5 years ago

Found the problem, and please someone else confirm. So I just tried it again doing the same test, once by hand, and it worked, then I tried it again, with my hand, but this time held the left flipper in, and it did not work, the ball just stuck to the other ball! So it looks like this is a firmware issue.

#28 5 years ago

Yes you are correct, it appears to be a timing issue. I just tried it again, started the mode and held the flipper, I moved my finger over the opto, and it did not see it, I continued to move my finger, then after a short moment it finally saw it. I tried it again without the flipper engaged and it saw my finger immediately.

#37 5 years ago
Quoted from Aurich:

I just tested with the flipper up, works fine. So I think you've got an issue with your opto not registering when your flipper is up.

It's strange though, I can flip the flipper, let it go back down and it will still cause a delay in the opto, it's just enough of a delay to allow the ball go past the opto and cling to the other ball. It's a very small delay too, maybe 2 - 3 seconds. And it does it with both flippers.

Are you running 1.4?

#38 5 years ago

I imagine Stern knows about this, but has anyone sent an email to them with this issue? It's very frustrating. I was going to downgrade to 1.3 and see what happens, but I can't find 1.3 on their site, they now only have 1.4.

#44 5 years ago
Quoted from phishrace:

You didn't mention if a hard hit to the ball on the magnet, so that it triggers the upper optos, turns off the magnet and launches another ball (starts the multiball properly). Have you tried that?

You guys are the ones telling the original poster his game is broken. I told him his game is fine. Read my first reply.

Yes, there are only two sets of opto's when the ball is stuck on the magnet it is blocking the second set of optos, I can throw the ball hard enough to move the ball up and my second ball will then sit on the magnet with no results.

#45 5 years ago
Quoted from Aurich:

So his lower opto not working right when the flipper is up is normal? Just to be clear, that's your position right? I say that's broken, you say that's normal, working fine.
And the people who own the game, and don't have this problem, and release the ball with the lower opto, flippers up or down, what? Our game *are* broken? Or we just haven't turned on the setting that isn't in the manual for "super hard upper opto sticky magnet ball mode"? nodyeliab did you turn that on?
Just making sure we're clear, because you aren't making any sense to me. Maybe I'm misunderstanding your position, but you keep repeating it, so I'm not really sure.
nodyeliab, I suggest you call Stern's technical support. If they tell you that's all normal, and just whack that ball harder, or drop your flipper faster then let us know. Call 1-800-KICKERS, talk to Chas. Worst that can happen is you have to sit on hold for a little bit. It's a new game, he'll be happy to talk to you and help.
It's pretty obvious Stern has some opto issues with this game, be it hardware or software. 1.4.2 was purely about optos. Maybe it's a code problem, that would be great, next update could fix it for anyone having the problem.

Thanks, I will give Stern a call today and see what they say.

#49 5 years ago
Quoted from gweempose:

So it's pretty obvious that there is some sort of flaw in the game that is causing this. The question is, why is it happening on some games and not others?

I think it depends on what version you're running.

#50 5 years ago

I sent an email to Stern, now I'm waiting for a response...

#56 5 years ago
Quoted from gweempose:

Ever since I was made aware of this problem, I've been extra careful to always shoot the Vengeance release shot with a quick flip instead of holding the flipper up. I was playing tonight, and the ball got stuck. I was very conscious of the fact that it was a quick flip, so it's obviously not entirely dependent on the flipper state. Logic says that it has to be either an opto issue, a software issue, or a combination of both. I'm guessing there were a bunch of optos installed in these games that aren't performing to spec.

For me it doesn't work with a quick flip, if you hit the flipper just once, it starts the delay, then after about 3 seconds you can put something to block the opto and it will start the mode, but that's the problem, by the time the delay is over the ball is stuck on the other ball. I also notice that even when the delay is over and it hit the flipper again, it seems to start the delay again.

This is so frustrating, I hope they come up with a fix soon.

#58 5 years ago
Quoted from Aurich:

Did you call Stern yet? That tech support number I gave you was real, use it. Email is all fine and good, but a phone call is how you resolve things quickly.

Thanks, yes I will give them a call on my lunch break today, I'll keep you posted.

#60 5 years ago
Quoted from nodyeliab:

Thanks, yes I will give them a call on my lunch break today, I'll keep you posted.

Ok, I talked to Chas (super nice guy!), and explained the issue, he said he will talk to the programmer to take a look, I also told him I will send a video showing the issue. The video is taking a bit though, I'm trying to get it to a size that I can send to him. I told him that if I can't send it via email, I'll post it on youtube and send him the link.

#66 5 years ago
Quoted from gweempose:

Post a nice HD video on YouTube. That makes more sense than sending the file.

Ok, I posted it.

#68 5 years ago
Quoted from sillyoldelf:

It's odd because during tests it works perfectly using your hand to break opto. In game it happens through natural course of playing. changing the pitch to 7.2 degrees seems to have cured mine for the most - before it was 6.5
Now the first ball sticks to the magnet and second ball starts multiball.
I can't think this is an opto issue as it wouldn't work at all?

It's not so much an physical problem with the opto, it's a delay issue, I also have the machine up to where the bubble level by the shooter is centered.

#78 5 years ago
Quoted from gweempose:

Thanks for posting the video, nodyeliab! My game is acting exactly like yours. What's weird is that the problem seems to have gotten worse. I could have sworn that the opto failed to register only occasionally when I first got the game, but now it seems like mine is doing it every time when immediately followed by an activated flipper. If it's purely a software bug, I don't see how the problem could have increased in frequency like it has. It's also very curious that some games don't have this problem at all. It leads me back to my theory that some games have optos that are affected, while other games have optos that are immune to this problem. My guess is that swapping out the optos with new ones would solve the problem. It will be interesting to see if Stern can replicate this problem on one of the games they have at the factory.

You're welcome, my machine has done it from the first day I got it. On my machine I really don't think it's the opto itself, because if you start the mode and you do not use the flipper, then by hand throw the ball to it, it will start instantly, but you use the flipper you get that small delay where the opto is disabled, thus the opto does not see it in that short delay, goes past it and then sticks to the ball. I think the reason some people are not seeing the issue could be their fw version, the one at our mall is on 1.3 and doesn't do it.

#83 5 years ago
Quoted from gweempose:

nodyeliab,
Did you provide Chas with a link to this thread?

Crap, I forgot to, I'm sending it now...

#88 5 years ago
Quoted from caker137:

For those of you getting it to work by hand, but not with the flipper, something to try:
Hold the flipper bat down when you press the flipper button so that it can't move. Then immediately roll the ball into the locked ball by hand as if the flipper had made the shot (you may need a helper to do all this at once). This will either work fine or still hang both balls.
If it hangs both balls on the magnet, you know there is something electrical / code going on.
If it works now, you have an intermittent connection on one of your optos that is triggered to fail by the vibration of the flipper.
On mine it was auto starting modes on the ball load, due to the vibe of the up kicker causing the opto to flake out momentarily. Reflowing the offending opto fixed mine.
I do believe it's possible that stern adjusted some debouncing timing which has made some of these bad opto problems manifest more often.

I just tried that as someone else did here, I taped the flipper up, and tried the mode the same, if I press the flipper, it still sticks to the other ball

#104 5 years ago
Quoted from Rarehero:

You seem to think I'm wrong. Which makes you double wrong. Let's disregard your Pro vs. LE theory. I've played Robert's LE. He has an LE. I have an LE. His LE *ALWAYS* catches the 2 balls and waits for the time out...it NEVER awards you that hit EVER, and NEVER kicks out the 3rd ball (reward for hitting the magnet ball). Mine ALWAYS lets the ball go when you hit it - even lightly...becaaaauuuuse - it's TRIPPED BY THE FRONT OPTO!!! ...and then always kicks out the 3rd ball.
Robert clearly has a problem with his front opto. Fact. Nothing to do with code.

Just out of curiosity, are you both running the same FW on your LE's?

#107 5 years ago
Quoted from The_Dude_Abides:

If it was a software issue I would expect this to be occurring to way more owners. This is the first time I've read of people having this issue and on my Pro have never had this problem. None of the 5 other ST machines of different models have had this issue. That leads me to believe the problem lies with the hardware and not the software. I've been wrong more times then I care to remember though so perhaps I am here as well. Best thing to do is contact Stern directly and see what they say.

But we have to remember, what versions of the firmware are people running, this could be why some are not seeing the issue and some are.

#122 5 years ago

Ok, tonight just for laughs, I swapped the vengeance opto board with the one next to it, and now it's working! I haven't had time to put a bunch of games on it, but with the few test was I able to do, it no longer sticks, it starts the mode instantly. Now with that said, I'm not sure that just the act of moving the opto boards changed a bad connection or something else. It does show it working in the switch matrix test as it did before.

So if someone that is having the same problem could try this too, that would be great. I'm going to test it some more tomorrow. I will keep everyone posted...

#125 5 years ago
Quoted from phishrace:

Nice. Just to be clear here, did you swap the opto (amplifier) boards under the playfield? Or did you change the tiny boards the actual optos are soldered to on top of the playfield? Big difference.

I swapped the boards under the playfield.

#132 5 years ago

Ok, so last night I switched the opto boards, ran some test, and it was working, now today at lunch, I go and try it, guess what, back to doing it again! So when people on this thread say it has been getting worse I can see what they mean.

So tonight I’m going to try to switch out the actual sensors themselves with others on the game. But first I’m going to check and see if the connectors on the optp plugs aren’t partially faulty.

#134 5 years ago

The thing I don’t understand is why it’s only happening when the flippers are activated. If I don’t use the flippers it works fine. And I know it’s not vibration because I can tape the flipper in the up position, activate the flipper with no movement and it fails. This make me wonder if it’s power draw+bad opto somehow. Because even with the flipper taped in the up position, I’m still pulsing all that current through the coil on the flipper. More testing tonight… 

#137 5 years ago
Quoted from gweempose:

Are you any good with a multimeter? Perhaps you can see what's going on with the power to your optos, and compare it to someone who has a game that is unaffected.

Yes, I was thinking about hooking up my scope to see what’s going on, I might do that after checking the connections. I’ll keep you posted.

#140 5 years ago

ok, so I tried something different (simple) before going too deep. I took the connectors off the bottom opto board and pushed the connectors (prongs) a little bit outwards on the board to give a little bit different connection to the plugs, and it is now working again. I have played 3 games so far and the ball has not gotten stuck once.

Can someone here try this too and see if they get the same results?

3-10-2014 6-23-15 PM.jpg

#142 5 years ago
Quoted from gweempose:

What board number is it?

Sorry, I will take a picture when I get a chance, but It's the one on the left side closest to the ship.

#143 5 years ago

I've played it some more tonight, still no problems I think this could be it! Before this, it never worked.

#146 5 years ago
Quoted from gweempose:

I believe the boards have stickers next to them with numbers.

There are no stickers on the top of the boards, they all have the same printing on the top mask. But here is a picture.

20140310_212655.jpg

#147 5 years ago
Quoted from phishrace:

I hope that lasts for you but I suspect it won't. The way the edge connectors are orientated, pushing the pins towards the center of the board would probably work better. I still recommend removing the female connectors and increasing the tension on those instead.

Yes, I agree, this was just a quick test to test my theory, I will remove the connectors out of their plastic case and pinch them so they fit tighter to the pin and then I will retest.

520-5239-01. You can see it printed on the bottom right corner. Too small for a sticker. That board has been used for years. Spidey, Pirate's, FGY and WPT all have at least two, if you want to try a known good one.

#150 5 years ago
Quoted from gweempose:

Interesting. It must be different on the LEs. On my game, every board has a yellow sticker next to it indicating Board 1, Board 2, etc ...

Ah, I see, sorry I was looking at the board for a specific number. Yes the board number is on the sticker

#161 5 years ago
Quoted from sillyoldelf:

Weird because I emailed them a week ago about it and Patrick replied with some suggestions - none of them cured it.

I also talked to them also about this issue over the phone.

#162 5 years ago

Though I am happy to say my problem is completely gone now after cleaning and bending out the connectors in the plug!

#166 5 years ago
Quoted from gweempose:

So now I'm even more confused than ever. Is it the optos, the boards, the connectors, the software, or all of the above?
I actually have to go over to Stern today to pick up a new leg for my STLE. I'll call them and see if they can provide me some new optos while I'm there. I might as well cover all my bases. Do I need just new receivers, or new transmitters as well?

I I can’t speak for everyone here, but for me, it seems to be the connector on the opto itself (the plastic piece that has the two wires). I had to push them out of the plastic connector piece, I then took and eraser to clean the front of the connector that actually makes contact with the male pins on the opto controller board, then cleaned it off with alcohol. I then bent them a little bit out so more pressure would be on the male connector (sorry I didn’t take pictures).

Of course I could be wrong on all of this, because someone reported that they had a cold solder joint on the opto itself, it might be that just moving the wire made connection again and it wasn’t the connector at all. I will have to play around with it some more.

Promoted items from the Pinside Marketplace
$ 5,599.00
Pinball Machine
Little Shop Of Games
From: $ 5.00
Cabinet - Other
Rock Custom Pinball
$ 5,599.00
Pinball Machine
Classic Game Rooms
From: $ 20.00
Playfield - Toys/Add-ons
ModFather Pinball Mods

You're currently viewing posts by Pinsider nodyeliab.
Click here to go back to viewing the entire thread.

Hey there! Got a moment?

Great to see you're enjoying Pinside! Did you know Pinside is able to run thanks to donations from our visitors? Please donate to Pinside, support the site and get anext to your username to show for it! Donate to Pinside